ctpl-vl.spec 5.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179
  1. %global ctpl_docdir %{_defaultdocdir}/ctpl-%{version}
  2. Name: ctpl
  3. Version: 0.3.3
  4. Release: 3%{?_dist_release}
  5. Summary: Template engine library written in C
  6. Summary(ja): C で書かれたテンプレートエンジンライブラリ
  7. Group: Development/Tools
  8. License: GPLv3+
  9. URL: http://ctpl.tuxfamily.org/
  10. Source0: http://download.tuxfamily.org/ctpl/releases/ctpl-%{version}.tar.gz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: glib2-devel >= 2.10
  13. Requires: ctpl-libs = %{version}-%{release}
  14. %description
  15. CTPL is a template library written in C. It allows fast and easy parsing of
  16. templates from many sources (including in-memory data and local and remote
  17. streaming, thanks to GIO) and fine control over template parsing environment.
  18. CTPL has following features:
  19. * It is a library, then it can be easily used from programs
  20. * Separated lexer and parser
  21. * It is written in portable C
  22. * Simple syntax
  23. * Fast and strict parsing
  24. * Possible in-memory parsing, allowing non-file data parsing and avoiding
  25. I/O-latency, through GIO's GMemoryInputStream and GMemoryOutputStream
  26. %package libs
  27. Summary: Template library written in C
  28. Summary(ja): C で書かれたテンプレートライブラリ
  29. Group: System Environment/Libraries
  30. %description libs
  31. This package contains the CTPL library.
  32. %post libs -p /sbin/ldconfig
  33. %postun libs -p /sbin/ldconfig
  34. %package devel
  35. Summary: Development headers of the template library written in C
  36. Summary(ja): C で書かれたテンプレートライブラリの開発ヘッダ
  37. Group: Development/Libraries
  38. Requires: ctpl-libs = %{version}-%{release}
  39. %description devel
  40. This package contains the development headers of the CTPL library.
  41. %package doc
  42. Summary: Documentation for the CTPL library
  43. Summary: CTPL ライブラリのドキュメント
  44. Group: Documentation
  45. BuildArch: noarch
  46. Requires: ctpl-libs = %{version}-%{release}
  47. Requires: gtk-doc
  48. %description doc
  49. This package contains the HTML documentation reference for the CTPL library.
  50. %prep
  51. %setup -q
  52. # remove waf since this isn't needed for the build, we're building the
  53. # package with autotools
  54. rm -f waf
  55. rm -f wscript
  56. %build
  57. %configure --docdir %{ctpl_docdir}
  58. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  59. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  60. make %{?_smp_mflags}
  61. %install
  62. rm -rf $RPM_BUILD_ROOT
  63. make install DESTDIR=$RPM_BUILD_ROOT
  64. # Seems the --docdir flag is not working correctly, working around this here
  65. # for now
  66. install -d $RPM_BUILD_ROOT%{ctpl_docdir}
  67. install -Dpm0644 AUTHORS COPYING NEWS HACKING TODO README THANKS $RPM_BUILD_ROOT%{ctpl_docdir}
  68. rm -f $RPM_BUILD_ROOT%{_libdir}/libctpl.a
  69. rm -f $RPM_BUILD_ROOT%{_libdir}/libctpl.la
  70. %clean
  71. rm -rf $RPM_BUILD_ROOT
  72. %files
  73. %defattr(-,root,root,-)
  74. %doc %{_mandir}/man1/%{name}.1.*
  75. %{_bindir}/%{name}
  76. %files libs
  77. %defattr(-,root,root,-)
  78. %dir %{ctpl_docdir}
  79. %doc %{ctpl_docdir}/AUTHORS
  80. %doc %{ctpl_docdir}/COPYING
  81. %doc %{ctpl_docdir}/NEWS
  82. %{_libdir}/lib%{name}.so.*
  83. %files devel
  84. %defattr(-,root,root,-)
  85. %doc %{ctpl_docdir}/HACKING
  86. %doc %{ctpl_docdir}/TODO
  87. %{_libdir}/lib%{name}.so
  88. %{_includedir}/%{name}/
  89. %{_libdir}/pkgconfig/%{name}.pc
  90. %files doc
  91. %defattr(-,root,root,-)
  92. %doc %{ctpl_docdir}/README
  93. %doc %{ctpl_docdir}/THANKS
  94. %doc %{_datadir}/gtk-doc/html/%{name}
  95. %changelog
  96. * Sat Nov 2 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.3.3-3
  97. - moved libs to System Environment/Libraries Group
  98. - moved devel to Development/Libraries Group
  99. - moved doc to Documentation Group
  100. * Sat May 24 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.3.3-2
  101. - rebuild with new toolchain
  102. * Sun Oct 02 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.3.3-1
  103. - new upstream release
  104. * Sun Jan 23 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.3.2-1
  105. - new upstream release
  106. * Wed Dec 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.3.1-1
  107. - new upstream release
  108. * Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 0.2.2-2
  109. - rebuilt with rpm-4.8.1 for pkg-config
  110. * Sun Aug 8 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.2-1
  111. - initial build for VineSeed
  112. * Sat Jul 17 2010 Dominic Hopf <dmaphy@fedoraproject.org> - 0.2.2-4
  113. - fix rpmlint binary-or-shlib-defines-rpath error
  114. - fix rpmlint library-without-ldconfig-* errors
  115. - make the -doc package noarch
  116. - remove the -bin subpackage, the binary files will now be installed with the
  117. main package, thus when typing 'yum install ctpl'
  118. - require gtk-doc for the -doc package
  119. - ctpl-libs now owns /usr/share/doc/ctpl-0.2.2
  120. - fix redundant file listings
  121. - require -libs package with fully qualified version for the binary package
  122. * Fri Jul 16 2010 Dominic Hopf <dmaphy@fedoraproject.org> - 0.2.2-3
  123. - move the %%{_libdir}/lib%%{name}.so back to the -devel package where it
  124. belongs to
  125. * Fri Jul 16 2010 Dominic Hopf <dmaphy@fedoraproject.org> - 0.2.2-2
  126. - rename subpackage lib to libs
  127. - add Requires on the libs package to -bin, -devel and -doc package
  128. - install %%{_libdir}/lib%%{name}.so with a -static package
  129. - install manpage only with the binary
  130. - install HACKING and TODO only with the -devel package
  131. - install README and THANKS only with the -doc package
  132. - fix the installation path for documentation files
  133. * Thu Jul 15 2010 Dominic Hopf <dmaphy@fedoraproject.org> - 0.2.2-1
  134. - initial specfile