cryptsetup-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408
  1. %define _root_sbindir /sbin
  2. %define upstream_version %{version}
  3. Summary: A utility for setting up encrypted disks
  4. Summary(ja): 暗号化ファイルシステム設定用ユーティリティ
  5. Name: cryptsetup
  6. Group: Applications/System
  7. Version: 2.3.2
  8. Release: 1%{?_dist_release}
  9. License: GPLv2 and LGPLv2+
  10. URL: https://gitlab.com/cryptsetup/cryptsetup
  11. %global shortver %(echo %{version} | sed -e 's/\.[0-9]*$//')
  12. Source0: https://www.kernel.org/pub/linux/utils/cryptsetup/v%{shortver}/cryptsetup-%{upstream_version}.tar.xz
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: popt-devel
  15. BuildRequires: device-mapper-devel
  16. BuildRequires: json-c-devel
  17. BuildRequires: libblkid-devel
  18. BuildRequires: libgcrypt-devel
  19. BuildRequires: libgpg-error-devel
  20. BuildRequires: libuuid-devel
  21. BuildRequires: openssl-devel
  22. Provides: cryptsetup-luks = %{version}-%{release}
  23. Obsoletes: cryptsetup-luks < 1.4.0
  24. Requires: cryptsetup-libs = %{version}-%{release}
  25. Obsoletes: %{name}-python < 2.0.0
  26. %description
  27. The cryptsetup package contains a utility for setting up
  28. disk encryption using dm-crypt kernel module.
  29. %description -l ja
  30. cryptsetup パッケージには、dm-crypt カーネルモジュールを使って
  31. ディスクの暗号化を設定するユーティリティが収録されています。
  32. %package devel
  33. Summary: Headers and libraries for using encrypted file systems
  34. Summary(ja): 暗号化ファイルシステムを使うためのヘッダとライブラリ
  35. Group: Development/Libraries
  36. Requires: %{name} = %{version}-%{release}
  37. Requires: libgcrypt-devel > 1.1.42
  38. Requires: device-mapper-devel
  39. Requires: libuuid-devel
  40. Requires: pkgconfig
  41. Provides: cryptsetup-luks-devel = %{version}-%{release}
  42. Obsoletes: cryptsetup-luks-devel < 1.4.0
  43. %description devel
  44. The cryptsetup-devel package contains libraries and header files
  45. used for writing code that makes use of disk encryption.
  46. %description devel -l ja
  47. cryptsetup-devel パッケージには、ディスクの暗号化を使うコードを
  48. 書くのに使われるライブラリとヘッダファイルが収録されています。
  49. %package libs
  50. Summary: Cryptsetup shared library
  51. Summary(ja): Cryptsetup 共有ライブラリ
  52. Group: System Environment/Libraries
  53. Provides: cryptsetup-luks-libs = %{version}-%{release}
  54. Obsoletes: cryptsetup-luks-libs < 1.4.0
  55. %description libs
  56. This package contains the cryptsetup shared library, libcryptsetup.
  57. %description libs -l ja
  58. このパッケージには、cryptsetup の共有ライブラリ、libcryptsetup が
  59. 収録されています。
  60. %prep
  61. %setup -q -n cryptsetup-%{upstream_version}
  62. %build
  63. export PYTHON=%{__python3}
  64. %configure \
  65. --sbindir=%{_root_sbindir} \
  66. --libdir=/%{_lib} \
  67. --disable-selinux
  68. # remove rpath
  69. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  70. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  71. make %{?_smp_mflags}
  72. %install
  73. rm -rf %{buildroot}
  74. make install DESTDIR=%{buildroot}
  75. rm -rf %{buildroot}/%{_lib}/*.la %{buildroot}/%{_lib}/cryptsetup
  76. # move libcryptsetup.so to %%{_libdir}
  77. pushd %{buildroot}/%{_lib}
  78. rm libcryptsetup.so
  79. mkdir -p %{buildroot}/%{_libdir}
  80. ln -s ../../%{_lib}/$(ls libcryptsetup.so.??.?.?) %{buildroot}/%{_libdir}/libcryptsetup.so
  81. mv %{buildroot}/%{_lib}/pkgconfig %{buildroot}/%{_libdir}
  82. popd
  83. %find_lang cryptsetup
  84. %clean
  85. rm -rf %{buildroot}
  86. %post -n cryptsetup-libs -p /sbin/ldconfig
  87. %postun -n cryptsetup-libs -p /sbin/ldconfig
  88. %files -f cryptsetup.lang
  89. %license COPYING
  90. %doc ChangeLog AUTHORS TODO FAQ
  91. %{_mandir}/man8/*.8.gz
  92. %{_root_sbindir}/*
  93. %files devel
  94. %doc docs/examples/*
  95. %{_includedir}/libcryptsetup.h
  96. %{_libdir}/libcryptsetup.so
  97. %{_libdir}/pkgconfig/libcryptsetup.pc
  98. %files libs
  99. %license COPYING
  100. /%{_lib}/libcryptsetup.so.*
  101. %changelog
  102. * Sat May 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.3.2-1
  103. - new upstream release.
  104. * Sun Mar 29 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.3.1-1
  105. - new upstream release.
  106. * Sun Sep 10 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.7.5-1
  107. - updated to 1.7.5.
  108. * Sat Dec 6 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.4.1-4
  109. - rebuilt with libgcrypt 1.6.0
  110. * Fri Mar 23 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.4.1-3
  111. - updated to 1.4.1; spec revamp; Japanese summary & description
  112. - Sun Sep 21 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.5-8vl5
  113. - applied new versioning policy
  114. - Sun Dec 9 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.5-7vl1
  115. - initial build for VineSeed
  116. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.1-2
  117. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  118. * Wed Nov 09 2011 Milan Broz <mbroz@redhat.com> - 1.4.1-1
  119. - Update to cryptsetup 1.4.1.
  120. - Add Python cryptsetup bindings.
  121. - Obsolete separate python-cryptsetup package.
  122. * Wed Oct 26 2011 Milan Broz <mbroz@redhat.com> - 1.4.0-1
  123. - Update to cryptsetup 1.4.0.
  124. * Mon Oct 10 2011 Milan Broz <mbroz@redhat.com> - 1.4.0-0.1
  125. - Update to cryptsetup 1.4.0-rc1.
  126. - Rename package back from cryptsetup-luks to cryptsetup.
  127. * Wed Jun 22 2011 Milan Broz <mbroz@redhat.com> - 1.3.1-2
  128. - Fix return code for status command when device doesn't exist.
  129. * Tue May 24 2011 Milan Broz <mbroz@redhat.com> - 1.3.1-1
  130. - Update to cryptsetup 1.3.1.
  131. * Tue Apr 05 2011 Milan Broz <mbroz@redhat.com> - 1.3.0-1
  132. - Update to cryptsetup 1.3.0.
  133. * Tue Mar 22 2011 Milan Broz <mbroz@redhat.com> - 1.3.0-0.2
  134. - Update to cryptsetup 1.3.0-rc2
  135. * Mon Mar 14 2011 Milan Broz <mbroz@redhat.com> - 1.3.0-0.1
  136. - Update to cryptsetup 1.3.0-rc1
  137. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0-2
  138. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  139. * Mon Dec 20 2010 Milan Broz <mbroz@redhat.com> - 1.2.0-1
  140. - Update to cryptsetup 1.2.0
  141. * Thu Nov 25 2010 Milan Broz <mbroz@redhat.com> - 1.2.0-0.2
  142. - Fix crypt_activate_by_keyfile() to work with PLAIN devices.
  143. * Tue Nov 16 2010 Milan Broz <mbroz@redhat.com> - 1.2.0-0.1
  144. - Add FAQ to documentation.
  145. - Update to cryptsetup 1.2.0-rc1
  146. * Sat Jul 03 2010 Milan Broz <mbroz@redhat.com> - 1.1.3-1
  147. - Update to cryptsetup 1.1.3
  148. * Mon Jun 07 2010 Milan Broz <mbroz@redhat.com> - 1.1.2-2
  149. - Fix alignment ioctl use.
  150. - Fix API activation calls to handle NULL device name.
  151. * Sun May 30 2010 Milan Broz <mbroz@redhat.com> - 1.1.2-1
  152. - Update to cryptsetup 1.1.2
  153. - Fix luksOpen handling of new line char on stdin.
  154. * Sun May 23 2010 Milan Broz <mbroz@redhat.com> - 1.1.1-1
  155. - Update to cryptsetup 1.1.1
  156. - Fix luksClose for stacked LUKS/LVM devices.
  157. * Mon May 03 2010 Milan Broz <mbroz@redhat.com> - 1.1.1-0.2
  158. - Update to cryptsetup 1.1.1-rc2.
  159. * Sat May 01 2010 Milan Broz <mbroz@redhat.com> - 1.1.1-0.1
  160. - Update to cryptsetup 1.1.1-rc1.
  161. * Sun Jan 17 2010 Milan Broz <mbroz@redhat.com> - 1.1.0-1
  162. - Update to cryptsetup 1.1.0.
  163. * Fri Jan 15 2010 Milan Broz <mbroz@redhat.com> - 1.1.0-0.6
  164. - Fix gcrypt initialisation.
  165. - Fix backward compatibility for hash algorithm (uppercase).
  166. * Wed Dec 30 2009 Milan Broz <mbroz@redhat.com> - 1.1.0-0.5
  167. - Update to cryptsetup 1.1.0-rc4
  168. * Mon Nov 16 2009 Milan Broz <mbroz@redhat.com> - 1.1.0-0.4
  169. - Update to cryptsetup 1.1.0-rc3
  170. * Thu Oct 01 2009 Milan Broz <mbroz@redhat.com> - 1.1.0-0.3
  171. - Update to cryptsetup 1.1.0-rc2
  172. - Fix libcryptsetup to properly export only versioned symbols.
  173. * Tue Sep 29 2009 Milan Broz <mbroz@redhat.com> - 1.1.0-0.2
  174. - Update to cryptsetup 1.1.0-rc1
  175. - Add luksHeaderBackup and luksHeaderRestore commands.
  176. * Fri Sep 11 2009 Milan Broz <mbroz@redhat.com> - 1.1.0-0.1
  177. - Update to new upstream testing version with new API interface.
  178. - Add luksSuspend and luksResume commands.
  179. - Introduce pkgconfig.
  180. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.7-2
  181. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  182. * Wed Jul 22 2009 Milan Broz <mbroz@redhat.com> - 1.0.7-1
  183. - Update to upstream final release.
  184. - Split libs subpackage.
  185. - Remove rpath setting from cryptsetup binary.
  186. * Wed Jul 15 2009 Till Maas <opensource@till.name> - 1.0.7-0.2
  187. - update BR because of libuuid splitout from e2fsprogs
  188. * Mon Jun 22 2009 Milan Broz <mbroz@redhat.com> - 1.0.7-0.1
  189. - Update to new upstream 1.0.7-rc1.
  190. - Wipe old fs headers to not confuse blkid (#468062)
  191. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.6-7
  192. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  193. * Thu Oct 30 2008 Milan Broz <mbroz@redhat.com> - 1.0.6-6
  194. - Wipe old fs headers to not confuse blkid (#468062)
  195. * Tue Sep 23 2008 Milan Broz <mbroz@redhat.com> - 1.0.6-5
  196. - Change new project home page.
  197. - Print more descriptive messages for initialization errors.
  198. - Refresh patches to versions commited upstream.
  199. * Sat Sep 06 2008 Milan Broz <mbroz@redhat.com> - 1.0.6-4
  200. - Fix close of zero decriptor.
  201. - Fix udevsettle delays - use temporary crypt device remapping.
  202. * Wed May 28 2008 Till Maas <opensource till name> - 1.0.6-3
  203. - remove a duplicate sentence from the manpage (RH #448705)
  204. - add patch metadata about upstream status
  205. * Tue Apr 15 2008 Bill Nottinghm <notting@redhat.com> - 1.0.6-2
  206. - Add the device to the luksOpen prompt (#433406)
  207. - Use iconv, not recode (#442574)
  208. * Thu Mar 13 2008 Till Maas <opensource till name> - 1.0.6-1
  209. - Update to latest version
  210. - remove patches that have been merged upstream
  211. * Mon Mar 03 2008 Till Maas <opensource till name> - 1.0.6-0.1.pre2
  212. - Update to new version with several bugfixes
  213. - remove patches that have been merged upstream
  214. - add patch from cryptsetup newsgroup
  215. - fix typo / missing luksRemoveKey in manpage (patch)
  216. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0.5-9
  217. - Autorebuild for GCC 4.3
  218. * Sat Jan 19 2008 Peter Jones <pjones@redhat.com> - 1.0.5-8
  219. - Rebuild for broken deps.
  220. * Thu Aug 30 2007 Till Maas <opensource till name> - 1.0.5-7
  221. - update URL
  222. - update license tag
  223. - recode ChangeLog from latin1 to uf8
  224. - add smp_mflags to make
  225. * Fri Aug 24 2007 Till Maas <opensource till name> - 1.0.5-6
  226. - cleanup BuildRequires:
  227. - removed versions, packages in Fedora are new enough
  228. - changed popt to popt-devel
  229. * Thu Aug 23 2007 Till Maas <opensource till name> - 1.0.5-5
  230. - fix devel subpackage requires
  231. - remove empty NEWS README
  232. - remove uneeded INSTALL
  233. - remove uneeded ldconfig requires
  234. - add readonly detection patch
  235. * Wed Aug 08 2007 Till Maas <opensource till name> - 1.0.5-4
  236. - disable patch2, libsepol is now detected by configure
  237. - move libcryptsetup.so to %%{_libdir} instead of /%%{_lib}
  238. * Fri Jul 27 2007 Till Maas <opensource till name> - 1.0.5-3
  239. - Use /%%{_lib} instead of /lib to use /lib64 on 64bit archs
  240. * Thu Jul 26 2007 Till Maas <opensource till name> - 1.0.5-2
  241. - Use /lib as libdir (#243228)
  242. - sync header and library (#215349)
  243. - do not use %%makeinstall (recommended by PackageGuidelines)
  244. - select sbindir with %%configure instead with make
  245. - add TODO
  246. * Wed Jun 13 2007 Jeremy Katz <katzj@redhat.com> - 1.0.5-1
  247. - update to 1.0.5
  248. * Mon Jun 04 2007 Peter Jones <pjones@redhat.com> - 1.0.3-5
  249. - Don't build static any more.
  250. * Mon Feb 05 2007 Alasdair Kergon <agk@redhat.com> - 1.0.3-4
  251. - Add build dependency on new device-mapper-devel package.
  252. - Add preun and post ldconfig requirements.
  253. - Update BuildRoot.
  254. * Wed Nov 1 2006 Peter Jones <pjones@redhat.com> - 1.0.3-3
  255. - Require newer libselinux (#213414)
  256. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.0.3-2.1
  257. - rebuild
  258. * Wed Jun 7 2006 Jeremy Katz <katzj@redhat.com> - 1.0.3-2
  259. - put shared libs in the right subpackages
  260. * Fri Apr 7 2006 Bill Nottingham <notting@redhat.com> 1.0.3-1
  261. - update to final 1.0.3
  262. * Mon Feb 27 2006 Bill Nottingham <notting@redhat.com> 1.0.3-0.rc2
  263. - update to 1.0.3rc2, fixes bug with HAL & encrypted devices (#182658)
  264. * Wed Feb 22 2006 Bill Nottingham <notting@redhat.com> 1.0.3-0.rc1
  265. - update to 1.0.3rc1, reverts changes to default encryption type
  266. * Tue Feb 21 2006 Bill Nottingham <notting@redhat.com> 1.0.2-1
  267. - update to 1.0.2, fix incompatiblity with old cryptsetup (#176726)
  268. * Mon Feb 20 2006 Karsten Hopp <karsten@redhat.de> 1.0.1-5
  269. - BuildRequires: libselinux-devel
  270. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.0.1-4.2.1
  271. - bump again for double-long bug on ppc(64)
  272. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.0.1-4.2
  273. - rebuilt for new gcc4.1 snapshot and glibc changes
  274. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  275. - rebuilt
  276. * Mon Dec 5 2005 Bill Nottingham <notting@redhat.com> 1.0.1-4
  277. - rebuild against new libdevmapper
  278. * Thu Oct 13 2005 Florian La Roche <laroche@redhat.com>
  279. - add -lsepol to rebuild on current fc5
  280. * Mon Aug 22 2005 Karel Zak <kzak@redhat.com> 1.0.1-2
  281. - fix cryptsetup help for isLuks action
  282. * Fri Jul 1 2005 Bill Nottingham <notting@redhat.com> 1.0.1-1
  283. - update to 1.0.1 - fixes incompatiblity with previous cryptsetup for
  284. piped passwords
  285. * Thu Jun 16 2005 Bill Nottingham <notting@redhat.com> 1.0-2
  286. - add patch for 32/64 bit compatibility (#160445, <redhat@paukstadt.de>)
  287. * Tue Mar 29 2005 Bill Nottingham <notting@redhat.com> 1.0-1
  288. - update to 1.0
  289. * Thu Mar 10 2005 Bill Nottingham <notting@redhat.com> 0.993-1
  290. - switch to cryptsetup-luks, for LUKS support
  291. * Tue Oct 12 2004 Bill Nottingham <notting@redhat.com> 0.1-4
  292. - oops, make that *everything* static (#129926)
  293. * Tue Aug 31 2004 Bill Nottingham <notting@redhat.com> 0.1-3
  294. - link some things static, move to /sbin (#129926)
  295. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  296. - rebuilt
  297. * Fri Apr 16 2004 Bill Nottingham <notting@redhat.com> 0.1-1
  298. - initial packaging