Cython-vl.spec 3.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108
  1. Summary: A language for writing Python extension modules
  2. Summary(ja): Python 拡張モジュールを簡単に作成するためのプログラミング言語
  3. Name: Cython
  4. Version: 0.29.13
  5. Release: 1%{?_dist_release}
  6. Group: Development/Languages
  7. License: Apache
  8. URL: http://cython.org/
  9. Source0: http://cython.org/release/%{name}-%{version}.tar.gz
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  11. BuildRequires: python-devel
  12. BuildRequires: python-setuptools
  13. BuildRequires: python-rpm-macros
  14. Vendor: Project Vine
  15. Distribution: Vine Linux
  16. %description
  17. Cython is a language that makes writing C extensions for the Python language as easy as Python itself. Cython is based on the well-known Pyrex, but supports more cutting edge functionality and optimizations.
  18. The Cython language is very close to the Python language, but Cython additionally supports calling C functions and declaring C types on variables and class attributes.
  19. This allows the compiler to generate very efficient C code from Cython code.
  20. The generated C code compiles with Python 2.4 and later (including Python 3).
  21. This makes Cython the ideal language for wrapping external C libraries, and for fast C modules that speed up the execution of Python code.
  22. %package -n python3-Cython
  23. Summary: A language for writing Python extension modules
  24. Summary(ja): Python 拡張モジュールを簡単に作成するためのプログラミング言語
  25. Group: Development/Languages
  26. BuildRequires: python3-devel
  27. BuildRequires: python3-setuptools
  28. BuildRequires: python3-rpm-macros
  29. %description -n python3-Cython
  30. Cython is a language that makes writing C extensions for the Python language as easy as Python itself. Cython is based on the well-known Pyrex, but supports more cutting edge functionality and optimizations.
  31. The Cython language is very close to the Python language, but Cython additionally supports calling C functions and declaring C types on variables and class attributes.
  32. This allows the compiler to generate very efficient C code from Cython code.
  33. The generated C code compiles with Python 2.4 and later (including Python 3).
  34. This makes Cython the ideal language for wrapping external C libraries, and for fast C modules that speed up the execution of Python code.
  35. %prep
  36. %setup -q
  37. %build
  38. %{py_build}
  39. %{py3_build}
  40. %install
  41. rm -rf $RPM_BUILD_ROOT
  42. %{py_install}
  43. %{py3_install}
  44. %clean
  45. rm -rf $RPM_BUILD_ROOT
  46. %files
  47. %defattr(-,root,root,-)
  48. %license COPYING.txt LICENSE.txt
  49. %doc README.txt USAGE.txt
  50. #{_bindir}/cygdb
  51. #{_bindir}/cython
  52. #{_bindir}/cythonize
  53. %{python_sitearch}/Cython
  54. %{python_sitearch}/pyximport
  55. %{python_sitearch}/Cython-%{version}-*-info
  56. %{python_sitearch}/cython.*
  57. %files -n python3-Cython
  58. %license COPYING.txt LICENSE.txt
  59. %doc README.txt USAGE.txt
  60. %{_bindir}/cygdb
  61. %{_bindir}/cython
  62. %{_bindir}/cythonize
  63. %{python3_sitearch}/*
  64. %changelog
  65. * Fri Oct 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.29.13-1
  66. - new upstream release.
  67. * Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.23.4-1
  68. - new upstream release
  69. * Sun Jul 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.22.1-1
  70. - new upstream release
  71. * Wed Feb 4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.21.2-1
  72. - new upstream release
  73. - moved to Development/Languages Group
  74. * Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.19.2-1
  75. - new upstream release
  76. * Thu Mar 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.18-1
  77. - new upstream release
  78. * Sun Apr 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.15.1-1
  79. - initial build for Vine Linux