ConsoleKit-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347
  1. %define glib2_version 2.26.0
  2. %define dbus_version 1.4.14
  3. %define dbus_glib_version 0.94
  4. %define polkit_version 0.101
  5. Summary: System daemon for tracking users, sessions and seats
  6. Summary(ja): ユーザ、セッションおよび座席を捕捉するシステムデーモン
  7. Name: ConsoleKit
  8. Version: 0.4.6
  9. Release: 3%{?_dist_release}
  10. License: GPLv2+
  11. Group: System Environment/Daemons
  12. URL: http://www.freedesktop.org/wiki/Software/ConsoleKit
  13. Source0: http://people.freedesktop.org/~mccann/dist/ConsoleKit-%{version}.tar.xz
  14. # Convert to new upstart syntax
  15. Patch0: ConsoleKit-0.4.1-upstart06.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  17. BuildRequires: glib2-devel >= %{glib2_version}
  18. BuildRequires: dbus-devel >= %{dbus_version}
  19. BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
  20. BuildRequires: polkit-devel >= %{polkit_version}
  21. BuildRequires: eudev-libudev-devel
  22. BuildRequires: libacl-devel
  23. BuildRequires: pam-devel
  24. BuildRequires: libX11-devel
  25. BuildRequires: zlib-devel
  26. BuildRequires: xmlto
  27. BuildRequires: autoconf, automake
  28. Requires: dbus
  29. Requires: dbus-glib
  30. Vendor: Project Vine
  31. Distribution: Vine Linux
  32. Packager: daisuke, takemikaduchi
  33. %description
  34. ConsoleKit is a system daemon for tracking what users are logged
  35. into the system and how they interact with the computer (e.g.
  36. which keyboard and mouse they use).
  37. It provides asynchronous notification via the system message bus.
  38. %package x11
  39. Summary: X11-requiring add-ons for ConsoleKit
  40. Summary(ja): X11 を必要とする ConsoleKit アドオン
  41. License: GPLv2+
  42. Group: System Environment/Daemons
  43. Requires: %{name} = %{version}-%{release}
  44. Requires: libX11
  45. %description x11
  46. ConsoleKit contains some tools that require Xlib to be installed,
  47. those are in this separate package so server systems need not install
  48. X. Applications (such as xorg-x11-xinit) and login managers (such as
  49. gdm) that need to register their X sessions with ConsoleKit needs to
  50. have a Requires: for this package.
  51. %package libs
  52. Summary: ConsoleKit libraries
  53. Summary(ja): ConsoleKit ライブラリ
  54. License: MIT
  55. Group: System Environment/Libraries
  56. Requires: pam
  57. Requires: dbus
  58. %description libs
  59. Libraries and a PAM module for interacting with ConsoleKit.
  60. %package devel
  61. Summary: Development libraries and headers for ConsoleKit
  62. Summary(ja): ConsoleKit の開発用ライブラリおよびヘッダファイル
  63. License: MIT
  64. Group: Development/Libraries
  65. Requires: %{name} = %{version}-%{release}
  66. Requires: dbus-devel
  67. Requires: pkgconfig
  68. %description devel
  69. Headers, libraries and API docs for ConsoleKit
  70. %package docs
  71. Summary: Developer documentation for ConsoleKit
  72. Summary(ja): ConsoleKit の開発用ドキュメント
  73. Group: Documentation
  74. Requires: %{name} = %{version}-%{release}
  75. %description docs
  76. Developer documentation for ConsoleKit.
  77. %prep
  78. %setup -q
  79. %patch0 -p1 -b .upstart06
  80. %build
  81. autoreconf -i -f
  82. # To avoid build failure, skip validation at xmlto
  83. export XMLTO_FLAGS="--skip-validation"
  84. %configure \
  85. --with-pid-file=%{_localstatedir}/run/console-kit-daemon.pid \
  86. --enable-pam-module \
  87. --with-pam-module-dir=/%{_lib}/security \
  88. --enable-udev-acl \
  89. --enable-docbook-docs \
  90. --docdir=%{_datadir}/doc/%{name}-%{version}
  91. make
  92. %install
  93. rm -rf $RPM_BUILD_ROOT
  94. make install DESTDIR=$RPM_BUILD_ROOT
  95. rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
  96. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  97. rm -f $RPM_BUILD_ROOT/%{_lib}/security/*.a
  98. rm -f $RPM_BUILD_ROOT/%{_lib}/security/*.la
  99. # make sure we don't package a history log
  100. rm -f $RPM_BUILD_ROOT/%{_var}/log/ConsoleKit/history
  101. cp AUTHORS COPYING ChangeLog HACKING INSTALL NEWS README TODO \
  102. $RPM_BUILD_ROOT%{_datadir}/doc/%{name}-%{version}
  103. #mkdir -p %{buildroot}%{_sysconfdir}/init.d
  104. #install -m 755 %{SOURCE10} %{buildroot}%{_sysconfdir}/init.d/ConsoleKit
  105. %clean
  106. rm -rf $RPM_BUILD_ROOT
  107. %post
  108. if [ -f /var/log/ConsoleKit/history ]; then
  109. chmod a+r /var/log/ConsoleKit/history
  110. fi
  111. %post libs -p /sbin/ldconfig
  112. %postun libs -p /sbin/ldconfig
  113. %files
  114. %defattr(-,root,root,-)
  115. %doc %dir %{_datadir}/doc/%{name}-%{version}
  116. %doc %{_datadir}/doc/%{name}-%{version}/[A-Z]*
  117. %{_sysconfdir}/dbus-1/system.d/*
  118. %{_datadir}/dbus-1/system-services/*.service
  119. %{_datadir}/polkit-1/actions/*.policy
  120. /lib/udev/rules.d/*.rules
  121. /lib/udev/udev-acl
  122. %dir %{_sysconfdir}/ConsoleKit
  123. %dir %{_sysconfdir}/ConsoleKit/seats.d
  124. %dir %{_sysconfdir}/ConsoleKit/run-seat.d
  125. %dir %{_sysconfdir}/ConsoleKit/run-session.d
  126. %dir %{_prefix}/lib/ConsoleKit
  127. %dir %{_prefix}/lib/ConsoleKit/scripts
  128. %dir %{_prefix}/lib/ConsoleKit/run-seat.d
  129. %dir %{_prefix}/lib/ConsoleKit/run-session.d
  130. %dir %{_var}/run/ConsoleKit
  131. %attr(755,root,root) %dir %{_var}/log/ConsoleKit
  132. %config %{_sysconfdir}/ConsoleKit/seats.d/00-primary.seat
  133. %{_sbindir}/console-kit-daemon
  134. %{_sbindir}/ck-log-system-restart
  135. %{_sbindir}/ck-log-system-start
  136. %{_sbindir}/ck-log-system-stop
  137. %{_bindir}/ck-history
  138. %{_bindir}/ck-launch-session
  139. %{_bindir}/ck-list-sessions
  140. %{_prefix}/lib/ConsoleKit/run-seat.d/udev-acl.ck
  141. %{_prefix}/lib/ConsoleKit/scripts/*
  142. %files x11
  143. %defattr(-,root,root,-)
  144. %{_libexecdir}/*
  145. %files libs
  146. %defattr(-,root,root,-)
  147. %{_libdir}/lib*.so.*
  148. /%{_lib}/security/*.so
  149. %{_mandir}/man8/pam_ck_connector.8.gz
  150. %files devel
  151. %defattr(-,root,root,-)
  152. %{_libdir}/lib*.so
  153. %{_libdir}/pkgconfig/*
  154. %{_includedir}/*
  155. %{_datadir}/dbus-1/interfaces/org.freedesktop.ConsoleKit.*.xml
  156. %files docs
  157. %defattr(-,root,root,-)
  158. %doc %dir %{_datadir}/doc/%{name}-%{version}/spec
  159. %doc %{_datadir}/doc/%{name}-%{version}/spec/*
  160. %changelog
  161. * Mon Jan 26 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.4.6-3
  162. - moved docs subpackage to Documentation Group
  163. - added --skip-validation option to xmlto
  164. * Tue Jun 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.6-2
  165. - change BuildRequires: eudev-libudev-devel instead of libudev-devel
  166. * Sun Nov 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.6-1
  167. - new upstream release
  168. - remove Patch1 (ConsoleKit-0.4.5-git20120320.patch)
  169. * Sat Nov 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.5-3
  170. - add "--enable-udev-acl" option
  171. - add BR: libudev-devel, libacl-devel
  172. - add BR: autoconf, automake
  173. * Sat Oct 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.5-2
  174. - add Patch0 (ConsoleKit-0.4.1-upstart06.patch)
  175. - add Patch1 (ConsoleKit-0.4.5-git20120320.patch)
  176. * Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.5-1
  177. - new upstream release
  178. * Thu Dec 30 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.3-1
  179. - new upstream release
  180. * Wed Oct 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.2-1
  181. - new upstream release
  182. * Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.4.1-2
  183. - rebuilt with rpm-4.8.1 for pkg-config
  184. * Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.1-1
  185. - new upstream release
  186. * Mon May 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.0-6
  187. - add patch11 to enable policy access to the Manager.GetSessions
  188. method in the default ConsoleKit.conf
  189. https://bugs.freedesktop.org/show_bug.cgi?id=20471
  190. http://bugzilla.gnome.org/show_bug.cgi?id=580259
  191. * Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.0-5
  192. - add patch10 to fix dbus permissions
  193. https://bugs.freedesktop.org/show_bug.cgi?id=19020
  194. (This patch is already committed to master)
  195. * Sat Feb 14 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.0-4
  196. - changed Group to System Environment/Daemons
  197. - changed x11 subpackage's Group to System Environment/Daemons
  198. - changed libs subpackage's Group to System Environment/Libraries
  199. - added %%post, %%postun section fo libs subpackage
  200. * Sat Aug 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.3.0-3
  201. - changed %%{_libdir}/ConsoleKit to %%{_prefix}/lib/ConsoleKit
  202. * Thu Aug 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.0-2
  203. - remove init script, console-kit-daemon is now launched from dbus.
  204. * Mon Aug 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.0-1
  205. - new upstream release
  206. * Tue Jul 1 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.2.10-3
  207. - fix Japanese description
  208. - spec in UTF-8
  209. - add Source10 (init.d script for console-kit-daemon);
  210. add %%post/%%preun scripts, until "initng" being introduced to Vine
  211. * Wed Jun 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.2.10-2
  212. - rebuilt with PolicyKit-0.8
  213. * Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.10-1
  214. - new upstream release
  215. - new versioning policy
  216. * Tue Jan 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-0vl1
  217. - initial build for Vine Linux
  218. * Mon Oct 22 2007 Matthias Clasen <mclasen@redhat.com> - 0.2.3-2
  219. - Rebuild against new dbus-glib
  220. * Tue Sep 18 2007 Matthias Clasen <mclasen@redhat.com> - 0.2.3-1
  221. - Update to 0.2.3
  222. * Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 0.2.2-1
  223. - Update to 0.2.2
  224. * Mon Aug 6 2007 Matthias Clasen <mclasen@redhat.com> - 0.2.1-4
  225. - Update license field
  226. * Fri Jul 6 2007 Matthias Clasen <mclasen@redhat.com> - 0.2.1-3
  227. - Add LSB header to init script (#246894)
  228. * Mon Apr 16 2007 David Zeuthen <davidz@redhat.com> - 0.2.1-2
  229. - Set doc directory correctly
  230. * Mon Apr 16 2007 David Zeuthen <davidz@redhat.com> - 0.2.1-1
  231. - Update to upstream release 0.2.1
  232. - Drop the patch to daemonize properly as that was merged upstream
  233. * Mon Apr 02 2007 David Zeuthen <davidz@redhat.com> - 0.2.1-0.git20070402
  234. - Update to git snapshot to get a lot of bug fixes
  235. - Use libX11 rather than gtk2 to verify X11 sessions; update BR and R
  236. - Split X11-using bits into a new subpackage ConsoleKit-x11 (#233982)
  237. - Use correct location for PAM module on 64-bit (#234545)
  238. - Build developer documentation and put them in ConsoleKit-docs
  239. * Mon Mar 19 2007 David Zeuthen <davidz@redhat.com> - 0.2.0-2
  240. - BR gtk2-devel and make ConsoleKit Require gtk2 (could just be
  241. libX11 with a simple patch)
  242. * Mon Mar 19 2007 David Zeuthen <davidz@redhat.com> - 0.2.0-1
  243. - Update to upstream release 0.2.0
  244. - Daemonize properly (#229206)
  245. * Sat Mar 3 2007 David Zeuthen <davidz@redhat.com> - 0.1.3-0.git20070301.1
  246. - Allow caller to pass uid=0 in libck-connector
  247. * Thu Mar 1 2007 David Zeuthen <davidz@redhat.com> - 0.1.3-0.git20070301
  248. - Update to git snapshot
  249. - Drop all patches as they are committed upstream
  250. - New tool ck-list-sessions
  251. - New -libs subpackage with run-time libraries and a PAM module
  252. - New -devel subpackage with headers
  253. * Tue Feb 6 2007 David Zeuthen <davidz@redhat.com> - 0.1.0-5%{?dist}
  254. - Start ConsoleKit a bit earlier so it starts before HAL (98 -> 90)
  255. - Minimize stack usage so VIRT size is more reasonable (mclasen)
  256. - Make session inactive when switching to non-session (davidz)
  257. * Fri Jan 12 2007 Matthias Clasen <mclasen@redhat.com> - 0.1.0-4
  258. - Don't mark initscripts %%config
  259. - Use proper lock and pid ile names
  260. * Fri Jan 12 2007 Matthias Clasen <mclasen@redhat.com> - 0.1.0-3
  261. - More package review feedback
  262. * Fri Jan 12 2007 Matthias Clasen <mclasen@redhat.com> - 0.1.0-2
  263. - Incorporate package review feedback
  264. * Thu Jan 11 2007 Matthias Clasen <mclasen@redhat.com> - 0.1.0-1
  265. - Update to the first public release 0.1.0
  266. - Some spec cleanups
  267. * Mon Oct 23 2006 David Zeuthen <davidz@redhat.com> - 0.0.3-1
  268. - Initial build.