gnome-python-vl.spec 8.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273
  1. %define pyver %(python -c 'import sys;print(sys.version[0:3])')
  2. # libzvt is in Extras but not Core
  3. %define buildzvt 0
  4. Summary: The sources for the PyGNOME Python extension module.
  5. Name: gnome-python
  6. Version: 2.28.1
  7. Release: 2%{?_dist_release}
  8. Source: ftp://ftp.gnome.org/pub/GNOME/sources/gnome-python/2.28/gnome-python-%{version}.tar.bz2
  9. License: LGPL
  10. Group: Development/Libraries
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: pygtk2-devel >= 2.14.0
  13. BuildRequires: python-devel >= 2.5
  14. BuildRequires: pyorbit-devel >= 2.24.0
  15. BuildRequires: pygobject-devel >= 2.17.0
  16. BuildRequires: libbonobo-devel >= 2.24.1
  17. BuildRequires: libbonoboui-devel >= 2.24.1
  18. BuildRequires: libgnome-devel >= 2.26.0
  19. BuildRequires: gnome-vfs2-devel >= 2.24.0
  20. BuildRequires: GConf2-devel >= 2.26.0
  21. BuildRequires: libgnomeui-devel >= 2.8.0
  22. %if %{buildzvt}
  23. BuildRequires: libzvt-devel >= 2.0.2
  24. %endif
  25. ## needed for automake/autoconf to work right with multilib python
  26. #BuildRequires: automake >= 1.9.6, libtool, autoconf
  27. #Obsoletes: gnome-python-applet
  28. Obsoletes: gnome-python-bonobo
  29. Obsoletes: gnome-python-canvas
  30. Obsoletes: gnome-python-gconf
  31. #Obsoletes: gnome-python-gnomeprint
  32. Obsoletes: gnome-python-gnomevfs
  33. #Obsoletes: gnome-python-gtkhtml2
  34. Obsoletes: gnome-python-nautilus
  35. %if %{buildzvt}
  36. Obsoletes: gnome-python-zvt
  37. %endif
  38. Requires: pyorbit >= 2.24.0
  39. Requires: pygtk2 >= 2.14.1
  40. %description
  41. The gnome-python package contains the source packages for the Python
  42. bindings for GNOME called PyGNOME.
  43. PyGNOME is an extension module for Python that provides access to the
  44. base GNOME libraries, so you have access to more widgets, a simple
  45. configuration interface, and metadata support.
  46. %package devel
  47. Summary: Development files for building add-on libraries
  48. Group: Development/Libraries
  49. Requires: %{name} = %{version}-%{release}
  50. Requires: gnome-vfs2-devel >= 2.24.0
  51. Requires: pkgconfig
  52. Requires: python-devel >= %{pyver}
  53. %description devel
  54. This package contains files required to build wrappers for GNOME add-on
  55. libraries so that they interoperate with gnome-python.
  56. %prep
  57. %setup -q -n gnome-python-%{version}
  58. %build
  59. # libtoolize --force
  60. # aclocal && automake && autoconf
  61. #export PYTHON=/usr/bin/python%{pyver}
  62. #CFLAGS="$RPM_OPT_FLAGS -L/usr/lib/python%{pyver}/config" \
  63. # ./configure --prefix=%{_prefix}
  64. %configure
  65. make
  66. %install
  67. rm -rf $RPM_BUILD_ROOT
  68. make install DESTDIR=$RPM_BUILD_ROOT
  69. find $RPM_BUILD_ROOT -name '*.la' -exec rm {} \;
  70. %clean
  71. rm -rf $RPM_BUILD_ROOT
  72. %files
  73. %defattr(-,root,root,-)
  74. %doc AUTHORS COPYING ChangeLog INSTALL NEWS README examples
  75. %{_libdir}/gnome-vfs-2.0/modules/libpythonmethod.so
  76. %{_libdir}/python?.?/site-packages/gtk-2.0/bonobo
  77. %{_libdir}/python?.?/site-packages/gtk-2.0/gconf.so
  78. %{_libdir}/python?.?/site-packages/gtk-2.0/gnome
  79. %{_libdir}/python?.?/site-packages/gtk-2.0/gnomecanvas.so
  80. %{_libdir}/python?.?/site-packages/gtk-2.0/gnomevfs
  81. %if %{buildzvt}
  82. %{_libdir}/python?.?/site-packages/gtk-2.0/zvt.so
  83. %endif
  84. %{_datadir}/pygtk/*
  85. %files devel
  86. %defattr(-,root,root,-)
  87. %{_includedir}/gnome-python-2.0
  88. %{_libdir}/pkgconfig/gnome-python-2.0.pc
  89. %{_datadir}/gtk-doc/html/pygnomevfs
  90. ## old versions did not have .pyc and .pyo files in their file list
  91. ## remove them now, or bad things will now happen because of the new
  92. ## paths. This trigger must remain until upgrading from RHL 8.0 is no
  93. ## longer supported.
  94. #%triggerun bonobo -- gnome-python-bonobo < 1.99.14-5
  95. #rm -f /usr/lib/python%{pyver}/site-packages/bonobo/__init__.{pyc,pyo}
  96. %changelog
  97. * Sat Jun 05 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 2.28.1-2
  98. - add BuildRequires: libgnomeui-devel >= 2.8.0
  99. * Fri Apr 09 2010 Shu KONNO <owa@bg.wakwak.com> 2.28.1-1
  100. - new upstream release
  101. - dropt "Obsoletes: gnome-python-gtkhtml2" (provided by gnome-python-extras)
  102. * Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.0-2
  103. - rebuild for python-2.6
  104. * Sun Nov 1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
  105. - new upstream release
  106. * Sun Apr 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
  107. - new upstream release
  108. - add Requires: pygtk2, pyorbit
  109. * Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
  110. - new upstream release
  111. * Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
  112. - new upstream release
  113. * Sat Jul 19 2008 Shu KONNO <owa@bg.wakwak.com> 2.22.0-2vl5
  114. - rebuilt with python-2.5
  115. * Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
  116. - new upstream release
  117. - split devel package
  118. * Wed Jan 9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-0vl1
  119. - new upstream release
  120. * Sat Jul 7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl1
  121. - new upstream release
  122. * Mon May 8 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.4-0vl1
  123. - new upstream release 2.12.4
  124. * Thu Oct 13 2005 Shu KONNO <owa@bg.wakwak.com> 2.12.1-0vl1
  125. - new upstream release 2.12.1
  126. - obsolete all sub-packages
  127. * Sat Jun 11 2005 Shu KONNO <owa@bg.wakwak.com> 2.10.0-0vl2
  128. - dropped "Obsoletes: gnome-python-applet, -capplet, -nautilus,
  129. -gtkhtml2, -gnomeprint" because they moved to gnome-python-extras srpm
  130. * Mon Apr 04 2005 Shu KONNO <owa@bg.wakwak.com> 2.10.0-0vl1
  131. - new upstream release 2.10.0
  132. - rebuilt with python 2.4.1
  133. - dropped gnome-python-applet
  134. - dropped gnome-python-capplet
  135. - dropped gnome-python-nautilus
  136. - dropped gnome-python-gtkhtml2
  137. - dropped gnome-python-gnomeprint
  138. see also ftp://ftp.gnome.org/pub/GNOME/sources/gnome-python-extras
  139. * Mon Dec 27 2004 Kazuhisa TAKEI <takei@vinelinux.org> 2.6.2-0vl3
  140. - fixed BuildRequires/Requires for pyorbit's version
  141. * Mon Dec 27 2004 Kazuhisa TAKEI <takei@vinelinux.org> 2.6.2-0vl1
  142. - new upstream release
  143. * Thu Jun 17 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.2-0vl1
  144. - new upstream release
  145. * Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 2.0.0-2vl2
  146. - rebuild with python-2.3.3-0vl1
  147. * Sat Apr 10 2004 Shu KONNO <owa@bg.wakwak.com> 2.0.0-2vl1.1
  148. - rebuild with python-2.3.3-0vl0.3 (for TestPkg)
  149. * Sat Jan 17 2004 Tomoya TAKA <taka@vinelinux.org> 2.0.0-2vl1
  150. - sync with Fedora 2.0.0-2
  151. * Thu Oct 2 2003 Matt Wilson <msw@redhat.com> 2.0.0-2
  152. - fix segv in gnome.ui.About() (#104396)
  153. - rebuild with new toolchain and pyorbit
  154. - s/Copyright/License/
  155. * Fri Sep 12 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.0.0-1vl1
  156. - build for Vine Linux
  157. * Thu Sep 4 2003 Jeremy Katz <katzj@redhat.com> 2.0.0-1
  158. - 2.0.0
  159. * Wed Aug 20 2003 Jeremy Katz <katzj@redhat.com> 1.99.16-1
  160. - update to 1.99.16
  161. - add gnomeprint subpackage
  162. - don't double include the gnome-vfs module (#102074)
  163. * Tue Aug 5 2003 Elliot Lee <sopwith@redhat.com> 1.99.14-7
  164. - Fix libtool
  165. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  166. - rebuilt
  167. * Thu Feb 6 2003 Matt Wilson <msw@redhat.com> 1.99.14-5
  168. - added a trigger to remove left-over bonobo .pyc and .pyo files (#79652)
  169. * Thu Feb 6 2003 Mihai Ibanescu <misa@redhat.com> 1.99.14-4
  170. - rebuilt against new python
  171. * Tue Jan 28 2003 Jeremy Katz <katzj@redhat.com> 1.99.14-3
  172. - libdir-ify
  173. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  174. - rebuilt
  175. * Fri Dec 27 2002 Jeremy Katz <katzj@redhat.com> 1.99.14-1
  176. - update to 1.99.14
  177. * Fri Dec 13 2002 Jeremy Katz <katzj@redhat.com>
  178. - update to 1.99.13
  179. - add gnomevfs subpackage
  180. * Thu Oct 31 2002 Matt Wilson <msw@redhat.com>
  181. - use %%configure
  182. * Wed Oct 30 2002 Matt Wilson <msw@redhat.com>
  183. - add gnome-python-2.0.pc to file list
  184. * Wed Aug 28 2002 Matt Wilson <msw@redhat.com>
  185. - bind gnome_client_set_*_command
  186. * Wed Aug 28 2002 Tim Powers <timp@redhat.com>
  187. - rebuilt
  188. * Tue Aug 20 2002 Matt Wilson <msw@redhat.com>
  189. - obsolete pygtk-applet (#69830)
  190. * Thu Aug 1 2002 Jonathan Blandford <jrb@redhat.com>
  191. - make the GnomeDruid's fields accessible from python
  192. * Tue Jul 30 2002 Matt Wilson <msw@redhat.com>
  193. - official 1.99.11 release
  194. * Thu May 30 2002 Matt Wilson <msw@redhat.com>
  195. - s/Gconf/GConf/
  196. * Thu May 30 2002 Jeremy Katz <katzj@redhat.com>
  197. - add gtkhtml2 and gconf subpackages
  198. * Wed May 29 2002 Bill Nottingham <notting@redhat.com>
  199. - add some defattrs
  200. * Fri May 24 2002 Matt Wilson <msw@redhat.com>
  201. - added bonobo, nautilus subpackages. re-enabled applet subpackage
  202. * Mon Nov 26 2001 Matt Wilson <msw@redhat.com>
  203. - subpackages will need __init__ included in them
  204. * Thu Oct 18 2001 Matt Wilson <msw@redhat.com>
  205. - doesn't obsolete pygnome - it can be installed side-by-side
  206. - added _gnomemodule.so to base package filelist
  207. * Mon Oct 15 2001 Matt Wilson <msw@redhat.com>
  208. - added __init__ files to gnome-python main package
  209. * Mon Oct 8 2001 Matt Wilson <msw@redhat.com>
  210. - new gnome-python package based on old pygtk package.