rhythmbox-vl.spec 20 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641
  1. # -*- coding: utf-8-unix -*-
  2. %define desktop_file_utils_version 0.9
  3. %define enable_DLNA_UPnP 0
  4. Summary: Music Management Application
  5. Summary(ja): 音楽管理アプリケーション
  6. Name: rhythmbox
  7. Version: 3.2
  8. Release: 1%{?_dist_release}
  9. License: GPL2+ with exceptions and GFDL
  10. Group: Applications/Multimedia
  11. URL: http://projects.gnome.org/rhythmbox/
  12. Source0: http://download.gnome.org/sources/${name}/3.2/%{name}-%{version}.tar.xz
  13. Source101: rhythmbox-png.tar.bz2
  14. Patch0: rhythmbox-3.0-disable-python3.patch
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: gtk3-devel
  17. BuildRequires: avahi-glib-devel >= 0.6
  18. BuildRequires: brasero-devel >= 2.32.0
  19. BuildRequires: dbus-glib-devel
  20. BuildRequires: gstreamer1-plugins-base-devel
  21. BuildRequires: json-glib-devel
  22. BuildRequires: libSM-devel
  23. BuildRequires: libgnome-keyring-devel >= 2.30.0
  24. BuildRequires: libgpod-devel
  25. BuildRequires: eudev-libgudev1-devel
  26. BuildRequires: libmusicbrainz3-devel >= 3.0.2
  27. BuildRequires: libnotify-devel
  28. BuildRequires: libsoup-devel
  29. BuildRequires: pygobject3-devel
  30. BuildRequires: totem-pl-parser-devel
  31. BuildRequires: WebKit3-gtk-devel
  32. BuildRequires: libpeas-devel
  33. BuildRequires: clutter-gtk-devel
  34. BuildRequires: clutter-gst-devel
  35. BuildRequires: libmx-devel
  36. BuildRequires: check-devel
  37. BuildRequires: libmtp-devel
  38. BuildRequires: libtdb-devel
  39. BuildRequires: grilo-devel
  40. BuildRequires: libdmapsharing-devel
  41. BuildRequires: lirc
  42. BuildRequires: gnome-doc-utils >= 0.3.2
  43. BuildRequires: yelp-tools
  44. Requires: brasero
  45. Requires: libgnome-keyring
  46. %if %{enable_DLNA_UPnP}
  47. Requires: python-Coherence
  48. %endif
  49. Requires: desktop-file-utils >= %{desktop_file_utils_version}
  50. # # gstreamer-plugins-ffmpeg and gstreamer-plugins-ugly package provided by
  51. # # self-build-gstreamer-plugins-ffmpeg and self-build-gstreamer-plugins-ugly,
  52. # # respectively.
  53. # Requires: self-build-gstreamer-plugins-ffmpeg
  54. # Requires: self-build-gstreamer-plugins-ugly
  55. Vendor: Project Vine
  56. Distribution: Vine Linux
  57. %description
  58. Rhythmbox is an integrated music management application based on the powerful
  59. GStreamer media framework. It has a number of features, including an easy to
  60. use music browser, searching and sorting, comprehensive audio format support
  61. through GStreamer, Internet Radio support, playlists and more.
  62. Rhythmbox is extensible through a plugin system.
  63. %description -l ja
  64. Rhythmbox は、強力な GStreamer メディアフレームワークに基づいている
  65. 統合音楽管理アプリケーションです。
  66. 見やすいユーザインターフェースを備え、検索や整列ができ、
  67. GStreamer により数多くの音声フォーマットをサポート、
  68. インターネットラジオをサポート、プレイリスト管理などの
  69. 数多くの特徴を持ちます。
  70. %package devel
  71. Summary: Development tools for rhythmbox applications.
  72. Summary(ja): rhythmbox アプリケーションの開発用ファイル
  73. Group: Development/Libraries
  74. Requires: %{name} = %{version}-%{release}
  75. Requires: pkgconfig
  76. Requires: libxml2-devel
  77. Requires: glib2-devel
  78. Requires: gtk3-devel
  79. Requires: libsoup-devel
  80. Requires: totem-pl-parser-devel
  81. Requires: gstreamer1-devel
  82. %description devel
  83. Header files and libraries for building a extension library for the rhythmbox.
  84. %description devel -l ja
  85. %prep
  86. %setup -q
  87. %patch0 -p1
  88. tar xjf %{SOURCE101}
  89. %build
  90. autoreconf -if
  91. intltoolize --force --copy
  92. %configure --with-ipod \
  93. --with-mtp \
  94. --enable-lirc \
  95. --disable-python \
  96. --disable-vala \
  97. --disable-browser-plugin \
  98. --disable-static \
  99. --enable-browser-plugin \
  100. --without-hal
  101. %__make %{?_smp_mflags}
  102. %install
  103. %__rm -rf $RPM_BUILD_ROOT
  104. %__make install DESTDIR=$RPM_BUILD_ROOT
  105. %__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/*.{a,la}
  106. %__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/librb-nautilus-context-menu.so
  107. %__rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
  108. %__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*.{a,la}
  109. %__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*/*.{a,la}
  110. %__rm -f $RPM_BUILD_ROOT%{_libdir}/librhythmbox-core.{a,la}
  111. %__rm -f $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins/*.{a,la}
  112. ## Don't package DLNA/UPnP plugin
  113. %if !%{enable_DLNA_UPnP}
  114. %__rm -rf $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/upnp_coherence
  115. %endif
  116. %find_lang %{name} --all-name --with-gnome
  117. # Don't package api docs
  118. %__rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc/
  119. # And don't package vala
  120. %__rm -f %{buildroot}%{_libdir}/rhythmbox/plugins/libsample-vala.so \
  121. %{buildroot}%{_libdir}/rhythmbox/plugins/sample-vala.rb-plugin
  122. # remove sample plugins
  123. rm -rf $RPM_BUILD_ROOT/%{_libdir}/%{name}/sample-plugins
  124. %clean
  125. %__rm -rf $RPM_BUILD_ROOT
  126. %post
  127. /sbin/ldconfig
  128. update-desktop-database -q
  129. touch --no-create %{_datadir}/icons/hicolor
  130. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  131. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  132. fi
  133. %postun
  134. /sbin/ldconfig
  135. update-desktop-database -q
  136. touch --no-create %{_datadir}/icons/hicolor
  137. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  138. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  139. fi
  140. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  141. %posttrans
  142. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  143. %files -f %{name}.lang
  144. %defattr(-, root, root)
  145. %doc AUTHORS COPYING ChangeLog README NEWS
  146. %{_bindir}/*
  147. %{_libdir}/girepository-1.0/*.typelib
  148. %{_libdir}/lib*.so.*
  149. %{_libdir}/mozilla/plugins/librhythmbox-itms-detection-plugin.so
  150. %{_libdir}/rhythmbox/plugins
  151. %{_datadir}/appdata/rhythmbox.appdata.xml
  152. %{_datadir}/applications/rhythmbox.desktop
  153. %{_datadir}/applications/rhythmbox-device.desktop
  154. %{_datadir}/dbus-1/services/org.gnome.Rhythmbox3.service
  155. %{_datadir}/glib-2.0/schemas/org.gnome.rhythmbox.gschema.xml
  156. %{_datadir}/icons/*
  157. %{_datadir}/rhythmbox
  158. %{_mandir}/man1/*
  159. %{_libexecdir}/rhythmbox-metadata
  160. %files devel
  161. %defattr(-, root, root)
  162. %{_includedir}/%{name}/*
  163. %{_libdir}/*.so
  164. %{_libdir}/pkgconfig/*.pc
  165. %{_datadir}/gir-1.0/*.gir
  166. %changelog
  167. * Sat Apr 04 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2-1
  168. - new upstream release
  169. * Wed Jul 09 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 3.0.3-2
  170. - rebuild with new libimobiledevice
  171. * Sat Jun 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.3-1
  172. - new upstream release
  173. * Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.2-1
  174. - new upstream release
  175. * Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.1-2
  176. - rebuild with VineSeed environment
  177. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.1-1
  178. - new upstream release
  179. * Fri Sep 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0-1
  180. - new upstream release
  181. - add Patch0 (rhythmbox-3.0-disable-python3.patch)
  182. * Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.1-1
  183. - new upstream release
  184. - add BuildRequies: yelp-tools
  185. - change BuildRequires: gstreamer1-plugins-base-devel instead of gstreamer-plugins-base-devel
  186. * Sun Mar 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.98-2
  187. - rebuild with libimobiledevice-1.1.5
  188. * Mon Oct 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.98-1
  189. - new upstream release
  190. - add BuildRequires: grilo-devel, libdmapsharing-devel
  191. * Tue Jun 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.97-1
  192. - new upstream release
  193. * Wed Apr 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.96-1
  194. - new upstream release
  195. * Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.95-1
  196. - new upstream release
  197. - add BuildRequires: gtk3-devel, libtdb-devel, pygobject3-devel
  198. - remove BuildRequires: gnome-vfs2-devel, gstreamer-python-devel, libffi-devel, libgnome-media-profiles-devel, libgnomeui-devel, libsexy-devel, popt-devel, python-devel, pygtk2-devel, sqlite3-devel
  199. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-4
  200. - rebuild with cogl-0.8.0
  201. * Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-3
  202. - rebuild with libnotify-0.7
  203. - change BuildRequires: libmusicbrainz3-devel instead of libmusicbrainz-devel
  204. - change BuildRequires: libgnome-media-profiles-devel instead of gnome-media-devel
  205. - add BuildRequires: WebKit3-gtk-devel, libpeas-devel, clutter-gtk-devel, clutter-gst-devel, libmx-devel
  206. - add Patch0 (rhythmbox-0.13.3-git20110809.patch)
  207. - add Source101 (rhythmbox-png.tar.bz2)
  208. * Fri Aug 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-2
  209. - add BuildRequires: json-glib-devel
  210. - remove unrecognized configure option (--with-dbus, --with-cd-burning, --with-metadata-helper)
  211. * Sun Jan 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-1
  212. - new upstream release
  213. - change BuildRequires: gstreamer-python-devel instead of gstreamer-python
  214. * Sat Nov 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.2-1
  215. - new upstream release
  216. * Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-3
  217. - rebuild with brasero-2.32.0
  218. * Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-2
  219. - rebuild with rpm-4.8.1 for pkg-config file
  220. * Sun Sep 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-1
  221. - new upstream release
  222. - fix %files (add rhythmbox-device.desktop)
  223. * Sun Aug 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.0-1
  224. - new upstream release
  225. - change BuildRequires: gnome-media-devel instead of gnome-media
  226. - add devel package
  227. - drop Patch0
  228. * Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.8-1
  229. - new upstream release
  230. - drop Patch1, Patch2, Patch3
  231. - change BuildRequires: nautilus-cd-burner -> brasero-devel
  232. - change Requires: nautilus-cd-burner -> brasero
  233. - change BuildRequires: hal-devel -> libgudev1-devel
  234. - change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
  235. - change Requires: gnome-keyring -> libgnome-keyring
  236. - add configure option (--without-hal)
  237. * Mon Feb 15 2010 Shu KONNO <owa@bg.wakwak.com> 0.12.6-2
  238. - rebuilt with new environment
  239. * Thu Jan 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.6-1
  240. - new upstream release
  241. - dropped upstreamed/obsolete patches
  242. - added patches applied Fedora development
  243. * Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.5-1
  244. - new upstream release
  245. - added configure options:
  246. --disable-vala
  247. --disable-browser-plugin
  248. * Thu Jul 30 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.2-2
  249. - added Japanese description
  250. * Thu Jul 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.2-1
  251. - new upstream release
  252. - dropped rb-disable-power-plugin-by-default.patch
  253. - added BuildRequires:
  254. - libSM-devel
  255. - gnome-media
  256. * Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.12.1-2
  257. - rebuild with libgpod-0.7.2
  258. * Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.1-1
  259. - new upstream release
  260. - corrected License tag
  261. - dropped rhythmbox-0.11.6-libmtp.patch
  262. - added BuildRequires:
  263. - sqlite3-devel
  264. - libffi-devel
  265. * Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-2
  266. - defined enable_DLNA_UPnP = 0: unpacked DLNA/UPnP plugin
  267. - applied rhythmbox-0.11.6-libmtp.patch
  268. - added Requires:
  269. - libgpod
  270. - libnotify
  271. - libsexy
  272. - lirc
  273. - libmtp
  274. - libgnomeui
  275. - nautilus-cd-burner
  276. - gstreamer-python
  277. - gnome-vfs2
  278. - gnome-themes
  279. - gnome-keyring
  280. - python-Coherence, if enable_DLNA_UPnP = 1
  281. - added BuildRequires:
  282. - libnotify-devel
  283. - libsexy-devel
  284. - lirc
  285. - libmtp-devel
  286. - gnome-vfs2-devel, instead of gnome-vfs2
  287. - gnome-keyring-devel
  288. - dropped --with-internal-libsexy in configure options
  289. - added in configure options:
  290. --with-mtp --with-libnautilus-burn --enable-lirc --disable-static
  291. - added %%preun to remove the schema
  292. * Sun Jan 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-1
  293. - new upstream release
  294. - changed to --with-metadata-helper in configure options
  295. - added BuildRequires:
  296. - gstreamer-python
  297. - intltool >= 0.35.0
  298. - popt-devel
  299. * Sat Aug 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-1vl5
  300. - added BuildRequires: totem-pl-parser-devel, instead of totem-devel
  301. - rebuilt with python-2.5.2
  302. - applied new versioning policy
  303. - spec in utf-8
  304. * Sun Jan 06 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-0vl2
  305. - rebuilt with libgpod-0.6.0
  306. * Sun Aug 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.2-0vl1
  307. - new upstream release
  308. * Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.1-0vl1
  309. - new upstream release
  310. * Tue May 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.10.0-0vl2
  311. - rebuilt with new toolchain and libgpod-0.4.2
  312. - add BuildRequires: dbus-glib-devel
  313. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.0-0vl1
  314. - new upstream release
  315. * Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl2
  316. - rebuilt for VineSeed
  317. * Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl1
  318. - new upstream release
  319. - added --enable-python option to %%configure
  320. - added Requires: gnome-python
  321. * Sun Jan 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.7-0vl1
  322. - new upstream release
  323. - built with libsoup 2.2.99
  324. * Thu Nov 23 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl4
  325. - added --with-cd-burner to configure
  326. - added BuildRequires: libsexy-devel hal-devel libsoup-devel
  327. * Wed Oct 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl3
  328. - add BuildRequires:
  329. - gnome-doc-utils >= 0.3.2
  330. - python-devel
  331. - pygtk2-devel
  332. - check >= 0.8.2
  333. * Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl2
  334. - rebuild with gnutls-1.4.1
  335. * Sun Oct 1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl1
  336. - new upstream release
  337. * Mon Jun 19 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.5-0vl1
  338. - new upstream release
  339. - run scrollkeeper-update at %post and %postun
  340. - added BuildRequires: libnotify-devel
  341. * Sun May 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.4.1-0vl1
  342. - new upstream release (dropped patch0)
  343. - added --without-metadata-helper at configure
  344. * Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3.1-0vl1
  345. - Initial build for Vine Linux based on FC pacakge
  346. * Fri Mar 03 2006 Ray Strode <rstrode@redhat.com> - 0.9.3.1-2
  347. - add patch from James "Doc" Livingston to stop a hang
  348. for new users (bug 183883)
  349. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.2
  350. - bump again for double-long bug on ppc(64)
  351. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.1
  352. - rebuilt for new gcc4.1 snapshot and glibc changes
  353. * Sat Feb 4 2006 Christopher Aillon <caillon@redhat.com> 0.9.3.1-1
  354. - Update to 0.9.3.1
  355. - Use gstreamer (0.10)
  356. * Wed Feb 1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-2
  357. - Remove hack for 173869, as its no longer needed.
  358. * Wed Feb 1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-1
  359. - 0.9.3
  360. * Wed Feb 1 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060201-1
  361. - Newer CVS snapshot
  362. * Sun Jan 22 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060123-1
  363. - Update to latest CVS
  364. - Add hack to workaround bug #173869
  365. * Thu Jan 19 2006 Christopher Aillon <caillon@redhat.com> 0.9.2-8
  366. - Rebuild, now that gstreamer08-plugins has been fixed
  367. * Thu Jan 19 2006 Ray Strode <rstrode@redhat.com> 0.9.2-7
  368. - bonobo multilib issue (bug 156982)
  369. * Wed Jan 04 2006 John (J5) Palmieri <johnp@redhat.com> 0.9.2-5
  370. - rebuild with ipod support
  371. * Tue Jan 03 2006 Jesse Keating <jkeating@redhat.com> 0.9.2-4
  372. - rebuilt again
  373. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  374. - rebuilt
  375. * Mon Dec 5 2005 Matthias Clasen <mclasen@redhat.com>
  376. - rebuild
  377. * Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com>
  378. - rebuild for new dbus
  379. * Wed Nov 30 2005 Matthias Clasen <mclasen@redhat.com>
  380. - Update to 0.9.2
  381. * Tue Oct 25 2005 Matthias Clasen <mclasen@redhat.com>
  382. - Update to 0.9.1
  383. * Fri Sep 02 2005 Colin Walters <walters@redhat.com>
  384. - Add configure flags --with-bonobo --with-dbus
  385. - BR nautilus-cd-burner-devel
  386. - New upstream CVS snapshot for testing
  387. - Drop IDL file and ui .xml
  388. - Add dbus service file
  389. - Drop upstreamed rhythmbox-bluecurve.tar.gz
  390. - Drop upstreamed rhythmbox-0.8.8-cell-renderer.patch
  391. * Mon Jun 13 2005 Colin Walters <walters@redhat.com> - 0.8.8-3
  392. - Add Bluecurve-ized icons from Jeff Schroeder (157716)
  393. - Add rhythmbox-0.8.8-cell-renderer.patch to remove use of custom
  394. cell renderer for playback icon (no longer necessary) and
  395. changes the rating renderer to work with non-b&w icons
  396. * Mon Mar 14 2005 Colin Walters <walters@redhat.com> - 0.8.8-2
  397. - Rebuild for GCC4
  398. * Tue Oct 05 2004 Colin Walters <walters@redhat.com> - 0.8.8-1
  399. - New upstream version
  400. - Remove librb-nautilus-context-menu.so, killed upstream
  401. * Thu Sep 30 2004 Christopher Aillon <caillon@redhat.com> 0.8.7-2
  402. - PreReq desktop-file-utils >= 0.9
  403. * Wed Sep 29 2004 Colin Walters <walters@redhat.com> - 0.8.7-1
  404. - New upstream version
  405. * Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-2
  406. - Fix postun to use correct syntax, thanks Nils Philippsen
  407. * Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-1
  408. - New upstream version
  409. - Call update-desktop-database in post and postun
  410. * Thu Jun 24 2004 Colin Walters <walters@redhat.com> - 0.8.5-1
  411. - New upstream version
  412. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  413. - rebuilt
  414. * Tue May 18 2004 Colin Walters <walters@redhat.com> - 0.8.4-1
  415. - New upstream version
  416. - Remove backported patches
  417. - Gratuitiously bump various BuildRequires versions
  418. * Mon May 10 2004 Colin Walters <walters@redhat.com> - 0.8.3-4
  419. - Remove code to unregister GConf schema for now (Closes: #122532)
  420. * Fri May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-3
  421. - Apply tiny patch from 0.8 arch to fix GConf key used
  422. for initial sorting
  423. * Fri May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-2
  424. - Apply patch from 0.8 arch tree to fix a number of memleaks
  425. * Sun May 02 2004 Colin Walters <walters@redhat.com> - 0.8.3-1
  426. - Update to 0.8.3: fixes showstopper bug with internet radio
  427. * Fri Apr 30 2004 Colin Walters <walters@redhat.com> - 0.8.2-1
  428. - Update to 0.8.2
  429. - Fix Source url
  430. - Add smp_mflags
  431. - Bump BuildRequires on gstreamer to 0.8.1
  432. * Fri Apr 23 2004 Colin Walters <walters@redhat.com> - 0.8.1-2
  433. - Uninstall GConf schemas on removal
  434. * Tue Apr 20 2004 Colin Walters <walters@redhat.com> - 0.8.1-1
  435. - Update to 0.8.1
  436. * Fri Apr 16 2004 Colin Walters <walters@redhat.com> - 0.8.0-1
  437. - Update to 0.8.0
  438. * Fri Apr 02 2004 Colin Walters <walters@redhat.com> - 0.7.2-1
  439. - Update to 0.7.2
  440. * Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-2
  441. - Remove BuildRequires on autoconf and libvorbis-devel
  442. * Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-1
  443. - New major version - I know we are past major version slush, but
  444. this should have been done two weeks ago along with the GNOME 2.6
  445. upload. As upstream author as well, I believe this version is
  446. good enough for FC2.
  447. - Remove --disable-mp3
  448. - Remove id3, flac variables
  449. - Remove GStreamer major version patch
  450. - Fix typo in description
  451. * Tue Mar 16 2004 Jeremy Katz <katzj@redhat.com> - 0.6.8-2
  452. - rebuild for new gstreamer
  453. * Thu Mar 11 2004 Alex Larsson <alexl@redhat.com> 0.6.8-1
  454. - update to 0.6.8
  455. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  456. - rebuilt
  457. * Mon Mar 1 2004 Alexander Larsson <alexl@redhat.com> 0.6.7-1
  458. - update to 0.6.7
  459. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  460. - rebuilt
  461. * Mon Jan 12 2004 Colin Walters <walters@verbum.org> 0.6.4-1
  462. - New upstream version
  463. - Don't re-run the autotools; upstream incorporates newer versions.
  464. * Tue Oct 28 2003 Jonathan Blandford <jrb@redhat.com> 0.5.4-1
  465. - new version
  466. - remove smp_flags
  467. * Fri Oct 24 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-5
  468. - remove the initial iradio channels as they all are mp3 based.
  469. * Wed Oct 8 2003 Matthias Saou <matthias@rpmforge.net> 0.5.3-3
  470. - Fix category from Development/Libraries to Applications/Multimedia.
  471. - Use bz2 instead of gz as ftp.gnome.org has both, 300k saved in the src.rpm.
  472. - Fix SCHEMES vs. SCHEMAS in the post scriplet.
  473. - Added gstreamer-plugins-devel, libvorbis-devel, scrollkeeper and gettext deps.
  474. - Removed unnecessary date expansion define.
  475. - Updated description, including mp3 reference removal.
  476. - Added libid3tag and flac optional support for convenient rebuild.
  477. - Removed obsolete omf.make and xmldocs.make (included ones are the same now).
  478. * Mon Sep 22 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-1
  479. - new version
  480. - use %{_sysconfdir} instead of /etc
  481. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  482. - rebuilt
  483. * Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
  484. - gave up on other archs for the Beta
  485. - new version
  486. - remove werror and add missing files
  487. * Thu Nov 7 2002 Jeremy Katz <katzj@redhat.com>
  488. - update to newer cvs snap
  489. * Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
  490. - update to cvs snap
  491. * Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
  492. - use %%(lang)
  493. * Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
  494. - fix post to actually install the schema
  495. * Sat Jun 22 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
  496. - Added gconf file
  497. - Added i18n directory
  498. * Sat Jun 15 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
  499. - Updated for new rewrite of rhythmbox, thanks to Jeroen
  500. * Mon Mar 18 2002 Jorn Baayen <jorn@nl.linux.org>
  501. - removed bonobo dependency
  502. * Sat Mar 02 2002 Christian Schaller <Uraeus@linuxrising.org>
  503. - created new spec file