unixODBC-vl.spec 9.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312
  1. Name: unixODBC
  2. Version: 2.3.2
  3. Release: 2%{?_dist_release}
  4. Summary: A complete ODBC Driver Manager for Linux
  5. Summary(ja): Linux 用 ODBC ドライバマネージャー
  6. Group: System Environment/Libraries
  7. # Programs are GPL, libraries are LGPL, except News Server library is GPL.
  8. License: GPLv2+ and LGPLv2+
  9. URL: http://www.unixODBC.org/
  10. Source: http://www.unixODBC.org/%{name}-%{version}.tar.gz
  11. Source1: odbcinst.ini
  12. Source4: conffile.h
  13. Source5: README.dist
  14. Source6: iusql.1
  15. Source7: dltest.1
  16. Source8: odbc_config.1
  17. Source9: unixODBC.7
  18. Patch1: depcomp.patch
  19. Patch6: export-symbols.patch
  20. Patch8: so-version-bump.patch
  21. Patch9: keep-typedefs.patch
  22. Patch10: unixODBC-isql.1.patch
  23. Conflicts: iodbc
  24. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  25. BuildRequires: automake autoconf libtool libtool-ltdl-devel bison flex
  26. BuildRequires: readline-devel
  27. Vendor: Project Vine
  28. Distribution: Vine Linux
  29. %description
  30. Install unixODBC if you want to access databases through ODBC.
  31. You will also need the mysql-connector-odbc package if you want to access
  32. a MySQL database, and/or the postgresql-odbc package for PostgreSQL.
  33. %package devel
  34. Summary: Development files for programs which will use the unixODBC library.
  35. Summary(ja): unixODBC ライブラリを用いるプログラムのための開発用ファイル
  36. Group: Development/Libraries
  37. Requires: %{name} = %{version}-%{release}
  38. %description devel
  39. The unixODBC package can be used to access databases through ODBC
  40. drivers. If you want to develop programs that will access data through
  41. ODBC, you need to install this package.
  42. %prep
  43. %setup -q
  44. %patch1 -p1
  45. %patch6 -p1
  46. %patch8 -p1
  47. %patch9 -p1
  48. %patch10 -p1
  49. chmod 0644 Drivers/MiniSQL/*.c
  50. chmod 0644 Drivers/nn/*.c
  51. chmod 0644 Drivers/template/*.c
  52. chmod 0644 doc/ProgrammerManual/Tutorial/*.html
  53. chmod 0644 doc/lst/*
  54. chmod 0644 include/odbcinst.h
  55. # Blow away the embedded libtool and replace with build system's libtool.
  56. # (We will use the installed libtool anyway, but this makes sure they match.)
  57. rm -rf config.guess config.sub install-sh ltmain.sh libltdl
  58. # this hack is so we can build with either libtool 2.2 or 1.5
  59. libtoolize --install || libtoolize
  60. %build
  61. aclocal
  62. automake --add-missing
  63. autoconf
  64. # unixODBC 2.2.14 is not aliasing-safe
  65. CFLAGS="%{optflags} -fno-strict-aliasing"
  66. CXXFLAGS="$CFLAGS"
  67. export CFLAGS CXXFLAGS
  68. %configure --with-gnu-ld=yes --enable-threads=yes \
  69. --enable-drivers=yes --enable-driverc=yes --enable-ltdllib
  70. make all
  71. %install
  72. rm -rf $RPM_BUILD_ROOT
  73. make DESTDIR=$RPM_BUILD_ROOT install
  74. install -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
  75. # multilib header hacks
  76. # we only apply this to known Red Hat multilib arches, per bug #181335
  77. case `uname -i` in
  78. i386 | x86_64 | ia64 | ppc | ppc64 | s390 | s390x | sparc | sparc64 )
  79. mv $RPM_BUILD_ROOT%{_includedir}/unixodbc_conf.h $RPM_BUILD_ROOT%{_includedir}/unixodbc_conf_`uname -i`.h
  80. rm -f unixodbc_conf.h
  81. sed s/CONFFILE/unixodbc_conf/ %{SOURCE4} >unixodbc_conf.h
  82. install -m 644 unixodbc_conf.h $RPM_BUILD_ROOT%{_includedir}
  83. ;;
  84. *)
  85. ;;
  86. esac
  87. # add some explanatory documentation
  88. cp %{SOURCE5} README.dist
  89. # remove obsolete Postgres drivers from the package (but not the setup code)
  90. rm -f $RPM_BUILD_ROOT%{_libdir}/libodbcpsql.so*
  91. # copy text driver documentation into main doc directory
  92. # currently disabled because upstream no longer includes text driver
  93. # mkdir -p doc/Drivers/txt
  94. # cp -pr Drivers/txt/doc/* doc/Drivers/txt
  95. # don't want to install doc Makefiles as docs
  96. find doc -name 'Makefile*' | xargs rm
  97. # we do not want to ship static libraries
  98. rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
  99. # remove unpackaged files from the buildroot
  100. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  101. rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.*
  102. rm -rf $RPM_BUILD_ROOT%{_datadir}/libtool
  103. # initialize lists of .so files
  104. find $RPM_BUILD_ROOT%{_libdir} -name "*.so.*" | sed "s|^$RPM_BUILD_ROOT||" > base-so-list
  105. find $RPM_BUILD_ROOT%{_libdir} -name "*.so" | sed "s|^$RPM_BUILD_ROOT||" > devel-so-list
  106. # move these to main package, they're often dlopened...
  107. for lib in libodbc.so libodbcinst.so libodbcpsqlS.so libodbcmyS.so
  108. do
  109. echo "%{_libdir}/$lib" >> base-so-list
  110. grep -v "/$lib$" devel-so-list > devel-so-list.x
  111. mv -f devel-so-list.x devel-so-list
  112. done
  113. # install man pages that are not part of the upstream yet
  114. install -Dm644 %{SOURCE6} $RPM_BUILD_ROOT%{_mandir}/man1/iusql.1
  115. install -Dm644 %{SOURCE7} $RPM_BUILD_ROOT%{_mandir}/man1/dltest.1
  116. install -Dm644 %{SOURCE8} $RPM_BUILD_ROOT%{_mandir}/man1/odbc_config.1
  117. install -Dm644 %{SOURCE9} $RPM_BUILD_ROOT%{_mandir}/man7/unixODBC.7
  118. %clean
  119. rm -rf $RPM_BUILD_ROOT
  120. %post -p /sbin/ldconfig
  121. %postun -p /sbin/ldconfig
  122. %files -f base-so-list
  123. %doc README COPYING AUTHORS ChangeLog NEWS doc
  124. %doc README.dist
  125. %config(noreplace) %{_sysconfdir}/odbc*
  126. %{_bindir}/odbcinst
  127. %{_bindir}/isql
  128. %{_bindir}/dltest
  129. %{_bindir}/iusql
  130. %{_bindir}/odbc_config
  131. %{_bindir}/slencheck
  132. %{_mandir}/man*/*
  133. %files devel -f devel-so-list
  134. %{_includedir}/*
  135. %changelog
  136. * Tue Mar 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.3.2-2
  137. - rebuilt with readline 6.3
  138. - removed kde-subpackage-related BuildRequires
  139. - added Japanese summary
  140. * Tue Jul 8 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.2-1
  141. - new upstream release.
  142. - gui was discontinued in upstream.
  143. * Fri Dec 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.14-3
  144. - rebuild with VineSeed environment
  145. * Tue Apr 12 2011 IWAI, Masaharu <iwai@alib.jp> 2.2.14-2
  146. - add --with-qt-includes option for configure
  147. * Sat Apr 09 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.14-1
  148. - updated to 2.2.14
  149. * Sat Sep 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.12-1
  150. - applied new versioning policy
  151. - removed *.la files from devel package
  152. * Sun Sep 02 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.12-0vl1
  153. - updated to 2.2.12
  154. - rebuilt with new toolchain
  155. * Thu Sep 07 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.11-0vl3
  156. - use installed libltdl
  157. - added unixODBC-2.2.11-symbols.patch and nortldglobal.patch
  158. * Sat Apr 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-0vl2
  159. - rebuilt with readline 5.1
  160. * Wed Aug 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-0vl1
  161. - updated to 2.2.11
  162. - not libtoolize
  163. * Sat Sep 27 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.5-0vl2
  164. - added Patch100 to fix typo in doc/Makefile.am from failure on compiling
  165. * Fri Jun 6 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.5-0vl1
  166. - source upgrade
  167. - remove patch (no need)
  168. - run libtoolize etc for VineSeed
  169. * Wed Feb 12 2003 Tomoya TAKA <taka@vinelinux.org> 2.2.4-0vl2
  170. - enable -kde subpackage on alpha, but still disable for Vine2.5/2.6
  171. * Sun Feb 9 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.4-0vl1
  172. - source upgrade
  173. - change spec to build both VineSeed and Vine2.5/2.6
  174. - add patch from rawhide 2.2.3-6
  175. * Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.3-0vl2
  176. - Requires: libjpeg (not libjpeg-6b)
  177. * Sun Oct 6 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.3-0vl1
  178. - source upgrade
  179. - add BuildPrereq: autoconf253 automake15
  180. - add PreReq: ldconfig
  181. - fix %files section and clean up spec
  182. - for unixODBC-kde package
  183. - add Requires: unixODBC = %{version}
  184. - add Requires: XFree86-libs qt freetype2 libjpeg-6b libmng libpng zlib
  185. - delete .desktop files
  186. * Thu Apr 4 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.0-0vl2
  187. - rebuild with KDE3
  188. * Sat Feb 23 2002 Satoshi MACHINO <machino@vinelinux.org> 2.2.0-0vl1
  189. - updated unixODBC-2.2.0
  190. - fixed LinuxODBC.xpm and smallLinuxODBC.xpm dir
  191. * Wed Jan 30 2002 Tomoya TAKA <taka@vinelinux.org> 2.0.7-3vl2
  192. - remove -kde package on alpha
  193. * Fri Jan 4 2002 Akira TAGOH <tagoh@gnome.gr.jp> 2.0.7-3vl1
  194. - Rebuild for Vine.
  195. * Sun Jun 24 2001 Than Ngo <than@redhat.com>
  196. - rebuild against qt-2.3.1, kde-2.1.x
  197. * Fri Jun 15 2001 Trond Eivind Glomsrød <teg@redhat.com>
  198. - Better default odbcinst.ini
  199. - Minor cleanups
  200. * Wed Jun 6 2001 Trond Eivind Glomsrød <teg@redhat.com>
  201. - 2.0.7
  202. * Wed Apr 25 2001 Trond Eivind Glomsrød <teg@redhat.com>
  203. - Fix for isql segfault on EOF/ctrl-d exit
  204. * Fri Apr 20 2001 Trond Eivind Glomsrød <teg@redhat.com>
  205. - 2.0.6
  206. - add patch for 64 bit archs (dword shouldn't be "long int")
  207. * Wed Feb 28 2001 Trond Eivind Glomsrød <teg@redhat.com>
  208. - rebuild
  209. * Tue Nov 28 2000 Trond Eivind Glomsrød <teg@redhat.com>
  210. - 1.8.13
  211. * Tue Oct 10 2000 Trond Eivind Glomsrød <teg@redhat.com>
  212. - enable GUI now that we have KDE compiled with the standard
  213. compiler
  214. - move the applnk entries to the KDE package
  215. * Thu Aug 24 2000 Nalin Dahyabhai <nalin@redhat.com>
  216. - add the missing shared libs to the non-devel package
  217. * Wed Aug 23 2000 Preston Brown <pbrown@redhat.com>
  218. - 1.8.12 fixes problems with the postgresql driver
  219. * Mon Jul 31 2000 Trond Eivind Glomsrød <teg@redhat.com>
  220. - disable KDE subpackage to avoid the mess that is C++ binary
  221. compatibility
  222. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  223. - automatic rebuild
  224. * Fri Jun 30 2000 Florian La Roche <laroche@redhat.com>
  225. - improved QTDIR detection
  226. * Wed Jun 28 2000 Trond Eivind Glomsrød <teg@redhat.com>
  227. - 1.8.10
  228. - use %%{_tmppath}
  229. - update URL
  230. - including two missing libraries
  231. * Tue Jun 13 2000 Preston Brown <pbrown@redhat.com>
  232. - 1.8.9
  233. * Fri Jun 09 2000 Preston Brown <pbrown@redhat.com>
  234. - adopted for Winston, changed to Red Hat packaging standards
  235. * Tue Apr 18 2000 Murray Todd Williams <murray@codingapes.com>
  236. - added a unixODBC-devel RPM to the group, added KDE links and icons to system
  237. - all of which came from recommendations from Fredrick Meunier
  238. - <Fredrick.Meunier@computershare.com.au>
  239. * Mon Apr 17 2000 Murray Todd Williams <murray@codingapes.com>
  240. - unixODBC-1.8.7
  241. - moved install to $RPM_BUILD_ROOT so it didn't overrun existing files.