chromium-vl.spec 26 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658
  1. # Thanks to malcolmlewis for help with this script
  2. # Thanks to Tom "spot" Callaway for much of the patchwork
  3. # Thanks to jhaygood for most of the icu patch
  4. # norootforbuild
  5. %if %{?_dist_release} == "vl6"
  6. %define with_system_icu 1
  7. %endif
  8. %define svn_rev 62756
  9. %define v8_ver 2.4.9
  10. Name: chromium
  11. Summary: Google's opens source browser project
  12. Summary(ja): Googleのオープンソースウェブブラウザ
  13. #'
  14. Version: 8.0.556.0
  15. Release: 1%{?_dist_release}
  16. License: BSD
  17. Group: Applications/Internet
  18. Source0: %{name}.%{version}.svn%{svn_rev}.tar.lzma
  19. ## The following are included for source reasons only
  20. # Custom build tools for chromium, hammer is a fancy front-end for scons
  21. Source1: http://src.chromium.org/svn/trunk/tools/depot_tools.tar.gz
  22. # Script used to create the tar.lzma archive from the daily tarball downloadable at http://build.chromium.org/buildbot/archives/
  23. Source2: repack_chromium_archive.sh
  24. # Script used to create the tar.lzma archive from a checked out source
  25. Source3: pack_chromium_source.sh
  26. #Source10: chromium.desktop
  27. #Source10: chromium-vine.desktop
  28. # Patch template which adds vendor to user agent
  29. ##!!Source20: chromium-vendor.patch.in
  30. Source20: chromium-vendor-vine.patch.in
  31. ##!!Source30: master_preferences
  32. Source30: master_preferences.vine
  33. #Source31: default_bookmarks.html
  34. #Source31: default_bookmarks.html.vine
  35. # icu-4.2.1 contained in chromium.5.0.353.0.svn41449 (for Vine Linux 5.X)
  36. Source50: icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2
  37. Source99: chrome-wrapper
  38. ##!!Source100: chromium-browser.sh
  39. Source100: chromium-browser-vine.sh
  40. ##!!Source101: chromium-browser.desktop
  41. Source101: chromium-browser-vine.desktop
  42. Source102: chromium-browser.xml
  43. Source103: chromium-browser-rpmlintrc
  44. %{?nosrc:NoSource: 0}
  45. %{?nosrc:NoSource: 1}
  46. %{?nosrc:NoSource: 50}
  47. Provides: chromium-browser = %{version}
  48. ##Provides: chromium-based-browser
  49. ##Obsoletes: chromium-browser < %{version}
  50. ## Start Patches
  51. # Many changes to the gyp system so we can use system libraries
  52. # My first ever patch set. I hope I did well.
  53. Patch3: chromium-gyp-system-icu.patch
  54. Patch4: chromium-no-sqlite-debug.patch
  55. Patch5: chromium-gyp-system-04-nss-nspr.patch
  56. Patch7: chromium-codechanges-nss-nspr.patch
  57. Patch8: chromium-codechanges-zlib.patch
  58. Patch12: chromium-no-test-sources.patch
  59. Patch13: chromium-no-courgette.patch
  60. Patch14: chromium-master-prefs-path.patch
  61. Patch17: chromium-system-glew.patch
  62. Patch18: chromium-system-expat.patch
  63. Patch19: chromium-system-zlib.patch
  64. Patch20: chromium-noffmpeg.patch
  65. Patch21: chromium-system-old-ffmpeg-way.patch
  66. Patch23: chromium-disable-mmx.patch
  67. Patch25: tcmalloc-factory.patch
  68. Patch26: chromium-remoting-build-fix.diff
  69. # Shared Library patches
  70. Patch60: chromium-sharedlibfixes.patch
  71. Patch61: chromium-shared-chromiumthreading.patch
  72. Patch62: chromium-norpath.patch
  73. Patch63: chromium-6.0.406.0-system-gyp-v8.patch
  74. # Patches for MeeGo Netbook
  75. Patch80: chromium-browser-window-focus.patch
  76. Patch81: chromium-20100319-default-browser-setting.patch
  77. Patch82: chromium-20100506-expose-chromium-browser-api.patch
  78. Patch83: chromium-fix-toolbar-icon-size.patch
  79. # Vine
  80. BuildRequires: gcc gcc-c++
  81. %if %{?_dist_release} == "vl5"
  82. BuildRequires: libstdc++34 libstdc++34-devel
  83. %elseif %{?_dist_release} == "vl6"
  84. BuildRequires: libstdc++ libstdc++-devel
  85. %endif
  86. BuildRequires: libevent
  87. ##!!BuildRequires: pkg-config
  88. BuildRequires: python
  89. ##!!BuildRequires: python-xml
  90. BuildRequires: python-pyxml
  91. BuildRequires: perl bison flex gperf
  92. ##!!BuildRequires: wdiff
  93. ##!!BuildRequires: update-desktop-files
  94. BuildRequires: lzma
  95. ##!!BuildRequires: mozilla-nss-devel
  96. BuildRequires: nss-devel
  97. ##!!BuildRequires: alsa-devel
  98. BuildRequires: alsa-lib-devel
  99. BuildRequires: gtk2-devel
  100. BuildRequires: glib2-devel
  101. BuildRequires: cairo-devel >= 1.6
  102. ##!!BuildRequires: mozilla-nspr-devel
  103. BuildRequires: nspr-devel
  104. ##!!BuildRequires: gconf2-devel
  105. BuildRequires: GConf2-devel
  106. BuildRequires: freetype2-devel
  107. ##!!BuildRequires: dbus-1-devel
  108. BuildRequires: dbus-devel
  109. BuildRequires: libxslt-devel
  110. BuildRequires: libxml2-devel
  111. BuildRequires: libjpeg-devel
  112. BuildRequires: zlib-devel
  113. ##!!BuildRequires: libbz2-devel
  114. BuildRequires: bzip2-devel
  115. BuildRequires: cups-devel
  116. %if %{?_dist_release} == "vl6"
  117. BuildRequires: fdupes
  118. %endif
  119. ##!!BuildRequires: libexpat-devel
  120. BuildRequires: expat-devel
  121. BuildRequires: libpng-devel
  122. BuildRequires: sqlite3-devel
  123. BuildRequires: gnutls-devel
  124. BuildRequires: desktop-file-utils
  125. BuildRequires: v8-devel = %{v8_ver}
  126. BuildRequires: libvpx-devel
  127. %if %{?_dist_release} == "vl5"
  128. BuildRequires: gnome-keyring-devel
  129. %elseif %{?_dist_release} == "vl6"
  130. BuildRequires: libgnome-keyring-devel
  131. %endif
  132. BuildRequires: glew-devel
  133. ##!!BuildRequires: Mesa-devel
  134. BuildRequires: mesa-libGLU-devel
  135. %{?with_system_icu:BuildRequires: libicu-devel >= 4.0}
  136. BuildRequires: libevent-devel
  137. ##Vine Linux
  138. Requires: v8 = %{v8_ver}
  139. BuildRequires: libXScrnSaver-devel
  140. #BuildRequires: gle-devel
  141. #BuildRequires: webkit-gtk-devel
  142. #BuildRequires: scons
  143. %ifarch x86_64
  144. Requires: nspluginwrapper
  145. %endif
  146. ##!!Requires: alsa
  147. Requires: alsa-lib
  148. # shouldn't be required to name all dependencies
  149. # Requires: mozilla-nss mozilla-nspr gtk2 glib2 cairo >= 1.6 freetype2 dbus-1 alsa v8 >= 1.3.15
  150. ## Recommends the ffmpeg libraries (available from packman)
  151. #Recommends: libavcodec52 libavformat52 libavutil50
  152. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  153. %description
  154. Chromium is the open-source project behind Google Chrome.
  155. We invite you to join us in our effort to help build a safer, faster,
  156. and more stable way for all Internet users to experience the web,
  157. and to create a powerful platform for developing a new generation of
  158. web applications.
  159. %description -l ja
  160. Chromium は Google Chrome の後方にあるオープンソースプロジェクトです。
  161. 私たちは、ウェブを体験しているすべてのインターネットユーザに対して
  162. より安全で、より速くて、より安定した方法を築き上げるのを助けるために、
  163. ウェブアプリケーションの新しい世代を発展させるように
  164. 強力なプラットホームを作成するために、
  165. 私たちの取り組みで私たちに加わるようにあなたを誘います。
  166. %package devel
  167. Summary: Header file for chromium browser
  168. Group: Development/Libraries
  169. Requires: chromium = %{version}-%{release}
  170. %description devel
  171. This package contains the header files and pc file of chromium browser for
  172. applications which will use chromium browser APIs.
  173. %prep
  174. [ -d %{name} ] && %__rm -rf %{name}
  175. lzma -cd %{SOURCE0} | tar xf -
  176. %setup -D -T -n %{name}
  177. # use static libicu
  178. %if %{?_dist_release} == "vl5"
  179. cd src/third_party || exit 1
  180. %__rm -rf icu || exit 1
  181. tar jxvf %{SOURCE50} || exit 1
  182. %__mv icu-4.2.1-chromium.5.0.353.0.svn41449 icu || exit 1
  183. cd - || exit 1
  184. %endif
  185. %patch60 -p1
  186. %patch61 -p1
  187. %patch62 -p1
  188. %patch63 -p1
  189. %patch80 -p1
  190. %patch81 -p1
  191. %patch82 -p1
  192. %patch83 -p1
  193. # use system libicu only if >= 4.0
  194. %{?with_system_icu:%patch3 -p1}
  195. %patch4 -p1
  196. %patch5 -p1
  197. %patch7 -p1
  198. %patch8 -p1
  199. %patch12 -p1
  200. %patch13 -p1
  201. %patch14 -p1
  202. %patch17 -p1
  203. %patch18 -p1
  204. %patch19 -p1
  205. %patch20 -p1
  206. %patch21 -p1
  207. %patch25 -p1
  208. %ifarch %ix86
  209. %patch23 -p1
  210. %endif
  211. %patch26 -p1
  212. # apply vendor patch after substitution
  213. %__sed "s:RPM_VERSION:%{version}-%{release}:" %{SOURCE20} | patch -p0
  214. %build
  215. ## create make files
  216. PARSED_OPT_FLAGS=`echo \'$RPM_OPT_FLAGS -DUSE_SYSTEM_LIBEVENT -fPIC -fno-ipa-cp -fno-strict-aliasing \' | %__sed "s/ /',/g" | %__sed "s/',/', '/g"`
  217. for i in src/build/common.gypi; do
  218. %__sed -i "s|'-march=pentium4',||g" $i
  219. %__sed -i "s|'-msse2',||g" $i
  220. %__sed -i "s|'-mfpmath=sse',||g" $i
  221. %__sed -i "s|'-O<(debug_optimize)',||g" $i
  222. %__sed -i "s|'-m32',||g" $i
  223. %__sed -i "s|'-fno-exceptions',|$PARSED_OPT_FLAGS|g" $i
  224. %__sed -i "s|'-Werror'|'-Wno-error'|g" $i
  225. done
  226. # '
  227. pushd src
  228. ./build/gyp_chromium -f make build/all.gyp \
  229. -Dlinux_sandbox_path=%{_libdir}/chromium/chrome-sandbox \
  230. -Dlinux_sandbox_chrome_path=%{_libdir}/chromium/chromium-browser \
  231. -Duse_system_ffmpeg=1 \
  232. -Duse_system_zlib=1 \
  233. -Duse_system_libpng=1 \
  234. -Duse_system_bzip2=1 \
  235. -Duse_system_libbz2=1 \
  236. -Duse_system_libjpeg=1 \
  237. -Duse_system_libxml=1 \
  238. -Duse_system_libxslt=1 \
  239. -Duse_system_libevent=1 \
  240. -Duse_system_vpx=1 \
  241. -Dproprietary_codecs=1 \
  242. -Dlibrary=shared_library \
  243. -Dlinux_fpic=1 \
  244. %{?with_system_icu:-Duse_system_icu=1} \
  245. %{!?with_system_icu:-Duse_system_icu=0} \
  246. %ifarch %{ix86}
  247. -Dtarget_arch=ia32 \
  248. -Ddisable_sse2=1 \
  249. %endif
  250. %ifarch x86_64
  251. -Dtarget_arch=x64 \
  252. %endif
  253. %if %{?_dist_release} == "vl6"
  254. -Dno_strict_aliasing=1 -Dgcc_version=44 \
  255. %endif
  256. -Drelease_extra_cflags=-fPIC \
  257. ;
  258. #make -r %{?jobs:-j%jobs} chrome BUILDTYPE=Release
  259. #%__make -r -j5 chrome BUILDTYPE=Release
  260. %__make %{?_smp_mflags} chrome BUILDTYPE=Release
  261. popd
  262. %install
  263. %{__rm} -rf %{buildroot}
  264. %__mkdir -p %{buildroot}%{_bindir}
  265. %__install -m 755 %{SOURCE100} %{buildroot}%{_bindir}/chromium
  266. # x86_64 capable systems need this
  267. %__sed -i "s|/usr/lib/chromium|%{_libdir}/chromium|g" %{buildroot}%{_bindir}/chromium
  268. %__mkdir -p %{buildroot}%{_libdir}/chromium/
  269. %__mkdir -p %{buildroot}%{_mandir}/man1/
  270. pushd src/out/Release
  271. %__cp -a chrome.pak locales resources xdg-settings %{buildroot}%{_libdir}/chromium/
  272. %__cp -a resources.pak %{buildroot}%{_libdir}/chromium/
  273. %__cp -a chrome %{buildroot}%{_libdir}/chromium/chromium
  274. %__cp -a lib.target/lib*.so %{buildroot}%{_libdir}/chromium/
  275. %__cp -a lib.host/lib*.so %{buildroot}%{_libdir}/chromium/
  276. #%__cp -a chrome_sandbox %{buildroot}%{_libdir}/chromium/chrome-sandbox
  277. %__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chrome.1
  278. %__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chromium.1
  279. %if %{?_dist_release} == "vl6"
  280. fdupes %{buildroot}%{_mandir}/man1/
  281. %endif
  282. popd
  283. # devel package install
  284. mkdir -p %{buildroot}%{_libdir}/chromium/include
  285. pushd src
  286. find base -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
  287. find app -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
  288. find chrome -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
  289. find skia -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
  290. find build -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
  291. find googleurl -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
  292. find ipc -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
  293. find testing -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
  294. find net -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
  295. find third_party/skia -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
  296. find third_party/WebKit -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
  297. find webkit -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
  298. find gfx -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
  299. popd
  300. find %{buildroot}%{_libdir}/chromium/include -name "*.h" -exec chmod 644 {} \;
  301. %if %{?_dist_release} == "vl6"
  302. fdupes %{buildroot}%{_libdir}/chromium/include
  303. %endif
  304. %__mkdir_p %{buildroot}/%{_libdir}/pkgconfig
  305. cat <<! > %{buildroot}/%{_libdir}/pkgconfig/chromium-browser.pc
  306. Name: Chromium browser
  307. Description: Chromium browser development package
  308. Version: 1.0.1
  309. Libs: -L%{_libdir}/chromium -lapp_base -lappcache -lbase_i18n -lbase -lblob -lbrowser -lcacheinvalidation -lchrome_gpu -lchromoting_base -lchromoting_client -lchromoting_host -lchromoting_jingle_glue -lchromotocol_proto_lib -lcld -lcommon_constants -lcommon_net -lcommon -ldatabase -ldebugger -ldefault_plugin -ldynamic_annotations -lffmpeg -lfileapi -lgfx -lglue -lgoogleurl -lgtest -lharfbuzz_interface -lharfbuzz -lhttp_listen_socket -lhunspell -lil -linstaller_util -lipc -ljingle_p2p -ljingle -lmedia -lmodp_b64 -lnet_base -lnet -lnotifier -lomx_wrapper -lots -lpcre -lplugin -lprinting -lprofile_import -lprotobuf_lite -lprotobuf -lrenderer -lsandbox -lsdch -lservice -lskia_opts -lskia -lspeex -lsqlite3 -lsrtp -lssl -lsymbolize -lsyncapi -lsync_notifier -lsync -ltrace_proto_lib -lutility -lwebcore_bindings -lwebcore_platform -lwebcore_remaining -lwebcore_svg -lwebkit_user_agent -lworker -lwtf -lxdg_mime -lzlib
  310. Cflags: -I%{_libdir}/chromium/include -I%{_libdir}/chromium/include/skia/config
  311. !
  312. %__mkdir_p %{buildroot}%{_datadir}/pixmaps/
  313. %__cp -a src/chrome/app/theme/chromium/product_logo_48.png %{buildroot}%{_datadir}/pixmaps/chromium-browser.png
  314. %__mkdir_p %{buildroot}%{_datadir}/applications/
  315. desktop-file-install --dir %{buildroot}%{_datadir}/applications %{SOURCE101}
  316. %__mkdir_p %{buildroot}%{_datadir}/gnome-control-center/default-apps/
  317. %__cp -a %{SOURCE102} %{buildroot}%{_datadir}/gnome-control-center/default-apps/
  318. # # link to browser plugin path. Plugin patch doesn't work. Why?
  319. # %{__mkdir_p} %{buildroot}%{_libdir}/browser-plugins
  320. # pushd %{buildroot}%{_libdir}/%{name}
  321. # %{__ln_s} %{_libdir}/browser-plugins plugins
  322. # popd
  323. pushd %{buildroot}%{_libdir}/%{name}
  324. %ifarch x86_64
  325. %{__ln_s} %{_libdir}/mozilla/plugins-wrapped plugins
  326. %else
  327. %{__ln_s} %{_libdir}/mozilla/plugins plugins
  328. %endif
  329. ## support ffmpeg libs
  330. touch %{buildroot}%{_libdir}/libavcodec.so.52
  331. %{__ln_s} %{_libdir}/libavcodec.so.52 libavcodec.so.52
  332. touch %{buildroot}%{_libdir}/libavformat.so.52
  333. %{__ln_s} %{_libdir}/libavformat.so.52 libavformat.so.52
  334. touch %{buildroot}%{_libdir}/libavutil.so.50
  335. %{__ln_s} %{_libdir}/libavutil.so.50 libavutil.so.50
  336. popd
  337. # Install the master_preferences file
  338. %__mkdir_p %{buildroot}%{_sysconfdir}/%{name}
  339. #%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{name}
  340. %__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{name}/$(basename %{SOURCE30} .vine)
  341. #%__install -m 0644 %{SOURCE31} %{buildroot}%{_sysconfdir}/%{name}
  342. %clean
  343. %{__rm} -rf %{buildroot}
  344. %files
  345. %defattr(-,root,root,-)
  346. %config %{_sysconfdir}/%{name}
  347. %dir /usr/share/gnome-control-center
  348. %dir /usr/share/gnome-control-center/default-apps
  349. %{_bindir}/chromium
  350. %{_libdir}/chromium/chromium
  351. # These unique permissions are intentional and necessary for the sandboxing
  352. #%attr(4555, root, root) %{_libdir}/chromium/chrome-sandbox
  353. %{_libdir}/chromium/plugins/
  354. %{_libdir}/chromium/resources/
  355. %{_libdir}/chromium/xdg-settings
  356. %{_mandir}/man1/chrom*
  357. %{_datadir}/pixmaps/chromium-browser.png
  358. %{_datadir}/applications/*.desktop
  359. %{_datadir}/gnome-control-center/default-apps/chromium-browser.xml
  360. %{_libdir}/chromium/libavcodec.so.52
  361. %{_libdir}/chromium/libavutil.so.50
  362. %{_libdir}/chromium/libavformat.so.52
  363. %exclude %{_libdir}/libavcodec.so.52
  364. %exclude %{_libdir}/libavutil.so.50
  365. %exclude %{_libdir}/libavformat.so.52
  366. ## libs
  367. %dir %{_libdir}/chromium/
  368. %{_libdir}/chromium/chrome.pak
  369. %{_libdir}/chromium/resources.pak
  370. %{_libdir}/chromium/locales/
  371. %{_libdir}/chromium/lib*.so
  372. %files devel
  373. %defattr(-,root,root,-)
  374. %{_libdir}/chromium/include/
  375. %_libdir/pkgconfig/chromium-browser.pc
  376. %changelog
  377. * Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.556.0-1
  378. - updated to snapshot 8.0.556
  379. * Sun Oct 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.551.0-1
  380. - updated to snapshot 8.0.551
  381. * Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.527.0-1
  382. - updated to snapshot 7.0.527
  383. * Thu Sep 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.519.0-1
  384. - updated to snapshot 7.0.519
  385. * Fri Sep 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.513.0-1
  386. - updated to snapshot 7.0.513
  387. - updated chromium-vendor-vine.patch.in
  388. * Sat Aug 28 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.507.0-1
  389. - updated to snapshot 7.0.507
  390. * Wed Aug 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.498.0-1
  391. - updated to snapshot 7.0.498
  392. * Sat Aug 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.493.0-1
  393. - updated to snapshot 6.0.493
  394. - used with_system_icu (for vl6)
  395. - added BuildRequires: libicu-devel
  396. * Thu Jul 22 2010 IWAI, Masaharu <iwai@alib.jp> 6.0.454.0-2vl5
  397. - build for Vine Linux 5.x
  398. - add BuildRequires: gnome-keyring-devel
  399. * Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.454.0-1
  400. - updated to snapshot 6.0.454
  401. - added BuildRequires:
  402. - sqlite3-devel
  403. - gnutls-devel
  404. - libgnome-keyring-devel
  405. * Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.431.0-1
  406. - updated to snapshot 6.0.431.0 r49253
  407. - added BuildRequires: cups-devel
  408. * Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.405.0-1
  409. - updated to snapshot 6.0.405.0 r47263
  410. * Fri Apr 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-2
  411. - unused with_system_icu (for vl6)
  412. - used icu-4.2.1-chromium.5.0.353.0.svn41449 (for vl6)
  413. * Wed Apr 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-1
  414. - updated to snapshot 5.0.378.0 r44472
  415. - used with_system_icu (for vl6)
  416. - added icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2 (for vl5)
  417. * Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.372.0-1
  418. - updated to snapshot 5.0.372.0 r43947
  419. - added BuildRequires: glew-devel
  420. - changed Group tag to Applications/Internet
  421. - added Summary(ja) and %%description -l ja
  422. * Mon Apr 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.365.0-1
  423. - updated to snapshot 5.0.365.0 r42966
  424. - merged 5.0.353.0-4vl5
  425. * Fri Apr 2 2010 IWAI, Masaharu <iwai@alib.jp> 5.0.353.0-4vl5
  426. - build on Vine Linux 5.1
  427. - add BuildRequires: libstdc++34 libstdc++34-devel for Vine5
  428. * Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.364.0-1
  429. - updated to snapshot 5.0.364.0 r42779
  430. * Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.359.0-1
  431. - updated to snapshot 5.0.359.0 r42116
  432. - dropped chromium-20100122-ubuntu-html5-video-mimetypes.patch
  433. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-4
  434. - fixed master_preferences.vine, little
  435. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-3
  436. - fixed to install master_preferences
  437. - dropped chromium-5.0.353-no-ffmpeg-vine.patch
  438. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-2
  439. - applied chromium-5.0.353-no-ffmpeg-vine.patch
  440. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-1
  441. - updated to snapshot 5.0.353.0 r41449
  442. * Wed Mar 10 2010 bgmerrell@novell.com
  443. - Add master_preferences source file and install it to /etc/chromium.
  444. - Create a new patch (chromium-master-prefs-path.patch) which tells
  445. chromium to look in /etc/chromium for the master_preferences file
  446. (instead of looking in the default directory, which is the same
  447. directory as the 'chrome' binary).
  448. * Sun Feb 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.335.0-1
  449. - updated to snapshot 5.0.335.0 r39556
  450. * Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-2
  451. - applied chromium-20100122-ubuntu-html5-video-mimetypes.patch from Gentoo
  452. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-1
  453. - updated to snapshot 5.0.330.0 r39074
  454. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-5
  455. - use_system_ffmpeg
  456. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-4
  457. - added Requires: nspluginwrapper
  458. - fixed a symbolic link of plugins directory with nspluginwrapper
  459. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-3
  460. - replaced %%{SOUECE20} to chromium-vendor-vine.patch.in
  461. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-2
  462. - added BuildRequires: mesa-libGLU-devel
  463. - added BuildRequires: libstdc++34 libstdc++34-devel for vl5
  464. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-1
  465. - built based on chromium-5.0.329.0-167.1.src.rpm of OpenSuse
  466. * Sun Nov 29 2009 - tittiatcoke@gmail.com - 4.0.260.0
  467. - Update to 4.0.260
  468. * Fri Nov 27 2009 - tittiatcoke@gmail.com - 4.0.259.0
  469. - Update to 4.0.259
  470. * Thu Nov 26 2009 - tittiatcoke@gmail.com - 4.0.258.0
  471. - Update to 4.0.258
  472. * Tue Nov 24 2009 - tittatcoke@gmai.com - 4.0.257.0
  473. - In order to complete prevent the wrong v8 version to be used, the Chromium build has been
  474. changed to having an built-in v8
  475. * Tue Nov 24 2009 - dbuck@example.com - 4.0.257.0
  476. - Re-base patches. Fixed a few patch errors. Rename some patches to better correspond with function. Removed some patches.
  477. - Minor SPEC changes. I changed the v8 requirement to be exact, instead of greater than a specific version.
  478. * Sat Oct 24 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.223.5
  479. - don't create desktop files in wrapper, fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
  480. * Tue Oct 20 2009 - Raymond Wooninck >tittiatcoke@gmail.com> - 4.0.223.5
  481. - update to newer svn snapshot
  482. + Obsoletes fwrite patch (included upstream)
  483. * Fri Oct 16 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.223.2
  484. - update to newer svn snapshot
  485. + Requires newer version of v8
  486. * Thu Oct 15 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.222.6
  487. - do not force SSE on x86 (drop-sse.patch)
  488. * Tue Oct 13 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.222.6
  489. - Update to newer svn snapshot
  490. - Fixed spec file in order to build
  491. - Included patch to build with system zlib
  492. * Mon Oct 12 2009 - Pavol Rusnak <prusnak@suse.cz> 4.0.222.2
  493. - package renamed to chromium
  494. - cleaned up spec file
  495. * Tue Oct 6 2009 - dbuck <dbuck@example.com> - 4.0.222.2
  496. - v8 is now built as a separate package, and is required
  497. - included many patches to use system libraries: v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
  498. * Sun Oct 1 2009 - dbuck <dbuck@example.com> - 4.0.221.1
  499. - included a newer DEP than is in svn, native_client@823. So things should compile cleanly now
  500. * Sun Aug 31 2009 - dbuck <dbuck@example.com> - 4.0.204.0
  501. - initial build
  502. #% changelog
  503. * Sun Jan 24 2010 prusnak@suse.cz
  504. - added vendor to user agent (chromium-vendor.patch.in)
  505. * Sun Nov 29 2009 prusnak@suse.cz
  506. - added --enable-sync to wrapper to enable bookmark sync
  507. * Fri Nov 13 2009 tittiatcoke@gmail.com
  508. - update to 247.0 svn 31928
  509. * Fri Oct 30 2009 tittiatcoke@gmail.com
  510. - update to 229.0 svn 30454
  511. + Fix regression where popups and app frames lost their titlebars.
  512. + Makes it so that when a folder is open on the bookmark bar
  513. and the mouse moves over another folder, the menu for that
  514. folder is shown.
  515. + Lazily create the find bar.
  516. + Polish to the gmail checker sample.
  517. * New, crisper icons that are exactly 19x19
  518. * Add a loading animation at the beginning before Gmail
  519. responds.
  520. * Fix a bug where we sometimes don't update the UI after a
  521. logout/login cycle.
  522. + Refactor widget methods to support desktop notifications,
  523. including GTK stubs.
  524. + Find-in-page should not ding while deleting characters.
  525. + Add SSL wrapper for linux and mac. This allows notifier to
  526. use chrome's SSL layer instead of OpenSSL.
  527. + Add three of the six extensions to PAC that Internet Explorer supports.
  528. + WebSocket support in chromium. (Run with --enable-web-sockets
  529. enables WebSocket features.)
  530. + Do not allow GTK File Chooser dialogs to return directories.
  531. + Fix the notifier SSL layer to make notifications work for
  532. Linux Bookmark sync.
  533. + linux: don't override mouse selection behavior in omnibox
  534. * Sun Oct 25 2009 tittiatcoke@gmail.com
  535. - Update to 224.4 svn 30027
  536. + First cut at new page and browser action docs based
  537. on new API. Deleted old stuff.
  538. + Add suppression for new memory leak caused by WebKit merge 49830:49844
  539. + Cleanup: change PIDs to base::ProcessId (or pid_t, as appropriate)
  540. + Minimize dependency of user scripts
  541. + Fixup the flip_framer eof-handling semantics now that we have
  542. the FIN bit in place
  543. + app depends on x11 because of active_window_watcher_x
  544. + Adding two images for the new Extension managment UI
  545. + Removing hard-coded Chrome Frame output path
  546. + Rearrange clipboard code
  547. + Fix crash bug when attempting to download a url with unsupported scheme,
  548. e.g. 'data:', by 'Alt + Click'
  549. + GTK: Change text for extension download UI
  550. + Ignore invalid urls on command line
  551. + Make dropped tabs animate from where they were dropped.
  552. + Make room for the full width of the tab placeholder.
  553. + Make tab dragging as smooth as glass.
  554. + Remove an annoying NOTIMPLEMNETED
  555. + Extensions: guarantee removal of BROWSER_WINDOW_READY registration
  556. + If we're in the middle of a drag, don't allow the user to middle
  557. click to close or right click for the context menu
  558. + "Fix" a NOTIMPLEMENTED on Linux by using the default password store
  559. + Remove +x bit from files that shouldn't have it
  560. + Fold first 3 channels of multichannel instead of 5. Use fixed point
  561. + Adding new image needed for the managment UI
  562. + Fix a race bug where content scripts would not apply to the first page load
  563. + Make escape remove a bookmark if it's just been added (but not if it already existed)
  564. + Fix bubbles deactivating the opaque frame
  565. + Allow ESC to cancel ALT+SHIFT+T in Toolbar
  566. + ake all pepper plugins default to windowless and transparent
  567. + Add styles for printing
  568. + Implement the new extension management UI
  569. + Add support for to automation interface load install and load extensions
  570. + GTK: theme the info bar border
  571. + Update V8 to version 1.3.16.1
  572. + Introduce WebSecurityPolicy for security related methods
  573. + New button scheme...borders are separate from the inner contents so
  574. that they can be highlighted / depressed independently
  575. + When opening Chrome maximized with an application window already
  576. running, the Chrome window was not activated
  577. + Fix compatibility problems with FileZilla FTP Server
  578. + Remove the extension shelf on Linux
  579. + Fix the proxy host and port string to start with http:// if it does not already
  580. + Enable HTML5 databases for all extension renderer processes