texlive-macros-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418
  1. ## -*- coding: utf-8-unix -*-
  2. %define tex_destdir %{_datadir}
  3. %define texmf %{_prefix}/share/texmf
  4. %define texlive_src %{tex_destdir}/texlive-sources
  5. %define build_tex_destdir %{buildroot}%{tex_destdir}
  6. %define build_texmf %{buildroot}%{texmf}
  7. %define build_texlive_src %{buildroot}%{tex_destdir}-sources
  8. %define knjfonts kanjifonts-3.1
  9. %define jsclasses_ver 110510
  10. %define jlisting_ver 0.2
  11. %define bkmk2uni convert-bkmk2uni
  12. %define list_macros \
  13. jsclasses-%{jsclasses_ver} \
  14. jlisting-%{jlisting_ver}
  15. ## use some macros for %post, %posttrans
  16. %define touch_run(%1) %{expand:( %__mkdir_p /var/run/texlive; touch /var/run/texlive/run-%1; )
  17. }
  18. %define exec_upddeffont [ -x %{_sbindir}/update-defaultfont ] && \\\
  19. %{_sbindir}/update-defaultfont 2> /dev/null
  20. %define exec_texhash [ -e /var/run/texlive/run-texhash ] && ( \\\
  21. [ -x %{_bindir}/texhash ] && \\\
  22. echo -n " "; echo -n "Running texhash... "; \\\
  23. %{_bindir}/texhash 2> /dev/null; \\\
  24. echo "done." ) && %__rm -f /var/run/texlive/run-texhash;
  25. %define exec_mtxrun [ -e /var/run/texlive/run-mtxrun ] && ( \\\
  26. [ -x %{_bindir}/mtxrun ] && \\\
  27. echo -n " "; echo -n "Running mtxrun... "; \\\
  28. export TEXMF=%{texmf}-dist TEXMFCNF=%{texmf}/web2c TEXMFCACHE=%{texmfsysvar}; \\\
  29. %{_bindir}/mtxrun --generate &> /dev/null; \\\
  30. echo "done." ) && %__rm -f /var/run/texlive/run-mtxrun;
  31. %define exec_fmtutil [ -e /var/run/texlive/run-fmtutil ] && ( \\\
  32. [ -x %{_bindir}/fmtutil-sys ] && \\\
  33. echo -n " "; echo -n "Running fmtutil-sys... "; \\\
  34. %{_bindir}/fmtutil-sys --all &> /dev/null; \\\
  35. echo "done." ) && %__rm -f /var/run/texlive/run-fmtutil;
  36. %define exec_updmap [ -e /var/run/texlive/run-updmap ] && ( \\\
  37. [ -x %{_bindir}/updmap-sys ] && \\\
  38. echo -n " "; echo -n "Running updmap-sys... "; \\\
  39. %{_bindir}/updmap-sys --nohash --quiet &> /dev/null; \\\
  40. echo "done." ) && %__rm -f /var/run/texlive/run-updmap;
  41. Summary: A collection of useful macro packages for texlive package
  42. Summary(ja): texlive パッケージで使うマクロパッケージ集
  43. Name: texlive-macros
  44. Version: 2012
  45. Release: 1%{?_dist_release}
  46. License: distributable
  47. Group: Applications/Publishing
  48. ## Vine Linux
  49. Source0: %{knjfonts}.tar.bz2
  50. Source1: sample.tex
  51. ## jsclasses
  52. Source10: http://oku.edu.mie-u.ac.jp/~okumura/jsclasses/jsclasses-%{jsclasses_ver}.zip
  53. Source11: http://oku.edu.mie-u.ac.jp/~okumura/jsclasses/index.html
  54. ## jlisting
  55. Source20: http://prdownloads.sourceforge.jp/mytexpert/26068/jlisting.sty.bz2
  56. Requires: perl
  57. Requires: texlive-common = %{version}
  58. BuildRequires: texlive-common = %{version}
  59. BuildRequires: nkf unzip
  60. Buildroot: %{_tmppath}/%{name}-%{version}-root
  61. BuildArch: noarch
  62. Obsoletes: tetex-macros
  63. Obsoletes: pLaTeX2e_Macros
  64. Distribution: Vine Linux
  65. Vendor: Project Vine
  66. Packager: munepi
  67. %description
  68. A collection of useful macro packages for texlive package, including
  69. kanjifonts-3.1 (for Ricoh Fonts/DynaLab Fonts and JIS font metric)
  70. %{list_macros}
  71. # This package contained a perl script
  72. # http://www.rmatsumoto.org/tex-ps-pdf/convert-euc.txt
  73. %description -l ja
  74. texlive パッケージで使うマクロパッケージ集です。
  75. 以下のマクロを収録しています。
  76. kanjifonts-3.1 (Vine Linux 3.1R 付属のリコーフォント/ダイナフォントやJISフォントメトリックを使う)
  77. %{list_macros}
  78. # このパッケージには prosper, powerdot 用に
  79. # PDF ブックマークの文字化けを修正するための perl スクリプト
  80. # http://www.rmatsumoto.org/tex-ps-pdf/convert-euc.txt
  81. # を同梱しています.
  82. %prep
  83. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && %__rm -rf $RPM_BUILD_ROOT
  84. %setup -q -c -n %{name}-%{version}
  85. %__mkdir_p jsclasses
  86. (cd jsclasses
  87. %__mkdir_p jsclasses
  88. %__unzip -a -qq %{SOURCE10}
  89. %__cp -p %{SOURCE11} ./jsclasses/README.html
  90. )
  91. # get rid of unwanted files
  92. find . -type d -name CVS | xargs -r %__rm -frv
  93. find . -type f -name .cvsignore | xargs -r %__rm -fv
  94. (cd jsclasses
  95. %__mkdir_p tmp
  96. for i in *.*; do nkf $i > tmp/$i; done
  97. %__mv tmp/* .
  98. %__rm -rf tmp
  99. )
  100. %build
  101. (cd jsclasses
  102. for i in jsclasses okumacro okuverb morisawa; do
  103. platex ${i}.dtx && platex ${i}.dtx || exit 1
  104. done
  105. for i in jsclasses okumacro okuverb; do
  106. dvipdfmx $i || exit 1
  107. done
  108. %__cp *.dvi *.pdf jsclasses
  109. )
  110. %install
  111. %__rm -rf %{buildroot}
  112. %__mkdir_p %{build_texmf}/packages/
  113. ## install kanjifonts
  114. %__mkdir_p %{build_texmf}/tex/platex/kanjifonts
  115. %__mv %{knjfonts}/*.sty %{build_texmf}/tex/platex/kanjifonts
  116. %__mv %{knjfonts}/*.def %{build_texmf}/tex/platex/kanjifonts
  117. # nkf --utf8 %{SOURCE25} | \
  118. # sed -e "s@^#!/usr/local/bin/perl5 -w@#!/usr/bin/perl -w@" > \
  119. # %{buildroot}%{_bindir}/%{bkmk2uni}
  120. # chmod 755 %{buildroot}%{_bindir}/%{bkmk2uni}
  121. ## install jsclasses
  122. (cd jsclasses
  123. %__mkdir_p %{build_texmf}/tex/platex/jsclasses
  124. %__cp -fp *.dtx *.ins *.cls *.sty %{build_texmf}/tex/platex/jsclasses/
  125. )
  126. ## install jlisting
  127. %__mkdir_p %{build_texmf}/tex/latex/jlisting
  128. %__install -m 644 %{SOURCE20} %{build_texmf}/tex/latex/jlisting/
  129. bunzip2 %{build_texmf}/tex/latex/jlisting/jlisting.sty.bz2
  130. %post
  131. %touch_run texhash
  132. exit 0
  133. %postun
  134. if [ "$1" = 0 ]; then
  135. %touch_run texhash
  136. fi
  137. exit 0
  138. %posttrans
  139. %{exec_texhash}
  140. exit 0
  141. %clean
  142. %__rm -rf $RPM_BUILD_ROOT
  143. %files
  144. %defattr(-,root,root)
  145. %doc %{knjfonts}
  146. %doc jsclasses/jsclasses
  147. #%{_bindir}/%{bkmk2uni}
  148. %{texmf}/tex/platex/kanjifonts/kanjifonts.sty
  149. %{texmf}/tex/platex/kanjifonts/*.def
  150. %{texmf}/tex/platex/jsclasses
  151. %{texmf}/tex/latex/jlisting
  152. %changelog
  153. * Sat Nov 24 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-1
  154. - TeX Live 2012
  155. * Thu Feb 9 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-3
  156. - move jlisting package to %%{texmf}/tex/latex/jlisting
  157. * Thu Dec 1 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-2
  158. - updated jsclasses to 110510
  159. - mistook to change %%jsclasses_ver at 2011-1
  160. * Sun Nov 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
  161. - TeX Live 2011
  162. - updated jsclasses to 110510
  163. * Fri Dec 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
  164. - dropped BuildRequires: jvf
  165. - for vl5, added Conflicts: tetex-macros
  166. * Tue Aug 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
  167. - removed %%{exec_updmap} in %%post and %%postun
  168. * Tue May 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
  169. - ported from tetex-macros-3.0-7
  170. - TeX Live 2009
  171. * Mon Oct 12 2009 Munehiro Yamamoto <munepi@vinelinux.org> 3.0-7
  172. - added BuildRequires: unzip
  173. - updated jsclasses to 090826
  174. - updated pict2e to 0.2x
  175. * Sun May 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-6
  176. - dropped epsbox.sty, eclepsf.sty
  177. (bacause there style files for platex209 are obsolete)
  178. * Fri May 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-5
  179. - added jlisting v0.2
  180. - defined list_macros
  181. - used %%{list_macros} in %%description and %%description -l ja
  182. * Thu May 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-4
  183. - dropped convert-euc.txt
  184. * Sat May 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-3
  185. - updated prosper
  186. - added some contrib themes from CTAN
  187. - added prosper.cls v1.6 from CVS HEAD
  188. - added a perl script: convert-euc.txt
  189. - added powerdot v1.3
  190. - added xkeyval v2.5d
  191. - added beamer v3.07
  192. - added pgf v2.00
  193. - added pict2e v0.2w
  194. * Sat May 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-2
  195. - updated jsclasses to 20090222
  196. - updated jsclasses/index.html to 2009-02-22
  197. - removed /usr/share/texmf/dvips/config/extmap/morisawa.map (See [BTS:524])
  198. * Wed Sep 03 2008 Shu KONNO <owa@bg.wakwak.com> 3.0-1vl5
  199. - applied new versioning policy, spec in utf-8
  200. * Mon Oct 08 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl3
  201. - update jsclasses/index.html to 2006-11-06.
  202. * Fri May 19 2006 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl2
  203. - update jsclasses/index.html to 2006-02-12.
  204. * Sun Nov 06 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl1
  205. - update jsclasses/index.html to 2005-10-26.
  206. * Sat Jun 18 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl0.1
  207. - update jsclasses/index.html to 2005-4-30.
  208. - added breqn
  209. * Tue Jan 18 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 2.0-0vl7
  210. - update jsclasses/index.html to 2004-12-29.
  211. * Mon Jan 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-0vl6
  212. - add missing files in kanjifonts-3.0
  213. * Sun Jan 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-0vl6
  214. - update to kanjifonts.sty-3.0.
  215. * Mon Nov 29 2004 KOBAYASHI Taizo <tkoba@vinelinux.org> 2.0-0vl4
  216. - update jsclasses/index.html to 2004-11-03.
  217. * Sat Oct 16 2004 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0vl3
  218. - update jsclasses/index.html to 2004-09-27.
  219. * Sat Apr 17 2004 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0vl2
  220. - update jsclasses/index.html to 2004-02-25.
  221. - added eclepsf.sty.
  222. - removed epsf.sty (symlink to epsbox.sty).
  223. - removed geometry, which is in tetex-2.0.
  224. * Fri Apr 18 2003 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0vl1
  225. - update jsclasses/index.html to 2003-04-18.
  226. - added morisawa.dvi.
  227. * Fri Mar 14 2003 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0t2
  228. - update jsclasses/index.html to 2003-03-06
  229. * Mon Feb 3 2003 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0t1
  230. - remove natbib, which is in tetex-2.0
  231. - let version number same as tetex
  232. - added Requires: tetex
  233. * Sat Jan 18 2003 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl9
  234. - update jsclasses/index.html to 2003-01-16
  235. * Mon Jan 13 2003 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl8
  236. - update jsclasses to 2003-01-05
  237. - update index.html to 2003-01-12
  238. * Thu Nov 28 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl7
  239. - update jsclasses and index.html to 2002-11-27
  240. * Sun Nov 03 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl6
  241. - update jsclasses and index.html to 2002-11-01
  242. * Thu Oct 17 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl5
  243. - oops, packager was incorrect
  244. * Mon Jul 15 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl4
  245. - update jsclasses to 2002-06-29
  246. - update index.html to 2002-07-03
  247. * Sun Apr 28 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl3
  248. - update jsclasses to 2002-04-21
  249. - update index.html to 2002-04-09
  250. * Tue Apr 16 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.1-0vl2
  251. - added MORISAWA basic 5 fonts
  252. * Mon Mar 25 2002 Jun Nishii <jun@vinelinux.org> 1.1-0vl1
  253. - update to kanjifonts-1.1
  254. * Thu Feb 07 2002 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl11
  255. - update jsclasses and index.html to 2002-02-07
  256. * Tue Jan 31 2002 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl10
  257. - update jsclasses and index.html to 2002-01-27
  258. - fix typo in changelog
  259. * Fri Jan 25 2002 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl9
  260. - update jsclasses and index.html to 2002-01-18
  261. * Tue Dec 18 2001 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl8
  262. - update index.html (jsclasses)
  263. * Sat Dec 15 2001 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl7
  264. - update jsclasses to 2001-11-29
  265. * Sun Sep 16 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.0-0vl6
  266. - fixed spec file for Prosper and jsclasses
  267. - use RPM macro in %files
  268. - added BuildPrereq: jvf
  269. * Mon Sep 10 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl5
  270. - move revtex4 to texmacro-aps package
  271. * Sun Sep 9 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl4
  272. - added prosper jsclasses
  273. * Mon Sep 6 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl3
  274. - added revtex4 natbib
  275. * Mon Sep 3 2001 Jun Nishii <jun@vinelinux.org> 1.0-0vl2
  276. - remove prereq tetex to avoid dependency-loop
  277. * Wed Aug 1 2001 Jun Nishii <jun@vinelinux.org>
  278. - tetex-macros-1.0-0vl1
  279. * Fri Jan 21 2000 Jun Nishii <jun@vinelinux.org>
  280. - 2.0-2
  281. - added kanjifonts-1.0 and removed jisfontsmetric
  282. * Sun Jan 9 2000 Jun Nishii <jun@vinelinux.org>
  283. - 2.0-1
  284. - install ldf in babel
  285. * Sat Jan 8 2000 Jun Nishii <jun@vinelinux.org>
  286. - added jisfontmetric.tex
  287. * Fri Oct 29 1999 Norihito Ohmori <ohmori@flatout.org>
  288. - change group.
  289. * Sun Oct 17 1999 Jun Nishii <jun@flatout.org>
  290. - added babel
  291. * Fri Aug 27 1999 Jun Nishii <jun@flatout.org>
  292. - added hoekwater
  293. * Mon Aug 3 1999 Jun Nishii <jun@flatout.org>
  294. - added psfrag
  295. * Mon Jun 21 1999 Jun Nishii <jun@flatout.org>
  296. - added psnfss
  297. - Change directory tree according to the suggestion by Dr.Okumura.
  298. - remove many files from packages directory except documentations
  299. - disable mktexlsr and erase ls-R
  300. * Tue Feb 16 1999 Jun Nishii <jun@flatout.org>
  301. - added url.sty
  302. * Thu Dec 3 1998 Jun Nishii <jun@flatout.org>
  303. - pLaTeX2e_Macros-1-2
  304. - added fancyhdr.sty, boxedminipage.sty
  305. - added graphics.cfg, color.cfg (use dvips as default)
  306. - symlink from epsbox to epsf
  307. * Mon Nov 9 1998 Jun Nishii <jun@flatout.org>
  308. - pLaTeX2e_Macros-1-1
  309. (rename as pLaTeX2e_Macros from pLaTeX-Classes)
  310. - added def files of graphics
  311. - added tools and hyperref
  312. - check the existence of mktexlsr
  313. * Tue Oct 5 1998 Jun Nishii <jun@flatout.org>
  314. - buildarch: noarch
  315. - added requires
  316. * Tue Sep 29 1998 Jun Nishii <jun@flatout.org>
  317. - tiny bug fix and add %defattr
  318. * Wed Sep 23 1998 Jun Nishii <jun@flatout.org>
  319. - first version fo platex-19980901