expect-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376
  1. %{!?tcl_version: %define tcl_version %(echo 'puts $tcl_version' | tclsh)}
  2. %{!?tcl_sitearch: %define tcl_sitearch %{_libdir}/tcl%{tcl_version}}
  3. %define tcl_major 8.4
  4. %define majorver 5.45
  5. Summary: A Tcl/Tk development environment: expect
  6. Summary(ja): Tcl/Tk 開発環境: expect
  7. Name: expect
  8. Version: %{majorver}
  9. Release: 2%{?_dist_release}
  10. License: Public Domain
  11. Group: Development/Languages
  12. # URL: probably more useful is http://sourceforge.net/projects/expect/
  13. URL: http://expect.nist.gov/
  14. Source: http://downloads.sourceforge.net/%{name}/%{name}%{version}.tar.gz
  15. # Patch0: fixes change log file permissions
  16. Patch0: expect-5.43.0-log_file.patch
  17. # Patch1: fixes install location, change pkgIndex
  18. Patch1: expect-5.43.0-pkgpath.patch
  19. # Patch2: fixes minor man page formatting issue
  20. Patch2: expect-5.45-man-page.patch
  21. # Patch3: fixes segmentation fault during matching characters
  22. Patch3: expect-5.45-match-gt-numchars-segfault.patch
  23. # Patch4: fixes memory leak when using -re, http://sourceforge.net/p/expect/patches/13/
  24. Patch4: expect-5.45-re-memleak.patch
  25. # Patch5: use vsnprintf instead of vsprintf to avoid buffer overflow
  26. Patch5: expect-5.45-exp-log-buf-overflow.patch
  27. # Patch6: fixes segfaults if Tcl is built with stubs and Expect is used directly
  28. # from C program rhbz#1091060
  29. Patch6: expect-5.45-segfault-with-stubs.patch
  30. # Patch7: fixes leaked fd, patch by Matej Mužila, rhbz#1001220
  31. Patch7: expect-5.45-fd-leak.patch
  32. # examples patches
  33. # Patch100: changes random function
  34. Patch100: expect-5.32.2-random.patch
  35. # Patch101: fixes bz674184 - mkpasswd fails randomly
  36. Patch101: expect-5.45-mkpasswd-dash.patch
  37. # Patch102: fixes bz703702 - let user know that telnet is needed for
  38. # running some examples
  39. Patch102: expect-5.45-check-telnet.patch
  40. # Patch103: use full path to 'su', it's safer
  41. Patch103: expect-5.45-passmass-su-full-path.patch
  42. # Patch104: rhbz 963889, fixes inaccuracy in mkpasswd man page
  43. Patch104: expect-5.45-mkpasswd-man.patch
  44. Buildroot: %{_tmppath}/%{name}-%{version}-root
  45. BuildRequires: tk-devel >= %{tcl_major}
  46. BuildRequires: autoconf
  47. BuildRequires: chrpath
  48. BuildRequires: libX11-devel
  49. BuildRequires: libXft-devel
  50. Vendor: Project Vine
  51. Distribution: Vine Linux
  52. %description -n expect
  53. Expect is a tcl extension for automating interactive applications such
  54. as telnet, ftp, passwd, fsck, rlogin, tip, etc. Expect is also useful
  55. for testing the named applications. Expect makes it easy for a script
  56. to control another program and interact with it.
  57. Install the expect package if you'd like to develop scripts which interact
  58. with interactive applications. You'll also need to install the tcl
  59. package.
  60. %package devel
  61. Summary: Development files for expect library.
  62. Summary(ja): expect ライブラリの開発用ファイル
  63. Group: Development/Libraries
  64. Requires: expect = %{version}-%{release}
  65. Obsoletes: expect <= 5.43-0vl4
  66. %description devel
  67. This package contains development files for the expect library.
  68. %package -n expectk
  69. Summary: A program-script interaction and testing utility
  70. Group: Development/Tools
  71. Requires: expect = %{version}-%{release}
  72. Obsoletes: expect <= 5.43-0vl4
  73. %description -n expectk
  74. This package originally contained expectk and some scripts
  75. that used it. As expectk was removed from upstream tarball
  76. in expect-5.45, now the package contains just these scripts.
  77. Please use tclsh with package require Tk and Expect instead
  78. of expectk.
  79. %prep
  80. %setup -q -n expect%{version}
  81. %patch0 -p1 -b .log_file
  82. %patch1 -p1 -b .pkgpath
  83. %patch2 -p1 -b .man-page
  84. %patch3 -p1 -b .match-gt-numchars-segfault
  85. %patch4 -p1 -b .re-memleak
  86. %patch5 -p1 -b .exp-log-buf-overflow
  87. %patch6 -p1 -b .segfault-with-stubs
  88. %patch7 -p1 -b .fd-leak
  89. # examples fixes
  90. %patch100 -p1 -b .random
  91. %patch101 -p1 -b .mkpasswd-dash
  92. %patch102 -p1 -b .check-telnet
  93. %patch103 -p1 -b .passmass-su-full-path
  94. %patch104 -p1 -b .mkpasswd-man
  95. # -pkgpath.patch touch configure.in
  96. aclocal
  97. autoconf
  98. ( cd testsuite
  99. autoconf -I.. )
  100. %build
  101. %configure --with-tcl=%{_libdir} --with-tk=%{_libdir} --enable-shared \
  102. --with-tclinclude=%{_includedir}/tcl-private/generic
  103. make %{?_smp_mflags}
  104. %check
  105. make test
  106. %install
  107. rm -rf ${RPM_BUILD_ROOT}
  108. make install DESTDIR="$RPM_BUILD_ROOT"
  109. # move
  110. mv "$RPM_BUILD_ROOT"%{tcl_sitearch}/expect%{version}/libexpect%{version}.so "$RPM_BUILD_ROOT"%{_libdir}
  111. # for linking with -lexpect
  112. ln -s libexpect%{majorver}.so "$RPM_BUILD_ROOT"%{_libdir}/libexpect.so
  113. # remove cryptdir/decryptdir, as Linux has no crypt command (bug 6668).
  114. rm -f "$RPM_BUILD_ROOT"%{_bindir}/{cryptdir,decryptdir}
  115. rm -f "$RPM_BUILD_ROOT"%{_mandir}/man1/{cryptdir,decryptdir}.1*
  116. rm -f "$RPM_BUILD_ROOT"%{_bindir}/autopasswd
  117. # remove rpath
  118. chrpath --delete $RPM_BUILD_ROOT%{_libdir}/libexpect%{version}.so
  119. %post -p /sbin/ldconfig -n expect
  120. %postun -p /sbin/ldconfig -n expect
  121. %clean
  122. rm -rf $RPM_BUILD_ROOT
  123. %files
  124. %%defattr(-,root,root)
  125. %doc FAQ HISTORY NEWS README
  126. %{_bindir}/expect
  127. %{_bindir}/autoexpect
  128. %{_bindir}/dislocate
  129. %{_bindir}/ftp-rfc
  130. %{_bindir}/kibitz
  131. %{_bindir}/lpunlock
  132. %{_bindir}/mkpasswd
  133. %{_bindir}/passmass
  134. %{_bindir}/rftp
  135. %{_bindir}/rlogin-cwd
  136. %{_bindir}/timed-read
  137. %{_bindir}/timed-run
  138. %{_bindir}/unbuffer
  139. %{_bindir}/weather
  140. %{_bindir}/xkibitz
  141. %dir %{tcl_sitearch}/expect%{version}
  142. %{tcl_sitearch}/expect%{version}/pkgIndex.tcl
  143. %{_libdir}/libexpect%{version}.so
  144. %{_mandir}/man1/autoexpect.1.gz
  145. %{_mandir}/man1/dislocate.1.gz
  146. %{_mandir}/man1/expect.1.gz
  147. %{_mandir}/man1/kibitz.1.gz
  148. %{_mandir}/man1/mkpasswd.1.gz
  149. %{_mandir}/man1/passmass.1.gz
  150. %{_mandir}/man1/tknewsbiff.1.gz
  151. %{_mandir}/man1/unbuffer.1.gz
  152. %{_mandir}/man1/xkibitz.1.gz
  153. %files devel
  154. %defattr(-,root,root,-)
  155. %{_libdir}/libexpect.so
  156. %{_mandir}/man3/libexpect.3*
  157. %{_includedir}/*
  158. %files -n expectk
  159. %defattr(-,root,root,-)
  160. %{_bindir}/multixterm
  161. %{_bindir}/tknewsbiff
  162. %{_bindir}/tkpasswd
  163. %{_bindir}/xpstat
  164. %{_mandir}/man1/multixterm.1*
  165. %{_mandir}/man1/tknewsbiff.1*
  166. %changelog
  167. * Sat Dec 5 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.45-2
  168. - fixed a symlink.
  169. - fixed BR:.
  170. * Wed Dec 31 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 5.45-1
  171. - updated to 5.45
  172. - rebuilt with tcl/tk 8.5.15
  173. * Fri Jan 4 2013 IWAI, Masaharu <iwai@alib.jp> 5.44.1.15-1
  174. - update to 5.44.1.15:sync ed Hat Enterprise Linux 6 expect-5.44.1.15-4.el6
  175. - add BuildRequires: tk, chrpath
  176. - update License: Public Domain
  177. - drop obsolete patches
  178. - random patch (Patch0)
  179. - spawn-43310 patch (Patch6)
  180. - setpgrp patch (Patch8)
  181. - lib spec patch (Patch10)
  182. - libdir patch (Patch11)
  183. - add some patches from RHEL expect-5.44.1.15-4.el6
  184. - fixes log file permissions patch (Patch500)
  185. - fixes install location patch (Patch501)
  186. - tk init patch (Patch502)
  187. - match gt numchars segfault patch (Patch503)
  188. - man page patch (Patch504)
  189. - random patch (Patch600)
  190. - unbuffer exit code patch (Patch601)
  191. - passmass su full path Patch (Patch602)
  192. - update build and install section: sync RHEL expect-5.44.1.15-4.el6
  193. - add Vendor and Distribution tags
  194. * Tue Apr 19 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.43-5
  195. - add missing BuildRequires: libX11-devel
  196. * Sat Apr 16 2011 Shu KONNO <owa@bg.wakwak.com> 5.43-4
  197. - rebuilt with rpm-4.8.1-3
  198. * Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 5.43-3
  199. - rebuilt with tcl/tk-8.4.19-2
  200. * Tue May 18 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.43-2
  201. - rebuilt with new toolchain
  202. - changed devel Group to Development/Libraries
  203. * Sun Jul 27 2008 Shu KONNO <owa@bg.wakwak.com> 5.43-1vl5
  204. - applied new versioning policy and spec in utf-8
  205. * Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl6
  206. - rebuilt with tcl/tk-8.4.18
  207. * Fri Nov 09 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 5.43-0vl5
  208. - split to expect-devel and expectk sub package.
  209. - add libexpect.so to expect-devel (<BTS:wishes:0136>)
  210. * Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl4
  211. - rebuilt with tcl/tk-8.4.16
  212. * Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl3
  213. - rebuilt with new toolchain
  214. * Sun Jan 29 2006 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl2
  215. - rebuild for tcl/tk-8.4.12
  216. - added --enable-64bit to configure's option
  217. * Fri Sep 09 2005 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl1
  218. - updated expect to 5.43.0
  219. - dropped expect-5.39.0-64bit-82547.patch (for fixed)
  220. - dropped expect-5.32.2-kibitz.patch (for fixed)
  221. - dropped expect-5.38.0-autopasswd-9917.patch (for fixed)
  222. - rebuilt with tcl/tk 8.4.11
  223. * Wed Jun 30 2004 Shu KONNO <owa@bg.wakwak.com> 5.39-95vl2
  224. - rebuild for tcl/tk-8.4.6
  225. * Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 5.39-95vl1
  226. - update based on fedora
  227. * Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl1
  228. - update based on BitWalk's tcltk-8.4.2-83bw and RawHide tcltk-8.3.5-89
  229. * Thu Nov 15 2001 Kazuhusa TAKEI <takei@linux.or.jp> 8.0.5_jp-10vl3
  230. - splite source package
  231. - add include files
  232. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
  233. - expand some macros.. (FIXME)
  234. * Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
  235. - use %configure macros
  236. - add Patch 47,50
  237. * Thu May 31 2001 <sagami@vinelinux.org>
  238. - 8.0.5_jp-10
  239. - unexpand old %%{configure}, new one causes build failure
  240. - fixed missing libtkx.so libtclx.so symlink in /usr/lib
  241. - install manpages into %%{_mandir} and mode 644
  242. * Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  243. - 8.0.5_jp-9
  244. - modified %install section to handle compressed man pages
  245. - fixed /usr/lib/tk8.0jp/demos.jp/images symlink
  246. * Sun Jul 2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
  247. - changed default fonts
  248. * Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
  249. - added defattr
  250. * Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
  251. - added some symlinks, such as libtcl8.0.so.
  252. - obsoletes version number using _jp, now 8.0.5-31vl1
  253. * Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
  254. - Apply Tcl/Tk 8.0 Japanese Patch 1.7
  255. * Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
  256. - fix tclX symlinks.
  257. - compile on systems where SIGPWR == SIGLOST.
  258. * Sat May 1 1999 Jeff Johnson <jbj@redhat.com>
  259. - update tcl/tk to 8.0.5.
  260. - avoid "containing" in Tix (#2332).
  261. * Thu Apr 8 1999 Jeff Johnson <jbj@redhat.com>
  262. - use /usr/bin/write in kibitz (#1320).
  263. - use cirrus.sprl.umich.edu in weather (#1926).
  264. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  265. - auto rebuild in the new build environment (release 28)
  266. * Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
  267. - whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
  268. * Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
  269. - expect does unaligned access on alpha (#989)
  270. - upgrade tcl/tk/tclX to 8.0.4
  271. - upgrade expect to 5.28.
  272. - add itcl 3.0.1
  273. * Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
  274. - call libtoolize to allow building on the arm
  275. - build for glibc 2.1
  276. - strip binaries
  277. * Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
  278. - update tcl/tk/tclX to 8.0.3, expect is updated also.
  279. * Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
  280. - expect: mkpasswd needs delay before sending password (problem #576)
  281. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  282. - translations modified for de, fr, tr
  283. * Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
  284. - fixed expect binaries exec permissions
  285. * Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
  286. - updated to Tix 4.1.0.006
  287. - updated version numbers of tcl/tk to relflect includsion of p2
  288. * Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
  289. - updated tcl/tk to patch level 2
  290. - updated tclX to 8.0.2
  291. * Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
  292. - fixed filelist for tix... replacing path to the expect binary in scripts
  293. was leaving junk files around.
  294. * Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
  295. - added patch to remove libieee test in configure.in for tcl and tk.
  296. Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
  297. solution for all systems
  298. - fixed src urls
  299. * Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
  300. - removed version numbers from descriptions
  301. * Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
  302. - updated to tcl/tk 8.0 and related versions of packages
  303. * Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
  304. - built against glibc
  305. - fixed dangling tclx/tkx symlinks