module-init-tools-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540
  1. Summary: Kernel module management utilities.
  2. Summary(ja): カーネルモジュール管理ユーティリティ
  3. Name: module-init-tools
  4. Version: 3.8
  5. Release: 4%{?_dist_release}
  6. License: GPLv2+
  7. Group: System Environment/Kernel
  8. Source: http://www.kernel.org/pub/linux/utils/kernel/module-init-tools/module-init-tools-%{version}.tar.bz2
  9. Source1: http://www.kernel.org/pub/linux/utils/kernel/module-init-tools/module-init-tools-%{version}.tar.bz2.sign
  10. Source2: modprobe-dist.conf
  11. Source3: weak-modules
  12. Source4: depmod-dist.conf
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: zlib-devel, docbook-utils
  15. BuildRequires: zlib-static
  16. Exclusiveos: Linux
  17. Requires(post): chkconfig, coreutils
  18. Obsoletes: modutils-devel, modutils
  19. Provides: modutils = %{version}
  20. %description
  21. The module-init-tools package includes various programs needed for automatic
  22. loading and unloading of modules under 2.6 and later kernels, as well
  23. as other module management programs. Device drivers and filesystems
  24. are two examples of loaded and unloaded modules.
  25. %description -l ja
  26. module-init-tools パッケージには,バージョン 2.6 以上の kernel モジュールを
  27. 自動的にロード/アンロードする為の様々なプログラムや,モジュール管理の
  28. 為のプログラムなどが収められています.モジュールとしては,デバイスドライバ,
  29. ファイルシステム,その他が挙げられます.
  30. %prep
  31. %setup -q
  32. %build
  33. export CC=gcc
  34. export CFLAGS="$RPM_OPT_FLAGS -DCONFIG_NO_BACKWARDS_COMPAT=1"
  35. %configure --enable-zlib
  36. make
  37. %install
  38. rm -rf $RPM_BUILD_ROOT
  39. %makeinstall sbindir=$RPM_BUILD_ROOT/sbin
  40. install -m 755 generate-modprobe.conf \
  41. $RPM_BUILD_ROOT/sbin
  42. install -m 644 modprobe.conf.5 \
  43. $RPM_BUILD_ROOT/%{_mandir}/man5/modprobe.d.5
  44. install -m 644 depmod.conf.5 \
  45. $RPM_BUILD_ROOT/%{_mandir}/man5/depmod.d.5
  46. mkdir -p $RPM_BUILD_ROOT/etc
  47. mkdir -p $RPM_BUILD_ROOT/etc/modprobe.d
  48. install -m 644 %{SOURCE2} $RPM_BUILD_ROOT/etc/modprobe.d/modprobe-dist.conf
  49. install -m 755 %{SOURCE3} $RPM_BUILD_ROOT/sbin/weak-modules
  50. mkdir -p $RPM_BUILD_ROOT/etc/depmod.d
  51. install -m 644 %{SOURCE4} $RPM_BUILD_ROOT/etc/depmod.d/depmod-dist.conf
  52. mv $RPM_BUILD_ROOT/%{_bindir}/lsmod $RPM_BUILD_ROOT/sbin
  53. touch $RPM_BUILD_ROOT/etc/modprobe.d/modprobe.conf
  54. %clean
  55. rm -rf $RPM_BUILD_ROOT
  56. %post
  57. if [ -f /etc/modprobe.conf -a ! -f /etc/modprobe.d/modprobe.conf ] ; then
  58. mv -f /etc/modprobe.conf /etc/modprobe.d/modprobe.conf
  59. fi
  60. %files
  61. %defattr(-,root,root)
  62. /etc/modprobe.d
  63. /etc/depmod.d
  64. /sbin/*
  65. %{_mandir}/*/*
  66. %ghost %config(noreplace) %verify(not md5 size mtime) /etc/modprobe.d/modprobe.conf
  67. %changelog
  68. * Tue May 12 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8-4
  69. - remove kernel 2.4 compatibility from %%post
  70. * Wed May 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8-3
  71. - move /etc/modprobe.conf to /etc/modprobe.d/modprobe.conf
  72. * Mon May 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8-2
  73. - rename /etc/modprobe.d/{depmod,modprobe}.conf.dist to
  74. {depmod,modprobe}-dist.conf
  75. * Sun May 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8-1
  76. - new upstream release
  77. - add BR: zlib-static
  78. * Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.6-1
  79. - new upstream release
  80. - rename to module-init-tools
  81. - Provides: modutils, Obsoletes: modules, modutils-devel
  82. - drop modutils compatibility support
  83. * Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 3.2.2-1vl5
  84. - applied new versioning policy, spec in utf-8
  85. * Mon Oct 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.2-0vl4
  86. - add Patch102 to build with gcc4
  87. - enable combined-rmmod for insmod.static (initramfs needs rmmod)
  88. * Sun Oct 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.2-0vl3
  89. - update modprobe.conf.dist
  90. - load mmc_block when sdhci is loaded
  91. * Sun Aug 06 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.2-0vl2
  92. - enable %%build_small
  93. - add modutils-devel subpackage for internal use.
  94. * Sun Mar 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.2-0vl1
  95. - update module-init-tools-3.2.2
  96. - use module-init-tools version for package version
  97. - update modprobe.conf.dist, move to /etc/modprobe.d
  98. - remove "include" statement from /etc/modprobe.conf if found.
  99. * Thu May 6 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.27-0vl1
  100. - new upstream release
  101. - modutils-2.4.27
  102. - module-init-tools-3.0
  103. - import fedora fixes
  104. * Wed May 5 2004 Bill Nottingham <notting@redhat.com> 2.4.26-16
  105. - fix sound restoring on module load when done via OSS compat
  106. * Thu Apr 15 2004 Bill Nottingham <notting@redhat.com> 2.4.26-15
  107. - don't buildreq autoconf-2.13 (#116770)
  108. - sound-slot-0/snd-card-0 hacking-around
  109. * Mon Mar 29 2004 Bill Nottingham <notting@redhat.com> 2.4.26-14
  110. - modinfo: use new modinfo if passed <foo>.ko
  111. * Tue Mar 23 2004 Steve Dickson <SteveD@RedHat.com>
  112. - Added the mounting of /proc/fs/nfsd to modprobe.conf.dist
  113. so it gets mounted when nfsd is loaded.
  114. * Tue Mar 16 2004 Steve Dickson <SteveD@RedHat.com>
  115. - /var/lib/nfs/rpc_pipefs not /var/lib/rpc_pipes should be
  116. mounted when sunrpc is loaded.
  117. * Fri Mar 12 2004 Steve Dickson <SteveD@RedHat.com>
  118. - umount rpc_pipefs when sunrpc is unloaded
  119. * Thu Mar 11 2004 Bill Nottingham <notting@redhat.com> 2.4.26-9
  120. - add nfsv4 aliases to modprobe.conf.dist
  121. - clean out upstreamed aliases in modprobe.conf.dist
  122. - mount rpc_pipefs when sunrpc is loaded
  123. * Fri Mar 5 2004 Bill Nottingham <notting@redhat.com> 2.4.26-7
  124. - blacklist eth1394 (#117383)
  125. * Mon Feb 23 2004 Bill Nottingham <notting@redhat.com> 2.4.26-6
  126. - update module-init-tools to 3.0pre10
  127. - fix modinfo (#116305)
  128. - always include /etc/modprobe.conf.dist (don't require the line in modprobe.conf)
  129. - ship a static modprobe.conf.dist, don't generate it at build time
  130. - clean up modprobe.conf.dist a little (#113772, #113768)
  131. * Wed Feb 11 2004 Bill Nottingham <notting@redhat.com>
  132. - don't use trampolines in insmod, working around #106005
  133. * Thu Jan 29 2004 Bill Nottingham <notting@redhat.com> 2.4.26-3
  134. - fix irda (#114268), bluetooth (#114019) and alsa aliases
  135. * Wed Jan 14 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.4.26-2vl1
  136. - syncd with fedora
  137. * Fri Nov 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.26-0vl1
  138. - new upstream release
  139. * Thu May 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.25-0vl1
  140. - new upstream release
  141. * Tue Dec 10 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.22-0vl3
  142. - enable build with dietlibc also on ppc and alpha
  143. * Tue Dec 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.22-0vl2
  144. - enable zlib
  145. - remove pre-defined "above"s. it's not needed for Vine Linux.
  146. * Sun Dec 8 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.22-0vl1
  147. - new upstream release
  148. * Sun Sep 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.20-0vl1
  149. - new upstream release
  150. * Thu Jul 18 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.16-1vl2
  151. - BuildPreReq: dietlibc for ix86 only
  152. * Tue Jul 09 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.16-1vl1
  153. - new upstream release
  154. * Sun May 05 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.14-1vl2
  155. - rebuild with diet.
  156. - merged with Skipjack.
  157. * Mon Apr 1 2002 Bill Nottingham <notting@redhat.com> 2.4.14-2
  158. - fix support for symbols that contain _R (<streeter@redhat.com>)
  159. * Thu Mar 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.4.14-1vl1
  160. - source update
  161. * Sat Mar 2 2002 Bill Nottingham <notting@redhat.com> 2.4.14-1
  162. - update to 2.4.14
  163. - take out genksyms.old, no more buildprereq for gperf
  164. * Thu Feb 28 2002 Bill Nottingham <notting@redhat.com> 2.4.13-7/8
  165. - rebuild against diet
  166. - reenable rmmod in the library version, shrink it too
  167. * Wed Feb 27 2002 Bill Nottingham <notting@redhat.com> 2.4.13-5
  168. - rebuild in earlier environments
  169. * Fri Feb 22 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.4.13-4vl1
  170. - modified for Vine
  171. - merged devel-package with parent package
  172. * Sun Feb 10 2002 Bill Nottingham <notting@redhat.com> 2.4.13-4
  173. - various space shavings in -devel
  174. * Fri Feb 8 2002 Bill Nottingham <notting@redhat.com> 2.4.13-3
  175. - bump rev
  176. - buildprereq gperf
  177. * Mon Feb 4 2002 Bill Nottingham <notting@redhat.com> 2.4.13-1
  178. - update to 2.4.13
  179. - fix GPL symbol export
  180. * Wed Jan 30 2002 Bill Nottingham <notting@redhat.com> 2.4.12-9
  181. - shrink insmod.static
  182. * Thu Jan 24 2002 Bill Nottingham <notting@redhat.com> 2.4.12-8
  183. - fix installation of extra libraries (#58427)
  184. * Thu Jan 17 2002 Bill Nottingham <notting@redhat.com> 2.4.12-7
  185. - hack to allow depmod of 64bit kernels on 32bit PPC
  186. * Tue Jan 15 2002 Bill Nottingham <notting@redhat.com> 2.4.12-6
  187. - more ppc64 fixes
  188. * Thu Jan 10 2002 Bill Nottingham <notting@redhat.com> 2.4.12-5
  189. - fix build on combined 32/64 targets (ppc/sparc)
  190. * Tue Dec 11 2001 Matt Wilson <msw@redhat.com>
  191. - added a -devel subpackage that contains libraries that apps can use
  192. to implement insmod and rmmod
  193. * Tue Dec 4 2001 Bill Nottingham <notting@redhat.com>
  194. - get rid of some obsolete patches, other tweaks
  195. * Thu Nov 29 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  196. - update to 2.4.12
  197. * Sat Nov 17 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  198. - update to 2.4.11
  199. * Tue Oct 2 2001 Bill Nottingham <notting@redhat.com>
  200. - update to 2.4.10
  201. - deprecate -i, -m arguments to depmod
  202. * Tue Sep 25 2001 Bill Nottingham <notting@redhat.com>
  203. - update to 2.4.9
  204. * Wed Aug 29 2001 Bill Nottingham <notting@redhat.com>
  205. - replace modutils-2.4.6-error patch with version that was integrated
  206. upstream
  207. * Sat Aug 18 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  208. - disable char-major-4 for s390/s390x
  209. * Mon Jul 8 2001 Bill Nottingham <notting@redhat.com>
  210. - remove /etc/cron.d/kmod
  211. * Fri Jul 6 2001 Bill Nottingham <notting@redhat.com>
  212. - update to 2.4.6
  213. - alias binfmt-0000 off (#9709)
  214. - turn off 'modules.conf is more recent than modules.dep' message (#14276,
  215. others)
  216. - return nonzero from depmod if there are errors (#40935)
  217. - fix manpage typo (#33123)
  218. * Thu Jul 05 2001 Karsten Hopp <karsten@redhat.de>
  219. - new S390 patch from IBM
  220. * Tue Jun 26 2001 Elliot Lee <sopwith@redhat.com> 2.4.5-3
  221. - Add modutils-2.4.5-stblocal.patch from Jakub. See the e-mail message
  222. inside the patch file for details.
  223. - Use smp_mflags macro
  224. * Thu Jun 21 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  225. - add s390/s390x support
  226. * Tue Apr 24 2001 Bill Nottingham <notting@redhat.com>
  227. - update to 2.4.5
  228. * Tue Mar 6 2001 Bill Nottingham <notting@redhat.com>
  229. - add default post/preun for binfmt_misc
  230. * Mon Feb 19 2001 Bill Nottingham <notting@redhat.com>
  231. - change ipv6 alias to 'alias net-pf-10 off'
  232. * Tue Feb 13 2001 Bill Nottingham <notting@redhat.com>
  233. - add 'net-pf-10 ipv6' alias (#25405)
  234. * Sun Jan 28 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  235. - change "#ifdef s390" -> "#if defined(__s390__) || defined(__s390x__)"
  236. * Tue Jan 23 2001 Bill Nottingham <notting@redhat.com>
  237. - update to 2.4.2
  238. - ship a genksyms.old
  239. * Fri Jan 19 2001 Bill Nottingham <notting@redhat.com>
  240. - fix ppp aliases
  241. * Tue Jan 9 2001 Bill Nottingham <notting@redhat.com>
  242. - oops, I blew away other people's changes. Fix that.
  243. - only have tty-ldisc-11 in the aliases once
  244. * Mon Jan 8 2001 Bill Nottingham <notting@redhat.com>
  245. - update to 2.4.0
  246. - tweak irda aliases
  247. - remove vixie-cron dependency (it's not *required*)
  248. - add missing %build (where did that go?)
  249. * Sun Jan 7 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  250. - 2.4.0
  251. - Get rid of obsolete char-major-60==ircom-tty patch
  252. (moved to 161)
  253. * Sat Jan 06 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  254. - add "ctc{0,1,2} -> ctc" alias for s390
  255. * Sat Dec 23 2000 Bill Nottingham <notting@redhat.com>
  256. - add missing comma in alias list
  257. - add irda aliases
  258. * Tue Dec 12 2000 Bill Nottingham <notting@redhat.com>
  259. - add char-major-108 ppp_async alias
  260. * Mon Dec 11 2000 Bill Nottingham <notting@redhat.com>
  261. - fix ide-probe aliases (now ide-probe-mod)
  262. * Wed Nov 22 2000 Matt Wilson <msw@redhat.com>
  263. - 2.3.21, fixes more security problems.
  264. * Thu Nov 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  265. - 2.3.20, fixes security holes
  266. * Tue Oct 31 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  267. - 2.3.19
  268. - add IrDA devices to alias patch
  269. - update source URL
  270. * Thu Oct 26 2000 Bill Nottingham <notting@redhat.com>
  271. - fix ia64 module loading
  272. * Mon Oct 2 2000 Bill Nottingham <notting@redhat.com>
  273. - stupid ia64 tricks
  274. * Fri Sep 29 2000 Jeff Johnson <jbj@redhat.com>
  275. - upgrade to 2.3.17.
  276. - sparc64 ELF hacks.
  277. * Mon Aug 21 2000 Michael K. Johnson <johnsonm@redhat.com>
  278. - Use %{_mandir} for removing kerneld-related man pages.
  279. * Wed Aug 9 2000 Jakub Jelinek <jakub@redhat.com>
  280. - fix build on SPARC
  281. * Tue Aug 8 2000 Jakub Jelinek <jakub@redhat.com>
  282. - update to 2.3.14
  283. * Tue Jul 25 2000 Bill Nottingham <notting@redhat.com>
  284. - update to 2.3.13
  285. - turn psaux off again
  286. - remove sound patch; it's obsolete
  287. * Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
  288. - rebuild to cope with glibc locale binary incompatibility
  289. * Thu Jul 13 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  290. - 2.3.12
  291. - fix up ia64
  292. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  293. - automatic rebuild
  294. * Sat Jul 1 2000 Florian La Roche <laroche@redhat.com>
  295. - add aliases for cipcb[0-3]
  296. * Wed Jun 14 2000 Matt Wilson <msw@redhat.com>
  297. - fix build on combined 32/64 bit sparc
  298. * Thu Jun 1 2000 Bill Nottingham <notting@redhat.com>
  299. - modules.confiscation
  300. * Wed May 17 2000 Bill Nottingham <notting@redhat.com>
  301. - add ia64 patch from Intel
  302. * Wed May 17 2000 Jakub Jelinek <jakub@redhat.com>
  303. - fix build with glibc 2.2
  304. * Tue May 09 2000 Doug Ledford <dledford@redhat.com>
  305. - Correct %description to reflect that we don't build kerneld by default
  306. * Fri Apr 21 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  307. - 2.3.11
  308. * Mon Apr 3 2000 Bill Nottingham <notting@redhat.com>
  309. - fix net-pf-* aliases for ipx, appletalk
  310. * Fri Mar 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  311. - 2.3.10
  312. * Thu Feb 17 2000 Matt Wilson <msw@redhat.com>
  313. - added alias for agpgart
  314. * Mon Feb 14 2000 Bill Nottingham <notting@redhat.com>
  315. - hardcode psaux alias to off everywhere
  316. * Thu Feb 3 2000 Bill Nottingham <notting@redhat.com>
  317. - add a symlink from conf.modules.5 to modules.conf.5
  318. * Fri Jan 29 2000 Bill Nottingham <notting@redhat.com>
  319. - fix breakage *correctly*
  320. * Sat Jan 22 2000 Bill Nottingham <notting@redhat.com>
  321. - fix breakage of our own cause w.r.t sound modules
  322. * Thu Jan 06 2000 Jakub Jelinek <jakub@redhat.com>
  323. - update to 2.3.9.
  324. - port RH patches from 2.1.121 to 2.3.9 where needed.
  325. - disable warning about conf.modules for now, in 7.0
  326. we should move to modules.conf.
  327. * Wed Oct 13 1999 Jakub Jelinek <jakub@redhat.com>
  328. - hardcode psaux alias on sparc to off.
  329. * Tue Oct 05 1999 Bill Nottingham <notting@redhat.com>
  330. - hardcode parport aliases....
  331. * Mon Oct 04 1999 Cristian Gafton <gafton@redhat.com>
  332. - rebuild against new glibc in the sparc tree
  333. * Wed Sep 15 1999 Jakub Jelinek <jakub@redhat.com>
  334. - rewrite sparckludge so that separate *64 binaries
  335. are not needed anymore.
  336. * Sat Sep 11 1999 Cristian Gafton <gafton@redhat.com>
  337. - apply the last patch in the %prep section (doh!)
  338. * Mon Apr 19 1999 Cristian Gafton <gafton@redhat.com>
  339. - add support for the ppp compression modules by default
  340. * Tue Apr 13 1999 Michael K. Johnson <johnsonm@redhat.com>
  341. - add cron.d file to run rmmod -as
  342. * Fri Apr 09 1999 Cristian Gafton <gafton@redhat.com>
  343. - take out kerneld
  344. * Mon Apr 05 1999 Cristian Gafton <gafton@redhat.com>
  345. - add patch to make all raid personalities recognized
  346. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  347. - auto rebuild in the new build environment (release 7)
  348. * Thu Mar 18 1999 Cristian Gafton <gafton@redhat.com>
  349. - obsoletes modules
  350. - get rid of the /lib/modules/preferred hack
  351. * Mon Mar 15 1999 Bill Nottingham <notting@redhat.com>
  352. - added support for /lib/modules/foo/pcmcia
  353. - make kerneld initscript not start by default
  354. * Tue Feb 23 1999 Matt Wilson <msw@redhat.com>
  355. - added sparc64 support from UltraPenguin
  356. * Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
  357. - call libtoolize to allow it to compile on the arm
  358. * Wed Dec 23 1998 Jeff Johnson <jbj@redhat.com>
  359. - search /lib/modules/preferred before defaults but after specified paths.
  360. * Tue Nov 17 1998 Cristian Gafton <gafton@redhat.com>
  361. - upgraded to version 2.1.121
  362. * Thu Nov 05 1998 Erik Troan <ewt@redhat.com>
  363. - added -m, -i options
  364. * Thu Oct 01 1998 Michael K. Johnson <johnsonm@redhat.com>
  365. - fix syntax error I introduced when enhancing initscript
  366. * Wed Sep 30 1998 Michael K. Johnson <johnsonm@redhat.com>
  367. - enhance initscript
  368. * Fri Aug 28 1998 Jeff Johnson <jbj@redhat.com>
  369. - recompile statically linked binary for 5.2/sparc
  370. * Tue Jul 28 1998 Jeff Johnson <jbj@redhat.com>
  371. - pick up ultrapenguin patches (not applied for now).
  372. - pre-generate keyword.c so gperf doesn't have to be present (not applied).
  373. - util/sys_cm.c: fix create_module syscall (signed return on sparc too)
  374. * Wed Jul 15 1998 Jeff Johnson <jbj@redhat.com>
  375. - correct %postun typos
  376. * Fri May 01 1998 Erik Troan <ewt@redhat.com>
  377. - added /lib/modules/preferred to search path
  378. * Fri Apr 24 1998 Prospector System <bugs@redhat.com>
  379. - translations modified for de, fr, tr
  380. * Tue Apr 07 1998 Cristian Gafton <gafton@redhat.com>
  381. - updated to 2.1.85
  382. - actually make use of the BuildRoot
  383. * Fri Apr 3 1998 Jakub Jelinek <jj@ultra.linux.cz>
  384. - Fix sparc64, add modinfo64 on sparc.
  385. * Wed Mar 23 1998 Jakub Jelinek <jj@ultra.linux.cz>
  386. - Handle EM_SPARCV9, kludge to support both 32bit and 64bit kernels
  387. from the same package on sparc/sparc64.
  388. * Fri Nov 7 1997 Michael Fulbright
  389. - removed warning message when conf.modules exists and is a empty
  390. * Tue Oct 28 1997 Erik Troan <ewt@redhat.com>
  391. - patched to honor -k in options
  392. - added modprobe.1
  393. - added init script
  394. * Thu Oct 23 1997 Erik Troan <ewt@redhat.com>
  395. - removed bogus strip of lsmod (which is a script)
  396. * Mon Oct 20 1997 Erik Troan <ewt@redhat.com>
  397. - updated to 2.1.55
  398. - builds in a buildroot
  399. * Mon Aug 25 1997 Erik Troan <ewt@redhat.com>
  400. - added insmod.static
  401. * Sun Aug 24 1997 Erik Troan <ewt@redhat.com>
  402. - built on Intel
  403. - combined rmmod and insmod