wxGTK3-vl.spec 7.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237
  1. %global srcname wxWidgets
  2. %global wxgtkname wxGTK3
  3. %global wxbasename wxBase3
  4. %global gtkver 3
  5. Name: %{wxgtkname}
  6. Version: 3.0.4
  7. Release: 1%{?_dist_release}
  8. Summary: GTK port of the wxWidgets GUI library
  9. License: wxWidgets
  10. Group: System Environment/Libraries
  11. URL: http://www.wxwidgets.org/
  12. Vendor: Project Vine
  13. Distribution: Vine Linux
  14. Source0: https://github.com/wxWidgets/wxWidgets/releases/download/v%{version}/wxWidgets-%{version}.tar.bz2
  15. Source10: wx-config
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. BuildRequires: gtk%{gtkver}-devel
  18. #Note webkitgtk (GTK2) does not appear to be supported
  19. BuildRequires: webkitgtk4-devel
  20. BuildRequires: zlib-devel
  21. BuildRequires: libpng-devel
  22. BuildRequires: libjpeg-turbo-devel
  23. BuildRequires: libtiff-devel
  24. BuildRequires: expat-devel
  25. BuildRequires: SDL-devel
  26. BuildRequires: libgnomeprintui-devel
  27. BuildRequires: libGLU-devel
  28. BuildRequires: libSM-devel
  29. BuildRequires: gstreamer-plugins-base-devel
  30. BuildRequires: GConf2-devel
  31. BuildRequires: gettext
  32. BuildRequires: cppunit-devel
  33. BuildRequires: libmspack-devel
  34. Provides: %{srcname} = %{version}-%{release}
  35. Requires: %{wxbasename}%{?_isa} = %{version}-%{release}
  36. %description
  37. wxWidgets is the GTK port of the C++ cross-platform wxWidgets
  38. GUI library, offering classes for all common GUI controls as well as a
  39. comprehensive set of helper classes for most common application tasks,
  40. ranging from networking to HTML display and image manipulation.
  41. %package devel
  42. Group: Development/Libraries
  43. Summary: Development files for the wxGTK3 library
  44. Requires: %{name}%{?_isa} = %{version}-%{release}
  45. Requires: %{wxbasename} = %{version}-%{release}
  46. Requires: gtk%{gtkver}-devel
  47. Requires: libGLU-devel
  48. Provides: %{srcname}-devel = %{version}-%{release}
  49. %description devel
  50. This package include files needed to link with the wxGTK3 library.
  51. wxWidgets is the GTK port of the C++ cross-platform wxWidgets
  52. GUI library, offering classes for all common GUI controls as well as a
  53. comprehensive set of helper classes for most common application tasks,
  54. ranging from networking to HTML display and image manipulation.
  55. %package -n %{wxbasename}
  56. Summary: Non-GUI support classes from the wxWidgets library
  57. Group: System Environment/Libraries
  58. %description -n %{wxbasename}
  59. Every wxWidgets application must link against this library. It contains
  60. mandatory classes that any wxWidgets code depends on (like wxString) and
  61. portability classes that abstract differences between platforms. wxBase can
  62. be used to develop console mode applications -- it does not require any GUI
  63. libraries or the X Window System.
  64. #%package docs
  65. #Group: Development/Libraries
  66. #Summary: Documentation for the wxGTK3 library
  67. #Requires: %{name} = %{version}-%{release}
  68. #Provides: %{srcname}-docs = %{version}-%{release}
  69. #BuildArch: noarch
  70. #%description docs
  71. #This package provides documentation for the %{srcname} library.
  72. %prep
  73. %setup -q -n %{srcname}-%{version}
  74. # in case of gtk3
  75. %if %{gtkver} == 3
  76. sed -i -e 's|gtk2|gtk3|' %{SOURCE10}
  77. %endif
  78. # patch some installed files to avoid conflicts with 2.8.*
  79. sed -i -e 's|aclocal)|aclocal/wxwin3.m4)|' Makefile.in
  80. sed -i -e 's|wxstd.mo|wxstd3.mo|' Makefile.in
  81. sed -i -e 's|wxmsw.mo|wxmsw3.mo|' Makefile.in
  82. # rename docs directory
  83. #mv %{srcname}-%{version} html
  84. sed -i -e 's|/usr/lib\b|%{_libdir}|' wx-config.in configure
  85. # fix plugin dir for 64-bit
  86. sed -i -e 's|/lib|/%{_lib}|' src/unix/stdpaths.cpp
  87. %build
  88. # likely still dereferences type-punned pointers
  89. CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
  90. CXXFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
  91. # fix unused-direct-shlib-dependency error:
  92. export LDFLAGS="-Wl,--as-needed"
  93. %configure \
  94. --with-gtk=%{gtkver} \
  95. --with-opengl \
  96. --with-sdl \
  97. --with-gnomeprint \
  98. --with-libmspack \
  99. --enable-intl \
  100. --enable-no_deps \
  101. --disable-rpath \
  102. --enable-ipv6 \
  103. --enable-utf8 \
  104. make %{?_smp_mflags}
  105. %install
  106. %makeinstall
  107. # install our multilib-aware wrapper
  108. rm %{buildroot}%{_bindir}/wx-config
  109. rm %{buildroot}%{_bindir}/wxrc
  110. install -p -m 755 %{SOURCE10} %{buildroot}%{_bindir}/wx-config-3.0
  111. # move bakefiles to avoid conflicts with 2.8.*
  112. mkdir %{buildroot}%{_datadir}/bakefile/presets/wx3
  113. mv %{buildroot}%{_datadir}/bakefile/presets/*.* %{buildroot}%{_datadir}/bakefile/presets/wx3
  114. %find_lang wxstd3
  115. %find_lang wxmsw3
  116. cat wxmsw3.lang >> wxstd3.lang
  117. %check
  118. pushd tests
  119. make %{?_smp_mflags} test
  120. popd
  121. %post -p /sbin/ldconfig
  122. %postun -p /sbin/ldconfig
  123. %post -n %{wxbasename} -p /sbin/ldconfig
  124. %postun -n %{wxbasename} -p /sbin/ldconfig
  125. %files -f wxstd3.lang
  126. %license docs/gpl.txt docs/lgpl.txt docs/licence.txt docs/licendoc.txt docs/preamble.txt
  127. %doc docs/changes.txt docs/readme.txt
  128. %{_libdir}/libwx_gtk%{gtkver}u_adv-*.so.*
  129. %{_libdir}/libwx_gtk%{gtkver}u_aui-*.so.*
  130. %{_libdir}/libwx_gtk%{gtkver}u_core-*.so.*
  131. %{_libdir}/libwx_gtk%{gtkver}u_html-*.so.*
  132. %{_libdir}/libwx_gtk%{gtkver}u_gl-*.so.*
  133. %{_libdir}/libwx_gtk%{gtkver}u_media-*.so.*
  134. %{_libdir}/libwx_gtk%{gtkver}u_propgrid-*.so.*
  135. %{_libdir}/libwx_gtk%{gtkver}u_qa-*.so.*
  136. %{_libdir}/libwx_gtk%{gtkver}u_ribbon-*.so.*
  137. %{_libdir}/libwx_gtk%{gtkver}u_richtext-*.so.*
  138. %{_libdir}/libwx_gtk%{gtkver}u_stc-*.so.*
  139. %if %{gtkver} == 3
  140. %{_libdir}/libwx_gtk%{gtkver}u_webview-*.so.*
  141. %endif
  142. %{_libdir}/libwx_gtk%{gtkver}u_xrc-*.so.*
  143. %files devel
  144. %{_bindir}/wx-config*
  145. %{_bindir}/wxrc-3.0
  146. %{_includedir}/wx-3.0
  147. %{_libdir}/libwx_*.so
  148. %{_libdir}/wx
  149. %{_datadir}/aclocal/wxwin3.m4
  150. %{_datadir}/bakefile/presets/wx3/
  151. %files -n %{wxbasename}
  152. %doc docs/changes.txt docs/gpl.txt docs/lgpl.txt docs/licence.txt
  153. %doc docs/licendoc.txt docs/preamble.txt docs/readme.txt
  154. %{_libdir}/libwx_baseu-*.so.*
  155. %{_libdir}/libwx_baseu_net-*.so.*
  156. %{_libdir}/libwx_baseu_xml-*.so.*
  157. #%files docs
  158. #%doc html
  159. %changelog
  160. * Sun Oct 06 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.0.4-1
  161. - new upstream release.
  162. * Fri Jul 1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.0.2-2
  163. - rebuilt with new toolchain.
  164. * Sat Nov 29 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.0.2-1
  165. - new upstream release
  166. * Fri Sep 05 2014 Toshiharu Kudoh <kudoh@vinelinux.org> - 3.0.1-1
  167. - initial build for Vine Linux
  168. * Sat Jul 5 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.1-1
  169. - Bump to 3.0.1 RH#1076617
  170. * Tue Mar 18 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.0-6
  171. - Removed disable-catch_segvs, see RH#1076617
  172. * Mon Mar 17 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.0-5
  173. - Renable combat28 - without it causes bugs RH#1076617 and a few others
  174. * Wed Feb 19 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.0-4
  175. - Fixed GTK3 bug with wx-config
  176. - Fixed a unused-direct-shlib-dependency error
  177. * Mon Feb 17 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.0-3
  178. - Added patch to avoid build fail on gtk 3.10+
  179. - Reverted patching to make devel package compatible with wxGTK-devel
  180. - Added combatibility for RHEL 6+
  181. - Changed all mention of GTK3 and GTK2 to GTK for consistency
  182. * Mon Feb 10 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.0-2
  183. - Changed to build against gtk3
  184. - Add webkit to build requires
  185. - Removed patching to make devel package compatible with wxGTK-devel
  186. - Disable 2.8.* combatibility (redundant functionality)
  187. * Sat Jan 4 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.0-1
  188. - Initial build of wxwidgets version 3, mostly based on wxGTK spec