xerces-j2-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522
  1. %global cvs_version 2_11_0
  2. Name: xerces-j2
  3. Summary: Java XML parser
  4. Summary(ja): Java XML パーサ
  5. Version: 2.11.0
  6. Release: 1%{?_dist_release}
  7. Group: Development/Libraries
  8. License: ASL 2.0
  9. URL: http://xerces.apache.org/xerces2-j/
  10. Source0: http://mirror.ox.ac.uk/sites/rsync.apache.org/xerces/j/source/Xerces-J-src.%{version}.tar.gz
  11. Source1: %{name}-version.sh
  12. Source2: %{name}-constants.sh
  13. Source11: %{name}-version.1
  14. Source12: %{name}-constants.1
  15. # Custom javac ant task used by the build
  16. Source3: https://svn.apache.org/repos/asf/xerces/java/tags/Xerces-J_%{cvs_version}/tools/src/XJavac.java
  17. # Custom doclet tags used in javadocs
  18. Source5: https://svn.apache.org/repos/asf/xerces/java/tags/Xerces-J_%{cvs_version}/tools/src/ExperimentalTaglet.java
  19. Source6: https://svn.apache.org/repos/asf/xerces/java/tags/Xerces-J_%{cvs_version}/tools/src/InternalTaglet.java
  20. Source7: %{name}-pom.xml
  21. # Patch the build so that it doesn't try to use bundled xml-commons source
  22. Patch0: %{name}-build.patch
  23. # Patch the manifest so that it includes OSGi stuff
  24. Patch1: %{name}-manifest.patch
  25. # Backported fix from upstream http://svn.apache.org/viewvc?view=revision&revision=1499506
  26. # See https://bugzilla.redhat.com/show_bug.cgi?id=1140031
  27. Patch2: xerces-j2-CVE-2013-4002.patch
  28. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  29. BuildArch: noarch
  30. BuildRequires: java-devel >= 1.6.0
  31. BuildRequires: javapackages-tools >= 3.4.1-7vl7
  32. BuildRequires: xalan-j2 >= 2.7.1
  33. BuildRequires: xml-commons-apis >= 1.4.01
  34. BuildRequires: xml-commons-resolver >= 1.2
  35. BuildRequires: ant
  36. BuildRequires: jaxp_parser_impl
  37. #BuildRequires: dejavu-sans-fonts
  38. Requires: java-headless
  39. Requires: javapackages-tools
  40. Requires: xalan-j2 >= 2.7.1
  41. Requires: xml-commons-apis >= 1.4.01
  42. Requires: xml-commons-resolver >= 1.2
  43. Provides: jaxp_parser_impl = 1.4
  44. Provides: %{name}-scripts = %{version}-%{release}
  45. Obsoletes: %{name}-scripts < 2.9.0-5
  46. Requires(post): alternatives jaxp_parser_impl
  47. Requires(preun): alternatives jaxp_parser_impl
  48. # This documentation is provided by xml-commons-apis
  49. Obsoletes: %{name}-javadoc-apis < %{version}-%{release}
  50. # http://mail-archives.apache.org/mod_mbox/xerces-j-dev/201008.mbox/%3COF8D7E2F83.0271A181-ON8525777F.00528302-8525777F.0054BBE0@ca.ibm.com%3E
  51. Obsoletes: %{name}-manual < %{version}-%{release}
  52. %description
  53. Welcome to the future! Xerces2 is the next generation of high performance,
  54. fully compliant XML parsers in the Apache Xerces family. This new version of
  55. Xerces introduces the Xerces Native Interface (XNI), a complete framework for
  56. building parser components and configurations that is extremely modular and
  57. easy to program.
  58. The Apache Xerces2 parser is the reference implementation of XNI but other
  59. parser components, configurations, and parsers can be written using the Xerces
  60. Native Interface. For complete design and implementation documents, refer to
  61. the XNI Manual.
  62. Xerces2 is a fully conforming XML Schema processor. For more information,
  63. refer to the XML Schema page.
  64. Xerces2 also provides a complete implementation of the Document Object Model
  65. Level 3 Core and Load/Save W3C Recommendations and provides a complete
  66. implementation of the XML Inclusions (XInclude) W3C Recommendation. It also
  67. provides support for OASIS XML Catalogs v1.1.
  68. Xerces2 is able to parse documents written according to the XML 1.1
  69. Recommendation, except that it does not yet provide an option to enable
  70. normalization checking as described in section 2.13 of this specification. It
  71. also handles namespaces according to the XML Namespaces 1.1 Recommendation,
  72. and will correctly serialize XML 1.1 documents if the DOM level 3 load/save
  73. APIs are in use.
  74. %package javadoc
  75. Summary: Javadocs for %{name}
  76. Group: Documentation
  77. Requires: javapackages-tools
  78. # Consolidating all javadocs into one package
  79. Obsoletes: %{name}-javadoc-impl < %{version}-%{release}
  80. Obsoletes: %{name}-javadoc-xs < %{version}-%{release}
  81. Obsoletes: %{name}-javadoc-xni < %{version}-%{release}
  82. Obsoletes: %{name}-javadoc-other < %{version}-%{release}
  83. %description javadoc
  84. This package contains the API documentation for %{name}.
  85. %package demo
  86. Summary: Demonstrations and samples for %{name}
  87. Group: Development/Libraries
  88. Requires: %{name} = %{version}-%{release}
  89. %description demo
  90. %{summary}.
  91. %prep
  92. %setup -q -n xerces-%{cvs_version}
  93. %patch0 -p0 -b .orig
  94. %patch1 -p0 -b .orig
  95. %patch2 -p0 -b .orig
  96. # Copy the custom ant tasks into place
  97. mkdir -p tools/org/apache/xerces/util
  98. mkdir -p tools/bin
  99. cp -a %{SOURCE3} %{SOURCE5} %{SOURCE6} tools/org/apache/xerces/util
  100. # Make sure upstream hasn't sneaked in any jars we don't know about
  101. find -name '*.class' -exec rm -f '{}' \;
  102. find -name '*.jar' -exec rm -f '{}' \;
  103. sed -i 's/\r//' LICENSE README NOTICE
  104. %build
  105. pushd tools
  106. # Build custom ant tasks
  107. javac -classpath $(build-classpath ant) org/apache/xerces/util/XJavac.java
  108. jar cf bin/xjavac.jar org/apache/xerces/util/XJavac.class
  109. # Build custom doc taglets
  110. javac -classpath /usr/lib/jvm/java/lib/tools.jar org/apache/xerces/util/*Taglet.java
  111. jar cf bin/xerces2taglets.jar org/apache/xerces/util/*Taglet.class
  112. ln -sf $(build-classpath xalan-j2-serializer) serializer.jar
  113. ln -sf $(build-classpath xml-commons-apis) xml-apis.jar
  114. ln -sf $(build-classpath xml-commons-resolver) resolver.jar
  115. ln -sf $(build-classpath xerces-j2) x.jar
  116. popd
  117. # Build everything
  118. export ANT_OPTS="-Xmx256m -Djava.endorsed.dirs=$(pwd)/tools -Djava.awt.headless=true -Dbuild.sysclasspath=first -Ddisconnected=true"
  119. ant -Djavac.source=1.5 -Djavac.target=1.5 \
  120. -Dbuild.compiler=modern \
  121. clean jars javadocs
  122. %install
  123. rm -rf $RPM_BUILD_ROOT
  124. # jars
  125. install -pD -T build/xercesImpl.jar $RPM_BUILD_ROOT%{_javadir}/%{name}.jar
  126. # javadoc
  127. mkdir -p $RPM_BUILD_ROOT%{_javadocdir}/%{name}
  128. mkdir -p $RPM_BUILD_ROOT%{_javadocdir}/%{name}/impl
  129. mkdir -p $RPM_BUILD_ROOT%{_javadocdir}/%{name}/xs
  130. mkdir -p $RPM_BUILD_ROOT%{_javadocdir}/%{name}/xni
  131. mkdir -p $RPM_BUILD_ROOT%{_javadocdir}/%{name}/other
  132. cp -pr build/docs/javadocs/xerces2/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}/impl
  133. cp -pr build/docs/javadocs/api/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}/xs
  134. cp -pr build/docs/javadocs/xni/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}/xni
  135. cp -pr build/docs/javadocs/other/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}/other
  136. # scripts
  137. install -pD -m755 -T %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}/%{name}-version
  138. install -pD -m755 -T %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}-constants
  139. # manual pages
  140. install -d -m 755 $RPM_BUILD_ROOT%{_mandir}/man1
  141. install -p -m 644 %{SOURCE11} $RPM_BUILD_ROOT%{_mandir}/man1
  142. install -p -m 644 %{SOURCE12} $RPM_BUILD_ROOT%{_mandir}/man1
  143. # demo
  144. install -pD -T build/xercesSamples.jar $RPM_BUILD_ROOT%{_datadir}/%{name}/%{name}-samples.jar
  145. cp -pr data $RPM_BUILD_ROOT%{_datadir}/%{name}
  146. # Pom
  147. #install -pD -T -m 644 %{SOURCE7} %{buildroot}%{_mavenpomdir}/JPP-%{name}.pom
  148. # Depmap with legacy depmaps for compatability
  149. #add_maven_depmap JPP-%{name}.pom %{name}.jar -a "xerces:xerces,xerces:xmlParserAPIs,apache:xerces-j2"
  150. # jaxp_parser_impl ghost symlink
  151. ln -s %{_sysconfdir}/alternatives \
  152. $RPM_BUILD_ROOT%{_javadir}/jaxp_parser_impl.jar
  153. %clean
  154. rm -rf $RPM_BUILD_ROOT
  155. %post
  156. /sbin/update-alternatives --install %{_javadir}/jaxp_parser_impl.jar \
  157. jaxp_parser_impl %{_javadir}/%{name}.jar 40
  158. %preun
  159. if [ $1 = 0 ]; then
  160. /sbin/update-alternatives --remove jaxp_parser_impl \
  161. %{_javadir}/%{name}.jar
  162. fi
  163. %files
  164. %defattr(-,root,root,-)
  165. %doc LICENSE NOTICE README
  166. %{_javadir}/%{name}*
  167. %{_bindir}/*
  168. %{_mandir}/*/*
  169. %ghost %{_javadir}/jaxp_parser_impl.jar
  170. %files javadoc
  171. %defattr(-,root,root,-)
  172. %{_javadocdir}/%{name}
  173. %files demo
  174. %defattr(-,root,root,-)
  175. %{_datadir}/%{name}
  176. %changelog
  177. * Sat Jan 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.11.0-1
  178. - updated to 2.11.0
  179. * Sat Feb 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.9.0-6
  180. - rebuild with Vine6 environment
  181. * Fri Aug 27 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.9.0-5
  182. - Initial build for Vine Linux
  183. * Sat Jun 12 2010 Mat Booth <fedora@matbooth.co.uk> - 2.9.0-4
  184. - Fix broken links in manual and fix javadoc requires.
  185. - Build 1.5 bytecode instead of 1.6, for compatibility.
  186. * Fri Jan 22 2010 Andrew Overholt <overholt@redhat.com> - 2.9.0-3
  187. - Fix unversioned Provides for jaxp_parser_impl (make it 1.3).
  188. * Thu Jan 14 2010 Mat Booth <fedora@matbooth.co.uk> - 2.9.0-2
  189. - Add a build dep on a font package because the JDK is missing a dependency
  190. to function correctly in headless mode. See RHBZ #478480 and #521523.
  191. - Fix groups.
  192. * Tue Jan 5 2010 Mat Booth <fedora@matbooth.co.uk> - 2.9.0-1
  193. - Update to 2.9.0: This is the version Eclipse expects, previously the OSGi
  194. manifest was lying about its version :-o
  195. - Enable manual sub-package now xml-stylebook is in Fedora.
  196. - Drop GCJ support.
  197. - Minor changes to spec to make it more conforming to the guidelines.
  198. - Drop the libgcj patch, we don't seem to need it anymore.
  199. - Add the OSGi manifest as part of the build instead of the install.
  200. - Fix packaging bug RHBZ #472646.
  201. * Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:2.7.1-12.3
  202. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  203. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:2.7.1-11.3
  204. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  205. * Fri Jan 30 2009 Alexander Kurtakov <akurtako@redhat.com> 0:2.7.1-10.3
  206. - Add osgi manifest.
  207. * Thu Jul 10 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0:2.7.1-10.2
  208. - drop repotag
  209. - fix license tag
  210. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0:2.7.1-10jpp.1
  211. - Autorebuild for GCC 4.3
  212. * Wed Mar 28 2007 Matt Wringe <mwringe@redhat.com> 0:2.7.1-9jpp.1
  213. - Update with newest jpp version
  214. - Clean up spec file for Fedora Review
  215. * Sun Aug 13 2006 Warren Togami <wtogami@redhat.com> 0:2.7.1-7jpp.2
  216. - fix typo in preun req
  217. * Sat Aug 12 2006 Matt Wringe <mwringe at redhat.com> 0:2.7.1-7jpp.1
  218. - Merge with upstream version
  219. * Sat Aug 12 2006 Matt Wringe <mwringe at redhat.com> 0:2.7.1-7jpp
  220. - Add conditional native compiling
  221. - Add missing requires for javadocs
  222. - Add missing requires for post and preun
  223. - Update version to 7jpp at Fedora's request
  224. * Sat Jul 22 2006 Jakub Jelinek <jakub@redhat.com> - 0:2.7.1-6jpp_9fc
  225. - Rebuilt
  226. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0:2.7.1-6jpp_8fc
  227. - rebuild
  228. * Thu Mar 30 2006 Fernando Nasser <fnasser@redhat.com> 0:2.7.1-3jpp
  229. - Add missing BR for xml-stylebook
  230. * Wed Mar 22 2006 Ralph Apel <r.apel at r-apel.de> 0:2.7.1-2jpp
  231. - First JPP-1.7 release
  232. - use tools subdir and give it as java.endorsed.dirs (for java-1.4.2-bea e.g.)
  233. * Mon Mar 6 2006 Jeremy Katz <katzj@redhat.com> - 0:2.7.1-6jpp_7fc
  234. - stop scriptlet spew
  235. * Wed Feb 22 2006 Rafael Schloming <rafaels@redhat.com> - 0:2.7.1-6jpp_6fc
  236. - Updated to 2.7.1
  237. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0:2.6.2-6jpp_5fc
  238. - bump again for double-long bug on ppc(64)
  239. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0:2.6.2-6jpp_4fc
  240. - rebuilt for new gcc4.1 snapshot and glibc changes
  241. * Thu Feb 2 2006 Archit Shah <ashah@redhat.com> 0:2.6.2-6jpp_3fc
  242. - build xerces without using native code
  243. * Mon Jan 9 2006 Archit Shah <ashah@redhat.com> 0:2.6.2-6jpp_2fc
  244. - rebuilt for new gcj
  245. * Wed Dec 21 2005 Jesse Keating <jkeating@redhat.com> 0:2.6.2-6jpp_1fc
  246. - rebuilt for new gcj
  247. * Tue Dec 13 2005 Jesse Keating <jkeating@redhat.com>
  248. - rebuilt for new gcj
  249. * Fri Oct 07 2005 Ralph Apel <r.apel at r-apel.de> 0:2.7.1-1jpp
  250. - Upgrade to 2.7.1
  251. * Thu Jul 21 2005 Ralph Apel <r.apel at r-apel.de> 0:2.6.2-7jpp
  252. - Include target jars-dom3
  253. - Create new subpackage dom3
  254. * Mon Jul 18 2005 Gary Benson <gbenson at redhat.com> 0:2.6.2-5jpp_2fc
  255. - Build on ia64, ppc64, s390 and s390x.
  256. - Switch to aot-compile-rpm (also BC-compiles samples).
  257. * Wed Jul 13 2005 Gary Benson <gbenson at redhat.com> 0:2.6.2-6jpp
  258. - Build with Sun JDK (from <gareth.armstrong at hp.com>).
  259. * Wed Jun 15 2005 Gary Benson <gbenson at redhat.com> 0:2.6.2-5jpp_1fc
  260. - Upgrade to 2.6.2-5jpp.
  261. * Tue Jun 14 2005 Gary Benson <gbenson at redhat.com> 0:2.6.2-5jpp
  262. - Remove the tools tarball, and build xjavac from source.
  263. - Patch xjavac to fix the classpath under libgcj too.
  264. * Fri Jun 10 2005 Gary Benson <gbenson@redhat.com> 0:2.6.2-4jpp_8fc
  265. - Remove the tools tarball, and build xjavac from source.
  266. - Replace classpath workaround to xjavac task and use
  267. xml-commons classes again (#152255).
  268. * Thu May 26 2005 Gary Benson <gbenson@redhat.com> 0:2.6.2-4jpp_7fc
  269. - Rearrange how BC-compiled stuff is built and installed.
  270. * Mon May 23 2005 Gary Benson <gbenson@redhat.com> 0:2.6.2-4jpp_6fc
  271. - Add alpha to the list of build architectures (#157522).
  272. - Use absolute paths for rebuild-gcj-db.
  273. * Thu May 5 2005 Gary Benson <gbenson@redhat.com> 0:2.6.2-4jpp_5fc
  274. - Add dependencies for %%post and %%postun scriptlets (#156901).
  275. * Fri Apr 29 2005 Gary Benson <gbenson@redhat.com> 0:2.6.2-4jpp_4fc
  276. - BC-compile.
  277. * Thu Apr 28 2005 Gary Benson <gbenson@redhat.com> 0:2.6.2-4jpp_3fc
  278. - Revert xjavac classpath workaround, and patch to use libgcj's
  279. classes instead of those in xml-commons (#152255).
  280. * Thu Apr 21 2005 Gary Benson <gbenson@redhat.com> 0:2.6.2-4jpp_2fc
  281. - Add classpath workaround to xjavac task (#152255).
  282. * Wed Jan 12 2005 Gary Benson <gbenson@redhat.com> 0:2.6.2-4jpp_1fc
  283. - Reenable building of classes that require javax.swing (#130006).
  284. - Sync with RHAPS.
  285. * Mon Nov 15 2004 Fernando Nasser <fnasser@redhat.com> 0:2.6.2-4jpp_1rh
  286. - Merge with upstream for 2.6.2 upgrade
  287. * Thu Nov 4 2004 Gary Benson <gbenson@redhat.com> 0:2.6.2-2jpp_5fc
  288. - Build into Fedora.
  289. * Thu Oct 28 2004 Gary Benson <gbenson@redhat.com> 0:2.6.2-2jpp_4fc
  290. - Bootstrap into Fedora.
  291. * Fri Oct 1 2004 Andrew Overholt <overholt@redhat.com> 0:2.6.2-2jpp_4rh
  292. - add coreutils BuildRequires
  293. * Thu Sep 30 2004 Andrew Overholt <overholt@redhat.com> 0:2.6.2-2jpp_3rh
  294. - Remove xml-commons-resolver as a Requires
  295. * Thu Aug 26 2004 Ralph Apel <r.apel at r-apel.de> 0:2.6.2-4jpp
  296. - Build with ant-1.6.2
  297. - Dropped jikes requirement, built for 1.4.2
  298. * Wed Jun 23 2004 Kaj J. Niemi <kajtzu@fi.basen.net> 0:2.6.2-3jpp
  299. - Updated Patch #0 to fix breakage using BEA 1.4.2 SDK, new patch
  300. from <mwringe@redhat.com> and <vivekl@redhat.com>.
  301. * Mon Jun 21 2004 Vivek Lakshmanan <vivekl@redhat.com> 0:2.6.2-2jpp_2rh
  302. - Added new Source1 URL and added new %%setup to expand it under the
  303. expanded result of Source0.
  304. - Updated Patch0 to fix version discrepancies.
  305. - Added build requirement for xml-commons-apis
  306. * Mon Jun 14 2004 Matt Wringe <mwringe@redhat.com> 0:2.6.2-2jpp_1rh
  307. - Update to 2.6.2
  308. - made patch names comformant
  309. * Mon Mar 29 2004 Kaj J. Niemi <kajtzu@fi.basen.net> 0:2.6.2-2jpp
  310. - Rebuilt with jikes 1.18 for java 1.3.1_11
  311. * Fri Mar 26 2004 Frank Ch. Eigler <fche@redhat.com> 0:2.6.1-1jpp_2rh
  312. - add RHUG upgrade cleanup
  313. * Tue Mar 23 2004 Kaj J. Niemi <kajtzu@fi.basen.net> 0:2.6.2-1jpp
  314. - 2.6.2
  315. * Thu Mar 11 2004 Frank Ch. Eigler <fche@redhat.com> 0:2.6.1-1jpp_1rh
  316. - RH vacuuming
  317. - remove jikes dependency
  318. - add nonjikes-cast.patch
  319. * Sun Feb 08 2004 David Walluck <david@anti-microsoft.org> 0:2.6.1-1jpp
  320. - 2.6.1
  321. - update Source0 URL
  322. - now requires xml-commons-resolver
  323. * Fri Jan 9 2004 Kaj J. Niemi <kajtzu@fi.basen.net> - 0:2.6.0-1jpp
  324. - Update to 2.6.0
  325. - Patch #1 (xerces-j2-manifest.patch) is unnecessary (upstream)
  326. * Tue Oct 21 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:2.5.0-1jpp
  327. - Update to 2.5.0.
  328. - Clean up versionless javadoc dir symlinking, own (ghost) the symlinks.
  329. - Mark javadocs as %%doc.
  330. * Wed Jun 4 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:2.4.0-3jpp
  331. - Own (ghost) %%{_javadir}/jaxp_parser_impl.jar.
  332. - Remove alternatives in preun instead of postun.
  333. * Mon May 12 2003 David Walluck <david@anti-microsoft.org> 0:2.4.0-2jpp
  334. - bug #17325 fixed upstream
  335. * Mon May 12 2003 David Walluck <david@anti-microsoft.org> 0:2.4.0-1jpp
  336. - 2.4.0
  337. - BuildRequires: jikes
  338. - update for JPackage 1.5
  339. - re-diff'ed build patch for 2.4.0
  340. - bug #17325 handled by perl now
  341. - scripts: s|find-jar|build-classpath| and don't test for java-functions
  342. * Wed Mar 26 2003 Nicolas Mailhot <Nicolas.Mailhot (at) JPackage.org> - 2.3.0-2jpp
  343. - For jpackage-utils 1.5
  344. - zapped manual, since it doesn't want to build
  345. - as a consequence, removed uneeded dependencies
  346. * Mon Feb 24 2003 Ville Skyttä <ville.skytta at iki.fi> - 2.3.0-1jpp
  347. - Update to 2.3.0.
  348. - Add a crude patch to work around invalid XML in doc sources, see
  349. <http://nagoya.apache.org/bugzilla/show_bug.cgi?id=17325>.
  350. - Built with IBM's 1.3.1 SR3.
  351. * Sat Dec 28 2002 Ville Skyttä <ville.skytta at iki.fi> - 2.2.1-2jpp
  352. - Add upstream patch which fixes problems with Tomcat's webapps.
  353. <http://nagoya.apache.org/bugzilla/show_bug.cgi?id=13282>
  354. <http://marc.theaimsgroup.com/?l=xerces-cvs&m=103791990130308>
  355. - Separate scripts subpackage.
  356. * Fri Nov 15 2002 Ville Skyttä <ville.skytta at iki.fi> - 2.2.1-1jpp
  357. - Update to 2.2.1.
  358. - Change alternative to point to non-versioned jar.
  359. - Don't remove alternative on upgrade.
  360. - Fix Group tag for demo, javadoc and manual subpackages.
  361. - Add version and constants scripts.
  362. - Some spec file cleanup.
  363. * Sun Oct 6 2002 Ville Skyttä <ville.skytta at iki.fi> 2.2.0-2jpp
  364. - Fix bad permissions for main jar.
  365. * Sun Sep 29 2002 Ville Skyttä <ville.skytta at iki.fi> 2.1.0-1jpp
  366. - Update to 2.2.0.
  367. * Tue Sep 10 2002 Ville Skyttä <ville.skytta at iki.fi> 2.1.0-2jpp
  368. - Rebuild with -Dcompiler=modern, not a Jikes bug this time, but sloppy code
  369. that is tolerated by javac. See <http://www-124.ibm.com/developerworks/bugs/?func=detailbug&bug_id=3218&group_id=10> for details.
  370. * Tue Sep 10 2002 Ville Skyttä <ville.skytta at iki.fi> 2.1.0-1jpp
  371. - 2.1.0.
  372. - Updated description.
  373. - Changed javadoc and manual group to Documentation.
  374. - Spec file cleanups.
  375. * Fri Jul 12 2002 Henri Gomez <hgomez@users.sourceforge.net> 2.0.2-4jpp
  376. - add BuildRequires xerces-j1 and xalan-j2
  377. - removed BuildRequires xml-commons-api since ant require jaxp_parser_impl
  378. which in turn require xml-commons-api ;)
  379. * Mon Jul 01 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.0.2-3jpp
  380. - vendor, distribution, group tags
  381. - provides jaxp_parser_impl
  382. - dropped api jar
  383. - renamed lone jar to %%{name}.jar
  384. - priority bumped to 40
  385. - fixed stylebook build (add xerces-j1 in classpath)
  386. * Wed Jun 26 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.0.2-2jpp
  387. - rebuild for missing symlinks
  388. - use sed instead of bash 2.x extension in link area to make spec compatible with distro using bash 1.1x
  389. * Mon Jun 24 2002 Henri Gomez <hgomez@users.sourceforge.net> 2.0.2-1jpp
  390. - 2.0.2
  391. * Sun Mar 10 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.0.1-1jpp
  392. - 2.0.1
  393. - provides jaxp_parser2 virtual resource
  394. - drop wrapper
  395. * Sun Feb 03 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.0.0-1jpp
  396. - first JPackage release