tcsh-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342
  1. %define _bindir /bin
  2. Summary: An enhanced version of csh, the C shell
  3. Summary(ja): csh, Cシェルの進化バージョン
  4. Name: tcsh
  5. Version: 6.18.01
  6. Release: 1%{?_dist_release}
  7. License: BSD
  8. URL: http://www.tcsh.org/
  9. Group: System Environment/Shells
  10. Source: ftp://ftp.astron.com/pub/tcsh/%{name}-%{version}.tar.gz
  11. Patch1: tcsh-6.15.00-closem.patch
  12. Patch2: tcsh-6.14.00-tinfo.patch
  13. Patch3: tcsh-6.14.00-unprintable.patch
  14. Patch4: tcsh-6.15.00-hist-sub.patch
  15. Patch8: tcsh-6.14.00-syntax.patch
  16. Patch9: tcsh-6.13.00-memoryuse.patch
  17. Patch11: tcsh-6.14.00-order.patch
  18. # Proposed upstream - http://github.com/tcsh-org/tcsh/pull/1
  19. Patch28: tcsh-6.17.00-manpage-spelling.patch
  20. # Proposed upstream - http://github.com/tcsh-org/tcsh/pull/2
  21. Patch31: tcsh-6.18.00-history-file-locking.patch
  22. Patch33: tcsh-6.18.00-history-merge.patch
  23. Patch34: tcsh-6.18.01-repeated-words-man.patch
  24. # Proposed upstream - http://mx.gw.com/pipermail/tcsh-bugs/2013-April/000833.html
  25. Patch35: tcsh-6.18.01-elf-interpreter.patch
  26. Patch36: tcsh-6.18.01-posix-exit-status-value.patch
  27. Patch37: tcsh-6.18.01-reverse-history-handling-in-loops.patch
  28. Provides: csh = %{version}
  29. Requires(post): grep
  30. Requires(postun): coreutils, grep
  31. Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
  32. BuildRequires: autoconf, automake, ncurses-devel, gettext-devel
  33. %description
  34. Tcsh is an enhanced but completely compatible version of csh, the C
  35. shell. Tcsh is a command language interpreter which can be used both
  36. as an interactive login shell and as a shell script command processor.
  37. Tcsh includes a command line editor, programmable word completion,
  38. spelling correction, a history mechanism, job control and a C language
  39. like syntax.
  40. %description -l ja
  41. tcsh は、バークレイ版 UNIX の C シェル csh と完全に互換性があり、
  42. さらに機能強化したシェルです。対話的なログインシェル、またシェルス
  43. クリプトのコマンドプロセッサの両方の用途で使われるコマンドインタプ
  44. リタです。
  45. tcsh には、コマンド行編集機能や、プログラム可能な単語の補完機能、
  46. スペル訂正、履歴、ジョブ制御、C 言語風の文法等が含まれます。
  47. %prep
  48. %setup -q
  49. %patch1 -p1 -b .closem
  50. %patch2 -p1 -b .tinfo
  51. %patch3 -p1 -b .unprintable
  52. %patch4 -p1 -b .hist-sub
  53. %patch8 -p1 -b .syntax
  54. %patch9 -p1 -b .memoryuse
  55. %patch11 -p1 -b .order
  56. %patch28 -p1 -b .manpage-spelling
  57. %patch31 -p1 -b .history-file-locking
  58. %patch33 -p1 -b .history-merge
  59. %patch34 -p1 -b .repeated-words-man
  60. %patch35 -p1 -b .elf-interpreter
  61. %patch36 -p1 -b .posix-exit-status-value
  62. %patch37 -p1 -b .reverse-history-handling-in-loops
  63. for i in Fixes WishList; do
  64. iconv -f iso-8859-1 -t utf-8 "$i" > "${i}_" && \
  65. touch -r "$i" "${i}_" && \
  66. mv "${i}_" "$i"
  67. done
  68. %build
  69. # For tcsh-6.14.00-tinfo.patch
  70. autoreconf
  71. %configure --without-hesiod
  72. make %{?_smp_mflags} all
  73. make %{?_smp_mflags} -C nls catalogs
  74. %install
  75. rm -rf $RPM_BUILD_ROOT
  76. mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man1 ${RPM_BUILD_ROOT}%{_bindir}
  77. install -p -m 755 tcsh ${RPM_BUILD_ROOT}%{_bindir}/tcsh
  78. install -p -m 644 tcsh.man ${RPM_BUILD_ROOT}%{_mandir}/man1/tcsh.1
  79. ln -sf tcsh ${RPM_BUILD_ROOT}%{_bindir}/csh
  80. ln -sf tcsh.1 ${RPM_BUILD_ROOT}%{_mandir}/man1/csh.1
  81. while read lang language ; do
  82. dest=${RPM_BUILD_ROOT}%{_datadir}/locale/$lang/LC_MESSAGES
  83. if test -f tcsh.$language.cat ; then
  84. mkdir -p $dest
  85. install -p -m 644 tcsh.$language.cat $dest/tcsh
  86. echo "%lang($lang) %{_datadir}/locale/$lang/LC_MESSAGES/tcsh"
  87. fi
  88. done > tcsh.lang << _EOF
  89. de german
  90. el greek
  91. en C
  92. es spanish
  93. et et
  94. fi finnish
  95. fr french
  96. it italian
  97. ja ja
  98. pl pl
  99. ru russian
  100. uk ukrainian
  101. _EOF
  102. %clean
  103. rm -rf $RPM_BUILD_ROOT
  104. %post
  105. if [ ! -f /etc/shells ]; then
  106. echo "%{_bindir}/tcsh" >> /etc/shells
  107. echo "%{_bindir}/csh" >> /etc/shells
  108. else
  109. grep -q '^%{_bindir}/tcsh$' /etc/shells || \
  110. echo "%{_bindir}/tcsh" >> /etc/shells
  111. grep -q '^%{_bindir}/csh$' /etc/shells || \
  112. echo "%{_bindir}/csh" >> /etc/shells
  113. fi
  114. %postun
  115. if [ ! -x %{_bindir}/tcsh ]; then
  116. grep -v '^%{_bindir}/tcsh$' /etc/shells | \
  117. grep -v '^%{_bindir}/csh$' > /etc/shells.rpm && \
  118. mv /etc/shells.rpm /etc/shells
  119. fi
  120. %files -f tcsh.lang
  121. %defattr(-,root,root,-)
  122. %doc BUGS FAQ Fixes NewThings WishList complete.tcsh
  123. %{_bindir}/tcsh
  124. %{_bindir}/csh
  125. %{_mandir}/man1/*.1*
  126. %changelog
  127. * Sun Jul 20 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 6.18.01-1
  128. - update to 6.18.01
  129. * Sun Jun 12 2011 IWAI, Masaharu <iwai@alib.jp> 6.17-1
  130. - new upstream release
  131. - drop wide str patch (Patch12): upstream fixed
  132. - update ca-color patch (Patch6) from Fedora tcsh-6.17-15
  133. - update syntax patch (Patch8) from Fedora tcsh-6.17-15
  134. - update rs-color patch from Fedora tcsh-6.17-15
  135. - resync with Fedora tcsh-6.17-15
  136. - change patch number Patch13 -> Patch12
  137. - add Patch13..24
  138. * Thu Mar 24 2011 Vojtech Vitek (V-Teq) <vvitek@redhat.com> - 6.17-15
  139. - Avoid infinite loop pendjob()-xprintf() when stdout is closed
  140. Resolves: #690356
  141. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 6.17-14
  142. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  143. * Fri Jan 28 2011 Vojtech Vitek (V-Teq) <vvitek@redhat.com> - 6.17-13
  144. - Modify verbose patch to match with upstream (don't print on history -S)
  145. Resolves: #672810
  146. * Wed Jan 26 2011 Vojtech Vitek (V-Teq) <vvitek@redhat.com> - 6.17-12
  147. - Fix error message on exit
  148. Resolves: #672810
  149. * Mon Jan 24 2011 Vojtech Vitek (V-Teq) <vvitek@redhat.com> - 6.17-11
  150. - Don't set $REMOTEHOST on the local machine
  151. Resolves: #669176
  152. - Don't print history in verbose mode
  153. Resolves: #583075, #658171
  154. - Don't allow illegal variable names to be set
  155. Resolves: #436901
  156. - Revert "Fix incorrect $status value of pipelined commands"
  157. * Tue Dec 21 2010 Vojtech Vitek (V-Teq) <vvitek@redhat.com> - 6.17-10
  158. - Make wait builtin command interruptible
  159. Resolves: #440465
  160. - Fix incorrect $status value of pipelined commands
  161. Resolves: #638955 (Patch by Tomas Smetana <tsmetana@redhat.com>)
  162. * Wed Oct 6 2010 Vitezslav Crhonek <vcrhonek@redhat.com> - 6.17-9
  163. - Remove fork when tcsh processes backquotes
  164. * Wed Apr 14 2010 Vitezslav Crhonek <vcrhonek@redhat.com> - 6.17-8
  165. - Fix testsuite
  166. * Mon Mar 1 2010 Vitezslav Crhonek <vcrhonek@redhat.com> - 6.17-7
  167. - Ship README file
  168. * Tue Dec 15 2009 Vitezslav Crhonek <vcrhonek@redhat.com> - 6.17-6
  169. - Fix tcsh obeys printexitvalue for back-ticks
  170. * Wed Nov 4 2009 Vitezslav Crhonek <vcrhonek@redhat.com> - 6.17-5
  171. - Fix few globbing problems
  172. * Mon Oct 19 2009 Vitezslav Crhonek <vcrhonek@redhat.com> - 6.17-4
  173. - Fix tcsh globbing causing bad automount
  174. - Fix truncated history file after network crash
  175. * Wed Aug 26 2009 Vitezslav Crhonek <vcrhonek@redhat.com> - 6.17-3
  176. - Add new colorls variable
  177. Resolves: #518808
  178. * Sun Jul 26 2009 Fedora Release Engineering <releng@lists.fedoraproject.org> - 6.17-2
  179. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  180. * Mon Jul 20 2009 Vitezslav Crhonek <vcrhonek@redhat.com> - 6.17-1
  181. - Update to tcsh-6.17.00
  182. * Sat Apr 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.16-2
  183. - rebuilt with current VineSeed
  184. * Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 6.16-1
  185. - new upstream release
  186. - resync with 6.16-1(fc12)
  187. - drop vine patch
  188. * Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 6.12-1vl5
  189. - applied new versioning policy, spec in utf-8
  190. * Wed Oct 18 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 6.12-0vl6
  191. - added patch11 from fedora
  192. * Thu Mar 23 2006 Miloslav Trmac <mitr@redhat.com> - 6.14-8
  193. - Backport a patch to ignore LS_COLOR codes introduced in newer coreutils
  194. (#186037)
  195. - added japanese description
  196. * Thu Apr 02 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 6.12-0vl5
  197. - added patch from fedora
  198. * Tue Feb 10 2004 Nalin Dahyabhai <nalin@redhat.com> 6.12-7
  199. - remove declaration of setpgrp() which conflicts with libc's (#115185)
  200. * Fri Nov 21 2003 Nalin Dahyabhai <nalin@redhat.com> 6.12-6
  201. - add missing buildprereqs on groff, libtermcap-devel (#110599)
  202. * Mon Oct 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.12-0vl4
  203. - rebuild with new toolchains
  204. - s/Copyright/License/
  205. - fix spec file to build correctly (based on Rawhide spec file)
  206. * Tue Aug 06 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 6.12-0vl3
  207. - "Re"-changed the way of fixing check locale from Patch8 to Patch9
  208. on ppc strlen() can not deal with 'short' variables
  209. * Sat Aug 03 2002 Satoshi MACHINO <machino@vinelinux.org> 6.12-0vl2
  210. - fixed changelog
  211. * Thu Jul 25 2002 K. Nagasaka <nagasaka@math.tsukuba.ac.jp> 6.12-0vl1
  212. - update
  213. * Sun Apr 28 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 6.11-0vl4
  214. - change limit.patch
  215. * Fri Apr 26 2002 Kosaku Nagasaka <nagasaka@math.tsukuba.ac.jp> 6.11-0vl3
  216. - fixed limit by Patch10
  217. * Sun Jan 27 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 6.11-0vl2
  218. - changed the way of fixing check locale from Patch8 to Patch9
  219. on ppc strlen() can not deal with 'short' variables
  220. * Mon Jan 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 6.11-0vl1
  221. - update
  222. * Thu Dec 28 2001 Satoshi MACHINO <machino@vinelinux.org> 6.10.02-0vl2
  223. - fixed check locale
  224. - merged some patches from RHL-7.2
  225. * Thu Aug 09 2001 <sagami@vinelinux.org>
  226. - 6.10.02-0vl1
  227. * Sun Jan 7 2001 Jun Nishii <jun@vinelinux.org>
  228. - 6.10-1vl2
  229. - build with gcc
  230. * Mon Dec 11 2000 Yasuhide OOMORI <dasen@icntv.ne.jp>
  231. - syncronized release tcsh based on a securty fix for RH6.2.
  232. * Thu Nov 30 2000 Nalin Dahyabhai <nalin@redhat.com>
  233. - update to 6.10.00 to fix here-script vulnerability
  234. * Wed Sep 18 2000 Adrian Havill <havill@redhat.com>
  235. - fix catalog locale dirname for Japanese
  236. * Thu Jun 15 2000 Jeff Johnson <jbj@redhat.com>
  237. - FHS packaging.
  238. - add locale support (#10345).
  239. * Tue Mar 7 2000 Jeff Johnson <jbj@redhat.com>
  240. - rebuild for sparc baud rates > 38400.
  241. * Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
  242. - rebuild to fix dependencies
  243. * Thu Jan 27 2000 Jeff Johnson <jbj@redhat.com>
  244. - append entries to spanking new /etc/shells.
  245. * Mon Jan 10 2000 Jeff Johnson <jbj@redhat.com>
  246. - update to 6.09.
  247. - fix strcoll oddness (#6000, #6244, #6398).
  248. * Sat Sep 25 1999 Michael K. Johnson <johnsonm@redhat.com>
  249. - fix $shell by using --bindir
  250. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  251. - auto rebuild in the new build environment (release 5)
  252. * Wed Feb 24 1999 Cristian Gafton <gafton@redhat.com>
  253. - patch for using PATH_MAX instead of some silly internal #defines for
  254. variables that handle filenames.
  255. * Fri Nov 6 1998 Jeff Johnson <jbj@redhat.com>
  256. - update to 6.08.00.
  257. * Fri Oct 02 1998 Cristian Gafton <gafton@redhat.com>
  258. - upgraded to 6.07.09 from the freebsd
  259. - security fix
  260. * Wed Aug 5 1998 Jeff Johnson <jbj@redhat.com>
  261. - use -ltermcap so that /bin/tcsh can be used in single user mode w/o /usr.
  262. - update url's
  263. * Mon Apr 27 1998 Prospector System <bugs@redhat.com>
  264. - translations modified for de, fr, tr
  265. * Thu Oct 21 1997 Cristian Gafton <gafton@redhat.com>
  266. - updated to 6.07; added BuildRoot
  267. - cleaned up the spec file; fixed source url
  268. * Wed Sep 03 1997 Erik Troan <ewt@redhat.com>
  269. - added termios hacks for new glibc
  270. - added /bin/csh to file list
  271. * Fri Jun 13 1997 Erik Troan <ewt@redhat.com>
  272. - built against glibc
  273. * Fri Feb 07 1997 Erik Troan <ewt@redhat.com>
  274. - Provides csh, adds and removes /bin/csh from /etc/shells if csh package
  275. isn't installed.