tcl-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346
  1. %define majorver 8.5
  2. %define minorver 15
  3. %define version %{majorver}.%{minorver}
  4. %define htmlver %{majorver}.15
  5. %{!?sdt:%define sdt 0}
  6. Summary: A Tcl/Tk development environment: tcl
  7. Summary(ja): Tcl/Tk 開発環境: tcl
  8. Name: tcl
  9. Version: %{version}
  10. Release: 3%{?_dist_release}
  11. Group: Development/Languages
  12. License: TCL
  13. URL: http://tcl.sourceforge.net/
  14. Source0: http://prdownloads.sourceforge.net/tcl/%{name}%{version}-src.tar.gz
  15. Source1: http://prdownloads.sourceforge.net/tcl/%{name}%{htmlver}-html.tar.gz
  16. # patches from Red Hat Enterprise Linux tcl-8.5.7-6.el6
  17. Patch100: tcl-8.5.1-autopath.patch
  18. Patch101: tcl-8.5.15-conf.patch
  19. Patch102: tcl-8.5.0-hidden.patch
  20. Buildroot: %{_tmppath}/%{name}-%{version}-root
  21. Buildrequires: autoconf
  22. BuildRequires: zlib-devel
  23. %if %sdt
  24. BuildRequires: systemtap-sdt-devel
  25. %endif
  26. Vendor: Project Vine
  27. Distribution: Vine Linux
  28. %description
  29. Tcl is a simple scripting language designed to be embedded into
  30. other applications. Tcl is designed to be used with Tk, a widget
  31. set, which is provided in the tk package. This package also includes
  32. tclsh, a simple example of a Tcl application.
  33. %description -l ja
  34. Tcl は様々なアプリケーションの実行を行うための、簡単なスクリプ
  35. ト言語です。Tclはウィジッド・セットであるTkとともに用いるように
  36. デザインしています。このパッケージにはTclの簡単な例として、tclsh
  37. も含んでいます。
  38. %package devel
  39. Summary: Tcl scripting language development environment
  40. Summary(ja): Tcl スクリプト言語の開発環境
  41. Group: Development/Libraries
  42. Requires: %{name} = %{version}-%{release}
  43. %description devel
  44. Tcl is a simple scripting language designed to be embedded into
  45. other applications. Tcl is designed to be used with Tk, a widget
  46. set, which is provided in the tk package. This package also includes
  47. tclsh, a simple example of a Tcl application.
  48. The package contains the development files and man pages for tcl.
  49. %prep
  50. %setup -n %{name}%{version} -q -a 1
  51. mv tcl%{htmlver}/html .
  52. %patch100 -p1 -b .autopath
  53. %patch101 -p1 -b .conf
  54. %patch102 -p1 -b .hidden
  55. %build
  56. pushd unix
  57. autoconf
  58. %configure \
  59. %if %sdt
  60. --enable-dtrace \
  61. %endif
  62. --disable-threads \
  63. --enable-symbols \
  64. --enable-shared
  65. make %{?_smp_mflags} TCL_LIBRARY=%{_datadir}/%{name}%{majorver}
  66. %install
  67. rm -rf $RPM_BUILD_ROOT
  68. make install -C unix INSTALL_ROOT=$RPM_BUILD_ROOT TCL_LIBRARY=%{_datadir}/%{name}%{majorver}
  69. ln -s tclsh%{majorver} $RPM_BUILD_ROOT%{_bindir}/tclsh
  70. # for linking with -lib%{name}
  71. ln -s lib%{name}%{majorver}.so $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so
  72. mkdir -p $RPM_BUILD_ROOT/%{_libdir}/%{name}%{majorver}
  73. # postgresql and maybe other packages too need tclConfig.sh
  74. # paths don't look at /usr/lib for efficiency, so we symlink into tcl8.5 for now
  75. ln -s %{_libdir}/%{name}Config.sh $RPM_BUILD_ROOT/%{_libdir}/%{name}%{majorver}/%{name}Config.sh
  76. mkdir -p $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/{generic,unix}
  77. find generic unix -name "*.h" -exec cp -p '{}' $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/'{}' ';'
  78. ( cd $RPM_BUILD_ROOT/%{_includedir}
  79. for i in *.h ; do
  80. [ -f $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/generic/$i ] && ln -sf ../../$i $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/generic ;
  81. done
  82. )
  83. # remove buildroot traces
  84. sed -i -e "s|$PWD/unix|%{_libdir}|; s|$PWD|%{_includedir}/%{name}-private|" $RPM_BUILD_ROOT/%{_libdir}/%{name}Config.sh
  85. rm -rf $RPM_BUILD_ROOT/%{_datadir}/%{name}%{majorver}/tclAppInit.c
  86. rm -rf $RPM_BUILD_ROOT/%{_datadir}/%{name}%{majorver}/ldAix
  87. %clean
  88. rm -rf $RPM_BUILD_ROOT
  89. %post -p /sbin/ldconfig
  90. %postun -p /sbin/ldconfig
  91. %files
  92. %defattr(-,root,root,-)
  93. %doc README changes
  94. %doc license.terms
  95. %doc html/*
  96. %{_bindir}/tclsh*
  97. %{_libdir}/libtcl%{majorver}.so
  98. %dir %{_libdir}/tcl%{majorver}
  99. %{_datadir}/%{name}8
  100. %{_datadir}/tcl%{majorver}
  101. %{_mandir}/man1/*
  102. %{_mandir}/mann/*
  103. %files devel
  104. %defattr(-,root,root,-)
  105. %{_includedir}/*
  106. %{_libdir}/libtcl.so
  107. %{_libdir}/libtclstub%{majorver}.a
  108. %{_libdir}/tclConfig.sh
  109. %{_libdir}/tcl%{majorver}/tclConfig.sh
  110. %{_mandir}/man3/*
  111. %changelog
  112. * Mon Jan 26 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 8.5.15-3
  113. - split development files into devel subpackage
  114. * Wed Jan 15 2014 NAKAMURA Kenta <kenta@vinelinux.org> 8.5.15-2
  115. - rebuilt with the current environment
  116. * Tue Oct 01 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.5.15-1
  117. - update to 8.5.15
  118. - update Patch101 (tcl-8.5.15-conf.patch)
  119. - remove Patch103 (tcl-8.5.7-sigabrt.patch)
  120. * Fri Jan 4 2013 IWAI, Masaharu <iwai@alib.jp> 8.5.7-1
  121. - update to 8.5.7: sync Red Hat Enterprise Linux 6 tcl-8.5.7-6.el6
  122. - update License: TCL
  123. - drop obsolete patches
  124. - tclm4-soname patch (Patch1)
  125. - lib-perm patch (Patch2)
  126. - configure patch (Patch3)
  127. - no rpath patch (Patch4)
  128. - init lib64 patch (Patch10)
  129. - add some patches from RHEL tcl-8.5.7-6.el6
  130. - autopath patch (Patch100)
  131. - conf patch (Patch101)
  132. - hidden patch (Patch102)
  133. - sigabrt patch (Patch103)
  134. - update build and install section: sync RHEL tcl-8.5.7-6.el6
  135. - add BR: systemtap-sdt-devel: default disable
  136. * Thu Apr 21 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.4.19-4
  137. - added imake to BR:.
  138. * Sat Apr 16 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.19-3
  139. - rebuilt with rpm-4.8.1-3
  140. * Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.19-2
  141. - rebuilt with new environment
  142. - updated Patch3: tcl8.4.16-configure.patch
  143. * Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.19-1
  144. - new upstream release
  145. * Tue Sep 30 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 8.4.18-2
  146. - spec in UTF-8
  147. - configure with disabled threads. See:
  148. https://bugzilla.redhat.com/show_bug.cgi?id=443246
  149. http://groups.google.com/group/comp.lang.tcl/msg/ce6a1324bada8db0
  150. * Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.18-1
  151. - rebuild with new environment
  152. * Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.18-0vl1
  153. - updated tcl to 8.4.18
  154. - updated tcl-html to 8.4.18
  155. * Mon Oct 08 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.16-0vl1
  156. - updated tcl to 8.4.16
  157. - updated tcl-html to 8.4.16
  158. - dropt Patch3: tcl8.3.5-tclConfig-package-path-90160.patch
  159. - added Patch3: tcl8.4.16-configure.patch
  160. * Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.15-0vl1
  161. - updated tcl to 8.4.15
  162. - updated tcl-html to 8.4.15
  163. - dropt Patch1: tcl-8.3.5-tclm4-soname.patch
  164. - added Patch10: tcl-8.4.15-init.lib64.patch
  165. - rebuilt with new toolchain
  166. * Wed May 10 2006 IWAI, Masaharu <iwai@alib.jp> 8.4.13-0vl1
  167. - updated tcl to 8.4.13
  168. - updated tcl-html to 8.4.13
  169. * Sat Jan 28 2006 Shu KONNO <owa@bg.wakwak.com> 8.4.12-0vl1
  170. - updated tcl to 8.4.12
  171. - updated patch4
  172. * Sat Aug 13 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.4.11-0vl1
  173. - updated tcl to 8.4.11
  174. - updated Patch4
  175. * Thu Jun 24 2004 Shu KONNO <owa@bg.wakwak.com> 8.4.6-0vl1
  176. - updated tcl to 8.4.6
  177. * Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.5-3vl2
  178. - merged with fedora
  179. * Mon Dec 1 2003 Thomas Woerner <twoerner@redhat.com> 8.4.5-3
  180. - removed rpath (patch 4)
  181. * Fri Nov 28 2003 Jens Petersen <petersen@redhat.com> - 8.4.5-2
  182. - put private header files under generic and unix subdirs
  183. - include real generic/tclPort.h not just a symlink to tclUnixPort.h
  184. - add tclMath.h to %{_includedir}/tcl-private/generic for building tk
  185. * Thu Nov 27 2003 Jens Petersen <petersen@redhat.com> - 8.4.5-1
  186. - new package split out from tcltk
  187. - update to tcl 8.4.5 (#88429)
  188. - drop tcl-8.3.3-heiierarchy.patch, tcl-8.3.3-dlopen.patch
  189. and tcl8.3.5-koi8-u.enc-88806.patch
  190. - include private include headers under %{_includedir}/tcl-private
  191. - filtered changelog for tcl
  192. - buildrequire autoconf213 (#110583) [mvd@mylinux.com.ua]
  193. * Sat Mar 29 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl1
  194. - update based on BitWalk's tcltk-8.4.2-83bw
  195. * Thu Nov 15 2001 Kazuhisa TAKEI <takei@linux.or.jp>
  196. - split source package.
  197. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
  198. - expand some macros.. (FIXME)
  199. * Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
  200. - use %configure macros
  201. - add Patch 47,50
  202. * Thu May 31 2001 <sagami@vinelinux.org>
  203. - 8.0.5_jp-10
  204. - unexpand old %%{configure}, new one causes build failure
  205. - fixed missing libtkx.so libtclx.so symlink in /usr/lib
  206. - install manpages into %%{_mandir} and mode 644
  207. * Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  208. - 8.0.5_jp-9
  209. - modified %install section to handle compressed man pages
  210. - fixed /usr/lib/tk8.0jp/demos.jp/images symlink
  211. * Sun Jul 2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
  212. - changed default fonts
  213. * Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
  214. - added defattr
  215. * Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
  216. - added some symlinks, such as libtcl8.0.so.
  217. - obsoletes version number using _jp, now 8.0.5-31vl1
  218. * Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
  219. - Apply Tcl/Tk 8.0 Japanese Patch 1.7
  220. * Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
  221. - fix tclX symlinks.
  222. - compile on systems where SIGPWR == SIGLOST.
  223. * Sat May 1 1999 Jeff Johnson <jbj@redhat.com>
  224. - update tcl/tk to 8.0.5.
  225. - avoid "containing" in Tix (#2332).
  226. * Thu Apr 8 1999 Jeff Johnson <jbj@redhat.com>
  227. - use /usr/bin/write in kibitz (#1320).
  228. - use cirrus.sprl.umich.edu in weather (#1926).
  229. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  230. - auto rebuild in the new build environment (release 28)
  231. * Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
  232. - whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
  233. * Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
  234. - expect does unaligned access on alpha (#989)
  235. - upgrade tcl/tk/tclX to 8.0.4
  236. - upgrade expect to 5.28.
  237. - add itcl 3.0.1
  238. * Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
  239. - call libtoolize to allow building on the arm
  240. - build for glibc 2.1
  241. - strip binaries
  242. * Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
  243. - update tcl/tk/tclX to 8.0.3, expect is updated also.
  244. * Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
  245. - expect: mkpasswd needs delay before sending password (problem #576)
  246. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  247. - translations modified for de, fr, tr
  248. * Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
  249. - fixed expect binaries exec permissions
  250. * Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
  251. - updated to Tix 4.1.0.006
  252. - updated version numbers of tcl/tk to relflect includsion of p2
  253. * Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
  254. - updated tcl/tk to patch level 2
  255. - updated tclX to 8.0.2
  256. * Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
  257. - fixed filelist for tix... replacing path to the expect binary in scripts
  258. was leaving junk files around.
  259. * Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
  260. - added patch to remove libieee test in configure.in for tcl and tk.
  261. Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
  262. solution for all systems
  263. - fixed src urls
  264. * Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
  265. - removed version numbers from descriptions
  266. * Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
  267. - updated to tcl/tk 8.0 and related versions of packages
  268. * Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
  269. - built against glibc
  270. - fixed dangling tclx/tkx symlinks