swig-vl.spec 5.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210
  1. %define tcl 1
  2. %define guile 0
  3. Summary: Connects C/C++/Objective C to some high-level programming languages
  4. Summary(ja): C/C++/Objective C を高級プログラミング言語に接続するためのツール
  5. Name: swig
  6. Version: 3.0.5
  7. Release: 1%{?_dist_release}
  8. License: GPLv3+ and BSD
  9. Group: Development/Tools
  10. URL: http://swig.sourceforge.net/
  11. Source: http://downloads.sourceforge.net/project/swig/swig/swig-%{version}/swig-%{version}.tar.gz
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  13. BuildRequires: lua-devel
  14. BuildRequires: pcre-devel
  15. BuildRequires: perl
  16. BuildRequires: python-devel
  17. BuildRequires: ruby-devel
  18. %if %{tcl}
  19. BuildRequires: tcl-devel
  20. %endif
  21. %if %{guile}
  22. BuildRequires: guile-devel
  23. %endif
  24. BuildRequires: autoconf, automake, gawk, nkf
  25. Obsoletes: swig-runtime
  26. %description
  27. Simplified Wrapper and Interface Generator (SWIG) is a software
  28. development tool for connecting C, C++ and Objective C programs with a
  29. variety of high-level programming languages. SWIG is primarily used
  30. with Perl, Python and Tcl/TK, but it has also been extended to Java,
  31. Eiffel and Guile. SWIG is normally used to create high-level
  32. interpreted programming environments, systems integration, and as a
  33. tool for building user interfaces
  34. %package doc
  35. Summary: Documentation files for SWIG
  36. Summary(ja): SWIG のドキュメント
  37. License: BSD
  38. Group: Documentation
  39. BuildArch: noarch
  40. %description doc
  41. This package contains documentation for SWIG and useful examples
  42. %prep
  43. %setup -q -n swig-%{version}
  44. # as written on https://fedoraproject.org/wiki/Packaging_talk:Perl, section 2
  45. # (specific req/prov filtering). Before you remove this hack make sure you don't
  46. # reintroduce https://bugzilla.redhat.com/show_bug.cgi?id=489421
  47. cat << \EOF > %{name}-prov
  48. #!/bin/sh
  49. %{__perl_provides} `perl -p -e 's|\S+%{_docdir}/%{name}-doc-%{version}\S+||'`
  50. EOF
  51. %global __perl_provides %{_builddir}/%{name}-%{version}/%{name}-prov
  52. chmod +x %{__perl_provides}
  53. cat << \EOF > %{name}-req
  54. #!/bin/sh
  55. %{__perl_requires} `perl -p -e 's|\S+%{_docdir}/%{name}-doc-%{version}\S+||'`
  56. EOF
  57. %global __perl_requires %{_builddir}/%{name}-%{version}/%{name}-req
  58. chmod +x %{__perl_requires}
  59. for all in CHANGES README; do
  60. iconv -f ISO88591 -t UTF8 < $all > $all.new
  61. touch -r $all $all.new
  62. mv -f $all.new $all
  63. done
  64. %build
  65. ./autogen.sh
  66. %configure
  67. make %{?_smp_mflags}
  68. # Test suite is currently broken
  69. #make check
  70. %install
  71. rm -rf %{buildroot}
  72. make clean-examples
  73. pushd Examples/
  74. # Remove all arch dependent files in Examples/
  75. find -type f -name 'Makefile.in' | xargs rm -f --
  76. # We don't want to ship files below.
  77. rm -rf test-suite
  78. find -type f -name '*.dsp' | xargs rm -f --
  79. find -type f -name '*.dsw' | xargs rm -f --
  80. # Convert files to UNIX format
  81. for all in `find -type f`; do
  82. nkf --unix $all
  83. chmod -x $all
  84. done
  85. popd
  86. make DESTDIR=%{buildroot} install
  87. %clean
  88. rm -rf %{buildroot}
  89. %files
  90. %defattr(-,root,root,-)
  91. %{_bindir}/*
  92. %{_datadir}/swig
  93. %{_mandir}/man1/ccache-swig.1*
  94. %doc ANNOUNCE CHANGES CHANGES.current INSTALL LICENSE LICENSE-GPL
  95. %doc LICENSE-UNIVERSITIES COPYRIGHT README TODO
  96. %files doc
  97. %defattr(-,root,root,-)
  98. %doc Doc Examples LICENSE LICENSE-GPL LICENSE-UNIVERSITIES COPYRIGHT
  99. %changelog
  100. * Wed Feb 4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.0.5-1
  101. - new upstream release
  102. - moved doc subpackage to Documentation Group
  103. * Mon Jun 16 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 3.0.2-1
  104. - update to 3.0.2
  105. * Fri Apr 18 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.0-1
  106. - update to 3.0.0
  107. - add BR: ruby-devel, lua-devel
  108. * Thu Oct 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.8-1
  109. - update to 2.0.8
  110. - build with pcre-8.31
  111. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.4-2
  112. - rebuild with python-2.7.2
  113. * Sat Oct 29 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.4-1
  114. - update to 2.0.4
  115. * Tue Mar 02 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.40-2
  116. - add missing man file(s) to the filelist
  117. * Mon Mar 01 2010 Shu KONNO <owa@bg.wakwak.com> 1.3.40-1
  118. - new upstream release
  119. - rebuild with new toolchain
  120. * Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.35-1
  121. - new upstream release
  122. * Wed Mar 28 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.3.31-0vl1
  123. - new upstream release
  124. - removed php-devel and ruby-devel from BuildPreReq:.
  125. * Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.29-0vl1
  126. - new upstream release
  127. - use %%configure
  128. - remove runtime subpackage
  129. * Sun Jan 23 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
  130. - 1.3.21-0vl2
  131. - un-libtoolize (tarball have already been libtoolized).
  132. - fix %%clean.
  133. - add guile-devel, php-devel, python-devel and ruby-devel to BuildPreReq:.
  134. * Wed Mar 03 2004 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
  135. - 1.3.21-0vl1
  136. - update version
  137. * Sat Dec 27 2003 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
  138. - 1.3.20-0vl1
  139. - update version
  140. * Mon Jun 03 2003 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
  141. - update version
  142. * Mon Mar 03 2002 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
  143. - update version
  144. * Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org>
  145. - import to Vine Linux
  146. * Wed Jul 19 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 1.3a3-1mdk
  147. - BM.
  148. - Clean up specs.
  149. - 1.3a3.
  150. * Tue Jun 20 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 1.1p5-5mdk
  151. - Use makeinstall macros.
  152. * Mon Apr 10 2000 Francis Galiegue <fg@mandrakesoft.com> 1.1p5-4mdk
  153. - Provides: swig
  154. * Mon Apr 3 2000 Pixel <pixel@mandrakesoft.com> 1.1p5-3mdk
  155. - rebuild with new perl
  156. - cleanup
  157. * Wed Mar 22 2000 Francis Galiegue <fg@mandrakesoft.com> 1.1p5-2mdk
  158. - Rebuilt on kenobi
  159. - Don't use prefix
  160. * Fri Mar 10 2000 Francis Galiegue <francis@mandrakesoft.com> 1.1p5-1mdk
  161. - First RPM for Mandrake