sbcl-vl.spec 2.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109
  1. %define pkg_name sbcl
  2. %define pkg_version 1.3.6
  3. %define pkg_release 1%{?_dist_release}
  4. %define sbcl 1
  5. Summary: Steel Bank Common Lisp
  6. Name: %{pkg_name}
  7. Version: %{pkg_version}
  8. Release: %{pkg_release}
  9. License: A mixture of BSD-style and public domain
  10. Group: Applications/Languages
  11. URL: http://www.sbcl.org/
  12. SOURCE: sbcl-%{version}-source.tar.bz2
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. %if !%{sbcl}
  15. BuildRequires: clisp
  16. %else
  17. BuildRequires: sbcl
  18. %endif
  19. BuildRequires: texinfo
  20. BuildRequires: texlive-common
  21. %if %{?_dist_release} == "vl6"
  22. BuildRequires: texlive-collection-texinfo
  23. %else
  24. BuildRequires: texlive-collection-plainextra
  25. BuildRequires: texlive-collection-fontsrecommended
  26. %endif
  27. Vendor: Project Vine
  28. Distribution: Vine Linux
  29. Packager: ara_t
  30. %description
  31. Steel Bank Common Lisp (SBCL) is a high performance Common Lisp compiler.
  32. It is open source / free software, with a permissive license.
  33. In addition to the compiler and runtime system for ANSI Common Lisp,
  34. it provides an interactive environment including a debugger,
  35. a statistical profiler, a code coverage tool, and many other extensions.
  36. %prep
  37. %{__rm} -rf ${RPM_BUILD_ROOT}
  38. %setup -q
  39. %build
  40. %if !%{sbcl}
  41. sh make.sh "clisp" --prefix=%{_usr}
  42. %else
  43. sh make.sh --prefix=%{_usr}
  44. %endif
  45. cd doc/manual
  46. %{__make} pdf html info
  47. %install
  48. export INSTALL_ROOT=${RPM_BUILD_ROOT}%{_prefix}
  49. sh install.sh
  50. %{__rm} ${RPM_BUILD_ROOT}%{_infodir}/dir
  51. %{__mv} ${RPM_BUILD_ROOT}%{_docdir}/sbcl/*.html \
  52. ${RPM_BUILD_ROOT}%{_docdir}/sbcl/html
  53. %{__mv} ${RPM_BUILD_ROOT}%{_docdir}/sbcl \
  54. ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}
  55. %post
  56. for doc in asdf sbcl; do
  57. file=%{_infodir}/${doc}.info.gz
  58. if [ -e ${file} ]; then
  59. /sbin/install-info ${file} %{_infodir}/dir 2>/dev/null
  60. fi
  61. done
  62. %preun
  63. if [ $1 = 0 ]; then
  64. for doc in asdf sbcl; do
  65. file=%{_infodir}/${doc}.info.gz
  66. if [ -e ${file} ]; then
  67. /sbin/install-info --delete ${file} %{_infodir}/dir 2>/dev/null
  68. fi
  69. done
  70. fi
  71. %clean
  72. %{__rm} -rf ${RPM_BUILD_ROOT}
  73. %files
  74. %defattr(-, root, root)
  75. %{_bindir}/
  76. /usr/lib/sbcl/
  77. %{_docdir}/sbcl-%{version}
  78. %{_infodir}/
  79. %{_mandir}/man1/
  80. %changelog
  81. * Sun Jun 19 2016 Toshiaki Ara <ara_t@384.jp> 1.3.6-1
  82. - update to 1.3.6
  83. - make PDF files for VineSeed
  84. * Sun Apr 17 2016 Toshiaki Ara <ara_t@384.jp> 1.3.4-1
  85. - new package