qt-assistant-adp-vl.spec 5.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169
  1. Name: qt-assistant-adp
  2. Version: 4.6.3
  3. Release: 6%{?_dist_release}
  4. Summary: Compatibility version of Qt Assistant
  5. Summary(ja): Qt Assistant の互換性を維持するためのライブラリ
  6. Group: System Environment/Libraries
  7. # See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
  8. License: LGPLv2 with exceptions or GPLv3 with exceptions
  9. URL: http://qt.nokia.com/doc/4.6/qassistantclient.html
  10. Source: ftp://ftp.qt.nokia.com/qt/source/qt-assistant-qassistantclient-library-compat-src-%{version}.tar.gz
  11. # missing header files from Debian (Fathi Boudra)
  12. Source1: QAssistantClient
  13. Source2: QtAssistant
  14. # build fixes from Debian (Fathi Boudra)
  15. Patch1: 01_build_system.diff
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. BuildRequires: qt4-devel >= 4.7.2-2%{?_dist_release}
  18. %description
  19. The old version of Qt Assistant, based on Assistant Document Profile (.adp)
  20. files, and the associated QtAssistantClient library, for compatibility with
  21. applications providing help in that format.
  22. New applications should use the new version of Qt Assistant introduced in Qt
  23. 4.4, based on the Qt Help Framework also introduced in Qt 4.4, instead.
  24. %package devel
  25. Summary: Development files for the compatibility QAssistantClient
  26. Summary(ja): QAssistantClient 互換の開発用ファイル
  27. Group: Development/Libraries
  28. Requires: %{name} = %{version}-%{release}
  29. Requires: qt4-devel
  30. %description devel
  31. This package contains the files necessary to build applications using the
  32. deprecated QAssistantClient class (in the deprecated QtAssistantClient library),
  33. which is used together with the legacy Assistant Document Profile (.adp) version
  34. of Qt Assistant.
  35. This class is obsolete. It is provided to keep old source code working. We
  36. strongly advise against using it in new code. New code should use the Qt Help
  37. Framework introduced in Qt 4.4 and/or the version of Qt Assistant based on it
  38. (also introduced in Qt 4.4) instead.
  39. %prep
  40. %setup -q -n qt-assistant-qassistantclient-library-compat-version-%{version}
  41. %patch1 -p1 -b .build_system
  42. mkdir include
  43. cp -p %{SOURCE1} %{SOURCE2} include/
  44. %build
  45. # build assistant_adp
  46. qmake QT_PRODUCT=OpenSource
  47. make %{?_smp_mflags}
  48. # build libQtAssistantClient
  49. cd lib
  50. qmake CONFIG=create_prl
  51. make %{?_smp_mflags}
  52. # build assistant_adp translations
  53. cd ../translations
  54. lrelease assistant_adp_*.ts
  55. cd ..
  56. %install
  57. rm -rf $RPM_BUILD_ROOT
  58. # install assistant_adp
  59. make install INSTALL_ROOT=$RPM_BUILD_ROOT
  60. # install libQtAssistantClient
  61. make install INSTALL_ROOT=$RPM_BUILD_ROOT -C lib
  62. # install assistant_adp translations
  63. mkdir -p $RPM_BUILD_ROOT%{_qt4_translationdir}
  64. install -p -m644 translations/assistant_adp_*.qm \
  65. $RPM_BUILD_ROOT%{_qt4_translationdir}/
  66. # install assistant.prf mkspec
  67. install -D -p -m644 features/assistant.prf \
  68. $RPM_BUILD_ROOT%{_qt4_datadir}/mkspecs/features/assistant.prf
  69. # install missing headers (thanks to Fathi Boudra from Debian)
  70. install -p -m644 include/Q* $RPM_BUILD_ROOT%{_qt4_headerdir}/QtAssistant/
  71. # nuke dangling reference(s) to the buildroot
  72. sed -i -e "/^QMAKE_PRL_BUILD_DIR/d" $RPM_BUILD_ROOT%{_qt4_libdir}/*.prl
  73. # let rpm handle binaries conflicts
  74. mkdir $RPM_BUILD_ROOT%{_bindir}
  75. pushd $RPM_BUILD_ROOT%{_qt4_bindir}
  76. mv assistant_adp ../../../bin/
  77. ln -s ../../../bin/assistant_adp .
  78. popd
  79. # _debug target (see bug #196513)
  80. pushd $RPM_BUILD_ROOT%{_qt4_libdir}
  81. echo "INPUT(-lQtAssistantClient)" >libQtAssistantClient_debug.so
  82. popd
  83. # Note that we intentionally DO NOT install a .desktop file for assistant_adp
  84. # because it makes no sense to invoke it without a specific .adp file to open.
  85. # By default, it views the Qt documentation, for which we already have a menu
  86. # entry using the current version of the Qt Assistant, and there is no UI for
  87. # viewing anything different. The .adp file needs to be passed on the command
  88. # line, which is usually done by the application.
  89. %find_lang assistant_adp --with-qt --without-mo
  90. %clean
  91. rm -rf $RPM_BUILD_ROOT
  92. %post -p /sbin/ldconfig
  93. %postun -p /sbin/ldconfig
  94. %files -f assistant_adp.lang
  95. %defattr(-,root,root,-)
  96. %doc LGPL_EXCEPTION.txt LICENSE.LGPL LICENSE.GPL3
  97. %{_bindir}/assistant_adp
  98. %{_qt4_bindir}/assistant_adp
  99. %{_qt4_libdir}/libQtAssistantClient.so.4*
  100. %files devel
  101. %defattr(-,root,root,-)
  102. %{_qt4_headerdir}/QtAssistant/
  103. %{_qt4_libdir}/libQtAssistantClient.so
  104. %{_qt4_libdir}/libQtAssistantClient_debug.so
  105. %{_qt4_libdir}/libQtAssistantClient.prl
  106. %{_libdir}/pkgconfig/QtAssistantClient.pc
  107. %{_qt4_datadir}/mkspecs/features/assistant.prf
  108. %changelog
  109. * Mon Feb 9 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 4.6.3-6
  110. - rebuilt on current VineSeed
  111. - added Japanese summary
  112. * Sat Jan 07 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.3-5
  113. - rebuilt with qt-4.8.0
  114. * Sat Apr 09 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.3-4
  115. - fixed BR
  116. * Sat Apr 09 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.3-3
  117. - Initial build for Vine Linux
  118. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.6.3-2
  119. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  120. * Mon Jul 05 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.6.3-1
  121. - new upstream tarball with only the compat assistant_adp and QAssistantClient
  122. - build fixes from Debian (Fathi Boudra)
  123. - use find_lang to package the qm files (#609749)
  124. * Tue Mar 16 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.6.2-2
  125. - use versioned BR/Requires to avoid Conflicts
  126. * Sat Mar 13 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.6.2-1
  127. - first Fedora package