pitivi-vl.spec 8.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271
  1. %global major 0.15
  2. %global minor 2
  3. Name: pitivi
  4. Version: %{major}.%{minor}
  5. Release: 1%{?_dist_release}
  6. Summary: Non-linear video editor
  7. Summary(ja): ノンリニアビデオ編集ソフトウェア
  8. Group: Applications/Multimedia
  9. License: LGPLv2+
  10. URL: http://www.pitivi.org/
  11. Source0: http://ftp.gnome.org/pub/GNOME/sources/pitivi/%{major}/pitivi-%{version}.tar.xz
  12. BuildRequires: intltool
  13. BuildRequires: python
  14. BuildRequires: desktop-file-utils
  15. BuildRequires: gnome-doc-utils
  16. Requires: gnonlin
  17. Requires: gstreamer-plugins-good
  18. Requires: gstreamer-python
  19. Requires: pygtk2
  20. Requires: pygoocanvas
  21. Requires: python-zope-interface
  22. Requires: python-setuptools
  23. Requires: hicolor-icon-theme
  24. BuildArch: noarch
  25. Vendor: Project Vine
  26. Distribution: Vine Linux
  27. Packager: kazutaka
  28. %description
  29. Pitivi is an application using the GStreamer multimedia framework to
  30. manipulate a large set of multimedia sources.
  31. At this level of development it can be compared to a classic video editing
  32. program.
  33. %description -l ja
  34. Pitivi は GStreamer マルチメディアフレームワークを利用した、
  35. 多くの種類のメディアファイルを操作できるアプリケーションです。
  36. まだ開発中ですが、現状でもビデオ編集に必要となる基本的な機能は
  37. 備えています。
  38. %prep
  39. %setup -q
  40. for f in `find . -name \*.py`
  41. do
  42. sed -e '/^#!/,1d' < $f > $f.tmp && mv $f.tmp $f
  43. done
  44. %build
  45. %configure --libdir=%{_datadir}
  46. %{__make} %{?_smp_mflags}
  47. %install
  48. %{__make} DESTDIR=%{buildroot} install
  49. desktop-file-install --delete-original \
  50. --dir %{buildroot}%{_datadir}/applications \
  51. --add-category AudioVideoEditing \
  52. data/pitivi.desktop
  53. %find_lang %{name}
  54. %clean
  55. %{__rm} -rf %{buildroot}
  56. %post
  57. touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  58. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  59. update-desktop-database &> /dev/null || :
  60. update-mime-database %{_datadir}/mime &> /dev/null || :
  61. %postun
  62. if [ $1 -eq 0 ] ; then
  63. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  64. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  65. fi
  66. update-desktop-database &> /dev/null || :
  67. update-mime-database %{_datadir}/mime &> /dev/null || :
  68. %files -f %{name}.lang
  69. %defattr(-,root,root,-)
  70. %doc AUTHORS ChangeLog COPYING NEWS
  71. %{_bindir}/%{name}
  72. %{_datadir}/%{name}
  73. %{_datadir}/applications/%{name}.desktop
  74. %{_datadir}/gnome/help/%{name}/*/
  75. %{_datadir}/icons/hicolor/*/apps/%{name}.*
  76. %{_datadir}/mime/packages/%{name}.xml
  77. %{_mandir}/man1/%{name}.1.gz
  78. %changelog
  79. * Tue Jul 17 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.15.2-1
  80. - new upstream release
  81. - changed source archive type bz2 to xz
  82. - added BuildRequires: gnome-doc-utils
  83. - run gtk-update-icon-cache in %%post, %%postun
  84. * Wed Apr 27 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 0.13.5-1
  85. - initial build for Vine Linux based on fedora development
  86. * Wed Sep 22 2010 Chen Lei <supercyper@163.com> - 0.13.5-1
  87. - Update to 0.13.5
  88. * Wed Aug 11 2010 David Malcolm <dmalcolm@redhat.com> - 0.13.4-3
  89. - recompiling .py files against Python 2.7 (rhbz#623347)
  90. * Mon Mar 15 2010 Benjamin Otte <otte@redhat.com> - 0.13.4-2
  91. - Make sure Pitivi has an icon in the menu.
  92. * Wed Mar 10 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.13.4-1.1
  93. - Upload new tarball :)
  94. * Wed Mar 10 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.13.4-1
  95. - Update to 0.13.4
  96. * Tue Mar 9 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.13.3.2-0.1
  97. - Update to 0.13.3.2
  98. * Fri Dec 11 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.13.3-3.3.837f0d73
  99. - Make sure we have the correct source uploaded.
  100. * Thu Dec 10 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.13.3-3.2.837f0d73
  101. - Update to git master to see if this fixes anyone's problems
  102. - Call update-desktop-database/update-mime-database in post/postun
  103. * Thu Dec 3 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.13.3-3
  104. - Add Req on python-setuptools for BZ#540192
  105. * Wed Sep 23 2009 Orcan Ogetbil <oget[DOT]fedora[AT]gmail[DOT]com> - 0.13.3-2
  106. - Update desktop file according to F-12 FedoraStudio feature
  107. * Mon Sep 14 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.13.3-1
  108. - 0.13.3 Release : ... we shall never (sur)render
  109. -
  110. - The PiTiVi team is proud to announce the second release in the
  111. - unstable 0.13 PiTiVi series.
  112. -
  113. - Due to its dependency on GStreamer, The PiTiVi team strongly
  114. - recommends users have all official latest gstreamer libraries and
  115. - plugins installed for the best user experience.
  116. -
  117. - Title is from a quote by Winston Churchill “We shall defend our
  118. - island, whatever the cost may be, we shall fight on the beaches, we
  119. - shall fight on the landing grounds, we shall fight in the fields and
  120. - in the streets, we shall fight in the hills; we shall never
  121. - surrender.”
  122. -
  123. - Features of this release
  124. -
  125. - * Fix rendering failures
  126. - * UI beautifications
  127. - * Switch to themeable ruler
  128. - * Speed optimisations
  129. - * Show the project name in the window title
  130. * Sat Aug 29 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.13.2.2-0.1
  131. - Update to prerelease for 0.13.3
  132. - Streamline BuildRequires
  133. * Fri Aug 14 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.13.2-2
  134. - Bump required version of gstreamer-python
  135. * Thu Aug 13 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.13.2-1
  136. - Update to 0.13.2 "Jailbreak (out of Deadlock City)"
  137. -
  138. - The PiTiVi team is proud to announce the second release in the
  139. - unstable 0.13 PiTiVi series.
  140. -
  141. - Due to its dependency on GStreamer, The PiTiVi team strongly
  142. - recommends users have all official latest gstreamer libraries and
  143. - plugins installed for the best user experience.
  144. -
  145. - Features of this release
  146. -
  147. - * Undo/Redo support
  148. - * Audio mixing
  149. - * Ripple/Roll edit
  150. - * misc fixes everywhere
  151. * Wed Aug 12 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.13.1.3-1
  152. - Update to latest prerelease.
  153. * Mon Jul 27 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.13.1.2-1
  154. - Update to prerelease
  155. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.13.1-2.1
  156. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  157. * Thu May 28 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.13.1-1
  158. - 0.13.1 Release "L'Aquila Immota Manet : The eagle remains unmoved"
  159. - ------------------------------------------------------------------
  160. -
  161. - The PiTiVi team is proud to announce the first release in the unstable 0.13
  162. - PiTiVi series.
  163. -
  164. - This release is in memory of those who have lost their lives, friends,
  165. - houses in the April 6th 2009 earthquake in l'Aquila, Italy.
  166. -
  167. - Due to its dependency on GStreamer, The PiTiVi team strongly
  168. - recommends users have all official latest gstreamer libraries and
  169. - plugins installed for the best user experience.
  170. -
  171. -
  172. - * Features of this release
  173. -
  174. - * core rewrite
  175. - * multi-layered timeline
  176. - * trimming features
  177. - * audio waveforms and video thumbnails in timeline
  178. - * picture support
  179. - * New project file format support
  180. * Thu May 21 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.13.0.2-1
  181. - Upgrade to 0.13.1 prerelease
  182. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.11.3-3
  183. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  184. * Sat Jan 17 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.11.3-2
  185. - Add patch from Denis Leroy to fix running with Python 2.6
  186. * Mon Dec 15 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.11.3-1
  187. - Update to 0.11.3
  188. * Thu Dec 4 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.11.2.2-2
  189. - Upload the sources
  190. * Thu Dec 4 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.11.2.2-1
  191. - Update to 0.11.2.2
  192. * Sat Nov 29 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.11.2-2
  193. - Rebuild for Python 2.6
  194. * Wed Oct 15 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.11.2-1
  195. - Update to 0.11.2
  196. * Mon Oct 13 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.11.1.4-1
  197. - Update to 0.11.1.4
  198. * Mon Jan 14 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.11.1-2
  199. - Add requirement for python-setuptools. (BZ#426855)
  200. * Sat Dec 8 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.11.1-1
  201. - Update to 0.11.1
  202. * Sun Nov 11 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.11.0-2
  203. - Add missing BR
  204. * Wed Oct 16 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.11.0-1
  205. - Update to 0.11.0
  206. * Wed Jun 27 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.10.3-2
  207. - Add versioned requires for gnonlin. (BZ#245981)
  208. * Fri Jun 22 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.10.3-1
  209. - Update to 0.10.3
  210. * Mon May 28 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.10.2.2-3
  211. - BR gettext
  212. * Mon May 28 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.10.2.2-2
  213. - BR perl(XML::Parser)