perl-XML-LibXML-vl.spec 5.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169
  1. Summary: Perl interface to the libxml2 library
  2. Summary(ja): libxml2 ライブラリへの Perl インターフェイス
  3. Name: perl-XML-LibXML
  4. # NOTE: also update perl-XML-LibXSLT to the same version, see
  5. # https://bugzilla.redhat.com/show_bug.cgi?id=469480
  6. Version: 2.0117
  7. Release: 1%{?_dist_release}
  8. License: GPL+ or Artistic
  9. Group: Development/Libraries
  10. URL: http://search.cpan.org/dist/XML-LibXML/
  11. Source0: http://www.cpan.org/authors/id/P/PA/PAJAS/XML-LibXML-%{version}.tar.gz
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: libxml2-devel
  14. BuildRequires: perl(XML::NamespaceSupport)
  15. BuildRequires: perl(XML::SAX)
  16. BuildRequires: perl(ExtUtils::MakeMaker)
  17. BuildRequires: perl(Test::More)
  18. Requires: %(perl -MConfig -le 'if (defined $Config{useithreads}) { print "perl(:WITH_ITHREADS)" } else { print "perl(:WITHOUT_ITHREADS)" }')
  19. Requires: %(perl -MConfig -le 'if (defined $Config{usethreads}) { print "perl(:WITH_THREADS)" } else { print "perl(:WITHOUT_THREADS)" }')
  20. Requires: %(perl -MConfig -le 'if (defined $Config{uselargefiles}) { print "perl(:WITH_LARGEFILES)" } else { print "perl(:WITHOUT_LARGEFILES)" }')
  21. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  22. Provides: perl-XML-LibXML-Common = %{version}
  23. Obsoletes: perl-XML-LibXML-Common <= 0.13
  24. Vendor: Project Vine
  25. Distribution: Vine Linux
  26. %description
  27. This module implements a Perl interface to the GNOME libxml2 library
  28. which provides interfaces for parsing and manipulating XML files. This
  29. module allows Perl programmers to make use of the highly capable
  30. validating XML parser and the high performance DOM implementation.
  31. %prep
  32. %setup -q -n XML-LibXML-%{version}
  33. %build
  34. %__perl Makefile.PL SKIP_SAX_INSTALL=1 INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS"
  35. %__make %{?_smp_mflags}
  36. %install
  37. %__rm -rf $RPM_BUILD_ROOT
  38. %__make install \
  39. PERL_INSTALL_ROOT=$RPM_BUILD_ROOT \
  40. INSTALLARCHLIB=$RPM_BUILD_ROOT%{perl_archlib}
  41. find $RPM_BUILD_ROOT -type f -a \( -name perllocal.pod -o -name .packlist \
  42. -o \( -name '*.bs' -a -empty \) \) -exec %__rm -f {} ';'
  43. find $RPM_BUILD_ROOT -type d -depth -exec %__rmdir {} 2>/dev/null ';'
  44. %__chmod -R u+w $RPM_BUILD_ROOT/*
  45. for i in Changes; do
  46. /usr/bin/iconv -f iso8859-1 -t utf-8 $i > $i.conv && %__mv -f $i.conv $i
  47. done
  48. %check
  49. %__make test
  50. %clean
  51. %__rm -rf $RPM_BUILD_ROOT
  52. %triggerin -- perl-XML-SAX
  53. for p in XML::LibXML::SAX::Parser XML::LibXML::SAX ; do
  54. perl -MXML::SAX -e "XML::SAX->add_parser(q($p))->save_parsers()" \
  55. 2>/dev/null || :
  56. done
  57. %preun
  58. if [ $1 -eq 0 ] ; then
  59. for p in XML::LibXML::SAX::Parser XML::LibXML::SAX ; do
  60. perl -MXML::SAX -e "XML::SAX->remove_parser(q($p))->save_parsers()" \
  61. 2>/dev/null || :
  62. done
  63. fi
  64. %files
  65. %defattr(-,root,root,-)
  66. %doc Changes LICENSE README
  67. %{perl_vendorarch}/auto/XML
  68. %{perl_vendorarch}/XML
  69. %{_mandir}/man3/*.3*
  70. %changelog
  71. * Sun Nov 30 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.0117-1
  72. - new upstream release.
  73. - built with libxml2 2.9.2
  74. - added Japanese summary
  75. * Mon Jun 30 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0116-1
  76. - new upstream release.
  77. * Sun Mar 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.70-2
  78. - rebuild with perl-5.12.3
  79. * Thu Aug 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 1.70-1
  80. - new upstream release
  81. * Fri May 07 2010 Marcela Maslanova <mmaslano@redhat.com> - 1:1.70-5
  82. - Mass rebuild with perl-5.12.0
  83. * Fri Jan 8 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1:1.70-4
  84. - remove BR XML::LibXML::Common
  85. * Mon Nov 30 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1:1.70-3
  86. - corrected version of obsoletes
  87. * Thu Nov 26 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1:1.70-2
  88. - 541605 this package now contains XML::LibXML::Common
  89. * Fri Nov 20 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1:1.70-1
  90. - update to fix 539102
  91. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:1.69-3
  92. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  93. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:1.69-2
  94. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  95. * Thu Dec 11 2008 Marcela Mašláňová <mmaslano@redhat.com> - 1:1.69-1
  96. - update to 1.69
  97. * Fri Aug 01 2008 Lubomir Rintel <lkundrak@v3.sk> - 1:1.66-2
  98. - Supress warning about nonexistent file in perl-XML-SAX install trigger
  99. * Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.66-1
  100. - new upsteream release
  101. - built with perl-5.10.0-2
  102. - changed Group to Development/Libraries
  103. * Sun Jul 16 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.58-2vl2
  104. - changed Group to Development/Languages
  105. - rebuilt with libxml2-2.6.26
  106. * Sun Apr 2 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.58-2vl1
  107. - rebuilt for Vine Linux
  108. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.58-2.2.2
  109. - bump again for double-long bug on ppc(64)
  110. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.58-2.2.1
  111. - rebuilt for new gcc4.1 snapshot and glibc changes
  112. * Fri Feb 03 2006 Jason Vas Dias <jvdias@redhat.com> - 1.58-2.2
  113. - rebuild for new perl-5.8.8
  114. * Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
  115. - rebuilt for new gcc
  116. * Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
  117. - rebuilt for new gcj
  118. * Sat Mar 19 2005 Joe Orton <jorton@redhat.com> 1.58-2
  119. - rebuild
  120. * Sun Apr 18 2004 Ville Skyttä <ville.skytta at iki.fi> - 1.58-1
  121. - #121168
  122. - Update to 1.58.
  123. - Require perl(:MODULE_COMPAT_*).
  124. - Handle ParserDetails.ini parser registration.
  125. - BuildRequires libxml2-devel.
  126. - Own installed directories.
  127. * Fri Feb 27 2004 Chip Turner <cturner@redhat.com> - 1.56-1
  128. - Specfile autogenerated.