perl-EV-vl.spec 5.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161
  1. Name: perl-EV
  2. Version: 4.03
  3. Release: 2%{?_dist_release}
  4. Summary: Wrapper for the libev high-performance event loop library
  5. Summary(ja): 高性能イベントループライブラリ libev の Perl ラッパー
  6. Group: Development/Libraries
  7. # Note: The source archive includes a libev/ folder which contents are licensed
  8. # as "BSD or GPLv2+". However, those are removed at build-time and
  9. # perl-EV is instead built against the system-provided libev.
  10. License: GPL+ or Artistic
  11. URL: http://search.cpan.org/dist/EV/
  12. Source0: http://search.cpan.org/CPAN/authors/id/M/ML/MLEHMANN/EV-%{version}.tar.gz
  13. Patch0: perl-EV-4.03-Don-t-ask-questions-at-build-time.patch
  14. BuildRequires: perl(ExtUtils::MakeMaker)
  15. BuildRequires: perl(common::sense)
  16. BuildRequires: gdbm-devel
  17. BuildRequires: libev-source >= %{version}
  18. BuildRequires: perl(AnyEvent) => 2.6
  19. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  20. # As per review, a perl-EV-devel subpackage had at first been pushed to the
  21. # repositories. It now has broken deps if it's not properly obsoleted/provided.
  22. # TODO: Remove those two lines during the Fedora 17 development cycle.
  23. Provides: %{name}-devel = %{version}-%{release}
  24. Obsoletes: %{name}-devel < 4.03-5
  25. %{?perl_default_filter}
  26. %description
  27. This module provides an interface to libev
  28. (<http://software.schmorp.de/pkg/libev.html>). While the included documentation
  29. is comprehensive, one might also consult the documentation of libev itself
  30. (<http://cvs.schmorp.de/libev/ev.html>) for more subtle details on watcher
  31. semantics or some discussion on the available backends, or how to force a
  32. specific backend with "LIBEV_FLAGS", or just about in any case because it has
  33. much more detailed information.
  34. %prep
  35. %setup -q -n EV-%{version}
  36. # no questins during build
  37. %patch0 -p1
  38. # remove all traces of the bundled libev
  39. rm -fr libev/*
  40. # use the sources from the system libev
  41. mkdir -p ./libev
  42. cp -r /usr/share/libev-source/* ./libev/
  43. %build
  44. %{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS"
  45. make %{?_smp_mflags}
  46. %install
  47. make pure_install PERL_INSTALL_ROOT=%{buildroot}
  48. find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
  49. find %{buildroot} -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
  50. find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null ';'
  51. chmod -R u+w %{buildroot}/*
  52. %check
  53. make test
  54. %clean
  55. rm -rf %{buildroot}
  56. %files
  57. %defattr(-,root,root,-)
  58. %doc Changes COPYING README
  59. %{perl_vendorarch}/auto/*
  60. %{perl_vendorarch}/EV.pm
  61. %{perl_vendorarch}/EV
  62. %{perl_vendorarch}/EV/*.h
  63. %{_mandir}/man3/*.3*
  64. %changelog
  65. * Fri Jun 27 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 4.03-2
  66. - build with Perl 5.16
  67. * Fri Mar 02 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.03-1
  68. - initial build for Vine Linux
  69. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.03-8
  70. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  71. * Thu Dec 01 2011 Petr Pisar <ppisar@redhat.com> - 4.03-7
  72. - Build-require exact or higher version of libev-source (bug #759021)
  73. * Mon Jun 20 2011 Marcela Mašláňová <mmaslano@redhat.com> - 4.03-6
  74. - Perl mass rebuild
  75. * Tue Apr 12 2011 Mathieu Bridon <bochecha@fedoraproject.org> - 4.03-5
  76. - Add the correct Obsoletes/Provides to avoid broken deps from the -devel
  77. subpackage removal.
  78. * Thu Apr 07 2011 Mathieu Bridon <bochecha@fedoraproject.org> - 4.03-4
  79. - Readded the header file to the main package, as per guidelines:
  80. -> http://fedoraproject.org/wiki/Packaging/Perl#.h_files_in_module_packages
  81. * Tue Mar 08 2011 Mathieu Bridon <bochecha@fedoraproject.org> - 4.03-3
  82. - Some more fixes as part of the review process:
  83. - Fix the license tag to be only the license of perl-EV, and add a note about
  84. the included libev sources.
  85. - Removed manual cleaning of the buildroot since it has been useless since
  86. Fedora 10 and even EPEL (>=6) doesn't need it now.
  87. * Wed Feb 23 2011 Mathieu Bridon <bochecha@fedoraproject.org> - 4.03-2
  88. - Fixes asked during the review process:
  89. - Filter the private shared EV.so out of the automatic Provides
  90. - Put the header files in a -devel package
  91. - Removed the Buildroot line since it's useless for newer versions of Fedora
  92. and this package can only go in Fedora >= 15 due to its libev dependency)
  93. * Mon Jan 24 2011 Mathieu Bridon <bochecha@fedoraproject.org> - 4.03-1
  94. - Update to 4.03.
  95. - Use the system libev instead of the bundled one.
  96. * Sun Nov 8 2009 kwizart < kwizart at gmail.com > - 3.8-1
  97. - Update to 3.8
  98. * Tue Apr 28 2009 kwizart < kwizart at gmail.com > - 3.6-1
  99. - Update to 3.6
  100. * Mon Mar 2 2009 kwizart < kwizart at gmail.com > - 3.53-1
  101. - Update to 3.53
  102. * Tue Feb 3 2009 kwizart < kwizart at gmail.com > - 3.52-1
  103. - Update to 3.52
  104. * Tue Oct 14 2008 kwizart < kwizart at gmail.com > - 3.44-1
  105. - Update to 3.44
  106. - WIP conditional --with systemlibev
  107. * Wed Jul 15 2008 kwizart < kwizart at gmail.com > - 3.431-1
  108. - Update to 3.431
  109. - Update License to (GPL+ or Artistic) and (BSD or GPLv2+)
  110. - Add libev README and LICENSE
  111. * Wed Jul 8 2008 kwizart < kwizart at gmail.com > - 3.43-1
  112. - Update to 3.43
  113. * Mon Jun 9 2008 kwizart < kwizart at gmail.com > - 3.42-2
  114. - Disable filter AnyEvent
  115. * Tue May 27 2008 kwizart < kwizart at gmail.com > - 3.42-1
  116. - Update to 3.42
  117. * Wed Apr 30 2008 kwizart < kwizart at gmail.com > - 3.31-1
  118. - Initial package for Fedora