perl-DBI-vl.spec 6.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208
  1. %define version 1.632
  2. %define release 1
  3. Summary: A database access API for perl
  4. Summary(ja): perl 用データベース接続 API
  5. Name: perl-DBI
  6. Version: %{version}
  7. Release: %{release}%{?_dist_release}
  8. License: GPL or Artistic
  9. Group: Development/Libraries
  10. URL: http://dbi.perl.org/
  11. Source0: http://www.cpan.org/authors/id/T/TI/TIMB/DBI-%{version}.tar.gz
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: perl(ExtUtils::MakeMaker)
  14. # Run-time
  15. BuildRequires: perl(base)
  16. BuildRequires: perl(constant)
  17. BuildRequires: perl(Carp)
  18. # Clone is optional
  19. BuildRequires: perl(Clone)
  20. BuildRequires: perl(Coro)
  21. BuildRequires: perl(Coro::Handle)
  22. BuildRequires: perl(Coro::Select)
  23. BuildRequires: perl(Cwd)
  24. BuildRequires: perl(Data::Dumper)
  25. # DB_File is optional
  26. BuildRequires: perl(DB_File)
  27. BuildRequires: perl(DynaLoader)
  28. BuildRequires: perl(Errno)
  29. BuildRequires: perl(Exporter)
  30. BuildRequires: perl(Fcntl)
  31. BuildRequires: perl(File::Basename)
  32. BuildRequires: perl(File::Spec)
  33. BuildRequires: perl(Getopt::Long)
  34. BuildRequires: perl(IO::File)
  35. BuildRequires: perl(IO::Select)
  36. BuildRequires: perl(IPC::Open3)
  37. BuildRequires: perl(Math::BigInt)
  38. # MLDBM is optional
  39. ##BuildRequires: perl(MLDBM)
  40. # RPC::PlClient is optional
  41. ##BuildRequires: perl(RPC::PlClient) >= 0.2000
  42. # RPC::PlServer is optional
  43. ##BuildRequires: perl(RPC::PlServer)
  44. BuildRequires: perl(Scalar::Util)
  45. # SQL::Statement is optional
  46. BuildRequires: perl(SQL::Statement) > 1.33
  47. BuildRequires: perl(Storable)
  48. BuildRequires: perl(Symbol)
  49. BuildRequires: perl(threads)
  50. BuildRequires: perl(Tie::Hash)
  51. BuildRequires: perl(UNIVERSAL)
  52. # Tests
  53. BuildRequires: perl(Encode)
  54. BuildRequires: perl(File::Path)
  55. BuildRequires: perl(lib)
  56. BuildRequires: perl(Net::Daemon::Test)
  57. BuildRequires: perl(Test::More)
  58. BuildRequires: perl(Test::Simple) >= 0.90
  59. # Optional tests
  60. BuildRequires: perl(Test::Pod) >= 1.00
  61. BuildRequires: perl(Test::Pod::Coverage) >= 1.04
  62. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  63. Requires: perl(Math::BigInt)
  64. %description
  65. DBI is a database access Application Programming Interface (API) for
  66. the Perl Language. The DBI API Specification defines a set of
  67. functions, variables and conventions that provide a consistent
  68. database interface independent of the actual database being used.
  69. %description -l ja
  70. DBI は Perl でデータベースにアクセスするための API です.
  71. DBI API では,実際に使われるデータベースに依存しない様に,
  72. 関数,変数などの取り決めが定義されています.
  73. %prep
  74. %setup -q -n DBI-%{version}
  75. iconv -f iso8859-1 -t utf-8 lib/DBD/Gofer.pm >lib/DBD/Gofer.pm.new &&
  76. mv lib/DBD/Gofer.pm{.new,}
  77. chmod 644 ex/*
  78. chmod 744 dbixs_rev.pl
  79. sed -i 's?#!perl?#!%{__perl}?' ex/corogofer.pl
  80. %build
  81. perl Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
  82. make %{?_smp_mflags}
  83. %install
  84. [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
  85. make pure_install PERL_INSTALL_ROOT=%{buildroot}
  86. find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
  87. find %{buildroot} -type f -name '*.bs' -empty -exec rm -f {} ';'
  88. find %{buildroot} -type d -depth -exec rmdir {} 2>/dev/null ';'
  89. chmod -R u+w %{buildroot}/*
  90. # Remove Win32 specific files and man pages to avoid unwanted dependencies
  91. rm -rf %{buildroot}%{perl_vendorarch}/{Win32,DBI/W32ODBC.pm} \
  92. %{buildroot}%{_mandir}/man3/{DBI::W32,Win32::DBI}ODBC.3pm
  93. perl -pi -e 's"#!perl -w"#!/usr/bin/perl -w"' \
  94. %{buildroot}%{perl_vendorarch}/{goferperf,dbixs_rev}.pl
  95. %clean
  96. [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
  97. %check
  98. make test
  99. %files
  100. %defattr(-,root,root)
  101. %doc Changes README.md ex/
  102. %{perl_vendorarch}/*.p*
  103. %{perl_vendorarch}/Bundle/
  104. %{perl_vendorarch}/DBD/
  105. %{perl_vendorarch}/DBI/
  106. %{perl_vendorarch}/auto/DBI/
  107. %{_bindir}/*
  108. %{_mandir}/*/*
  109. %changelog
  110. * Fri Dec 5 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.632-1
  111. - updated to 1.632
  112. * Fri Jun 27 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.618-2
  113. - build with Perl 5.16
  114. * Fri Mar 02 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.618-1
  115. - updated to 1.618; spec revamped
  116. * Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 1.604-4vl6
  117. - rebuild with perl 5.12.3
  118. - using __perl_requires macro for VineSeed (vl6)
  119. * Wed Apr 08 2009 Shu KONNO <owa@bg.wakwak.com> 1.604-3
  120. - spec in utf-8
  121. * Thu May 1 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.604-2
  122. - rebuilt with perl-5.10.0.
  123. * Wed Apr 23 2008 IWAI, Masaharu <iwaim@cc.mbn.or.jp> 1.604-1
  124. - new upstream release
  125. * Mon Aug 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.58-0vl1
  126. - new upstream release
  127. * Sun Jan 28 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.53-0vl1
  128. - new upstream release
  129. * Sun Sep 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.51-0vl1
  130. - new upstream release
  131. - changed Group to Development/Libraries
  132. - installed module files to vendor_perl
  133. * Sat Jul 22 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.46-0vl2
  134. - use filter-requires-dbi.sh instead of find-requires.perl
  135. * Sat Dec 04 2004 IWAI, Masaharu <iwai@alib.jp> 1.46-0vl1
  136. - new upstream version
  137. - build on perl-5.8.6-0vl1
  138. * Sat May 22 2004 Satoshi MACHINO <machino@vinelinux.org> 1.40-0vl1
  139. - new upstream version
  140. * Sat May 24 2003 IWAI Masaharu <iwai@alib.jp> 1.37-0vl1
  141. - update 1.37
  142. - build with perl-5.8.0
  143. - add make test
  144. * Sat Feb 23 2002 Satoshi MACHINO <machino@vinelinux.org> 1.21-0vl1
  145. - updated 1.21
  146. * Wed Dec 05 2001 Satoshi MACHINO <machino@vinelinux.org> 1.20-0vl1
  147. - updated 1.20
  148. * Sat Sep 15 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.19-0vl2
  149. - the spec was in Shift-JIS. Fixed.
  150. * Fri Aug 03 2001 Satoshi MACHINO <machino@vinelinux.org> 1.19-0vl1
  151. - updated 1.19
  152. * Sat Jun 15 2001 Satoshi MACHINO <machino@vinelinux.org> 1.15-1vl2
  153. - rebuild on perl-5.6.0
  154. - changed mandir to /usr/share/man
  155. - removed version in Requires perl
  156. * Sun May 27 2001 Satoshi MACHINO <machino@vinelinux.org> 1.15-1vl1
  157. - updated perl-DBL-1.15
  158. * Tue May 08 2001 Satoshi MACHINO <machino@vinelinux.org> 1.14-10vl1
  159. - fixed Vine Linux
  160. * Tue Feb 27 2001 Trond Eivind Glomsr <teg@redhat.com>
  161. - Cleanups
  162. * Thu Nov 30 2000 Trond Eivind Glomsr <teg@redhat.com>
  163. - build for main distribution
  164. - use %%{_tmppath}
  165. - change name of specfile
  166. - don't use a find script to generate file lists
  167. - general cleanup
  168. - add descriptive summary and description
  169. * Mon Aug 14 2000 Tim Powers <timp@redhat.com>
  170. - Spec file was autogenerated.