pango-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608
  1. %define glib2_version 2.46.0
  2. %define pkgconfig_version 0.12
  3. %define freetype2_version 2.3.9
  4. %define fontconfig_version 2.10.91
  5. %define cairo_version 1.12.2
  6. # biarch support
  7. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  8. %define _querymodules_suffix %{nil}
  9. %if %{build_compat32}
  10. %define _querymodules_suffix -32
  11. %endif
  12. Summary: System for layout and rendering of internationalized text.
  13. Summary(ja): 国際化テキストのレイアウト・レンダリングシステム
  14. Name: pango
  15. Version: 1.38.1
  16. Release: 1%{?_dist_release}
  17. License: LGPL
  18. Group: System Environment/Libraries
  19. Source: ftp://ftp.gnome.org/pub/gnome/sources/pango/1.38/pango-%{version}.tar.xz
  20. URL: http://www.pango.org
  21. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  22. # We need to prereq this so we can run pango-querymodules
  23. Requires: glib2 >= %{glib2_version}
  24. Requires: freetype2 >= %{freetype2_version}
  25. BuildRequires: libtool >= 1.4.2
  26. BuildRequires: glib2-devel >= %{glib2_version}
  27. BuildRequires: pkgconfig >= %{pkgconfig_version}
  28. BuildRequires: freetype2-devel >= %{freetype2_version}
  29. BuildRequires: fontconfig-devel >= %{fontconfig_version}
  30. BuildRequires: libX11-devel, libXft-devel, libXrender-devel
  31. BuildRequires: cairo-devel >= %{cairo_version}
  32. BuildRequires: libSM-devel
  33. BuildRequires: gobject-introspection-devel
  34. BuildRequires: libthai-devel
  35. BuildRequires: harfbuzz-devel
  36. Obsoletes: pango-gtkbeta, fribidi-gtkbeta
  37. Vendor: Project Vine
  38. Distribution: Vine Linux
  39. Packager: Takemikaduchi
  40. %description
  41. Pango is a system for layout and rendering of internationalized text.
  42. %description -l ja
  43. Pango は国際化テキストのレイアウト・レンダリングシステムです。
  44. %package devel
  45. Summary: System for layout and rendering of internationalized text.
  46. Summary(ja): 国際化テキストのレイアウト・レンダリングシステム
  47. Group: Development/Libraries
  48. Requires: %{name} = %{version}
  49. Requires: glib2-devel >= %{glib2_version}
  50. Requires: freetype2-devel >= %{freetype2_version}
  51. Requires: cairo-devel >= %{cairo_version}
  52. Requires: libX11-devel, libXft-devel, libXrender-devel
  53. Requires: harfbuzz-devel
  54. Obsoletes: fribidi-gtkbeta-devel, pango-gtkbeta-devel
  55. %description devel
  56. The pango-devel package includes the static libraries, header files,
  57. and developer docs for the pango package.
  58. Install pango-devel if you want to develop programs which will use
  59. pango.
  60. #####################################################################
  61. # compat32
  62. %package -n compat32-%{name}
  63. Summary: System for layout and rendering of internationalized text.
  64. Summary(ja): 国際化テキストのレイアウト・レンダリングシステム
  65. Group: Development/Libraries
  66. %description -n compat32-%{name}
  67. Pango is a system for layout and rendering of internationalized text.
  68. %description -n compat32-%{name} -l ja
  69. Pango は国際化テキストのレイアウト・レンダリングシステムです。
  70. %package -n compat32-%{name}-devel
  71. Summary: Development files for pango
  72. Summary(ja): pango 用の開発ファイル
  73. Group: Development/Libraries
  74. Requires: compat32-%{name} = %{version}
  75. Requires: %{name}-devel = %{version}
  76. %description -n compat32-%{name}-devel
  77. The pango-devel package includes the static libraries, header files,
  78. and developer docs for the pango package.
  79. %prep
  80. %setup -q -n pango-%{version}
  81. %build
  82. ###%configure --with-included-modules=basic-fc
  83. (if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
  84. %configure CONFIGFLAGS --with-included-modules=basic-fc --disable-silent-rules --enable-introspection=yes)
  85. make %{?_smp_mflags}
  86. %install
  87. rm -rf $RPM_BUILD_ROOT
  88. make DESTDIR=$RPM_BUILD_ROOT install
  89. # remove unpackaged files
  90. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  91. rm -f $RPM_BUILD_ROOT%{_libdir}/pango/*/modules/*.la
  92. %clean
  93. rm -rf $RPM_BUILD_ROOT
  94. %post -p /sbin/ldconfig
  95. %postun -p /sbin/ldconfig
  96. %if %{build_compat32}
  97. %post -p /sbin/ldconfig -n compat32-%{name}
  98. %postun -p /sbin/ldconfig -n compat32-%{name}
  99. %endif
  100. %files
  101. %defattr(-, root, root)
  102. %doc README AUTHORS COPYING NEWS
  103. %doc pango-view/HELLO.txt
  104. #doc README AUTHORS COPYING ChangeLog
  105. #doc examples/HELLO.utf8
  106. %{_bindir}/pango-view
  107. %{_libdir}/libpango*-*.so.*
  108. %{_libdir}/girepository-1.0
  109. %{_mandir}/man*/*
  110. %files devel
  111. %defattr(-, root, root)
  112. %{_libdir}/libpango*.so
  113. %{_includedir}/*
  114. %{_libdir}/pkgconfig/*
  115. %{_datadir}/gtk-doc/*
  116. %{_datadir}/gir-1.0
  117. %if %{build_compat32}
  118. %files -n compat32-%{name}
  119. %defattr(-, root, root)
  120. %{_libdir}/libpango*-*.so.*
  121. %files -n compat32-%{name}-devel
  122. %defattr(-, root, root)
  123. %{_libdir}/libpango*.so
  124. %endif
  125. %changelog
  126. * Thu Oct 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.38.1-1
  127. - new upstream release
  128. - remove old patches
  129. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.36.8-1
  130. - new upstream release
  131. * Sat Jun 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.36.5-1
  132. - new upstream release
  133. * Fri Mar 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.36.3-1
  134. - new upstream release
  135. * Sat Feb 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.36.2-1
  136. - new upstream release
  137. * Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.36.1-1
  138. - new upstream release
  139. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.36.0-1
  140. - new upstream release
  141. * Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.34.1-1
  142. - new upstream release
  143. * Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.34.0-1
  144. - new upstream release
  145. * Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.32.5-1
  146. - new upstream release
  147. * Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.32.2-1
  148. - new upstream release
  149. * Fri Sep 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.32.1-1
  150. - new upstream release
  151. - update Patch0 (pango-1.31.2-lib64.patch)
  152. - add BuildRequires: harfbuzz-devel
  153. * Tue Jun 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.1-1
  154. - new upstream release
  155. * Sat Mar 31 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.0-1
  156. - new upstream release
  157. * Wed Jan 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.29.4-2
  158. - add BuildRequires: libthai-devel
  159. * Thu Oct 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.29.4-1
  160. - new upstream release
  161. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.29.3-1
  162. - new upstream release
  163. * Mon Apr 25 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.28.4-1
  164. - new upstream release with security fixes (CVE-2011-0020, 0064)
  165. - add Vendor/Distri tags
  166. * Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.28.3-1
  167. - add BuildRequires: libSM-devel, gobject-introspection-devel
  168. - add Patch1 (pango-1.28.1-gobject-introspection.patch)
  169. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.28.1-2
  170. - build with rpm-4.8.1-1 for pkg-config file
  171. * Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.28.1-1
  172. - new upstream release
  173. * Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.28.0-1
  174. - new upstream release
  175. * Sun Jan 10 2010 Shu KONNO <owa@bg.wakwak.com> 1.26.2-2
  176. - changed %%makeinstall to make install with DESTDIR option
  177. * Thu Jan 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.26.2-1
  178. - new upstream release
  179. * Sun Nov 29 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.26.1-1
  180. - new upstream release
  181. * Thu Sep 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.26.0-1
  182. - new upstream release
  183. * Sun Jul 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.5-1
  184. - new upstream release
  185. * Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.4-1
  186. - new upstream release
  187. * Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.2-1
  188. - new upstream release
  189. * Mon May 04 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.24.1-2
  190. - removed %%if !%%{build_compat32} case condition
  191. * Mon May 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.1-1
  192. - new upstream release
  193. * Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.0-1
  194. - new upstream release
  195. * Tue Dec 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22.4-1
  196. - new upstream release
  197. * Tue Nov 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22.3-1
  198. - new upstream release
  199. * Fri Oct 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22.1-1
  200. - new upstream release
  201. * Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22.0-1
  202. - new upstream release
  203. * Thu Jul 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.5-1
  204. - new upstream release
  205. * Sun May 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.20.3-2
  206. - spec in UTF-8 actually
  207. * Sun May 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.3-1
  208. - new upstream release
  209. - rebuilt with xorg-x11 7.3
  210. * Wed Apr 9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.1-1vl5
  211. - new upstream release
  212. * Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.0-1vl5
  213. - used %{?_dist_release}
  214. * Wed Mar 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.0-0vl1
  215. - new upstream release
  216. * Thu Jan 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.18.4-0vl1
  217. - new upstream release
  218. * Fri Nov 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.18.3-0vl1
  219. - new upstream release
  220. - added Patch0 instead of Patch5
  221. * Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16.4-0vl2
  222. - replace build with new environment
  223. * Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16.4-0vl2
  224. - rebuild with new environment
  225. * Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16.4-0vl1
  226. - new upstream release
  227. * Wed Apr 25 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16.2-0vl1
  228. - new upstream release
  229. * Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.14.9-0vl1
  230. - new upstream release
  231. * Sun Oct 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14.7-0vl1
  232. - new upstream release
  233. * Sat Sep 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14.4-0vl1
  234. - new upstream release
  235. * Thu Aug 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14.0-0vl1
  236. - new upstream release
  237. * Tue Aug 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.3-0vl3
  238. - rebuild with cairo-1.2.0
  239. * Tue Aug 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.3-0vl2
  240. - add Patch10 to create fake style(italic/bold) for all fonts.
  241. http://bugzilla.gnome.org/show_bug.cgi?id=319808
  242. - This patch is not applied in upstream, but it seems usefull
  243. for us.
  244. * Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.3-0vl1
  245. - new upstream release
  246. * Sun Apr 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.2-0vl1
  247. - new upstream release
  248. * Sat Apr 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.1-0vl1
  249. - new upstream release
  250. * Fri Mar 17 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.0-0vl2
  251. - fix broken dependancy
  252. * Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.0-0vl1
  253. - new upstream release
  254. * Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.11.99-0vl1
  255. - new upstream release
  256. - add compat32 package for x86_64 arch support
  257. - add Patch5 for biarch support
  258. * Sun Jan 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.2-0vl1
  259. - new upstream release
  260. * Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.1-0vl1
  261. - new upstream release
  262. * Sun Aug 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.0-0vl1
  263. - new upstream release
  264. * Mon Aug 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0vl2
  265. - rebuild with cairo-0.9
  266. - add patch10 to disable building example programs
  267. * Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0vl1
  268. - new upstream release
  269. * Mon Jan 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-0vl1
  270. - new upstream release
  271. - drop obsolete patches
  272. * Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl1
  273. - new upstream release
  274. - import upstream patches from fedora package.
  275. * Sat Aug 14 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.1-0vl1
  276. - new upstream release
  277. * Thu Mar 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.0-0vl1
  278. - new upstream release
  279. * Thu Mar 4 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl3
  280. - remove unneeded dependancy to freetype2-devel
  281. * Wed Nov 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl2
  282. - add patch10 to build against freetype-2.1.7
  283. - rebuild with freetype-2.1.7
  284. * Mon Sep 01 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl1
  285. - new upstream release
  286. * Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-0vl1
  287. - new upstream release
  288. * Mon Feb 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
  289. - new upstream release
  290. * Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-0vl2
  291. - merge patch1,2 from rawhide package.
  292. * Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-0vl1
  293. - new upstream release
  294. * Fri Dec 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.5-0vl1
  295. - new upstream release
  296. - Build for Vine Linux, specfile are based on rawhide release
  297. * Thu Nov 21 2002 Havoc Pennington <hp@redhat.com>
  298. - change PKG_CONFIG_PATH hack to also search /usr/X11R6/lib64/pkgconfig
  299. * Wed Nov 20 2002 Havoc Pennington <hp@redhat.com>
  300. - explicitly require pangoxft to be built, so we catch situations such
  301. as xft.pc moving to /usr/X11R6
  302. - also add /usr/X11R6/lib/pkgconfig to PKG_CONFIG_PATH as a temporary
  303. hack
  304. * Thu Nov 7 2002 Havoc Pennington <hp@redhat.com>
  305. - 1.1.3
  306. * Thu Oct 31 2002 Owen Taylor <otaylor@redhat.com> 1.1.1-5
  307. - Require the necessary freetype version, don't just
  308. BuildRequires it (#74744)
  309. * Thu Oct 31 2002 Owen Taylor <otaylor@redhat.com> 1.1.1-4
  310. - Own /etc/pango (#73962, Enrico Scholz)
  311. - Remove .la files from the build root
  312. * Mon Oct 7 2002 Havoc Pennington <hp@redhat.com>
  313. - require glib 2.0.6-3, try rebuild on more arches
  314. * Wed Aug 21 2002 Owen Taylor <otaylor@redhat.com>
  315. - Version 1.1.1 (main change, fixes font selection for FT2 backend,
  316. as in gdmgreeter)
  317. * Thu Aug 15 2002 Owen Taylor <otaylor@redhat.com>
  318. - Fix linked list manipulation problem that was causing hang for anaconda
  319. - Fix warning from loading mini-fonts with context == NULL
  320. * Wed Aug 14 2002 Owen Taylor <otaylor@redhat.com>
  321. - Fix major memory leak in the last patch
  322. * Tue Aug 13 2002 Owen Taylor <otaylor@redhat.com>
  323. - Actually use language tags at the rendering layer (should fix #68211)
  324. * Mon Jul 15 2002 Owen Taylor <otaylor@redhat.com>
  325. - Remove fixed-ltmain.sh, relibtoolize; to fix relink problems without
  326. - Fix bug causing hex boxes to be misrendered
  327. leaving RPATH (#66005)
  328. - For FT2 backend, supply FT_LOAD_NO_BITMAP to avoid problems with
  329. fonts with embedded bitmaps (#67851)
  330. * Mon Jul 8 2002 Owen Taylor <otaylor@redhat.com>
  331. - Make basic-x shaper work with our big-5 fonts
  332. * Wed Jul 3 2002 Owen Taylor <otaylor@redhat.com>
  333. - New upstream tarball with hooks for change-on-the fly font rendering
  334. * Tue Jun 25 2002 Owen Taylor <otaylor@redhat.com>
  335. - Up FreeType version to deal with FreeType-2.0.x / 2.1.x \
  336. ABI changes for pango's OpenType code.
  337. * Mon Jun 24 2002 Owen Taylor <otaylor@redhat.com>
  338. - Add some Korean aliases that the installer wants
  339. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  340. - automated rebuild
  341. * Sat Jun 8 2002 Havoc Pennington <hp@redhat.com>
  342. - devel package requires fontconfig/Xft devel packages
  343. * Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
  344. - rebuild in different environment
  345. * Thu Jun 6 2002 Owen Taylor <otaylor@redhat.com>
  346. - Snapshot with Xft2/fontconfig support
  347. * Wed May 29 2002 Owen Taylor <otaylor@redhat.com>
  348. - Version 1.0.2
  349. - Patch for charmaps problem
  350. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  351. - automated rebuild
  352. * Wed May 22 2002 Havoc Pennington <hp@redhat.com>
  353. - rebuild in different environment
  354. * Wed May 22 2002 Havoc Pennington <hp@redhat.com>
  355. - add patch to adjust to newer version of freetype
  356. * Wed Apr 3 2002 Alex Larsson <alexl@redhat.com>
  357. - Update to version 1.0.1, remove patch
  358. * Tue Mar 19 2002 Owen Taylor <otaylor@redhat.com>
  359. - Patch from CVS for big speedup with FreeType-2.0.9
  360. * Mon Mar 11 2002 Owen Taylor <otaylor@redhat.com>
  361. - Rebuild
  362. * Fri Mar 8 2002 Owen Taylor <otaylor@redhat.com>
  363. - Version 1.0.0
  364. * Mon Feb 25 2002 Alex Larsson <alexl@redhat.com>
  365. - Update to 0.26
  366. * Thu Feb 21 2002 Alex Larsson <alexl@redhat.com>
  367. - Bump for rebuild
  368. * Mon Feb 18 2002 Alex Larsson <alexl@redhat.com>
  369. - Update to 0.25
  370. * Fri Feb 15 2002 Havoc Pennington <hp@redhat.com>
  371. - add horrible buildrequires hack
  372. * Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
  373. - 0.24.90 cvs snap
  374. * Tue Jan 29 2002 Owen Taylor <otaylor@redhat.com>
  375. - Version 0.24
  376. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  377. - automated rebuild
  378. * Wed Jan 2 2002 Havoc Pennington <hp@redhat.com>
  379. - new snap 0.23.90
  380. * Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
  381. - rebuild with 64-bit-fixed glib
  382. * Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
  383. - Version 0.22
  384. - add explicit check for required glib2 version before we do the build,
  385. so we don't end up with bad RPMs on --nodeps builds
  386. - PreReq the glib2_version version, instead of 1.3.8 hardcoded that
  387. no one had updated recently
  388. * Thu Oct 25 2001 Owen Taylor <otaylor@redhat.com>
  389. - Version 0.21
  390. * Thu Oct 4 2001 Havoc Pennington <hp@redhat.com>
  391. - cvs snap
  392. - new cvs snap with a bugfix
  393. * Thu Sep 27 2001 Havoc Pennington <hp@redhat.com>
  394. - sync with Owen's changes, fix up dependency versions
  395. * Wed Sep 19 2001 Havoc Pennington <hp@redhat.com>
  396. - 0.19
  397. * Mon Sep 10 2001 Havoc Pennington <hp@redhat.com>
  398. - build CVS snap
  399. * Wed Sep 05 2001 Havoc Pennington <hp@redhat.com>
  400. - no relinking junk
  401. * Tue Sep 4 2001 root <root@dhcpd37.meridian.redhat.com>
  402. - Version 0.18
  403. * Fri Jul 20 2001 Owen Taylor <otaylor@redhat.com>
  404. - Configure --disable-gtk-doc
  405. - BuildRequires freetype-devel, XFree86-devel
  406. * Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
  407. - 0.17
  408. - libtool hackarounds
  409. * Fri May 04 2001 Owen Taylor <otaylor@redhat.com>
  410. - 0.16, rename back to pango from pango-gtkbeta
  411. * Fri Feb 16 2001 Owen Taylor <otaylor@redhat.com>
  412. - Obsolete fribidi-gtkbeta
  413. * Mon Dec 11 2000 Havoc Pennington <hp@redhat.com>
  414. - Remove that patch I just put in
  415. * Mon Dec 11 2000 Havoc Pennington <hp@redhat.com>
  416. - Patch pangox.pc.in to include -Iincludedir
  417. * Fri Nov 17 2000 Owen Taylor <otaylor@redhat.com>
  418. - final 0.13
  419. * Tue Nov 14 2000 Owen Taylor <otaylor@redhat.com>
  420. - New 0.13 tarball
  421. * Mon Nov 13 2000 Owen Taylor <otaylor@redhat.com>
  422. - 0.13pre1
  423. * Sun Aug 13 2000 Owen Taylor <otaylor@redhat.com>
  424. - Rename to 0.12b to avoid versioning problems
  425. * Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
  426. - Move to a CVS snapshot
  427. * Fri Jul 07 2000 Owen Taylor <otaylor@redhat.com>
  428. - Move back to /usr
  429. - Version 0.12
  430. * Mon Jun 19 2000 Owen Taylor <otaylor@redhat.com>
  431. - Add missing %%defattr
  432. * Thu Jun 8 2000 Owen Taylor <otaylor@redhat.com>
  433. - Rebuild with a prefix of /opt/gtk-beta
  434. * Wed May 31 2000 Owen Taylor <otaylor@redhat.com>
  435. - version 0.11
  436. - add --without-qt
  437. * Wed Apr 26 2000 Owen Taylor <otaylor@redhat.com>
  438. - Make the devel package require *-gtkbeta-* not the normal packages.
  439. * Tue Apr 25 2000 Owen Taylor <otaylor@redhat.com>
  440. - GTK+ snapshot version installing in /opt/gtk-beta
  441. * Fri Feb 11 2000 Owen Taylor <otaylor@redhat.com>
  442. - Created spec file