openssl097-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define soversion 4
  3. %define version 0.9.7m
  4. %define release 1%{?_dist_release}
  5. Summary: Secure Sockets Layer Toolkit
  6. Name: openssl097
  7. Version: %{version}
  8. Release: %{release}
  9. Source: openssl-%{version}.tar.gz
  10. Source2: Makefile.certificate
  11. Source3: ca-bundle.crt
  12. Source5: make-dummy-cert
  13. Source6: openssl-%{version}.pc
  14. Patch0: openssl-0.9.7h-soversion.patch
  15. Patch2: openssl-0.9.7m-rpm_opt.patch
  16. # security patch
  17. Patch10: http://openssl.org/news/patch-CVE-2007-3108.txt
  18. Patch20: openssl-0.9.7l_CVE-2007-5135.patch
  19. License: BSDish
  20. Group: System Environment/Libraries
  21. URL: http://www.openssl.org/
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  23. BuildPreReq: perl, sed
  24. Requires: mktemp
  25. Packager: Daisuke SUZUKI <daisuke@linux.or.jp>
  26. Vendor: Project Vine
  27. Distribution: Vine Linux
  28. %define solibbase %(echo %version | sed 's/[[:alpha:]]//g')
  29. %description
  30. The OpenSSL certificate management tool and the shared libraries that
  31. provide various cryptographic algorithms and protocols.
  32. %package devel
  33. Summary: OpenSSL libraries and development headers.
  34. Group: Development/Libraries
  35. Requires: %{name} = %{version}-%{release}
  36. %description devel
  37. The static libraries and include files needed to compile apps
  38. with support for various the cryptographic algorithms and protocols
  39. supported by OpenSSL.
  40. Patches for many networking apps can be found at:
  41. ftp://ftp.psy.uq.oz.au/pub/Crypto/SSLapps/
  42. %package perl
  43. Summary: OpenSSL scripts which require Perl.
  44. Group: Applications/Internet
  45. Requires: perl
  46. Requires: %{name} = %{version}-%{release}
  47. %description perl
  48. Perl scripts provided with OpenSSL for converting certificates and keys
  49. from other formats to those used by OpenSSL.
  50. ## to build compat32 for x86_64 architecture support
  51. %package -n compat32-%{name}
  52. Summary: Secure Sockets Layer Toolkit
  53. Group: System Environment/Libraries
  54. Requires: mktemp
  55. %description -n compat32-%{name}
  56. The OpenSSL certificate management tool and the shared libraries that
  57. provide various cryptographic algorithms and protocols.
  58. %package -n compat32-%{name}-devel
  59. Summary: OpenSSL libraries and development headers.
  60. Group: Development/Libraries
  61. Requires: compat32-%{name} = %{version}-%{release}
  62. %description -n compat32-%{name}-devel
  63. The static libraries and include files needed to compile apps
  64. with support for various the cryptographic algorithms and protocols
  65. supported by OpenSSL.
  66. %prep
  67. %setup -q -n openssl-%{version}
  68. %patch0 -p1 -b .soversion
  69. %patch2 -p1 -b .rpm_opt
  70. %patch10 -p1 -b CVE-2007-3108
  71. %patch20 -p1 -b CVE-2007-5135
  72. chmod 644 FAQ LICENSE CHANGES NEWS INSTALL README
  73. chmod 644 doc/README doc/c-indentation.el doc/openssl.txt
  74. chmod 644 doc/openssl_button.html doc/openssl_button.gif
  75. chmod 644 doc/ssleay.txt
  76. # Link the configuration header to the one we're going to make.
  77. ln -sf ../../crypto/opensslconf.h include/openssl/
  78. %build
  79. PATH=${PATH}:${PWD}/bin
  80. TOPDIR=${PWD}
  81. LD_LIBRARY_PATH=${TOPDIR}:${TOPDIR}/bin:${PATH} ; export LD_LIBRARY_PATH
  82. # Figure out which flags we want to use. Can't use assembler because it's
  83. # not lowest-common-denominator in most cases.
  84. perl util/perlpath.pl `dirname %{__perl}`
  85. %ifarch %ix86
  86. sslarch=linux-elf
  87. sslflags="no-asm 386"
  88. %endif
  89. %ifarch ppc
  90. sslarch=linux-ppc
  91. sslflags=no-asm
  92. %endif
  93. %ifarch sparc
  94. sslarch=linux-sparcv9
  95. sslflags=no-asm
  96. %endif
  97. %ifarch ia64
  98. sslarch=linux-ia64
  99. sslflags=no-asm
  100. %endif
  101. %ifarch alpha
  102. sslarch=linux-alpha-gcc
  103. sslflags=no-asm
  104. %endif
  105. %ifarch s390
  106. sslarch=linux-s390
  107. %endif
  108. %ifarch s390x
  109. sslarch=linux-s390x
  110. %endif
  111. %ifarch mipsel
  112. sslarch=linux-mips
  113. sslflags=no-asm
  114. %endif
  115. ## to build for x86_64 architecture support
  116. %ifarch x86_64
  117. sslarch=linux-x86_64
  118. sslflags=no-asm
  119. %endif
  120. # Configure the build tree. Override OpenSSL defaults with known-good defaults
  121. # usable on all platforms. The Configure script already knows to use -fPIC and
  122. # RPM_OPT_FLAGS, so we can skip specifiying them here.
  123. ./Configure \
  124. --prefix=%{_prefix} --openssldir=%{_datadir}/ssl ${sslflags} \
  125. shared ${sslarch}
  126. # Add -Wa,--noexecstack here so that libcrypto's assembler modules will be
  127. # marked as not requiring an executable stack.
  128. RPM_OPT_FLAGS="$RPM_OPT_FLAGS -Wa,--noexecstack"
  129. make depend
  130. make all build-shared
  131. # Generate hashes for the included certs.
  132. LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
  133. export LD_LIBRARY_PATH
  134. make rehash build-shared
  135. # Verify that what was compiled actually works.
  136. make -C test apps tests
  137. # Relink the main binary to get it dynamically linked.
  138. rm apps/openssl
  139. make all build-shared
  140. %install
  141. [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
  142. # Install OpenSSL.
  143. #install -d $RPM_BUILD_ROOT{/lib,%{_bindir},%{_includedir},%{_libdir},%{_mandir}}
  144. install -d $RPM_BUILD_ROOT/{%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir}}
  145. make INSTALL_PREFIX=$RPM_BUILD_ROOT install build-shared
  146. install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir}
  147. # added for lib64
  148. mv $RPM_BUILD_ROOT/usr/lib/* $RPM_BUILD_ROOT%{_libdir}/ || :
  149. mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.%{solibbase} $RPM_BUILD_ROOT/%{_lib}/
  150. mv $RPM_BUILD_ROOT%{_datadir}/ssl/man/* $RPM_BUILD_ROOT%{_mandir}
  151. rmdir $RPM_BUILD_ROOT%{_datadir}/ssl/man
  152. rename so.%{solibbase} so.%{version} $RPM_BUILD_ROOT/%{_lib}/*.so.%{solibbase}
  153. #for lib in $RPM_BUILD_ROOT/lib/*.so.%{version} ; do
  154. for lib in $RPM_BUILD_ROOT/%{_lib}/*.so.%{version} ; do
  155. chmod 755 ${lib}
  156. ln -s -f ../../%{_lib}/`basename ${lib}` $RPM_BUILD_ROOT%{_libdir}/`basename ${lib} .%{version}`
  157. ln -s -f ../../%{_lib}/`basename ${lib}` $RPM_BUILD_ROOT%{_libdir}/`basename ${lib} .%{version}`.%{soversion}
  158. done
  159. # install -m644 -D $RPM_SOURCE_DIR/openssl.pc $RPM_BUILD_ROOT%{_libdir}/pkgconfig/openssl.pc
  160. install -m644 -D %{SOURCE6} $RPM_BUILD_ROOT%{_libdir}/pkgconfig/openssl.pc
  161. # Install a makefile for generating keys and self-signed certs, and a script
  162. # for generating them on the fly.
  163. mkdir -p $RPM_BUILD_ROOT%{_datadir}/ssl/certs
  164. install -m644 $RPM_SOURCE_DIR/Makefile.certificate $RPM_BUILD_ROOT%{_datadir}/ssl/certs/Makefile
  165. install -m644 $RPM_SOURCE_DIR/make-dummy-cert $RPM_BUILD_ROOT%{_datadir}/ssl/certs/make-dummy-cert
  166. # Make sure we actually include the headers we built against.
  167. for header in $RPM_BUILD_ROOT%{_includedir}/openssl/* ; do
  168. if [ -f ${header} -a -f include/openssl/$(basename ${header}) ] ; then
  169. install -m644 include/openssl/`basename ${header}` ${header}
  170. fi
  171. done
  172. # Rename man pages so that they don't conflict with system man pages. We used
  173. # to change the file extensions, but that only prevents file conflicts. The
  174. # man viewer still can't select either of the two unless we physically change
  175. # the directory.
  176. for section in 1 2 3 4 5 6 7 8 ; do
  177. if test -d $RPM_BUILD_ROOT%{_mandir}/man${section} ; then
  178. mv $RPM_BUILD_ROOT%{_mandir}/man${section} \
  179. $RPM_BUILD_ROOT%{_mandir}/man${section}ssl
  180. fi
  181. done
  182. # Pick a CA script.
  183. pushd $RPM_BUILD_ROOT%{_datadir}/ssl/misc
  184. mv CA.sh CA
  185. popd
  186. # Install root CA stuffs.
  187. cat %{SOURCE3} > ca-bundle.crt
  188. install -m644 ca-bundle.crt $RPM_BUILD_ROOT%{_datadir}/ssl/certs/
  189. ln -s certs/ca-bundle.crt $RPM_BUILD_ROOT%{_datadir}/ssl/cert.pem
  190. # Fix libdir.
  191. #sed 's,^libdir=${exec_prefix}/lib,libdir=${exec_prefix}/%{_lib},g' \
  192. sed 's,^libdir=/usr/lib,libdir=%{_libdir},g' \
  193. $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc > \
  194. $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp && \
  195. cat $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp > \
  196. $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc && \
  197. rm -f $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp
  198. %clean
  199. [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
  200. %files
  201. %defattr(-,root,root)
  202. %doc FAQ LICENSE CHANGES NEWS INSTALL README
  203. %doc doc/README doc/c-indentation.el doc/openssl.txt
  204. %doc doc/openssl_button.html doc/openssl_button.gif
  205. %doc doc/ssleay.txt
  206. %dir %{_datadir}/ssl
  207. %attr(0755,root,root) /%{_lib}/*.so.%{version}
  208. ## to build compat32 for x86_64 architecture support
  209. %if %{build_compat32}
  210. %files -n compat32-%{name}
  211. %defattr(-,root,root)
  212. %attr(0755,root,root) /%{_lib}/*.so.%{version}
  213. %endif
  214. %post -p /sbin/ldconfig
  215. %postun -p /sbin/ldconfig
  216. %if %{build_compat32}
  217. %post -n compat32-%{name} -p /sbin/ldconfig
  218. %postun -n compat32-%{name} -p /sbin/ldconfig
  219. %endif
  220. %changelog
  221. * Thu Oct 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.9.7m-1vl5
  222. - applied new versioning policy
  223. * Sun Dec 23 2007 NAKAMURA Kenta <kenta@vinelinux.org> 0.9.7m-0vl4
  224. - dropped Patch1: openssl-0.9.7i.Configure-compat32.patch
  225. - removed %%if !%%{build_compat32} case condition
  226. * Fri Sep 28 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.7m-0vl3
  227. - add security patch in advance for CVE-2007-5135
  228. http://www.securityfocus.com/archive/1/archive/1/480855/100/0/threaded
  229. http://marc.info/?l=openssl-cvs&m=119020417919619&w=2
  230. * Fri Aug 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.7m-0vl2
  231. - added security patch for CVE-2007-3108
  232. (http://openssl.org/news/patch-CVE-2007-3108.txt)
  233. * Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7m-0vl1
  234. - new upstream release
  235. - build as compat library pacakge
  236. * Sat Dec 24 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl2
  237. - update (fix) openssl.pc <BTS:437>
  238. * Fri Sep 29 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl1
  239. - new upstream release (with security fix)
  240. * Mon Sep 11 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7k-0vl1
  241. - new upstream release
  242. - add patch2 to use RPM_OPT macro
  243. * Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl3
  244. - moved macros _lib to /usr/lib/rpm/rpmrc or macros files
  245. * Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl2
  246. - added compat32-* packages for x86_64 architecture support
  247. - added openssl-0.9.7i.Configure-compat32.patch
  248. - changed '/lib' to '/%{_lib}'
  249. * Mon Oct 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7i-0vl1
  250. - new upstream release
  251. * Mon Jan 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7d-0vl4
  252. - rebuild on VineSeed
  253. * Sun Jan 09 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.9.7d-0vl3.1
  254. - added a security patch from Gentoo.
  255. - Patch1: openssl-0.9.7c-tempfile.patch
  256. * Sun Mar 28 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.7d-0vl3
  257. - sslarch for ppc was missing... added.
  258. * Fri Mar 26 2004 Tomoya TAKA <taka@vinelinux.org> 0.9.7d-0vl2
  259. - use sslarch=linux-alpha-gcc instead of alpha-gcc
  260. * Mon Mar 22 2004 Satoshi MACHINO <machino@vinelinux.org> 0.9.7d-0vl1
  261. - new upstream version
  262. - clean up of spec file
  263. -- removed old patches
  264. * Sat Mar 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6m-0vl1
  265. - new upstream release
  266. - SECURITY fix.
  267. - http://www.openssl.org/news/secadv_20040317.txt
  268. * Wed Oct 1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6k-0vl1
  269. - new upstream release
  270. - [Security fix]
  271. - Vulnerabilities in ASN.1 parsing
  272. http://www.openssl.org/news/secadv_20030930.txt
  273. - see %{_docdir}/%{name}-%{version}/CHANGES for other changes
  274. * Wed Jun 04 2003 HOTTA Michihide <hotta@net-newbie.com> 0.9.6j-0vl2
  275. - add openssl.pc for pkgconfig
  276. * Fri Mar 11 2003 Satoshi MACHINO <machino@vinelinux.org> 0.9.6j-0vl1
  277. - New upstream version
  278. - dropped patch10, 11
  279. -- merged upstream version
  280. * Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl1
  281. - rebuild for VineSeed
  282. * Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26.1
  283. - [Security Fix]
  284. - Timing-based attacks on RSA keys
  285. http://www.openssl.org/news/secadv_20030317.txt
  286. - Klima-Pokorny0Rosa attack on RSA in SSL/TLS
  287. http://www.openssl.org/news/secadv_20030317.txt
  288. * Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26
  289. - new upstream release 0.9.6i
  290. - [Security Fix]
  291. - build for Vine Linux 2.6 errata
  292. * Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6h-0vl1
  293. - new upstream release 0.9.6h
  294. * Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6g-0vl1
  295. - new upstream release 0.9.6g
  296. * Mon Oct 28 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl6
  297. - SECURITY: CAN-2002-0659 fixed
  298. - added Patch101 from RedHat 7.2 updates 0.9.6b-28
  299. * Fri Aug 02 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-28
  300. - update asn patch to fix accidental reversal of a logic check
  301. * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-27
  302. - update asn patch to reduce chance that compiler optimization will remove
  303. one of the added tests
  304. * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-26
  305. - rebuild
  306. * Tue Jul 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-25
  307. - add patch to fix ASN.1 vulnerabilities
  308. * Wed Jul 31 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl5
  309. - rename spec file name
  310. - SECURITY: CA-2002-23 fixed
  311. - added Patch100 from RedHat 7.2 updates 0.9.6b-24
  312. * Thu Jul 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-24
  313. - add backport of Ben Laurie's patches for OpenSSL 0.9.6d
  314. * Mon Sep 10 2001 Satoshi MACHINO <machino@vinelinux.org> 0.9.6b-1vl4
  315. - added ${PATH} in LD_LIBRARY_PATH
  316. - added install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir} in %install
  317. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl3
  318. - remove --no-<cipher>
  319. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl2
  320. - add Patch10 for mipsel shared ( Configure )
  321. * Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl1
  322. - build for Vine Linux
  323. - use openssl-engine-0.9.6b.tar.gz
  324. * Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
  325. - update to 0.9.6b
  326. * Thu Jul 5 2001 Nalin Dahyabhai <nalin@redhat.com>
  327. - move .so symlinks back to %%{_libdir}
  328. * Tue Jul 3 2001 Nalin Dahyabhai <nalin@redhat.com>
  329. - move shared libraries to /lib (#38410)
  330. * Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
  331. - switch to engine code base
  332. * Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
  333. - add a script for creating dummy certificates
  334. - move man pages from %%{_mandir}/man?/foo.?ssl to %%{_mandir}/man?ssl/foo.?
  335. * Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  336. - add s390x support
  337. * Fri Jun 1 2001 Nalin Dahyabhai <nalin@redhat.com>
  338. - change two memcpy() calls to memmove()
  339. - don't define L_ENDIAN on alpha
  340. * Tue May 15 2001 Nalin Dahyabhai <nalin@redhat.com>
  341. - make subpackages depend on the main package
  342. * Tue May 1 2001 Nalin Dahyabhai <nalin@redhat.com>
  343. - adjust the hobble script to not disturb symlinks in include/ (fix from
  344. Joe Orton)
  345. * Fri Apr 26 2001 Nalin Dahyabhai <nalin@redhat.com>
  346. - drop the m2crypo patch we weren't using
  347. * Tue Apr 24 2001 Nalin Dahyabhai <nalin@redhat.com>
  348. - configure using "shared" as well
  349. * Sun Apr 8 2001 Nalin Dahyabhai <nalin@redhat.com>
  350. - update to 0.9.6a
  351. - use the build-shared target to build shared libraries
  352. - bump the soversion to 2 because we're no longer compatible with
  353. our 0.9.5a packages or our 0.9.6 packages
  354. - drop the patch for making rsatest a no-op when rsa null support is used
  355. - put all man pages into <section>ssl instead of <section>
  356. - break the m2crypto modules into a separate package
  357. * Tue Mar 13 2001 Nalin Dahyabhai <nalin@redhat.com>
  358. - use BN_LLONG on s390
  359. * Mon Mar 12 2001 Nalin Dahyabhai <nalin@redhat.com>
  360. - fix the s390 changes for 0.9.6 (isn't supposed to be marked as 64-bit)
  361. * Sat Mar 3 2001 Nalin Dahyabhai <nalin@redhat.com>
  362. - move c_rehash to the perl subpackage, because it's a perl script now
  363. * Fri Mar 2 2001 Nalin Dahyabhai <nalin@redhat.com>
  364. - update to 0.9.6
  365. - enable MD2
  366. - use the libcrypto.so and libssl.so targets to build shared libs with
  367. - bump the soversion to 1 because we're no longer compatible with any of
  368. the various 0.9.5a packages circulating around, which provide lib*.so.0
  369. * Wed Feb 28 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  370. - change hobble-openssl for disabling MD2 again
  371. * Tue Feb 27 2001 Nalin Dahyabhai <nalin@redhat.com>
  372. - re-disable MD2 -- the EVP_MD_CTX structure would grow from 100 to 152
  373. bytes or so, causing EVP_DigestInit() to zero out stack variables in
  374. apps built against a version of the library without it
  375. * Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
  376. - disable some inline assembly, which on x86 is Pentium-specific
  377. - re-enable MD2 (see http://www.ietf.org/ietf/IPR/RSA-MD-all)
  378. * Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  379. - fix s390 patch
  380. * Fri Dec 8 2000 Than Ngo <than@redhat.com>
  381. - added support s390
  382. * Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
  383. - remove -Wa,* and -m* compiler flags from the default Configure file (#20656)
  384. - add the CA.pl man page to the perl subpackage
  385. * Thu Nov 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  386. - always build with -mcpu=ev5 on alpha
  387. * Tue Oct 31 2000 Nalin Dahyabhai <nalin@redhat.com>
  388. - add a symlink from cert.pem to ca-bundle.crt
  389. * Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
  390. - add a ca-bundle file for packages like Samba to reference for CA certificates
  391. * Tue Oct 24 2000 Nalin Dahyabhai <nalin@redhat.com>
  392. - remove libcrypto's crypt(), which doesn't handle md5crypt (#19295)
  393. * Mon Oct 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  394. - add unzip as a buildprereq (#17662)
  395. - update m2crypto to 0.05-snap4
  396. * Tue Sep 26 2000 Bill Nottingham <notting@redhat.com>
  397. - fix some issues in building when it's not installed
  398. * Wed Sep 6 2000 Nalin Dahyabhai <nalin@redhat.com>
  399. - make sure the headers we include are the ones we built with (aaaaarrgh!)
  400. * Fri Sep 1 2000 Nalin Dahyabhai <nalin@redhat.com>
  401. - add Richard Henderson's patch for BN on ia64
  402. - clean up the changelog
  403. * Tue Aug 29 2000 Nalin Dahyabhai <nalin@redhat.com>
  404. - fix the building of python modules without openssl-devel already installed
  405. * Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
  406. - byte-compile python extensions without the build-root
  407. - adjust the makefile to not remove temporary files (like .key files when
  408. building .csr files) by marking them as .PRECIOUS
  409. * Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
  410. - break out python extensions into a subpackage
  411. * Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
  412. - tweak the makefile some more
  413. * Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
  414. - disable MD2 support
  415. * Thu Jul 6 2000 Nalin Dahyabhai <nalin@redhat.com>
  416. - disable MDC2 support
  417. * Sun Jul 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  418. - tweak the disabling of RC5, IDEA support
  419. - tweak the makefile
  420. * Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
  421. - strip binaries and libraries
  422. - rework certificate makefile to have the right parts for Apache
  423. * Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
  424. - use %%{_perl} instead of /usr/bin/perl
  425. - disable alpha until it passes its own test suite
  426. * Fri Jun 9 2000 Nalin Dahyabhai <nalin@redhat.com>
  427. - move the passwd.1 man page out of the passwd package's way
  428. * Fri Jun 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  429. - update to 0.9.5a, modified for U.S.
  430. - add perl as a build-time requirement
  431. - move certificate makefile to another package
  432. - disable RC5, IDEA, RSA support
  433. - remove optimizations for now
  434. * Wed Mar 1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  435. - Bero told me to move the Makefile into this package
  436. * Wed Mar 1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  437. - add lib*.so symlinks to link dynamically against shared libs
  438. * Tue Feb 29 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  439. - update to 0.9.5
  440. - run ldconfig directly in post/postun
  441. - add FAQ
  442. * Sat Dec 18 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
  443. - Fix build on non-x86 platforms
  444. * Fri Nov 12 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
  445. - move /usr/share/ssl/* from -devel to main package
  446. * Tue Oct 26 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
  447. - inital packaging
  448. - changes from base:
  449. - Move /usr/local/ssl to /usr/share/ssl for FHS compliance
  450. - handle RPM_OPT_FLAGS