ntfs-3g-vl.spec 8.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279
  1. %bcond_with externalfuse
  2. Summary: Linux NTFS userspace driver
  3. Summary(ja): Linux NTFS ユーザ空間ドライバ
  4. Name: ntfs-3g
  5. Version: 2015.3.14
  6. Release: 3%{?_dist_release}
  7. License: GPLv2+
  8. Group: System Environment/Base
  9. URL: http://www.ntfs-3g.org/
  10. Source0: http://tuxera.com/opensource/%{name}_ntfsprogs-%{version}.tgz
  11. Source1: 20-ntfs-config-write-policy.fdi
  12. Patch0: ntfs-3g_ntfsprogs-2011.10.9-RC-ntfsck-unsupported-return-0.patch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  14. BuildRequires: libtool
  15. BuildRequires: libattr-devel
  16. BuildRequires: libconfig-devel
  17. BuildRequires: libgcrypt-devel
  18. BuildRequires: gnutls-devel
  19. BuildRequires: libuuid-devel
  20. %if %{with externalfuse}
  21. BuildRequires: fuse-devel
  22. Requires: fuse
  23. %endif
  24. %description
  25. NTFS-3G is a stable, open source, GPL licensed, POSIX, read/write NTFS
  26. driver for Linux and many other operating systems. It provides safe
  27. handling of the Windows XP, Windows Server 2003, Windows 2000, Windows
  28. Vista, Windows Server 2008 and Windows 7 NTFS file systems. NTFS-3G can
  29. create, remove, rename, move files, directories, hard links, and streams;
  30. it can read and write normal and transparently compressed files, including
  31. streams and sparse files; it can handle special files like symbolic links,
  32. devices, and FIFOs, ACL, extended attributes; moreover it provides full
  33. file access right and ownership support.
  34. %package devel
  35. Summary: Development files and libraries for ntfs-3g
  36. Summary(ja): ntfs-3g の開発ファイルとライブラリ
  37. Group: Development/Libraries
  38. Requires: %{name} = %{version}-%{release}
  39. Requires: pkgconfig
  40. Provides: ntfsprogs-devel = %{version}-%{release}
  41. Obsoletes: ntfsprogs-devel < 2.0.0-3
  42. %description devel
  43. Headers and libraries for developing applications that use ntfs-3g
  44. functionality.
  45. %package -n ntfsprogs
  46. Summary: NTFS filesystem libraries and utilities
  47. Summary(ja): NTFS ファイルシステム用ライブラリおよびユーティリティ
  48. Group: System Environment/Base
  49. Provides: ntfsprogs-gnomevfs = %{version}-%{release}
  50. Obsoletes: ntfsprogs-gnomevfs < 2.0.0-3
  51. %description -n ntfsprogs
  52. The ntfsprogs package currently consists of a library and utilities
  53. such as mkntfs, ntfscat, ntfsls, ntfsresize, and ntfsundelete
  54. (for a full list of included utilities see man 8 ntfsprogs after
  55. installation).
  56. %prep
  57. %setup -q -n %{name}_ntfsprogs-%{version}
  58. %patch0 -p1 -b .unsupported
  59. %build
  60. %configure --disable-static \
  61. --disable-ldconfig \
  62. %{?with_ externalfuse:--with-fuse=external} \
  63. --exec-prefix=/ \
  64. --bindir=/bin \
  65. --sbindir=/sbin \
  66. --libdir=/%{_lib} \
  67. --enable-crypto \
  68. --enable-extras \
  69. --enable-quarantined
  70. make %{?_smp_mflags} LIBTOOL=%{_bindir}/libtool
  71. %install
  72. rm -rf $RPM_BUILD_ROOT
  73. make DESTDIR=$RPM_BUILD_ROOT LIBTOOL=%{_bindir}/libtool install
  74. rm -f $RPM_BUILD_ROOT%{_libdir}/*.{la,a}
  75. rm -f $RPM_BUILD_ROOT/%{_lib}/libntfs-3g.{la,a}
  76. mkdir -p $RPM_BUILD_ROOT/sbin
  77. # make the symlink an actual copy to avoid confusion
  78. rm -rf $RPM_BUILD_ROOT/sbin/mount.ntfs-3g
  79. cp -a $RPM_BUILD_ROOT/bin/ntfs-3g $RPM_BUILD_ROOT/sbin/mount.ntfs-3g
  80. # make compatibility symlinks
  81. ln -s ntfs-3g $RPM_BUILD_ROOT/bin/ntfsmount
  82. ln -s mount.ntfs-3g $RPM_BUILD_ROOT/sbin/mount.ntfs-fuse
  83. ln -s mount.ntfs-3g $RPM_BUILD_ROOT/sbin/mount.ntfs
  84. ln -s ../bin/ntfsck $RPM_BUILD_ROOT/sbin/fsck.ntfs
  85. mkdir -p $RPM_BUILD_ROOT%{_bindir}
  86. ln -s /bin/ntfs-3g $RPM_BUILD_ROOT%{_bindir}/ntfs-3g
  87. ln -s /bin/ntfsmount $RPM_BUILD_ROOT%{_bindir}/ntfsmount
  88. # Put the .pc file in the right place.
  89. mkdir -p $RPM_BUILD_ROOT%{_libdir}/pkgconfig/
  90. mv $RPM_BUILD_ROOT/%{_lib}/pkgconfig/libntfs-3g.pc $RPM_BUILD_ROOT%{_libdir}/pkgconfig/
  91. # We get this on our own, thanks.
  92. rm -rf $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}/README
  93. %clean
  94. rm -rf $RPM_BUILD_ROOT
  95. %post -p /sbin/ldconfig
  96. %postun -p /sbin/ldconfig
  97. %files
  98. %defattr(-,root,root,-)
  99. %doc AUTHORS ChangeLog COPYING CREDITS NEWS README
  100. /sbin/mount.ntfs
  101. %attr(4754,root,root) /sbin/mount.ntfs-3g
  102. /sbin/mount.ntfs-fuse
  103. /sbin/mount.lowntfs-3g
  104. /bin/lowntfs-3g
  105. /bin/ntfs-3g
  106. /bin/ntfs-3g.probe
  107. /bin/ntfs-3g.secaudit
  108. /bin/ntfs-3g.usermap
  109. /bin/ntfsmount
  110. %{_bindir}/ntfs-3g
  111. %{_bindir}/ntfsmount
  112. /%{_lib}/libntfs-3g.so.*
  113. %{_mandir}/man8/mount.lowntfs-3g.*
  114. %{_mandir}/man8/mount.ntfs-3g.*
  115. %{_mandir}/man8/ntfs-3g*
  116. %files devel
  117. %defattr(-,root,root,-)
  118. %{_includedir}/ntfs-3g/
  119. /%{_lib}/libntfs-3g.so
  120. %{_libdir}/pkgconfig/*.pc
  121. %files -n ntfsprogs
  122. %doc AUTHORS COPYING CREDITS ChangeLog NEWS README
  123. /bin/ntfscat
  124. /bin/ntfscluster
  125. /bin/ntfscmp
  126. /bin/ntfsfix
  127. /bin/ntfsinfo
  128. /bin/ntfsls
  129. # extras
  130. /bin/ntfsck
  131. /bin/ntfsdecrypt
  132. /bin/ntfsdump_logfile
  133. /bin/ntfsfallocate
  134. /bin/ntfsmftalloc
  135. /bin/ntfsmove
  136. /bin/ntfstruncate
  137. /bin/ntfswipe
  138. /sbin/fsck.ntfs
  139. /sbin/mkfs.ntfs
  140. /sbin/mkntfs
  141. /sbin/ntfsclone
  142. /sbin/ntfscp
  143. /sbin/ntfslabel
  144. /sbin/ntfsresize
  145. /sbin/ntfsundelete
  146. %{_mandir}/man8/mkntfs.8*
  147. %{_mandir}/man8/mkfs.ntfs.8*
  148. %{_mandir}/man8/ntfs[^m][^o]*.8*
  149. %exclude %{_mandir}/man8/ntfs-3g*
  150. %changelog
  151. * Wed Dec 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2015.3.14-3
  152. - rebuilt with gnutls-3.4.x.
  153. * Fri May 8 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2015.3.14-2
  154. - reverted file location <Vine Linux:2914>
  155. * Fri Apr 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2015.3.14-1
  156. - new upstream release
  157. - dropt hal files, since hal is very old
  158. * Sun Mar 02 2014 NAKAMURA Kenta <kenta@vinelinux.org> 2014.2.15-1
  159. - new upstream release
  160. * Wed Feb 19 2014 NAKAMURA Kenta <kenta@vinelinux.org> 2013.1.13-2
  161. - rebuilt with gnutls-3.2 and libgcrypt-1.6
  162. * Tue Feb 19 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2013.1.13-1
  163. - new upstream release
  164. * Mon Nov 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2012.1.15-1
  165. - new upstream release
  166. - merge ntfsprogs
  167. - add Obsoletes and Provides ntfsprogs*
  168. - add BR: for ntfsprogs
  169. * Sat Feb 26 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2011.1.15-1
  170. - new upstream release
  171. - fix %%files (add lowntfs-3g)
  172. * Mon Jun 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2009.4.4-1
  173. - new upstream release
  174. - use internal fuse-lite, remove BR: fuse-devel and R: fuse
  175. - move binaries to /bin
  176. - move libraries to /%%{_lib}
  177. - add fdi file to enable hal automounting
  178. * Sun Jan 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2009.1.1-1
  179. - new upstream release
  180. * Sun Aug 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2812-1
  181. - new upstream release
  182. * Fri Jul 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2712-1
  183. - new upstream release
  184. * Thu Apr 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2412-1
  185. - new upstream release
  186. * Tue Jun 05 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.516-0vl1
  187. - initial build for Vine Linux
  188. * Tue May 15 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.516-1
  189. - bump to 1.516
  190. - fix bugzilla 232031
  191. * Sun Apr 15 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.417-1
  192. - bump to 1.417
  193. * Sun Apr 15 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.416-1
  194. - bump to 1.416
  195. - drop patch0, upstreamed
  196. * Wed Apr 4 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.328-2
  197. - allow non-root users to mount/umount ntfs volumes (Laszlo Dvornik)
  198. * Sat Mar 31 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.328-1
  199. - bump to 1.328
  200. - drop patch, use --disable-ldconfig instead
  201. * Wed Feb 21 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.0-1
  202. - 1.0 release!
  203. * Fri Jan 19 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:0-0.9.20070118
  204. - symlink to mount.ntfs
  205. * Wed Jan 17 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:0-0.8.20070118
  206. - bump to 20070118
  207. * Wed Jan 17 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:0-0.7.20070116
  208. - bump to latest version for all active dists
  209. * Wed Jan 3 2007 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.6.20070102
  210. - bump to latest version (note that upstream fixed their date mistake)
  211. * Wed Nov 1 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.5.20070920
  212. - add an obsoletes for ntfsprogs-fuse
  213. - make some convenience symlinks
  214. * Wed Oct 25 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.4.20070920
  215. - add some extra Provides
  216. * Mon Oct 16 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.3.20070920
  217. - add explicit Requires on fuse
  218. * Mon Oct 16 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.2.20070920
  219. - fixed versioning (bumped epoch, since it now shows as older)
  220. - change sbin symlink to actual copy to be safe
  221. * Sun Oct 15 2006 Tom "spot" Callaway <tcallawa@redhat.com> 0.1.20070920-1
  222. - Initial package for Fedora Extras