nghttp2-vl.spec 6.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206
  1. %bcond_with test
  2. Summary: Experimental HTTP/2 client, server and proxy
  3. Summary(ja): HTTP/2クライアント・サーバ・プロキシの実験的実装
  4. Name: nghttp2
  5. Version: 1.11.1
  6. Release: 2%{?_dist_release}
  7. License: MIT
  8. Group: Applications/Internet
  9. URL: https://nghttp2.org/
  10. Source0: https://github.com/tatsuhiro-t/nghttp2/releases/download/v%{version}/nghttp2-%{version}.tar.xz
  11. %if %{with test}
  12. BuildRequires: CUnit-devel
  13. %endif
  14. BuildRequires: jemalloc-devel
  15. BuildRequires: libboost-devel
  16. BuildRequires: libboost-thread
  17. BuildRequires: libev-devel
  18. BuildRequires: openssl-devel
  19. BuildRequires: zlib-devel
  20. Requires: libnghttp2 = %{version}-%{release}
  21. %description
  22. This package contains the HTTP/2 client, server and proxy programs.
  23. %description -l ja
  24. This package contains the HTTP/2 client, server and proxy programs.
  25.  このパッケージにはHTTP/2クライアント・サーバ。プロキシのプログラム
  26. が含まれています。
  27. %package -n libnghttp2
  28. Summary: A library implementing the HTTP/2 protocol
  29. Summary(ja): HTTP/2ライブラリ
  30. Group: Development/Libraries
  31. %description -n libnghttp2
  32. libnghttp2 is a library implementing the Hypertext Transfer Protocol
  33. version 2 (HTTP/2) protocol in C.
  34. %description -l ja -n libnghttp2
  35.  libnghttp2はHypertext Transfer Protocol version 2 (HTTP/2)をC言語で
  36. 実装したライブラリです。
  37. %package -n libnghttp2-devel
  38. Summary: Files needed for building applications with libnghttp2
  39. Summary(ja): libnghttp2を利用するアプリケーションをビルドするために必要なファイル
  40. Group: Development/Libraries
  41. Requires: libnghttp2%{?_isa} = %{version}-%{release}
  42. Requires: pkgconfig
  43. %description -n libnghttp2-devel
  44. The libnghttp2-devel package includes libraries and header files needed
  45. for building applications with libnghttp2.
  46. %description -l ja -n libnghttp2-devel
  47.  libnghttp2-develパッケージにはlibnghttp2を利用するアプリケーション
  48. をビルドするために必要となるライブラリ・ヘッダファイルが含まれていま
  49. す。
  50. %prep
  51. %setup -q
  52. %build
  53. LIBEV_CFLAGS=`pkg-config --cflags libev`
  54. CFLAGS="%{optflags} -fPIC $LIBEV_CFLAGS" \
  55. CXXFLAGS="%{optflags} -fPIC $LIBEV_CFLAGS" \
  56. %configure \
  57. --enable-app \
  58. --enable-asio-lib \
  59. --with-pic \
  60. --with-boost \
  61. --with-boost-asio \
  62. --with-boost-system \
  63. --with-boost-thread \
  64. --disable-python-bindings \
  65. --disable-static \
  66. --without-libxml2 \
  67. --without-spdylay
  68. # avoid using rpath
  69. sed -i libtool \
  70. -e 's/^runpath_var=.*/runpath_var=/' \
  71. -e 's/^hardcode_libdir_flag_spec=".*"$/hardcode_libdir_flag_spec=""/'
  72. make %{?_smp_mflags} V=1
  73. %install
  74. %make_install
  75. # not needed on Fedora/RHEL
  76. rm -f $RPM_BUILD_ROOT%{_libdir}/libnghttp2*.la
  77. # will be installed via %%doc
  78. rm -f "$RPM_BUILD_ROOT%{_datadir}/doc/nghttp2/README.rst"
  79. %post -n libnghttp2 -p /sbin/ldconfig
  80. %postun -n libnghttp2 -p /sbin/ldconfig
  81. %check
  82. %if %{with test}
  83. # test the just built library instead of the system one, without using rpath
  84. export "LD_LIBRARY_PATH=$RPM_BUILD_ROOT%{_libdir}:$LD_LIBRARY_PATH"
  85. make %{?_smp_mflags} check
  86. %endif
  87. %files
  88. %{_bindir}/h2load
  89. %{_bindir}/nghttp
  90. %{_bindir}/nghttpd
  91. %{_bindir}/nghttpx
  92. %{_datadir}/nghttp2
  93. %{_mandir}/man1/h2load.1*
  94. %{_mandir}/man1/nghttp.1*
  95. %{_mandir}/man1/nghttpd.1*
  96. %{_mandir}/man1/nghttpx.1*
  97. %files -n libnghttp2
  98. %{_libdir}/libnghttp2*.so.*
  99. %{!?_licensedir:%global license %%doc}
  100. %license COPYING
  101. %files -n libnghttp2-devel
  102. %{_includedir}/nghttp2
  103. %{_libdir}/pkgconfig/libnghttp2*.pc
  104. %{_libdir}/libnghttp2*.so
  105. %doc README.rst
  106. %changelog
  107. * Tue Jun 7 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.11.1-2
  108. - initial build for Vne Linux.
  109. * Sun May 29 2016 Kamil Dudka <kdudka@redhat.com> 1.11.1-1
  110. - update to the latest upstream release
  111. * Thu May 26 2016 Kamil Dudka <kdudka@redhat.com> 1.11.0-1
  112. - update to the latest upstream release
  113. * Mon Apr 25 2016 Kamil Dudka <kdudka@redhat.com> 1.10.0-1
  114. - update to the latest upstream release
  115. * Sun Apr 03 2016 Kamil Dudka <kdudka@redhat.com> 1.9.2-1
  116. - update to the latest upstream release
  117. * Tue Mar 29 2016 Kamil Dudka <kdudka@redhat.com> 1.9.1-1
  118. - update to the latest upstream release
  119. * Thu Feb 25 2016 Kamil Dudka <kdudka@redhat.com> 1.8.0-1
  120. - update to the latest upstream release
  121. * Thu Feb 11 2016 Kamil Dudka <kdudka@redhat.com> 1.7.1-1
  122. - update to the latest upstream release (fixes CVE-2016-1544)
  123. * Fri Feb 05 2016 Kamil Dudka <kdudka@redhat.com> 1.7.0-3
  124. - make the package compile with gcc-6
  125. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.0-2
  126. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  127. * Mon Jan 25 2016 Kamil Dudka <kdudka@redhat.com> 1.7.0-1
  128. - update to the latest upstream release
  129. * Fri Dec 25 2015 Kamil Dudka <kdudka@redhat.com> 1.6.0-1
  130. - update to the latest upstream release (fixes CVE-2015-8659)
  131. * Thu Nov 26 2015 Kamil Dudka <kdudka@redhat.com> 1.5.0-1
  132. - update to the latest upstream release
  133. * Mon Oct 26 2015 Kamil Dudka <kdudka@redhat.com> 1.4.0-1
  134. - update to the latest upstream release
  135. * Thu Sep 24 2015 Kamil Dudka <kdudka@redhat.com> 1.3.4-1
  136. - update to the latest upstream release
  137. * Wed Sep 23 2015 Kamil Dudka <kdudka@redhat.com> 1.3.3-1
  138. - update to the latest upstream release
  139. * Wed Sep 16 2015 Kamil Dudka <kdudka@redhat.com> 1.3.2-1
  140. - update to the latest upstream release
  141. * Mon Sep 14 2015 Kamil Dudka <kdudka@redhat.com> 1.3.1-1
  142. - update to the latest upstream release
  143. * Mon Aug 31 2015 Kamil Dudka <kdudka@redhat.com> 1.3.0-1
  144. - update to the latest upstream release
  145. * Mon Aug 17 2015 Kamil Dudka <kdudka@redhat.com> 1.2.1-1
  146. - update to the latest upstream release
  147. * Sun Aug 09 2015 Kamil Dudka <kdudka@redhat.com> 1.2.0-1
  148. - update to the latest upstream release
  149. * Wed Jul 15 2015 Kamil Dudka <kdudka@redhat.com> 1.1.1-1
  150. - update to the latest upstream release
  151. * Tue Jun 30 2015 Kamil Dudka <kdudka@redhat.com> 1.0.5-1
  152. - packaged for Fedora (#1237247)