mozplugger-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310
  1. %define _mozillapath %{_libdir}/mozilla/plugins
  2. %define vine31 0
  3. Summary: A generic mozilla plug-in
  4. Summary: 汎用 mozilla プラグイン
  5. Name: mozplugger
  6. Version: 1.7.3
  7. Release: 0vl2
  8. License: GPL
  9. Group: Applications/Internet
  10. URL: http://mozplugger.mozdev.org
  11. Source0: http://mozplugger.mozdev.org/files/mozplugger-%{version}.tar.gz
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: XOrg-devel
  14. Requires: sox
  15. Requires: ImageMagick
  16. Requires: gqview
  17. Requires: perl
  18. #Requires: TiMidity++
  19. %if !%{vine31}
  20. Requires: totem
  21. %endif
  22. Obsoletes: plugger
  23. Provides: plugger
  24. %description
  25. MozPlugger is a generic Mozilla plug-in that allows the use of standard Linux
  26. programs as plug-ins for media types on the Internet.
  27. %prep
  28. %setup -q -n %{name}-%{version}
  29. %build
  30. make RPM_OPT_FLAGS="$RPM_OPT_FLAGS" XLIBDIR="/usr/X11R6/%{_lib}" linux
  31. %install
  32. rm -rf $RPM_BUILD_ROOT
  33. mkdir -p $RPM_BUILD_ROOT%{_mozillapath}/plugins \
  34. $RPM_BUILD_ROOT%{_libdir}/netscape/plugins \
  35. $RPM_BUILD_ROOT%{_bindir} \
  36. $RPM_BUILD_ROOT%{_sysconfdir} \
  37. $RPM_BUILD_ROOT%{_mandir}/man7
  38. install -m 755 mozplugger-helper $RPM_BUILD_ROOT%{_bindir}
  39. install -m 755 mozplugger-controller $RPM_BUILD_ROOT%{_bindir}
  40. install -m 755 mozplugger.so $RPM_BUILD_ROOT%{_mozillapath}
  41. install -m 644 mozpluggerrc $RPM_BUILD_ROOT%{_sysconfdir}/mozpluggerrc
  42. bzip2 -d mozplugger.7.bz2
  43. install -m 644 mozplugger.7 $RPM_BUILD_ROOT%{_mandir}/man7
  44. mkdir -p $RPM_BUILD_ROOT%{_mozillapath}
  45. ln -s %{_mozillapath}/mozplugger.so \
  46. $RPM_BUILD_ROOT%{_libdir}/netscape/plugins/mozplugger.so
  47. %clean
  48. rm -rf $RPM_BUILD_ROOT
  49. %triggerin -- acroread-nppdf
  50. [ "$2" -ge 1 ] || exit 0
  51. if [ -r %{_sysconfdir}/mozpluggerrc ]; then
  52. perl -pi -e 's@^application/pdf:@\#application/pdf:@g' %{_sysconfdir}/mozpluggerrc
  53. perl -pi -e 's@^application/x-pdf:@\#application/x-pdf:@g' %{_sysconfdir}/mozpluggerrc
  54. touch %{_mozillapath}/mozplugger.so
  55. fi
  56. %triggerun -- acroread-nppdf
  57. [ "$2" = "0" ] || exit 0
  58. if [ -r %{_sysconfdir}/mozpluggerrc ]; then
  59. perl -pi -e 's@^\#application/pdf:@application/pdf:@g' %{_sysconfdir}/mozpluggerrc
  60. perl -pi -e 's@^\#application/x-pdf:@application/x-pdf:@g' %{_sysconfdir}/mozpluggerrc
  61. touch %{_mozillapath}/mozplugger.so
  62. fi
  63. %triggerpostun -- acroread-nppdf
  64. [ "$2" = "0" ] || exit 0
  65. if [ -r %{_sysconfdir}/mozpluggerrc ]; then
  66. perl -pi -e 's@^\#application/pdf:@application/pdf:@g' %{_sysconfdir}/mozpluggerrc
  67. perl -pi -e 's@^\#application/x-pdf:@application/x-pdf:@g' %{_sysconfdir}/mozpluggerrc
  68. touch %{_mozillapath}/mozplugger.so
  69. fi
  70. %triggerin -- RealPlayer-rpnp
  71. [ "$2" -ge 1 ] || exit 0
  72. if [ -r %{_sysconfdir}/mozpluggerrc ]; then
  73. perl -pi -e 's@^audio/x-pn-realaudio-plugin:@\#audio/x-pn-realaudio-plugin:@g' %{_sysconfdir}/mozpluggerrc
  74. touch %{_mozillapath}/mozplugger.so
  75. fi
  76. %triggerun -- RealPlayer-rpnp
  77. [ "$2" = "0" ] || exit 0
  78. if [ -r %{_sysconfdir}/mozpluggerrc ]; then
  79. perl -pi -e 's@^\#audio/x-pn-realaudio-plugin@audio/x-pn-realaudio-plugin:@g' %{_sysconfdir}/mozpluggerrc
  80. touch %{_mozillapath}/mozplugger.so
  81. fi
  82. %triggerpostun -- RealPlayer-rpnp
  83. [ "$2" = "0" ] || exit 0
  84. if [ -r %{_sysconfdir}/mozpluggerrc ]; then
  85. perl -pi -e 's@^\#audio/x-pn-realaudio-plugin:@audio/x-pn-realaudio-plugin:@g' %{_sysconfdir}/mozpluggerrc
  86. touch %{_mozillapath}/mozplugger.so
  87. fi
  88. %files
  89. %defattr(-,root,root)
  90. %doc README COPYING
  91. %config(noreplace) %{_sysconfdir}/mozpluggerrc
  92. %{_bindir}/mozplugger-helper
  93. %{_bindir}/mozplugger-controller
  94. %{_libdir}/netscape/plugins/mozplugger.so
  95. %{_mozillapath}/mozplugger.so
  96. %{_mandir}/man7/*
  97. %changelog
  98. * Sat Jul 22 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.7.3-0vl2
  99. - rebuilt for VineSeed (4.0)
  100. - changed Group to Applications/Internet
  101. * Fri May 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.3-0vl1.1
  102. - rebuild with %%vine31 defined
  103. * Fri May 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.3-0vl1.1
  104. - rebuild with %%vine31 defined
  105. * Thu May 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.3-0vl1
  106. - rebuild for Vine Linux 3.x
  107. * Thu May 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.3-0vl2
  108. - new upstream release
  109. * Wed May 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.2-0vl1
  110. - new upstream source
  111. * Sun Dec 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.2-0vl1
  112. - initial build for Vine Linux
  113. * Thu Dec 18 2003 Giuseppe Ghib<ghibo@mandrakesoft.com> 1.4.2-2mdk
  114. - Added Patch0: removed -cache 100 (cause hang with mplayer sometimes), moved
  115. ooffice before soffice.
  116. * Thu Dec 18 2003 Giuseppe Ghib<ghibo@mandrakesoft.com> 1.4.2-1mdk
  117. - Release 1.4.2.
  118. - Removed Patch0, merged upstream.
  119. - Removed Patch5 (no longer needed).
  120. - Removed Patch3 (lib64), merged upstream.
  121. - Removed Patch4 (amd64), merged upstream.
  122. * Mon Oct 20 2003 Gwenole Beauchesne <gbeauchesne@mandrakesoft.com> 1.3.0-8mdk
  123. - Really make sure it works on 64-bit platforms.
  124. * Mon Oct 13 2003 Gwenole Beauchesne <gbeauchesne@mandrakesoft.com> 1.3.0-7mdk
  125. - Really make it work on amd64.
  126. * Mon Oct 13 2003 Gwenole Beauchesne <gbeauchesne@mandrakesoft.com> 1.3.0-6mdk
  127. - lib64 fixes
  128. * Fri Sep 12 2003 Giuseppe Ghibメ<ghibo@mandrakesoft.com> 1.3.0-5mdk
  129. - Backported patch from 1.3.2 to fix a regression (so to find the
  130. the mozplugger helper in ~/.mozilla, ~/.netscape or ~/.opera).
  131. * Tue Sep 02 2003 Giuseppe Ghibメ<ghibo@mandrakesoft.com> 1.3.0-4mdk
  132. - Avoid "exits" in timidity entry, otherwise MIDI file is played only once.
  133. * Tue Sep 02 2003 Giuseppe Ghibメ<ghibo@mandrakesoft.com> 1.3.0-3mdk
  134. - Added Requires: TiMidiTy++.
  135. - added text/rtf mime type, and use ooffice also to handle it.
  136. * Sun Aug 31 2003 Giuseppe Ghibメ<ghibo@mandrakesoft.com> 1.3.0-2mdk
  137. - Backported patches from 1.3.1: removed dead code & fixed problems with
  138. timidity.
  139. - Use -vo xv,x11.
  140. - Used by default mozplugger for application/pdf mime-type. Enabled
  141. triggering for acroread-nppdf, and RealPlayer-rpnp package.
  142. * Mon Jul 07 2003 Giuseppe Ghib<ghibo@mandrakesoft.com> 1.3.0-1mdk
  143. - Release 1.3.0.
  144. - Removed Patch1.
  145. - Default plugin dir to %{_mozillapath}.
  146. * Mon Jun 16 2003 Giuseppe Ghib<ghibo@mandrakesoft.com> 1.2.1-2mdk
  147. - Fixed Patch0 (it wasn't totally merged in upstream!!).
  148. * Mon Jun 16 2003 Per リyvind Karlsen <peroyvind@sintrax.net> 1.2.1-1mdk
  149. - Release 1.2.1
  150. - quiet setup
  151. - dropped P0, merged upstream
  152. - regenerate P1
  153. * Mon May 12 2003 Giuseppe Ghib<ghibo@mandrakesoft.com> 1.1.3-1mdk
  154. - Release 1.1.3.
  155. * Tue Feb 18 2003 Giuseppe Ghib<ghibo@mandrakesoft.com> 1.1.1-3mdk
  156. - use noisy option for quicktime entry too.
  157. * Tue Feb 18 2003 Giuseppe Ghib<ghibo@mandrakesoft.com> 1.1.1-2mdk
  158. - Removed .bmp,.png from mozpluggerrc, because natively supported.
  159. - Use noisy option.
  160. * Mon Feb 17 2003 Giuseppe Ghib<ghibo@mandrakesoft.com> 1.1.1-1mdk
  161. - Release: 1.1.1.
  162. - Updated Patch0.
  163. - Removed Patch2, now merged into main.
  164. * Mon Feb 17 2003 Giuseppe Ghib<ghibo@mandrakesoft.com> 1.1-3mdk
  165. - Removed preload from ogg entry in mozpluggerrc.
  166. - Updated Patch2.
  167. - Set path of mozilla.
  168. * Sun Feb 16 2003 Giuseppe Ghib<ghibo@mandrakesoft.com> 1.1-2mdk
  169. - Updated URL.
  170. * Sun Feb 16 2003 Giuseppe Ghib<ghibo@mandrakesoft.com> 1.1-1mdk
  171. - Release 1.1.
  172. * Sat Feb 15 2003 Giuseppe Ghib<ghibo@mandrakesoft.com> 1.0-1mdk
  173. - Initial release ofn mozplugger 1.0.
  174. - Readatped patches of previous plugger.
  175. * Sat Dec 14 2002 Giuseppe Ghib<ghibo@mandrakesoft.com> 4.0-8mdk
  176. - added application/x-maplyer2 to /etc/pluggerrc for .wmv files
  177. - added mplayer in Requires:.
  178. * Sat Sep 07 2002 Giuseppe Ghib<ghibo@mandrakesoft.com> 4.0-7mdk
  179. - added audio/x-realaudio to /etc/pluggerrc.
  180. * Sat Aug 31 2002 Giuseppe Ghib<ghibo@mandrakesoft.com> 4.0-6mdk
  181. - added missed MPlayer in video/x-mpeg mime item of pluggerrc.
  182. * Fri Aug 30 2002 Giuseppe Ghib<ghibo@mandrakesoft.com> 4.0-5mdk
  183. - removed audio/x-pn-realaudio-plugin in pluggerrc (let the
  184. native rpnp.so plugin provide this if needed).
  185. - added in /etc/pluggerrc: application/vnd.rn-realmedia, application/smil,
  186. audio/vnd.rn-realaudio, audio/x-pn-realaudio, video/vnd.rn-realvideo
  187. to be used with realplay.
  188. * Wed Aug 28 2002 Giuseppe Ghib<ghibo@mandrakesoft.com> 4.0-4mdk
  189. - Removed streaming for mtvp (video/x-mpeg) and mpg123 (audio/x-mp3) because
  190. streaming doesn't work under mozilla.
  191. - Moved mtvp beyond xine and mplayer in video/x-mpeg.
  192. - Let application/pdf, application/x-pdf be used with the acroread plugin
  193. because it works better than "swallowing".
  194. - Added OpenOffice mime entries in pluggerrc (from RH).
  195. - Added Typo & Description patches from RH.
  196. - Added Patch4 for compiling with gcc 2.96 (but not yet enabled).
  197. - Updated mozilla path.
  198. * Sun Aug 04 2002 Giuseppe Ghib<ghibo@mandrakesoft.com> 4.0-3mdk
  199. - Fixed path (bug #33) for new mozilla.
  200. * Mon Jan 28 2002 Frederic Crozat <fcrozat@mandrakesoft.com> 4.0-2mdk
  201. - Remove dependency on netscape, since plugger can be user by mozilla
  202. and its derivate
  203. * Sat Jan 26 2002 Giuseppe Ghib<ghibo@mandrakesoft.com> 4.0-1mdk
  204. - updated to version 4.0.
  205. - updated pluggerrc file.
  206. - removed debug patch (Patch1).
  207. - updated Patch2.
  208. - added Patch3 (-mozilla), merged from RedHat.
  209. * Sat Aug 26 2001 Giuseppe Ghib<ghibo@mandrakesoft.com> 3.3-1mdk
  210. - updated to version 3.3.
  211. - new pluggerrc file.
  212. * Thu Jul 19 2001 Stefan van der Eijk <stefan@eijk.nu> 3.2-8mdk
  213. - BuildRequires: XFree86-devel
  214. - Copyright --> License
  215. * Wed Mar 14 2001 Giuseppe Ghib<ghibo@mandrakesoft.com> 3.2-7mdk
  216. - removed debug.
  217. * Fri Sep 29 2000 Giuseppe Ghib<ghibo@mandrakesoft.com> 3.2-6mdk
  218. - more macros.
  219. - removed xanim in Requires.
  220. * Tue Aug 29 2000 Giuseppe Ghib<ghibo@mandrakesoft.com> 3.2-5mdk
  221. - use of %%_mandir.
  222. * Sat Apr 22 2000 Giuseppe Ghib<ghibo@mandrakesoft.com> 3.2-4mdk
  223. - changed plugger debug file from /tmp/ndebug to $HOME/tmp/plugger-debug.
  224. so netscape doesn't crashes if /tmp/ndebug is already existing and
  225. not writeble (e.g. because owned by a different user).
  226. * Fri Apr 21 2000 Denis Havlik <denis@mandrakesoft.com> 3.2-3mdk
  227. - fixed "Requires:" (netscape-common -> netscape)
  228. * Wed Apr 19 2000 Denis Havlik <denis@mandrakesoft.com> 3.2-2mdk
  229. - spechelper, fixed release,
  230. - added "Obsoletes: npxanim"
  231. - added "Requires: netscape-common xanim mikmod mpg123 sox ImageMagick"
  232. * Wed Apr 19 2000 Giuseppe Ghib<ghibo@mandrakesoft.com> 3.2-1mdk
  233. - initial build based on RedHat 3.2-2 version
  234. - removed png from pluggerrc (netscape has native support for it).
  235. - fixed group.
  236. - added man page.
  237. * Thu Jan 27 2000 Tim Powers <timp@redhat.com>
  238. - fixed munged group, summary etc.
  239. * Tue Nov 23 1999 Tim Powers <timp@redhat.com>
  240. - updated to 3.2
  241. - quiet scripts
  242. - updated patch
  243. * Sat Aug 21 1999 Bill Nottingham <notting@redhat.com>
  244. - initial build