maxima-vl.spec 5.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195
  1. # -*- mode: rpm-spec -*-
  2. # By default, this spec file will generate RPMs for Clisp, CMUCL
  3. # and GCL. This can be changed by modifying the variables below.
  4. %define enable_clisp 1
  5. %define clisp_flags --enable-clisp
  6. %define enable_cmucl 0
  7. %define cmucl_flags --disable-cmucl
  8. %define enable_gcl 0
  9. %define gcl_flags --disable-gcl
  10. # Inhibit automatic compressing of info files. Compressed info
  11. # files break maxima's internal help.
  12. %define __spec_install_post /bin/true
  13. Summary: Maxima Symbolic Computation Program
  14. Summary(ja): 数式処理プログラム Maxima
  15. Name: maxima
  16. Version: 5.36.1
  17. Release: 1%{?_dist_release}
  18. License: GPL
  19. Group: Applications/Engineering
  20. URL: http://maxima.sourceforge.net
  21. Source0: %{name}-%{version}.tar.gz
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  23. BuildRequires: texinfo
  24. Requires: maxima_exec = %{version}-%{release}
  25. Requires(post): /sbin/install-info
  26. Requires(preun): /sbin/install-info
  27. %description
  28. Maxima is a full symbolic computation program. It is full featured
  29. doing symbolic manipulation of polynomials, matrices, rational
  30. functions, integration, Todd-coxeter, graphing, bigfloats. It has a
  31. symbolic debugger source level debugger for maxima code. Maxima is
  32. based on the original Macsyma developed at MIT in the 1970's. It is
  33. quite reliable, and has good garbage collection, and no memory leaks.
  34. It comes with hundreds of self tests.
  35. %description -l ja
  36. Maxima は高機能な数式処理プログラムです。Maximaを使えば、多項式、行列、
  37. 有理関数、積分、Todd-coxeter、グラフ描画、高精度浮動小数点といった演算
  38. も簡単にこなせます。Maxima のコードに対応したソースレベルの数式デバッ
  39. ガも備えています。Maxima は MIT で1970年台に開発されたオリジナルの
  40. Macsyma がベースとなっています。Maxima はとても信頼性が高く、すぐれた
  41. ガーベッジコレクションを搭載しており、メモリリークを起こしません。この
  42. 信頼性は、数百件に及ぶセルフテストによってもたらされたものです。
  43. %package xmaxima
  44. Summary: Tcl/Tk interface to Maxima
  45. Summary(ja): Maxima 用 Tcl/Tk インターフェース
  46. Group: Applications/Engineering
  47. Requires: %{name} = %{version}-%{release}
  48. Requires: tk > 8.1
  49. Provides: xmaxima
  50. %description xmaxima
  51. Tcl/Tk interface to Maxima.
  52. %if %{enable_clisp}
  53. %package exec-clisp
  54. Summary: Maxima compiled with clisp
  55. Group: Applications/Engineering
  56. Requires: clisp
  57. BuildRequires: clisp
  58. Provides: maxima_exec
  59. %description exec-clisp
  60. Maxima compiled with clisp.
  61. %endif
  62. %if %{enable_cmucl}
  63. %package exec-cmucl
  64. Summary: Maxima compiled with CMUCL
  65. Group: Applications/Engineering
  66. Requires: cmucl
  67. BuildRequires: cmucl
  68. Provides: maxima_exec
  69. %description exec-cmucl
  70. Maxima compiled with CMUCL.
  71. %endif
  72. %if %{enable_gcl}
  73. %package exec-gcl
  74. Summary: Maxima compiled with GCL
  75. Group: Applications/Engineering
  76. Requires: gcl
  77. BuildRequires: gcl
  78. Provides: maxima_exec
  79. %description exec-gcl
  80. Maxima compiled with Gnu Common Lisp.
  81. %endif
  82. %prep
  83. %setup -q
  84. %configure %{?cmucl_flags:} %{?gcl_flags:} %{?clisp_flags:}
  85. %build
  86. %__make
  87. %install
  88. %__rm -rf %{buildroot}
  89. %makeinstall
  90. rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  91. %post
  92. /sbin/install-info %{_infodir}/maxima.info %{_infodir}/dir
  93. %preun
  94. if [ "$1" = 0 ]; then
  95. /sbin/install-info --delete %{_infodir}/maxima.info %{_infodir}/dir
  96. fi
  97. %clean
  98. %__rm -rf %{buildroot}
  99. %files
  100. %defattr(-,root,root,-)
  101. %{_datadir}/maxima/%{version}
  102. %dir %{_libdir}/maxima/%{version}
  103. %{_libexecdir}/maxima/%{version}
  104. %{_infodir}/*
  105. %{_mandir}/man1/*
  106. %{_bindir}/*
  107. %doc AUTHORS COPYING ChangeLog INSTALL* NEWS README*
  108. %files xmaxima
  109. %{_bindir}/xmaxima
  110. %if %{enable_clisp}
  111. %files exec-clisp
  112. %{_libdir}/maxima/%{version}/binary-clisp
  113. %endif
  114. %if %{enable_cmucl}
  115. %files exec-cmucl
  116. %{_libdir}/maxima/%{version}/binary-cmucl
  117. %endif
  118. %if %{enable_gcl}
  119. %files exec-gcl
  120. %{_libdir}/maxima/%{version}/binary-gcl
  121. %endif
  122. %changelog
  123. * Fri Jul 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.36.1-1
  124. - update to 5.36.1
  125. - add BuildRequires: texinfo
  126. * Sat Mar 06 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.16.3-2
  127. - rebuilt with new toolchain, libsigsev-2.8 and clisp-2.48
  128. * Sun Oct 05 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.16.3-1vl5
  129. - new upstream release
  130. * Sat Oct 04 2008 Shu KONNO <owa@bg.wakwak.com> 5.11.0-1vl5
  131. - applied new versioning policy, spec in utf-8
  132. * Mon Mar 19 2007 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 5.11.0-0vl1
  133. - New upstream release
  134. - Change Group
  135. * Fri May 20 2005 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 5.9.1-0vl2
  136. - Japanese Summary and description by rpmSpecTranslate project
  137. * Sat Apr 23 2005 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 5.9.1-0vl1
  138. - New upstream release (for diff() bug fix)
  139. - Tidy up spec file
  140. * Sun Feb 1 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 5.9.0-0vl4
  141. - Change Requires and BuildPreReq clisp (= 2.29 -> >= 2.29)
  142. * Sat Aug 2 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 5.9.0-0vl3
  143. - Add exec-clisp BuildPreReq clisp
  144. - Add xmaxima Requires tk > 8.1
  145. - Remove xmaxima-olderTcl patch
  146. * Fri Jun 6 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> 5.9.0-0vl2
  147. - Rebuild for clisp-2.29-0vl1
  148. * Fri May 30 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> 5.9.0-0vl1
  149. - Enable clisp only, disable cmucl and gcl
  150. - Add xmaxima-olderTcl patch (for tclversion older than 8.1)
  151. - Remove %{_infodir}/dir file
  152. * Sat Jan 4 2003 James Amundson <amundson@fnal.gov>
  153. - Added doc files
  154. - Added explicit clisp version
  155. - Added conditional to postun
  156. - Renamed exec_* packages to exec-*
  157. - Use rpm macros instead of hard-coded paths
  158. - Thanks to Rex Dieter for helpful suggestions
  159. * Sun Sep 8 2002 James Amundson <amundson@fnal.gov>
  160. - Initial build.