lensfun-vl.spec 4.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174
  1. %global sse -DBUILD_FOR_SSE:BOOL=OFF
  2. %global sse2 -DBUILD_FOR_SSE2:BOOL=OFF
  3. %ifarch x86_64
  4. %global sse -DBUILD_FOR_SSE:BOOL=ON
  5. %global sse2 -DBUILD_FOR_SSE2:BOOL=ON
  6. %endif
  7. Name: lensfun
  8. Version: 0.3.0
  9. Release: 1%{?_dist_release}
  10. Summary: Library to rectify defects introduced by photographic lenses
  11. License: LGPLv3 and CC-BY-SA
  12. Group: System Environment/Libraries
  13. URL: http://lensfun.sourceforge.net/
  14. Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
  15. ## upstreamable patches
  16. # install manpages only when INSTALL_HELPER_SCRIPTS=ON
  17. Patch1: lensfun-0.3.0-INSTALL_HELPER_SCRIPTS.patch
  18. # install manpages in the correct place
  19. Patch2: lensfun-0.3.0-mandir.patch
  20. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  21. BuildRequires: cmake >= 2.8
  22. BuildRequires: doxygen
  23. BuildRequires: glib2-devel
  24. BuildRequires: libpng-devel
  25. BuildRequires: pkgconfig
  26. BuildRequires: python-docutils
  27. BuildRequires: zlib-devel
  28. Distribution: Vine Linux
  29. Vendor: Project Vine
  30. Packager: iwaim
  31. %description
  32. The lensfun library provides an open source database of photographic lenses and
  33. their characteristics. It not only provides a way to read and search the
  34. database, but also provides a set of algorithms for correcting images based on
  35. detailed knowledge of lens properties. Right now lensfun is designed to correct
  36. distortion, transversal (also known as lateral) chromatic aberrations,
  37. vignetting and color contribution of a lens.
  38. %package devel
  39. Summary: Development toolkit for %{name}
  40. Group: Development/Libraries
  41. License: LGPLv3
  42. Requires: %{name} = %{version}-%{release}
  43. Requires: pkgconfig
  44. %description devel
  45. This package contains library and header files needed to build applications
  46. using lensfun.
  47. %prep
  48. %setup -q
  49. %patch1 -p1 -b .INSTALL_HELPER_SCRIPTS
  50. %patch2 -p1 -b .mandir
  51. %build
  52. mkdir -p %{_target_platform}
  53. pushd %{_target_platform}
  54. %cmake \
  55. -DBUILD_DOC:BOOL=ON \
  56. -DBUILD_TESTS:BOOL=OFF \
  57. -DCMAKE_BUILD_TYPE:STRING=Release \
  58. %{?sse} %{?sse2} \
  59. ..
  60. popd
  61. make %{?_smp_mflags} -C %{_target_platform}
  62. make doc -C %{_target_platform}
  63. %install
  64. rm -rf %{buildroot}
  65. make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
  66. ## unpackaged files
  67. # omit cmake-installed doxygen docs, we handle that manually
  68. rm -rfv %{buildroot}%{_docdir}/%{name}-%{version}*
  69. # omit g-lensfun-update-data because it needs gksudo which we don't ship
  70. rm -fv %{buildroot}%{_bindir}/g-lensfun-update-data \
  71. %{buildroot}%{_mandir}/man1/g-lensfun-update-data.*
  72. %clean
  73. rm -rf %{buildroot}
  74. %post -p /sbin/ldconfig
  75. %postun -p /sbin/ldconfig
  76. %files
  77. %defattr(-,root,root,-)
  78. %doc README
  79. %doc docs/cc-by-sa-3.0.txt docs/lgpl-3.0.txt
  80. %doc docs/adobe-lens-profile.txt
  81. %{_bindir}/*
  82. %{_libdir}/liblensfun.so.0*
  83. %{_datadir}/lensfun/
  84. %{_mandir}/man1/*
  85. %files devel
  86. %defattr(-,root,root,-)
  87. %doc %{_target_platform}/doc_doxygen/*
  88. %{_includedir}/lensfun/
  89. %{_libdir}/liblensfun.so
  90. %{_libdir}/pkgconfig/lensfun.pc
  91. %changelog
  92. * Sun Feb 1 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.3.0-1
  93. - new upstream release
  94. - added BR: cmake
  95. * Sun Sep 4 2011 IWAI, Masaharu <iwai@alib.jp> 0.2.5-1
  96. - build for Vine Linux: based Fedora 0.2.5-5
  97. * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.5-5
  98. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  99. * Wed Sep 29 2010 jkeating - 0.2.5-4
  100. - Rebuilt for gcc bug 634757
  101. * Mon Sep 20 2010 Nils Philippsen <nils@redhat.com> 0.2.5-3
  102. - backport cpuid fixes (#631674)
  103. * Mon Jul 26 2010 Dan Horák <dan[at]danny.cz> 0.2.5-2
  104. - disable SSE vectorization on non x86 arches
  105. * Mon Jun 07 2010 Nils Philippsen <nils@redhat.com> 0.2.5-1
  106. - lensfun-0.2.5
  107. - add CC-BY-SA to main package license tag for lens data
  108. - don't ship GPLv3 text as nothing is licensed under it currently
  109. - mark documentation files as such
  110. - shorten summaries, expand package descriptions
  111. * Sun Oct 18 2009 Rex Dieter <rdieter@fedoraproject.orG> 0.2.4-1
  112. - lensfun-0.2.4 (#529506)
  113. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.3-5
  114. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  115. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.3-4
  116. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  117. * Fri Dec 12 2008 Rex Dieter <rdieter@fedoraproject.org> 0.2.3-3
  118. - rebuild for pkgconfig deps
  119. * Mon Nov 10 2008 Rex Dieter <rdieter@fedoraproject.org> 0.2.3-2
  120. - -devel: Requires: pkgconfig
  121. * Mon Nov 10 2008 Rex Dieter <rdieter@fedoraproject.org> 0.2.3-1
  122. - lensfun-0.2.3
  123. - fix SOURCE Url
  124. - configure --target=..generic
  125. * Mon Oct 13 2008 Rex Dieter <rdieter@fedoraproject.org> 0.2.2b-3
  126. - BR: doxygen
  127. * Mon Oct 13 2008 Rex Dieter <rdieter@fedoraproject.org> 0.2.2b-2
  128. - fix subpkg deps
  129. * Sun Sep 28 2008 Rex Dieter <rdieter@fedoraproject.org> 0.2.2b-1
  130. - adapt for fedora
  131. * Tue Jun 24 2008 Helio Chissini de Castro <helio@mandriva.com> 0.2.2b-1mdv2009.0
  132. + Revision: 228769
  133. - Added missing buildrequires
  134. - import lensfun