latexml-vl.spec 2.4 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788
  1. %define pkgname LaTeXML
  2. Name: latexml
  3. Version: 0.7.0
  4. Release: 4%{?_dist_release}
  5. Summary: LaTeX to XML Converter
  6. Group: Development/Libraries
  7. License: public domain
  8. Url: http://dlmf.nist.gov/LaTeXML/
  9. Source0: http://dlmf.nist.gov/LaTeXML/releases/%{pkgname}-%{version}.tar.gz
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  11. BuildArch: noarch
  12. BuildRequires: texlive-vtlpkg >= 2013
  13. BuildRequires: perl(Parse::RecDescent)
  14. BuildRequires: perl(Image::Magick)
  15. BuildRequires: perl(XML::LibXML) >= 1.70
  16. BuildRequires: perl(XML::LibXSLT) >= 1.70
  17. BuildRequires: perl(DB_File)
  18. BuildRequires: perl(Test::Simple)
  19. Distribution: Vine
  20. Vendor: Project Vine
  21. Packager: munepi
  22. %description
  23. latexml is a program, written in Perl, that attempts to faithfully mimic TeX's behaviour, but produces XML instead of dvi. The document model of the target XML makes explicit the model implied by LaTeX. The processing and model are both extensible; you can define the mapping between TeX constructs and the XML fragments to be created. A postprocessor, latexmlpost converts this XML into other formats such as HTML or XHTML, with options to convert the math into MathML (currently only presentation) or images.
  24. #'
  25. %prep
  26. %setup -q -n %{pkgname}-%{version}
  27. %build
  28. export CFLAGS="$RPM_OPT_FLAGS"
  29. %__perl Makefile.PL TEXMF=%{_tl_texmfvine} INSTALLDIRS=vendor
  30. %__make
  31. %install
  32. %__rm -rf $RPM_BUILD_ROOT
  33. %__make pure_install DESTDIR=$RPM_BUILD_ROOT
  34. find $RPM_BUILD_ROOT -type f -name .packlist | xargs %__rm -f
  35. %check
  36. %__make test ||:
  37. %post
  38. %_tl_touch_run texhash
  39. exit 0
  40. %postun
  41. if [ "$1" = 0 ]; then
  42. %_tl_touch_run texhash
  43. fi
  44. exit 0
  45. %posttrans
  46. %{_tl_exec_texhash}
  47. exit 0
  48. %files
  49. %defattr(-,root,root)
  50. %{_bindir}/latexml
  51. %{_bindir}/latexmlfind
  52. %{_bindir}/latexmlmath
  53. %{_bindir}/latexmlpost
  54. %{_tl_texmfvine}/tex/latex/latexml/latexml.sty
  55. %dir %{_tl_texmfvine}/tex/latex/latexml
  56. %{_mandir}/man*/*.*
  57. %{perl_vendorlib}/LaTeXML.pm
  58. %{perl_vendorlib}/LaTeXML/*
  59. %dir %{perl_vendorlib}/LaTeXML
  60. %changelog
  61. * Thu Aug 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> - 0.7.0-4
  62. - added BuildRequires: texlive-vtlpkg >= 2013
  63. - added some scriptlets to run mktexlsr
  64. * Tue Jun 28 2011 Munehiro Yamamoto <munepi@vinelinux.org> - 0.7.0-3
  65. - rebuilt on i386
  66. * Tue May 24 2011 Munehiro Yamamoto <munepi@vinelinux.org> - 0.7.0-2
  67. - rebuilt with perl-5.12.3
  68. * Thu Aug 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 0.7.0-1
  69. - initial build