korundum-vl.spec 7.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274
  1. %global ruby_vendorlib %(ruby -rrbconfig -e 'puts RbConfig::CONFIG["vendorlibdir"]')
  2. %global ruby_vendorarch %(ruby -rrbconfig -e 'puts RbConfig::CONFIG["vendorarchdir"]')
  3. Name: korundum
  4. Summary: Ruby bindings for KDE
  5. Summary(ja): KDE の Ruby バインディング
  6. Version: 4.14.3
  7. Release: 2%{?_dist_release}
  8. License: LGPLv2+ and GPLv2+
  9. Group: System Environment/Libraries
  10. URL: https://techbase.kde.org/Development/Languages/Ruby
  11. Source0: http://download.kde.org/stable/%{version}/src/%{name}-%{version}.tar.xz
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: cmake
  14. BuildRequires: akonadi-devel
  15. BuildRequires: kate-devel >= %{version}
  16. BuildRequires: kdelibs4-devel >= %{version}
  17. BuildRequires: kdepimlibs-devel >= %{version}
  18. BuildRequires: okular-devel >= %{version}
  19. BuildRequires: QtRuby-devel >= %{version}
  20. BuildRequires: ruby-devel >= 1.8
  21. BuildRequires: shared-desktop-ontologies-devel
  22. BuildRequires: smokekde-devel >= %{version}
  23. BuildRequires: smokeqt-devel >= %{version}
  24. BuildRequires: soprano-devel
  25. Requires: QtRuby >= %{version}
  26. Requires: smokekde >= %{version}
  27. Requires: smokeqt >= %{version}
  28. %description
  29. %{summary}.
  30. %package devel
  31. Summary: Development libraries for %{name}
  32. Summary(ja): %{name} の開発用ファイル
  33. Group: Development/Libraries
  34. Requires: %{name} = %{version}-%{release}
  35. %description devel
  36. %{summary}.
  37. %prep
  38. %setup -q
  39. %build
  40. mkdir -p %{_target_platform}
  41. pushd %{_target_platform}
  42. %cmake \
  43. -DCMAKE_BUILD_TYPE=release \
  44. -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
  45. -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
  46. -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
  47. -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
  48. -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
  49. -DCUSTOM_RUBY_SITE_ARCH_DIR:PATH=%{ruby_vendorarch} \
  50. -DCUSTOM_RUBY_SITE_LIB_DIR:PATH=%{ruby_vendorlib} \
  51. ..
  52. popd
  53. make %{?_smp_mflags} -C %{_target_platform}
  54. %install
  55. rm -rf $RPM_BUILD_ROOT
  56. make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
  57. %post -p /sbin/ldconfig
  58. %postun -p /sbin/ldconfig
  59. %clean
  60. rm -rf $RPM_BUILD_ROOT
  61. %files
  62. %defattr(-,root,root,-)
  63. %doc AUTHORS COPYING COPYING.LIB README
  64. %{_bindir}/krubyapplication
  65. %{ruby_vendorlib}/KDE/
  66. %{ruby_vendorlib}/akonadi/
  67. %{ruby_vendorlib}/khtml/
  68. %{ruby_vendorlib}/kio/
  69. %{ruby_vendorlib}/ktexteditor/
  70. %{ruby_vendorlib}/okular/
  71. %{ruby_vendorlib}/solid/
  72. %{ruby_vendorlib}/soprano/
  73. %{ruby_vendorlib}/nepomuk/
  74. %{ruby_vendorarch}/akonadi.so
  75. %{ruby_vendorarch}/kate.so
  76. %{ruby_vendorarch}/khtml.so
  77. %{ruby_vendorarch}/kio.so
  78. %{ruby_vendorarch}/korundum4.so
  79. %{ruby_vendorarch}/ktexteditor.so
  80. %{ruby_vendorarch}/okular.so
  81. %{ruby_vendorarch}/plasma_applet.so
  82. %{ruby_vendorarch}/solid.so
  83. %{ruby_vendorarch}/soprano.so
  84. %{ruby_vendorarch}/nepomuk.so
  85. %{_libdir}/kde4/krubypluginfactory.so
  86. %{_datadir}/applications/kde4/dbpedia_references.desktop
  87. %{_datadir}/kde4/apps/dbpedia_references
  88. %{_datadir}/kde4/apps/plasma_applet_ruby_clock/
  89. %{_datadir}/kde4/apps/plasma_ruby_digital_clock/
  90. %{_datadir}/kde4/services/*.desktop
  91. %files devel
  92. %defattr(-,root,root,-)
  93. %{_bindir}/rbkconfig_compiler4
  94. %changelog
  95. * Sat Sep 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.14.3-2
  96. - rebuild with ruby-2.2.3
  97. * Sun Jan 11 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.14.3-1
  98. - updated to 4.14.3
  99. - built with okluar-libs 4.14.3
  100. * Wed Nov 12 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.12.5-2
  101. - installed modules to vendor_ruby
  102. * Sun Nov 9 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.12.5-1
  103. - splitted from kdebindings
  104. * Thu Jun 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.4-1
  105. - new upstream release
  106. * Thu Apr 14 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-1
  107. - updated to 4.6.1
  108. - added BR: kdesdk-devel
  109. - disabled attica plugins temporaly
  110. - rebuilt with mono-2.10.1
  111. * Sun Sep 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.1-2
  112. - rebuilt with rpm-4.8.1 for pkg-config
  113. * Sat Sep 18 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.1-1
  114. - new upstream release
  115. - added Patch50
  116. - added more japanese summaries
  117. * Tue Aug 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-1
  118. - new upstream release
  119. * Sun Jul 4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-1
  120. - new upstream release
  121. * Fri May 7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-1
  122. - new upstream release
  123. * Thu Apr 15 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
  124. - new upstream release
  125. * Tue Mar 9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.1-1
  126. - new upstream release
  127. - added -DCMAKE_SKIP_RPATH:BOOL=OFF option to cmake
  128. (see https://bugs.kde.org/show_bug.cgi?id=214824)
  129. - built with new toolchain
  130. * Wed Nov 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.3-1
  131. - new upstream release
  132. * Thu Oct 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-4
  133. - merged 4.3.1-2 %changelog
  134. - re-define %%{mono_dir} to %{_prefix}/lib/mono (again)
  135. * Tue Oct 27 2009 Shu KONNO <owa@bg.wakwak.com> 4.3.2-3
  136. - use %%{_prefix}/lib for mono-dll (for x86_64)
  137. * Tue Oct 27 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-2
  138. - new upstream release
  139. - built with PyQt4-4.6
  140. * Sun Sep 06 2009 NAKAMURA Kenta <kenta@vinelinux.org> 4.3.1-2
  141. - define %%{mono_dir} to specify mono library install path
  142. * Sun Sep 6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-1
  143. - new upstream release
  144. - fixed ruby modules installation path
  145. * Thu Aug 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.0-1
  146. - new upstream release
  147. - spilt sub package based on Fedora
  148. * Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
  149. - applied new versioning policy
  150. - added Patch1
  151. (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=484191)
  152. * Fri Nov 23 2007 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.8-0vl3
  153. - added --with-qt-libraries option
  154. * Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
  155. - rebuild for VineSeed
  156. * Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
  157. - new upstream release
  158. * Mon Jun 25 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
  159. - rebuild for VineSeed
  160. * Thu May 31 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
  161. - new upstream release
  162. - update Patch0
  163. - drop Patch1
  164. * Mon Jan 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
  165. - new upstream release
  166. - add Patch1
  167. - add --enable-libsuffix option
  168. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
  169. - rebuild for VineSeed
  170. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
  171. - new upstream release
  172. * Wed Aug 2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
  173. - rebuild for VineSeed
  174. * Wed Aug 2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
  175. - new upstream release
  176. * Thu Jun 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
  177. - rebuild for VineSeed
  178. * Thu Jun 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
  179. - new upstream release
  180. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
  181. - rebuild for VineSeed
  182. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
  183. - new upstream release
  184. * Wed Feb 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
  185. - rebuild for VineSeed
  186. * Wed Feb 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
  187. - new upstream release
  188. - renew BuildPrereq and build section
  189. - renew %%files
  190. - enable python
  191. - change spec to make main and devel package
  192. - add BuildPrereq: ruby ruby-devel
  193. - add Patch0 to install ruby-bindings under /usr/lib/ruby
  194. * Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-1vl1
  195. - build for VineSeed
  196. - disable python and mozilla
  197. - objprelink (i386 only)
  198. * Wed Nov 21 2001 Than Ngo <than@redhat.com> <bero@redhat.com> 2.2.2-1
  199. - 2.2.2
  200. - build kmozilla binding only on x86/alpha
  201. * Thu Aug 9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-2
  202. - Make sure %%{name}-kmozilla isn't built on ia64
  203. * Mon Jul 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010723.2
  204. - Move python bindings to separate package
  205. - Add perl bindings
  206. - Shut up rpmlint
  207. * Wed Feb 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  208. - 2.1
  209. * Sun Jan 28 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  210. - initial RPM