guile-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define mver 2.0
  3. Name: guile
  4. Summary: A GNU implementation of Scheme for application extensibility.
  5. Summary(ja): アプリケーション拡張用 Scheme の GNU な実装
  6. Version: 2.0.11
  7. Release: 2%{?_dist_release}
  8. Group: Development/Languages
  9. License: GPLv2+ and LGPLv2+ and GFDL and OFSFDL
  10. URL: http://www.gnu.org/software/guile/
  11. Source: ftp://ftp.gnu.org/gnu/guile-%{version}.tar.gz
  12. # following patchs are imported from fedora-dev
  13. Patch1: guile-1.8.7-multilib.patch
  14. Buildroot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: libtool libtool-ltdl-devel >= 2.2.6a
  16. BuildRequires: gmp-devel readline-devel emacs
  17. BuildRequires: libunistring-devel
  18. BuildRequires: libffi-devel
  19. BuildRequires: gc-devel
  20. Requires(post): /sbin/install-info
  21. Requires(preun): /sbin/install-info
  22. Requires: coreutils
  23. Vendor: Project Vine
  24. Distribution: Vine Linux
  25. Packager: yasumichi
  26. %description
  27. GUILE (GNU's Ubiquitous Intelligent Language for Extension) is a library
  28. implementation of the Scheme programming language, written in C. GUILE
  29. provides a machine-independent execution platform that can be linked in
  30. as a library during the building of extensible programs.
  31. Install the guile package if you'd like to add extensibility to programs
  32. that you are developing.
  33. %package devel
  34. Summary: Libraries and header files for the GUILE extensibility library.
  35. Summary(ja): GUILE 用の開発ライブラリおよびヘッダファイル
  36. Group: Development/Libraries
  37. Requires: %{name} = %{version}-%{release}
  38. Requires: gmp-devel
  39. Requires: gc-devel
  40. %description devel
  41. The guile-devel package includes the libraries, header files, etc.,
  42. that you'll need to develop applications that are linked with the
  43. GUILE extensibility library.
  44. You need to install the guile-devel package if you want to develop
  45. applications that will be linked to GUILE. You'll also need to
  46. install the guile package.
  47. %package -n compat32-%{name}
  48. Summary: A GNU implementation of Scheme for application extensibility.
  49. Summary(ja): アプリケーション拡張用 Scheme の GNU な実装
  50. Group: System Environment/Libraries
  51. Requires: %{name} = %{version}-%{release}
  52. %description -n compat32-%{name}
  53. GUILE (GNU's Ubiquitous Intelligent Language for Extension) is a library
  54. implementation of the Scheme programming language, written in C. GUILE
  55. provides a machine-independent execution platform that can be linked in
  56. as a library during the building of extensible programs.
  57. Install the guile package if you'd like to add extensibility to programs
  58. that you are developing.
  59. %package -n compat32-%{name}-devel
  60. Summary: Libraries and header files for the GUILE extensibility library.
  61. Summary(ja): GUILE 用の開発ライブラリおよびヘッダファイル
  62. Group: Development/Libraries
  63. Requires: %{name}-devel = %{version}-%{release}
  64. Requires: compat32-%{name} = %{version}-%{release}
  65. Requires: compat32-gmp-devel
  66. Requires: compat32-gc-devel
  67. %description -n compat32-%{name}-devel
  68. The guile-devel package includes the libraries, header files, etc.,
  69. that you'll need to develop applications that are linked with the
  70. GUILE extensibility library.
  71. You need to install the guile-devel package if you want to develop
  72. applications that will be linked to GUILE. You'll also need to
  73. install the guile package.
  74. %prep
  75. %setup -q
  76. %patch1 -p1 -b .multilib
  77. %build
  78. %configure --disable-static --disable-error-on-warning
  79. # Remove RPATH
  80. sed -i 's|" $sys_lib_dlsearch_path "|" $sys_lib_dlsearch_path %{_libdir} "|' \
  81. libtool
  82. make %{?_smp_mflags}
  83. %install
  84. rm -rf $RPM_BUILD_ROOT
  85. make DESTDIR=$RPM_BUILD_ROOT install
  86. mkdir -p $RPM_BUILD_ROOT%{_datadir}/guile/site/%{mver}
  87. rm -f $RPM_BUILD_ROOT%{_libdir}/libguile*.la
  88. rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  89. # Our gdb doesn't support guile yet
  90. rm -f ${RPM_BUILD_ROOT}%{_libdir}/libguile*gdb.scm
  91. # Compress large documentation
  92. bzip2 NEWS
  93. for i in ${RPM_BUILD_ROOT}%{_infodir}/goops.info; do
  94. iconv -f iso8859-1 -t utf-8 < $i > $i.utf8 && mv -f ${i}{.utf8,}
  95. done
  96. %clean
  97. rm -rf $RPM_BUILD_ROOT
  98. %post
  99. /sbin/ldconfig
  100. /sbin/install-info %{_infodir}/guile.info.gz %{_infodir}/dir
  101. /sbin/install-info %{_infodir}/r5rs.info.gz %{_infodir}/dir
  102. %postun -p /sbin/ldconfig
  103. %preun
  104. if [ "$1" = 0 ]; then
  105. /sbin/install-info --delete %{_infodir}/guile.info.gz %{_infodir}/dir
  106. /sbin/install-info --delete %{_infodir}/r5rs.info.gz %{_infodir}/dir
  107. fi
  108. :
  109. %if %{build_compat32}
  110. %post -n compat32-%{name} -p /sbin/ldconfig
  111. %postun -n compat32-%{name} -p /sbin/ldconfig
  112. %endif
  113. %files
  114. %defattr(-,root,root,-)
  115. %doc AUTHORS COPYING* ChangeLog HACKING NEWS.bz2 README THANKS
  116. %{_bindir}/guild
  117. %{_bindir}/guile
  118. %{_bindir}/guile-tools
  119. %{_libdir}/libguile*.so.*
  120. %{_libdir}/libguilereadline-*.so
  121. %dir %{_libdir}/guile/%{mver}
  122. %{_libdir}/guile/%{mver}/ccache
  123. %dir %{_datadir}/guile
  124. %dir %{_datadir}/guile/%{mver}
  125. %{_datadir}/guile/%{mver}/*.scm
  126. %{_datadir}/guile/%{mver}/ice-9
  127. %{_datadir}/guile/%{mver}/language
  128. %{_datadir}/guile/%{mver}/oop
  129. %{_datadir}/guile/%{mver}/rnrs
  130. %{_datadir}/guile/%{mver}/scripts
  131. %{_datadir}/guile/%{mver}/srfi
  132. %{_datadir}/guile/%{mver}/sxml
  133. %{_datadir}/guile/%{mver}/system
  134. %{_datadir}/guile/%{mver}/texinfo
  135. %{_datadir}/guile/%{mver}/web
  136. %{_datadir}/guile/%{mver}/guile-procedures.txt
  137. %dir %{_datadir}/guile/site
  138. %{_infodir}/*
  139. %{_mandir}/man1/guile.1*
  140. %files devel
  141. %defattr(-,root,root,-)
  142. %{_bindir}/guile-config
  143. %{_bindir}/guile-snarf
  144. %{_datadir}/aclocal/*
  145. %{_libdir}/libguile-%{mver}.so
  146. %{_libdir}/pkgconfig/*.pc
  147. %{_includedir}/guile/%{mver}
  148. # compat32
  149. %if %{build_compat32}
  150. %files -n compat32-%{name}
  151. %defattr(-,root,root,-)
  152. %{_libdir}/libguile*.so.*
  153. %{_libdir}/libguilereadline-*.so
  154. %files -n compat32-%{name}-devel
  155. %defattr(-,root,root,-)
  156. %{_libdir}/libguile-%{mver}.so
  157. %endif
  158. %changelog
  159. * Tue Mar 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.0.11-2
  160. - rebuilt with readline 6.3
  161. * Sun Jan 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.11-1
  162. - update to 2.0.11
  163. - add BuildRequires: libunistring-devel, libffi-devel, gc-devel
  164. - remove Patch2,4
  165. * Tue Nov 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.8-1
  166. - update to 1.8.8
  167. - remove Patch3,5,6 (guile-1.8.7-ia64jmp.patch)
  168. * Sat Oct 09 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.7-2
  169. - rebuilt with rpm-4.8.1
  170. - added Patch1, 2, 3, 5 and 6 from Fedora
  171. * Tue Nov 03 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.8.7-1
  172. - new upstream release.
  173. - comment out Patch11,12.
  174. * Fri Jul 24 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.8.6-4
  175. - added Requires: gmp-devel to guile-devel
  176. * Sat Jun 27 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.8.6-3
  177. - added compat32 package for x86_64 arch support
  178. * Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.6-2
  179. - rebuild with libtool-2.2.6a
  180. * Mon Jan 12 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.8.6-1
  181. - new upstream release
  182. - import some patches from fedora development
  183. - drop some old patches
  184. - update spec based on fedora package
  185. - spec in utf-8
  186. * Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.6.7-6vl5
  187. - use macro for Release
  188. * Sat May 10 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.6.7-5vl5
  189. - apply new virsioning policy.
  190. - remove *.la
  191. * Sun Apr 23 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.7-4vl2
  192. - rebuilt with readline 5.1
  193. * Sun Oct 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.7-4vl1
  194. - added Patches from Fedora
  195. * Fri Sep 02 2005 Phil Knirsch <pknirsch@redhat.com> 5:1.6.7-4
  196. - Fix dynamic linking on 64bit archs (#159971)
  197. * Tue Dec 21 2004 Phil Knirsch <pknirsch@redhat.com> 5:1.6.4-16
  198. - Moved info files to base package as they are not devel related (#139948)
  199. - Moved static guilereadline and guile-srfi-srfi libs to devel package (#140893)
  200. - Fixed guile-tools not finding guile lib dir (#142642)
  201. - Added some nice tools (#142642)
  202. - Removed smp build, seems to be broken atm
  203. * Fri Jan 7 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.7-0vl1
  204. - new upstream release
  205. - dropped patch2, 4, 6
  206. - added BuildPrereq: perl
  207. * Fri Jan 2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-0vl2
  208. - rebuild with new toolchains
  209. - s/Copyright/License/
  210. - added srfi libs
  211. - patch for ppc64 from Fedora package
  212. * Thu May 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-0vl1
  213. - update to 1.6.4
  214. * Wed Apr 02 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.6.3-0vl3
  215. - rebuild with readline-4.3
  216. * Thu Feb 13 2003 Ryoichi INAGAKI <ryo1i@bc.wakwak.com> 1.6.3-0vl2
  217. - based on Rawhide 1.6.0-4
  218. - Included s390 as working arch as well, switch to general unknown arch patch
  219. - rebuild to fix broken deps
  220. - fix continuations.h on ia64
  221. - new upstream 1.6.3
  222. * Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.3.4-9vl1
  223. - porting for Vine Linux
  224. - remove 1.3 patches( not required so that upstream upgrade )
  225. * Fri Jul 14 2000 Nalin Dahyabhai <nalin@redhat.com>
  226. - Add version number to prereq for umb-scheme to get the post-install to
  227. work properly.
  228. * Thu Jul 13 2000 Nalin Dahyabhai <nalin@redhat.com>
  229. - Add an Epoch = 1 in case anyone happened to have 1.4 installed.
  230. * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
  231. - automatic rebuild
  232. * Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
  233. - Back down to 1.3.4.
  234. - Fix to actually link against the version of libguile in the package.
  235. * Sun Jun 4 2000 Nalin Dahyabhai <nalin@redhat.com>
  236. - FHS fixups using the %%{makeinstall} macro.
  237. * Sun Mar 26 2000 Florian La Roche <Florian.LaRoche@redhat.com>
  238. - fix preun-devel
  239. - call ldconfig directly in postun
  240. * Fri Mar 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  241. - rebuild with new readline
  242. - update to 1.3.4
  243. * Mon Feb 28 2000 Nalin Dahyabhai <nalin@redhat.com>
  244. - using the same catalog as umb-scheme makes umb-scheme a prereq
  245. * Thu Feb 17 2000 Florian La Roche <Florian.LaRoche@redhat.com>
  246. - readline is needed for %post
  247. * Tue Feb 8 2000 Nalin Dahyabhai <nalin@redhat.com>
  248. - use the same catalog as umb-scheme
  249. * Thu Sep 2 1999 Jeff Johnson <jbj@redhat.com>
  250. - fix broken %postun
  251. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  252. - auto rebuild in the new build environment (release 6)
  253. * Wed Mar 17 1999 Michael Johnson <johnsonm@redhat.com>
  254. - added .ansi patch to fix #endif
  255. * Wed Feb 10 1999 Cristian Gafton <gafton@redhat.com>
  256. - add patch for the scm stuff
  257. * Sun Jan 17 1999 Jeff Johnson <jbj@redhat.com>
  258. - integrate changes from rhcn version (#640)
  259. * Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
  260. - call libtoolize first to get it to compile on the arm
  261. * Sat Jan 9 1999 Todd Larason <jtl@molehill.org>
  262. - Added "Requires: guile" at suggestion of Manu Rouat <emmanuel.rouat@wanadoo.fr>
  263. * Fri Jan 1 1999 Todd Larason <jtl@molehill.org>
  264. - guile-devel does depend on guile
  265. - remove devel dependancy on m4
  266. - move guile-snarf from guile to guile-devel
  267. - Converted to rhcn
  268. * Wed Oct 21 1998 Jeff Johnson <jbj@redhat.com>
  269. - update to 1.3.
  270. - don't strip libguile.so.*.0.0. (but set the execute bits).
  271. * Thu Sep 10 1998 Cristian Gafton <gafton@redhat.com>
  272. - spec file fixups
  273. * Wed Sep 2 1998 Michael Fulbright <msf@redhat.com>
  274. - Updated for RH 5.2
  275. * Mon Jan 26 1998 Marc Ewing <marc@redhat.com>
  276. - Started with spec from Tomasz Koczko <kloczek@idk.com.pl>
  277. - added slib link
  278. * Thu Sep 18 1997 Tomasz Koczko <kloczek@idk.com.pl> (1.2-3)
  279. - added %attr(-, root, root) for %doc,
  280. - in %post, %postun ldconfig runed as parameter "-p",
  281. - removed /bin/sh from requires,
  282. - added %description,
  283. - changes in %files.
  284. * Fri Jul 11 1997 Tomasz Koczko <kloczek@rudy.mif.pg.gda.pl> (1.2-2)
  285. - all rewrited for using Buildroot,
  286. - added %postun,
  287. - removed making buid logs,
  288. - removed "--inclededir", added "--enable-dynamic-linking" to configure
  289. parameters,
  290. - added striping shared libs and /usr/bin/guile,
  291. - added "Requires: /bin/sh" (for guile-snarf) in guile package and
  292. "Requires: m4" for guile-devel,
  293. - added macro %{PACKAGE_VERSION} in "Source:" and %files,
  294. - added %attr macros in %files.