gnokii-vl.spec 16 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497
  1. # TODO: merge patches upstream where applicable
  2. Name: gnokii
  3. Version: 0.6.31
  4. Release: 3%{?_dist_release}
  5. Summary: Linux/Unix tool suite for various mobile phones
  6. Summary(ja): 様々な携帯電話向けの Linux/Unix ツール集
  7. Group: Applications/Communications
  8. License: GPLv2+
  9. URL: http://www.gnokii.org/
  10. Source0: http://www.gnokii.org/download/gnokii/%{name}-%{version}.tar.bz2
  11. #----------------------------------------------------------------------------
  12. Source2: gnokii-smsd.init
  13. Source3: gnokii-smsd.sysconfig
  14. Source4: gnokii-smsd.logrotate
  15. Source5: gnokii-smsd2mail.sh
  16. Source6: gnokii-smsd-README.smsd2mail
  17. # Patch to remove port locking and apply the system-wide /usr/sbin directory
  18. # to the path instead of the default /usr/local
  19. Patch1: gnokii-config.patch
  20. #----------------------------------------------------------------------------
  21. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  22. #----------------------------------------------------------------------------
  23. BuildRequires: flex
  24. BuildRequires: gettext
  25. BuildRequires: ImageMagick
  26. BuildRequires: bluez-libs-devel
  27. BuildRequires: desktop-file-utils
  28. BuildRequires: gtk2-devel
  29. BuildRequires: libusb-devel
  30. BuildRequires: libmysqlclient-devel
  31. BuildRequires: libpq-devel
  32. BuildRequires: readline-devel
  33. BuildRequires: pcsc-lite-devel
  34. BuildRequires: sqlite3-devel
  35. BuildRequires: zlib-devel
  36. BuildRequires: libical-devel >= 0.24
  37. BuildRequires: libXt-devel
  38. BuildRequires: libXpm-devel
  39. BuildRequires: perl(XML::Parser)
  40. Requires(pre): %{_sbindir}/groupadd
  41. #----------------------------------------------------------------------------
  42. %description
  43. Gnokii provides tools and a user space driver for use with mobile
  44. phones under Linux, various unices and Win32. With gnokii you can do
  45. such things as make data calls, update your address book, change
  46. calendar entries, send and receive SMS messages and load ring tones
  47. depending on the phone you have.
  48. #----------------------------------------------------------------------------
  49. %package -n xgnokii
  50. Summary: Graphical Linux/Unix tool suite for various mobile phones
  51. Summary(ja): 様々な携帯電話向けのグラフィカルな Linux/Unix ツール集
  52. Group: Applications/Communications
  53. Requires: %{name} = %{version}-%{release}
  54. %description -n xgnokii
  55. Xgnokii is graphical Linux/Unix tool suite for various mobile
  56. phones. It allows you to edit your contacts book, send/read SMS's
  57. from/in computer and more other features.
  58. #----------------------------------------------------------------------------
  59. %package smsd
  60. Summary: Gnokii SMS daemon
  61. Summary(ja): Gnokii SMS デーモン
  62. Group: System Environment/Daemons
  63. Requires: %{name} = %{version}-%{release}
  64. Requires(pre): %{_sbindir}/useradd
  65. Requires(post): /sbin/chkconfig
  66. Requires(preun): /sbin/chkconfig
  67. %description smsd
  68. The Gnokii SMS daemon receives and sends SMS messages.
  69. #----------------------------------------------------------------------------
  70. %package smsd-pgsql
  71. Summary: PostgreSQL support for Gnokii SMS daemon
  72. Summary(ja): Gnokii SMS デーモンの PostgreSQL サポート
  73. Group: System Environment/Daemons
  74. Requires: %{name}-smsd = %{version}-%{release}
  75. Obsoletes: %{name}-smsd-postgresql < 0.6.4-0.lvn.2
  76. %description smsd-pgsql
  77. %{summary}.
  78. #----------------------------------------------------------------------------
  79. %package smsd-mysql
  80. Summary: MySQL support for Gnokii SMS daemon
  81. Summary(ja): Gnokii SMS デーモンの MySQL サポート
  82. Group: System Environment/Daemons
  83. Requires: %{name}-smsd = %{version}-%{release}
  84. %description smsd-mysql
  85. %{summary}.
  86. #----------------------------------------------------------------------------
  87. %package devel
  88. Summary: Gnokii development files
  89. Summary(ja): Gnokii の開発用ファイル
  90. Group: Development/Libraries
  91. Requires: %{name} = %{version}-%{release}
  92. Requires: pkgconfig
  93. %description devel
  94. %{summary}.
  95. #----------------------------------------------------------------------------
  96. %prep
  97. %setup -q
  98. %patch1 -p0
  99. install -pm 644 %{SOURCE5} smsd2mail.sh
  100. install -pm 644 %{SOURCE6} README.smsd2mail
  101. %build
  102. %configure --enable-security --disable-rpath --disable-static \
  103. --enable-libical --with-x
  104. make %{?_smp_mflags}
  105. # xgnokii isn't built by the above make operation (Is it a bug?)
  106. make %{?_smp_mflags} -C xgnokii
  107. #----------------------------------------------------------------------------
  108. %install
  109. make install DESTDIR=$RPM_BUILD_ROOT
  110. make install DESTDIR=$RPM_BUILD_ROOT -C xgnokii
  111. # Rename smsd to gnokii-smsd
  112. mv $RPM_BUILD_ROOT%{_bindir}/{,gnokii-}smsd
  113. mv $RPM_BUILD_ROOT%{_mandir}/man8/{,gnokii-}smsd.8
  114. sed -i 's,smsd ,gnokii-smsd ,' $RPM_BUILD_ROOT%{_mandir}/man8/gnokii-smsd.8
  115. sed -i 's,smsd.,gnokii-smsd.,' $RPM_BUILD_ROOT%{_mandir}/man8/gnokii-smsd.8
  116. # Remove libtool droppings
  117. rm $RPM_BUILD_ROOT%{_libdir}{,/smsd}/lib*.la
  118. # Fix up the default desktop file
  119. desktop-file-install \
  120. --delete-original \
  121. --vendor "" \
  122. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  123. --mode 644 \
  124. --add-category X-VineLinux \
  125. $RPM_BUILD_ROOT%{_datadir}/applications/xgnokii.desktop
  126. # Convert the default icons to PNG
  127. install -dm 755 $RPM_BUILD_ROOT%{_datadir}/pixmaps
  128. convert Docs/sample/logo/gnokii.xpm \
  129. $RPM_BUILD_ROOT%{_datadir}/pixmaps/xgnokii.png
  130. chmod 644 $RPM_BUILD_ROOT%{_datadir}/pixmaps/xgnokii.png
  131. # Install the configuration files
  132. install -Dpm 755 %{SOURCE2} $RPM_BUILD_ROOT%{_initrddir}/gnokii-smsd
  133. install -Dpm 640 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/gnokii-smsd
  134. install -Dpm 644 %{SOURCE4} \
  135. $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/gnokii-smsd
  136. cp -a Docs/sample/gnokiirc $RPM_BUILD_ROOT%{_sysconfdir}/
  137. # Install the docs
  138. rm -rf temporary-gnokii-docs
  139. mkdir -p temporary-gnokii-docs/
  140. mv $RPM_BUILD_ROOT%{_datadir}/doc/gnokii/ temporary-gnokii-docs/
  141. %find_lang %{name}
  142. %clean
  143. rm -rf $RPM_BUILD_ROOT
  144. #----------------------------------------------------------------------------
  145. %pre
  146. %{_sbindir}/groupadd -r gnokii >/dev/null 2>&1 || :
  147. %pre smsd
  148. %{_sbindir}/useradd -r -M -d / -g gnokii \
  149. -s /sbin/nologin -c "Gnokii system user" gnokii >/dev/null 2>&1 || :
  150. %post -p /sbin/ldconfig
  151. %postun -p /sbin/ldconfig
  152. %post smsd
  153. /sbin/chkconfig --add gnokii-smsd
  154. %preun smsd
  155. if [ $1 -eq 0 ] ; then
  156. %{_initrddir}/gnokii-smsd stop >/dev/null 2>&1 || :
  157. /sbin/chkconfig --del gnokii-smsd
  158. fi
  159. %postun smsd
  160. if [ $1 -ge 1 ] ; then
  161. %{_initrddir}/gnokii-smsd try-restart >/dev/null 2>&1 || :
  162. fi
  163. #----------------------------------------------------------------------------
  164. %files -f %{name}.lang
  165. %defattr(-,root,root,-)
  166. %doc ChangeLog COPY* MAINTAINERS TODO temporary-gnokii-docs/*
  167. %config(noreplace) %{_sysconfdir}/gnokiirc
  168. %attr(4750,root,gnokii) %{_sbindir}/mgnokiidev
  169. %{_bindir}/gnokii
  170. %{_bindir}/sendsms
  171. %{_bindir}/gnokiid
  172. %{_libdir}/libgnokii.so.*
  173. %{_mandir}/man1/gnokii.1*
  174. %{_mandir}/man1/sendsms.1*
  175. %{_mandir}/man8/gnokiid.8*
  176. %{_mandir}/man8/mgnokiidev.8*
  177. %files -n xgnokii
  178. %defattr(-,root,root,-)
  179. %doc xgnokii/ChangeLog xgnokii/README.vcard
  180. %{_bindir}/xgnokii
  181. %{_datadir}/pixmaps/xgnokii.png
  182. %{_datadir}/applications/*xgnokii.desktop
  183. %{_mandir}/man1/xgnokii.1*
  184. %files smsd
  185. %defattr(-,root,root,-)
  186. %doc smsd/action smsd/ChangeLog smsd/README README.smsd2mail smsd2mail.sh
  187. %attr(-,gnokii,gnokii) %config(noreplace) %{_sysconfdir}/sysconfig/gnokii-smsd
  188. %config(noreplace) %{_sysconfdir}/logrotate.d/gnokii-smsd
  189. %{_initrddir}/gnokii-smsd
  190. %{_bindir}/gnokii-smsd
  191. %{_mandir}/man8/gnokii-smsd.8*
  192. %dir %{_libdir}/smsd/
  193. %{_libdir}/smsd/libsmsd_file.so
  194. %{_libdir}/smsd/libsmsd_sqlite.so
  195. %files smsd-pgsql
  196. %defattr(-,root,root,-)
  197. %doc smsd/sms.tables.pq.sql
  198. %{_libdir}/smsd/libsmsd_pq.so
  199. %files smsd-mysql
  200. %defattr(-,root,root,-)
  201. %doc smsd/sms.tables.mysql.sql
  202. %{_libdir}/smsd/libsmsd_mysql.so
  203. %files devel
  204. %defattr(-,root,root,-)
  205. %{_includedir}/gnokii*
  206. %{_libdir}/libgnokii.so
  207. %{_libdir}/pkgconfig/gnokii.pc
  208. %{_libdir}/pkgconfig/xgnokii.pc
  209. #----------------------------------------------------------------------------
  210. # Maintainers: babasaki@mindgear.org
  211. #
  212. #----------------------------------------------------------------------------
  213. %changelog
  214. * Sun Aug 02 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.31-3
  215. - rebuild with readline-6.3
  216. * Mon Feb 23 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.6.31-2
  217. - rebuilt with libical 1.0.1
  218. * Mon Dec 1 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.6.31-1
  219. - new upstream release
  220. - updated Patch1
  221. - built with libmysqlclient 10.0.15 and libpq 9.3.4
  222. - updated BR for libmysqlclient-devel and libpq-devel
  223. - added BR: pcsc-lite-devel
  224. * Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.30-1
  225. - new upstream release
  226. - remove Patch0
  227. - add BuildRequires: sqlite3-devel
  228. * Sun May 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.27-7
  229. - add BuildRequires: readline-devel
  230. * Tue Apr 12 2011 Shu KONNO <owa@bg.wakwak.com> 0.6.27-6
  231. - rebuilt with postgresql-9.0.3
  232. * Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.6.27-5
  233. - rebuilt with rpm-4.8.1 for pkg-config
  234. * Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.6.27-4
  235. - rebuilt with MySQL-5.1.34.
  236. * Mon Oct 27 2008 Seiichirou Babasaki - 0.6.27-3
  237. - Import gnokii - Packager: Babasaki
  238. - Updated specfile
  239. #----------------------------------------------------------------------------
  240. * Mon Oct 06 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.27-2
  241. - Fix htmlview patch
  242. * Mon Oct 06 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.27-1
  243. - Update to 0.6.27
  244. * Thu Sep 11 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.26-3
  245. - Rebuild
  246. * Thu Jun 19 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.26-2
  247. - Rebuild with libical support
  248. * Wed Jun 11 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.26-1
  249. - Update to 0.6.26
  250. * Fri May 23 2008 Robert Scheck <robert@fedoraproject.org> 0.6.25-2
  251. - Set empty --vendor rather none for using desktop-file-install
  252. - Fixed initscript as gnokii-smsd stays in /usr/bin not /usr/sbin
  253. * Mon May 19 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.25-1
  254. - Update to 0.6.25
  255. * Thu Mar 20 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.24-1
  256. - Update to 0.6.24
  257. * Mon Feb 11 2008 - Linus Walleij <triad@df.lth.se> - 0.6.22-3
  258. - Rebuild for GCC 4.3.
  259. * Thu Dec 6 2007 - Linus Walleij <triad@df.lth.se> - 0.6.22-2
  260. - Pick up new libssl .solib version dependency.
  261. * Thu Nov 29 2007 - Bastien Nocera <bnocera@redhat.com> - 0.6.22-1
  262. - Update to 0.6.22
  263. * Thu Nov 01 2007 - Bastien Nocera <bnocera@redhat.com> - 0.6.20-1
  264. - Update to 0.6.20
  265. * Sun Oct 28 2007 Jeremy Katz <katzj@redhat.com> - 0.6.18-3
  266. - Even better multilib fixing (#335161)
  267. * Tue Oct 23 2007 - Jeremy Katz <katzj@redhat.com> - 0.6.18-2
  268. - Quick fix to multilib conflict (#335161)
  269. * Fri Aug 17 2007 - Linus Walleij <triad@df.lth.se> - 0.6.18-1
  270. - New upstream release
  271. * Fri Aug 17 2007 - Linus Walleij <triad@df.lth.se> - 0.6.17-2
  272. - Update license field from GPL to GPLv2+
  273. * Wed Jul 04 2007 - Bastien Nocera <bnocera@redhat.com> - 0.6.17-1
  274. - New upstream release
  275. * Mon Jul 02 2007 - Bastien Nocera <bnocera@redhat.com> - 0.6.16-1
  276. - New upstream release
  277. - Update smsd name change patch
  278. - ppm2nokia, waitcall and todologo have moved to gnokii-extras, as per
  279. upstream
  280. * Wed Dec 06 2006 Linus Walleij <triad@df.lth.se> - 0.6.14-3
  281. - Rebuild to pick up new libpq IF
  282. * Thu Oct 05 2006 Christian Iseli <Christian.Iseli@licr.org> 0.6.14-2
  283. - rebuilt for unwind info generation, broken in gcc-4.1.1-21
  284. * Sat Sep 23 2006 Linus Walleij <triad@df.lth.se> - 0.6.14-1
  285. - New upstream release.
  286. * Tue Aug 29 2006 Linus Walleij <triad@df.lth.se> - 0.6.13-3
  287. - Rebuild for Fedora Extras 6.
  288. * Fri Aug 11 2006 Linus Walleij <triad@df.lth.se> - 0.6.13-2
  289. - Bump because tagged before committing sources and I just
  290. dont know how the f* you delete a tag in CVS at the moment
  291. and it does seem like a too big endavour to find out just
  292. in order to have a nice release tag.
  293. * Thu Aug 10 2006 Linus Walleij <triad@df.lth.se> - 0.6.13-1
  294. - New upstream release.
  295. - New dependency on libusb for USB serial, DKU no longer needed/wanted
  296. so now we have that troublesome issue resolved once and for all.
  297. - Remove patches to SQL files: these are now fixed upstream!
  298. * Mon Jun 12 2006 Linus Walleij <triad@df.lth.se> - 0.6.12-4
  299. - Rebuilding due to changed interface on libbluetooth.
  300. * Sun Apr 2 2006 Linus Walleij <triad@df.lth.se> - 0.6.12-4
  301. - Goofed up. Fixit it...
  302. * Sun Apr 2 2006 Linus Walleij <triad@df.lth.se> - 0.6.12-3
  303. - Post-import updates.
  304. * Fri Mar 31 2006 Linus Walleij <triad@df.lth.se> - 0.6.12-2
  305. - Updated after comments from Ville.
  306. * Thu Mar 16 2006 Linus Walleij <triad@df.lth.se> - 0.6.12-1
  307. - New upstream tarball
  308. * Wed Mar 8 2006 Linus Walleij <triad@df.lth.se> - 0.6.11-2
  309. - Updated after comments from Ville.
  310. * Sun Mar 5 2006 Linus Walleij <triad@df.lth.se> - 0.6.11-1
  311. - 0.6.11
  312. - Modified to drop into the Fedora Extras as the nice package it now is
  313. - Based work off Ville's good olde package
  314. * Sun Nov 13 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.6.10-0.lvn.1
  315. - 0.6.10.
  316. - Clean up pkgconfig file and -devel dependencies from bits needed only
  317. for static libs.
  318. * Thu Nov 3 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.6.9-0.lvn.1
  319. - 0.6.9, desktop entry file included upstream.
  320. - Drop zero Epochs.
  321. * Sat Aug 6 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.8-0.lvn.1
  322. - 0.6.8.
  323. - Don't ship static libraries.
  324. - Rename smsd to gnokii-smsd to avoid conflicts with smstools.
  325. - Remove not included files instead of using %%exclude.
  326. * Sat Jun 4 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.7-0.lvn.2
  327. - BuildRequire openssl-devel to work around https://bugzilla.redhat.com/159569
  328. * Thu Jun 2 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.7-0.lvn.1
  329. - 0.6.7.
  330. - Build unconditionally with bluetooth support.
  331. * Mon May 2 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.5-0.lvn.1
  332. - 0.6.5.
  333. * Fri Nov 5 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.4-0.lvn.2
  334. - Rename -smsd-postgresql to -smsd-pgsql for consistency with other similar
  335. packages in FC/Extras.
  336. * Fri Oct 22 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.4-0.lvn.1
  337. - Update to 0.6.4, perms and pgsql patches applied upstream.
  338. - Xgnokii help locale symlink hack no longer necessary.
  339. - Don't remove user/group on last erase, move smsd user to -smsd subpackage.
  340. - Add libical support (disabled), rebuild with "--with libical" to enable.
  341. * Mon Jul 5 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.3-0.lvn.1
  342. - Update to 0.6.3.
  343. * Sun Jun 20 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.1-0.lvn.4
  344. - Improve Xgnokii desktop entry according to GNOME HIG.
  345. * Sun Jun 13 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.1-0.lvn.3
  346. - Remove duplicate gettext build dependency (bug 95).
  347. * Sun Jun 6 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.1-0.lvn.2
  348. - Fix chown syntax in smsd init script.
  349. - Summary and description improvements.
  350. - Trim $RPM_OPT_FLAGS out from gnokii.pc.
  351. - Make -devel require XFree86-devel.
  352. * Sun Apr 18 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.1-0.lvn.1
  353. - Update to 0.6.1.
  354. * Thu Mar 18 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.0-0.lvn.2
  355. - Make -devel require pkgconfig.
  356. * Mon Feb 23 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.0-0.lvn.1
  357. - Update to 0.6.0.
  358. * Mon Feb 2 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.10-0.lvn.1
  359. - Update to 0.5.10.
  360. * Tue Jan 27 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.9-0.lvn.1
  361. - Update to 0.5.9.
  362. - Specfile cleanups, small init script enhancements.
  363. * Sat Dec 27 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.7-0.lvn.1
  364. - Update to 0.5.7.
  365. - Move smsd man page into -smsd subpackage.
  366. * Sat Nov 15 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.6-0.lvn.1
  367. - Update to 0.5.6.
  368. - Include sample action script for forwarding SMSD messages to mail.
  369. - s/fedora/livna/.
  370. - Specfile and init script cleanups.
  371. * Sat Jul 19 2003 Warren Togami <warren@togami.com> - 0:0.5.2-0.fdr.2
  372. - Disable smp flags to prevent build failure
  373. * Sun Jun 15 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.2-0.fdr.1
  374. - Update to 0.5.2.
  375. * Thu May 29 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.1-0.fdr.1
  376. - Update to 0.5.1.
  377. - Include init script, sysconfig and logrotate config for smsd.
  378. * Tue May 27 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.0-0.fdr.1
  379. - Update to 0.5.0.
  380. * Sun Nov 3 2002 Ville Skyttä <ville.skytta at iki.fi> 0.4.3-1cr
  381. - RedHat'ified PLD version.