git-vl.spec 25 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828829830831832833834835836837838839840841842843844845846847
  1. %bcond_with arch
  2. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  3. %define emacsen_pkgdir /usr/lib/emacsen-common/packages
  4. # Pass --without docs to rpmbuild if you don't want the documentation
  5. Name: git
  6. Version: 2.8.2
  7. Release: 1%{?_dist_release}
  8. Summary: Core git tools
  9. Summary(ja): Core git ツール
  10. License: GPLv2
  11. Group: Development/Tools
  12. URL: http://git-scm.com/
  13. Source0: https://www.kernel.org/pub/software/scm/git/%{name}-%{version}.tar.xz
  14. Source1: vine-default-git.el
  15. Source2: git.xinetd
  16. Source3: git.conf.httpd
  17. Source4: gitweb.conf.in
  18. Source10: %{name}-install.sh
  19. Source11: %{name}-remove.sh
  20. Source12: git-init.el
  21. Patch0: git-1.5-gitweb-home-link.patch
  22. # Security
  23. # none
  24. BuildRequires: zlib-devel >= 1.2, openssl-devel, curl-devel
  25. BuildRequires: expat-devel, gettext, asciidoc
  26. BuildRequires: pcre-devel
  27. BuildRequires: xmlto
  28. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  29. Requires: perl-Git = %{version}-%{release}
  30. Requires: zlib
  31. Provides: git-core = %{version}-%{release}
  32. Obsoletes: git-core <= 1.5.4.3
  33. Vendor: Project Vine
  34. Distribution: Vine Linux
  35. Packager: iwaim
  36. %description
  37. Git is a fast, scalable, distributed revision control system with an
  38. unusually rich command set that provides both high-level operations
  39. and full access to internals.
  40. The git rpm installs the core tools with minimal dependencies. To
  41. install all git packages, including tools for integrating with other
  42. SCMs, install the git-all meta-package.
  43. %package all
  44. Summary: Meta-package to pull in all git tools
  45. Summary(ja): すべての git ツール
  46. Group: Development/Tools
  47. Requires: git = %{version}-%{release}
  48. Requires: git-svn = %{version}-%{release}
  49. Requires: git-cvs = %{version}-%{release}
  50. %if "%{?_dist_release}" != "vl4" && %{with arch}
  51. Requires: git-arch = %{version}-%{release}
  52. %endif
  53. Requires: git-email = %{version}-%{release}
  54. Requires: gitk = %{version}-%{release}
  55. Requires: git-gui = %{version}-%{release}
  56. Requires: perl-Git = %{version}-%{release}
  57. Requires: emacs-git = %{version}-%{release}
  58. Requires: git-contrib = %{version}-%{release}
  59. Obsoletes: git <= 1.5.4.3
  60. %description all
  61. Git is a fast, scalable, distributed revision control system with an
  62. unusually rich command set that provides both high-level operations
  63. and full access to internals.
  64. This is a dummy package which brings in all subpackages.
  65. %package daemon
  66. Summary: Git protocol daemon
  67. Summary(ja): Git プロトコルデーモン
  68. Group: Development/Tools
  69. Requires: git = %{version}-%{release}
  70. %description daemon
  71. The git daemon for supporting git:// access to git repositories
  72. %package -n gitweb
  73. Summary: Simple web interface to git repositories
  74. Summary(ja): git リポジトリへのシンプルな Web インタフェース
  75. Group: Development/Tools
  76. Requires: git = %{version}-%{release}
  77. %description -n gitweb
  78. Simple web interface to track changes in git repositories
  79. %package svn
  80. Summary: Git tools for importing Subversion repositories
  81. Summary(ja): Subversion リポジトリを git へインポートするためのツール
  82. Group: Development/Tools
  83. Requires: git = %{version}-%{release}, subversion, perl(Term::ReadKey)
  84. Requires: perl(SVN::Core)
  85. %description svn
  86. Git tools for importing Subversion repositories.
  87. %package cvs
  88. Summary: Git tools for importing CVS repositories
  89. Summary(ja): CVS リポジトリを git へインポートするためのツール
  90. Group: Development/Tools
  91. Requires: git = %{version}-%{release}, cvs, cvsps
  92. %description cvs
  93. Git tools for importing CVS repositories.
  94. %package contrib
  95. Summary: Git contrib tools
  96. Group: Development/Tools
  97. Requires: git = %{version}-%{release}
  98. %description contrib
  99. Git contrib tools
  100. %if "%{?_dist_release}" != "vl4" && %{with arch}
  101. %package arch
  102. Summary: Git tools for importing Arch repositories
  103. Summary(ja): Arch リポジトリを git へインポートするためのツール
  104. Group: Development/Tools
  105. Requires: git = %{version}-%{release}, tla
  106. %description arch
  107. Git tools for importing Arch repositories.
  108. %endif
  109. %package email
  110. Summary: Git tools for sending email
  111. Summary(ja): Eメールを送るための git ツール
  112. Group: Development/Tools
  113. Requires: git = %{version}-%{release}, perl-Git = %{version}-%{release}
  114. %description email
  115. Git tools for sending email.
  116. %package gui
  117. Summary: Git GUI tool
  118. Summary(ja): Git の GUI ツール
  119. Group: Development/Tools
  120. Requires: git = %{version}-%{release}, tk
  121. %description gui
  122. Git GUI tool.
  123. %package -n gitk
  124. Summary: Git revision tree visualiser
  125. Summary(ja): Git リビジョンツリー可視化ツール
  126. Group: Development/Tools
  127. Requires: git = %{version}-%{release}, tk
  128. %description -n gitk
  129. Git revision tree visualiser.
  130. %package -n perl-Git
  131. Summary: Perl interface to Git
  132. Summary(ja): Git の perl インタフェース
  133. Group: Development/Libraries
  134. Requires: git = %{version}-%{release}, perl(Error)
  135. %if "%{?_dist_release}" == "vl4"
  136. Requires: perl = %(rpm -q --qf '%%{epoch}:%%{version}' perl)
  137. %else
  138. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  139. %endif
  140. #BuildRequires: perl(Error), perl(ExtUtils::MakeMaker)
  141. %description -n perl-Git
  142. Perl interface to Git.
  143. %package -n emacs-git
  144. Summary: Git version control system support for Emacs
  145. Summary(ja): Emacs の Git サポート
  146. Group: Applications/Editors
  147. Requires: git = %{version}-%{release}, emacsen-common
  148. %description -n emacs-git
  149. %{summary}.
  150. %package devel
  151. Summary: Header files for git-core
  152. Summary(ja): git-core 用ヘッダファイル
  153. Group: Development/Libraries
  154. %description devel
  155. Header files for git-core.
  156. %prep
  157. %setup -q
  158. %patch0 -p1
  159. %__mv contrib/diff-highlight/README contrib/diff-highlight/README.diff-highlight
  160. # Filter bogus perl requires
  161. cat << \EOF > %{name}-req
  162. #!/bin/sh
  163. %{__perl_requires} $* |\
  164. sed -e '/perl(packed-refs)/d'
  165. EOF
  166. %global __perl_requires %{_builddir}/%{name}-%{version}/%{name}-req
  167. chmod +x %{__perl_requires}
  168. %build
  169. make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" \
  170. ETC_GITCONFIG=/etc/gitconfig \
  171. USE_LIBPCRE=1 \
  172. GITWEB_PROJECTROOT=/var/lib/git \
  173. gitwebdir=/var/www/git \
  174. prefix=%{_prefix} all %{!?_without_docs: doc}
  175. %install
  176. rm -rf $RPM_BUILD_ROOT
  177. make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" DESTDIR=$RPM_BUILD_ROOT \
  178. prefix=%{_prefix} mandir=%{_mandir} \
  179. ETC_GITCONFIG=/etc/gitconfig \
  180. USE_LIBPCRE=1 \
  181. NO_PYTHON=1 \
  182. GITWEB_PROJECTROOT=/var/lib/git \
  183. gitwebdir=/var/www/git \
  184. INSTALLDIRS=vendor install %{!?_without_docs: install-doc}
  185. # perl-Git
  186. # Error.pm provide by perl-Error package
  187. rm -rf $RPM_BUILD_ROOT%{perl_vendorlib}/Error.pm
  188. # emacs-git
  189. mkdir -p $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git
  190. #mkdir -p $RPM_BUILD_ROOT%{_libdir}/emacsen-common/packages/install
  191. #mkdir -p $RPM_BUILD_ROOT%{_libdir}/emacsen-common/packages/remove
  192. mkdir -p $RPM_BUILD_ROOT%{emacsen_pkgdir}/install
  193. mkdir -p $RPM_BUILD_ROOT%{emacsen_pkgdir}/remove
  194. # install el files
  195. install -m644 contrib/emacs/*.el $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git/
  196. # install vine-default file
  197. install -m644 %{SOURCE1} %{SOURCE12} $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git/
  198. # install script( bytecompile el and install elc , remove )
  199. %_installemacsenscript git %{SOURCE10}
  200. %_removeemacsenscript git %{SOURCE11}
  201. mkdir -p $RPM_BUILD_ROOT/%{_var}/lib/git
  202. mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d
  203. install -m 644 %SOURCE2 $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d/git
  204. perl -p \
  205. -e "s|\@GITCOREDIR\@|%{_libexecdir}/git-core|g;" \
  206. -e "s|\@BASE_PATH\@|%{_var}/lib/git|g;" \
  207. %{SOURCE3} > %{buildroot}%{_sysconfdir}/xinetd.d/git
  208. ## for gitweb sub package
  209. mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d
  210. install -m 0644 %SOURCE3 $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d/git.conf
  211. sed "s|@PROJECTROOT@|%{_var}/lib/git|g" \
  212. %{SOURCE4} > %{buildroot}%{_sysconfdir}/gitweb.conf
  213. find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
  214. find $RPM_BUILD_ROOT -type f -name '*.bs' -empty -exec rm -f {} ';'
  215. find $RPM_BUILD_ROOT -type f -name perllocal.pod -exec rm -f {} ';'
  216. (find $RPM_BUILD_ROOT%{_libexecdir} -type f | grep -vE "archimport|svn|cvs|email|gitk|git-gui|git-citooli|git-daemon" | sed -e s@^$RPM_BUILD_ROOT@@) > bin-man-doc-files
  217. (find $RPM_BUILD_ROOT%{perl_vendorlib} -type f | sed -e s@^$RPM_BUILD_ROOT@@) >> perl-files
  218. %if %{!?_without_docs:1}0
  219. (find $RPM_BUILD_ROOT%{_mandir} $RPM_BUILD_ROOT/Documentation -type f | grep -vE "archimport|svn|git-cvs|email|gitk|git-gui|git-citool" | sed -e s@^$RPM_BUILD_ROOT@@ -e 's/$/*/' ) >> bin-man-doc-files
  220. %else
  221. rm -rf $RPM_BUILD_ROOT%{_mandir}
  222. %endif
  223. mkdir -p $RPM_BUILD_ROOT/srv/git
  224. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
  225. install -m 644 -T contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d/git
  226. install -m 755 contrib/diff-highlight/diff-highlight $RPM_BUILD_ROOT%{_bindir}/
  227. # header files and lib
  228. install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
  229. install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
  230. install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
  231. install libgit.a $RPM_BUILD_ROOT%{_libdir}
  232. install xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
  233. %find_lang %{name}
  234. %clean
  235. rm -rf $RPM_BUILD_ROOT
  236. %post -n emacs-git
  237. # bytecompile and install
  238. if [ "$1" = 2 ]; then
  239. %_emacsenPackageRemove git
  240. fi
  241. %_addemacsenlist git
  242. %_emacsenPackageInstall git
  243. %preun -n emacs-git
  244. if [ "$1" = 0 ]; then
  245. %_emacsenPackageRemove git
  246. %_removeemacsenlist git
  247. fi
  248. %files -f bin-man-doc-files -f %{name}.lang
  249. %defattr(-,root,root)
  250. %{_bindir}/git
  251. %{_bindir}/git-receive-pack
  252. %{_bindir}/git-upload-archive
  253. %{_bindir}/git-upload-pack
  254. %{_bindir}/git-shell
  255. %{_datadir}/git-core/
  256. %doc README COPYING Documentation/*.txt contrib/hooks
  257. %{!?_without_docs: %doc Documentation/*.html Documentation/docbook-xsl.css}
  258. %{!?_without_docs: %doc Documentation/howto Documentation/technical}
  259. %{_sysconfdir}/bash_completion.d
  260. %files svn
  261. %defattr(-,root,root)
  262. %{_libexecdir}/git-core/*svn*
  263. %doc Documentation/*svn*.txt
  264. %{!?_without_docs: %{_mandir}/man1/*svn*.1*}
  265. %{!?_without_docs: %doc Documentation/*svn*.html }
  266. %files cvs
  267. %defattr(-,root,root)
  268. %doc Documentation/*git-cvs*.txt
  269. %{_bindir}/git-cvsserver
  270. %{_libexecdir}/git-core/*cvs*
  271. %{!?_without_docs: %{_mandir}/man1/*cvs*.1*}
  272. %{!?_without_docs: %doc Documentation/*git-cvs*.html }
  273. %files contrib
  274. %defattr(-,root,root)
  275. %doc contrib/diff-highlight/README.diff-highlight
  276. %{_bindir}/diff-highlight
  277. %if "%{?_dist_release}" != "vl4" && %{with arch}
  278. %files arch
  279. %defattr(-,root,root)
  280. %doc Documentation/git-archimport.txt
  281. %{_libexecdir}/git-core/git-archimport
  282. %{!?_without_docs: %{_mandir}/man1/git-archimport.1*}
  283. %{!?_without_docs: %doc Documentation/git-archimport.html }
  284. %endif
  285. %files email
  286. %defattr(-,root,root)
  287. %doc Documentation/*email*.txt
  288. %{_libexecdir}/git-core/*email*
  289. %{!?_without_docs: %{_mandir}/man1/*email*.1*}
  290. %{!?_without_docs: %doc Documentation/*email*.html }
  291. %files gui
  292. %defattr(-,root,root)
  293. %{_libexecdir}/git-core/git-gui*
  294. %{_libexecdir}/git-core/git-citool
  295. %{_datadir}/git-gui/
  296. %{!?_without_docs: %{_mandir}/man1/git-gui.1*}
  297. %{!?_without_docs: %doc Documentation/git-gui.html}
  298. %{!?_without_docs: %{_mandir}/man1/git-citool.1*}
  299. %{!?_without_docs: %doc Documentation/git-citool.html}
  300. %files -n gitk
  301. %defattr(-,root,root)
  302. %doc Documentation/*gitk*.txt
  303. %{_bindir}/gitk
  304. %{_datadir}/gitk
  305. %{!?_without_docs: %{_mandir}/man1/*gitk*.1*}
  306. %{!?_without_docs: %doc Documentation/*gitk*.html }
  307. %files -n perl-Git -f perl-files
  308. %defattr(-,root,root)
  309. %files -n emacs-git
  310. %defattr(-,root,root)
  311. %{_datadir}/emacs/site-lisp/git
  312. #%{_libdir}/emacsen-common/packages/install/git
  313. #%{_libdir}/emacsen-common/packages/remove/git
  314. %{emacsen_pkgdir}/install/git
  315. %{emacsen_pkgdir}/remove/git
  316. %files daemon
  317. %defattr(-,root,root)
  318. %{_var}/lib/git
  319. %{_libexecdir}/git-core/git-daemon
  320. %config(noreplace)%{_sysconfdir}/xinetd.d/git
  321. /srv/git
  322. %files -n gitweb
  323. %defattr(-,root,root)
  324. %doc gitweb/README
  325. /var/www/git/
  326. %config(noreplace)%{_sysconfdir}/gitweb.conf
  327. %config(noreplace)%{_sysconfdir}/httpd/conf.d/git.conf
  328. %files devel
  329. %defattr(644,root,root,755)
  330. %{_includedir}/git
  331. %{_libdir}/libgit.a
  332. %{_libdir}/libgit_xdiff.a
  333. %files all
  334. # No files for you!
  335. %changelog
  336. * Sun May 8 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.8.2-1
  337. - update to 2.8.2.
  338. * Tue Apr 12 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.6.6-1
  339. - update to 2.6.6.
  340. * Thu Dec 31 2015 IWAI Masaharu <iwaim.sub@gmail.com> 2.6.4-1
  341. - update to 2.6.4
  342. - add locale files
  343. * Mon Dec 29 2014 IWAI Masaharu <iwaim.sub@gmail.com> 2.2.1-1
  344. - update to 2.2.1
  345. * Mon Jun 30 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 2.0.1-2
  346. - build with Perl 5.16
  347. * Thu Jun 26 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 2.0.1-1
  348. - update to 2.0.1
  349. - add "%%bcond_with arch": no create git-arch sub package by default
  350. * Fri Apr 18 2014 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-1
  351. - update to 1.9.2
  352. * Sun Dec 29 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.5.2-1
  353. - update to 1.8.5.2
  354. * Thu Nov 28 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.4.4-1
  355. - update to 1.8.4.4
  356. - new sub package: contrib
  357. * Fri Feb 8 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1.3-1
  358. - new upstream release
  359. * Tue Jan 29 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1.2-1
  360. - new upstream release
  361. * Thu Jan 17 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1.1-1
  362. - new upstream release
  363. * Thu Jan 3 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1-1
  364. - new upstream release
  365. * Wed Dec 12 2012 IWAI, Masaharu <iwai@alib.jp> 1.8.0.2-1
  366. - new upstream release
  367. * Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0.1-1
  368. - new upstream release
  369. * Mon Oct 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-1
  370. - new upstream release
  371. - enable libpcre support, add BR: pcre-devel
  372. - add /etc/gitweb.conf
  373. - add /var/lib/git for PROJECTROOT
  374. * Mon Sep 3 2012 IWAI, Masaharu <iwai@alib.jp> 1.7.12-1
  375. - new upstream release
  376. * Fri May 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.10.2-1
  377. - new upstream release
  378. * Sat May 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.10.1-1
  379. - new upstream release
  380. * Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.4.2-1
  381. - new upstream release
  382. * Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.5-2vl6
  383. - build with perl 5.12.3
  384. * Mon Jan 10 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.5-1
  385. - new upstream release
  386. - build with openssl 1.0.0c for VineSeed
  387. * Sat Jan 1 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.4-1
  388. - new upstream release: include security fix: CVE-2010-3906
  389. * Fri Oct 1 2010 IWAI, Masaharu <iwai@alib.jp> 1.7.3.1-1
  390. - new upstream release
  391. - drop CVE-2010-2542 patch (Patch100): upstream fixed
  392. - apply vine-default
  393. - rename Source1: git-init.el -> vine-default-git.el
  394. - add new git-init.el file (Source12)
  395. - update git-install.sh
  396. - update %%build and %%install section for gitweb subpackage
  397. - add README in gitweb subpackage
  398. * Tue Sep 28 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.1-2
  399. - add Patch100 for fix CVE-2010-2542 (BOF in is_git_directory)
  400. * Wed Jun 9 2010 IWAI, Masaharu <iwai@alib.jp> 1.7.1-1
  401. - new upstream release
  402. - fix git-daemon path in git.xinetd: <BTS:VineLinux:919>
  403. - disable building of unused python remote helper libs
  404. * Mon Jun 22 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.6.3.3-1
  405. - new upstream release with security fix
  406. - drop patch10 (included in new release)
  407. * Tue Jun 16 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.6.3.2-1
  408. - new upstream release
  409. - add patch10 git daemon extra arg parsing fix
  410. * Thu Apr 16 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.2.3-2
  411. - fix install script for Emacs Lisp: <BTS:VineLinux:685>
  412. - update git-install.sh (Source10) using contributed patch
  413. * Tue Apr 14 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.2.3-1
  414. - new upstream release
  415. * Sun Feb 22 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-3
  416. - delete arch sub package for Vine Linux 4.2: <BTS:VineLinux:667>
  417. - spec in EUC-JP for Vine Linux 4.2: <BTS:VineLinux:668>
  418. - fix summary and description in daemon sub package
  419. * Sun Feb 1 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-2
  420. - drop Error.pm: provide by perl-Error package
  421. * Thu Jan 29 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-1
  422. - new upstream relase
  423. - update URL tag
  424. - add Requires: perl(SVN::Core) for svn subpackage
  425. * Thu Jan 22 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1-3
  426. - add git-shell in git package
  427. - do not require perl(:MODULE_COMPAT_x.y.z) on Vine Linux 4.x
  428. * Mon Jan 5 2009 Shu KONNO <owa@bg.wakwak.com> - 1.6.1-2
  429. - added BuildRequires: xmlto
  430. * Mon Jan 5 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.6.1-1
  431. - new upstream release
  432. - add devel subpackage (see [wishes:0165])
  433. * Fri Oct 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.3-1
  434. - new upstream release
  435. * Mon Sep 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.2-1
  436. - new upstream release
  437. * Tue Aug 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.1-1
  438. - new upstream release
  439. * Mon Aug 25 2008 Shu KONNO <owa@bg.wakwak.com> 1.6.0-2
  440. - use %%emacsen_pkgdir macro
  441. * Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-1
  442. - new upstream release
  443. * Wed Aug 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6.4-1
  444. - initial build for Vine Linux
  445. * Thu Jul 24 2008 James Bowes <jbowes@redhat.com> 1.5.6-4
  446. - git-1.5.6.4
  447. * Thu Jun 19 2008 James Bowes <jbowes@redhat.com> 1.5.6-1
  448. - git-1.5.6
  449. * Tue Jun 3 2008 Stepan Kasal <skasal@redhat.com> 1.5.5.3-2
  450. - use tar.bz2 instead of tar.gz
  451. * Wed May 28 2008 James Bowes <jbowes@redhat.com> 1.5.5.3-1
  452. - git-1.5.5.3
  453. * Mon May 26 2008 James Bowes <jbowes@redhat.com> 1.5.5.2-1
  454. - git-1.5.5.2
  455. * Mon Apr 21 2008 James Bowes <jbowes@redhat.com> 1.5.5.1-1
  456. - git-1.5.5.1
  457. * Wed Apr 09 2008 James Bowes <jbowes@redhat.com> 1.5.5-1
  458. - git-1.5.5
  459. * Fri Apr 04 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-3
  460. - Remove the last two requires on git-core.
  461. * Wed Apr 02 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-2
  462. - Remove a patch that's already upstream.
  463. * Fri Mar 28 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-1
  464. - git-1.5.4.5
  465. * Wed Mar 26 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-4
  466. - Own /etc/bash_completion.d in case bash-completion isn't installed.
  467. * Tue Mar 25 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-3
  468. - Include the sample hooks from contrib/hooks as docs (bug 321151).
  469. - Install the bash completion script from contrib (bug 433255).
  470. - Include the html docs in the 'core' package again (bug 434271).
  471. * Wed Mar 19 2008 James Bowes 1.5.4.4-2
  472. - Obsolete git <= 1.5.4.3, to catch going from F8 to rawhide/F9
  473. * Thu Mar 13 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-1
  474. - git-1.5.4.4
  475. * Mon Mar 3 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5.4.3-3
  476. - rebuild for new perl (again)
  477. * Sun Feb 24 2008 Bernardo Innocenti <bernie@codewiz.org> 1.5.4.3-2
  478. - Do not silently overwrite /etc/httpd/conf.d/git.conf
  479. * Sat Feb 23 2008 James Bowes <jbowes@redhat.com> 1.5.4.3-1
  480. - git-1.5.4.3
  481. - Include Kristian Høgsberg's changes to rename git-core to
  482. git and git to git-all.
  483. * Sun Feb 17 2008 James Bowes <jbowes@redhat.com> 1.5.4.2-1
  484. - git-1.5.4.2
  485. * Mon Feb 11 2008 Jeremy Katz <katzj@redhat.com> - 1.5.4.1-2
  486. - Add upstream patch (e62a641de17b172ffc4d3a803085c8afbfbec3d1) to have
  487. gitweb rss feeds point be commitdiffs instead of commit
  488. * Sun Feb 10 2008 James Bowes <jbowes@redhat.com> 1.5.4.1-1
  489. - git-1.5.4.1
  490. * Tue Feb 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5.4-3
  491. - rebuild for new perl
  492. * Sun Feb 03 2008 James Bowes <jbowes@redhat.com> 1.5.4-1
  493. - Add BuidRequires on gettext.
  494. * Sat Feb 02 2008 James Bowes <jbowes@redhat.com> 1.5.4-1
  495. - git-1.5.4
  496. * Tue Jan 08 2008 James Bowes <jbowes@redhat.com> 1.5.3.8-1
  497. - git-1.5.3.8
  498. * Fri Dec 21 2007 James Bowes <jbowes@redhat.com> 1.5.3.7-2
  499. - Have git metapackage require explicit versions (bug 247214)
  500. * Mon Dec 03 2007 Josh Boyer <jwboyer@gmail.com> 1.5.3.7-1
  501. - git-1.5.3.7
  502. * Tue Nov 27 2007 Josh Boyer <jwboyer@gmail.com> 1.5.3.6-1
  503. - git-1.5.3.6
  504. - git-core requires perl(Error) (bug 367861)
  505. - git-svn requires perl(Term:ReadKey) (bug 261361)
  506. - git-email requires perl-Git (bug 333061)
  507. * Wed Oct 24 2007 Lubomir Kundrak <lkundrak@redhat.com> 1.5.3.4-2
  508. - git-Perl requires Error package
  509. * Tue Oct 09 2007 James Bowes <jbowes@redhat.com> 1.5.3.4-1
  510. - git-1.5.3.4
  511. * Sun Sep 30 2007 James Bowes <jbowes@redhat.com> 1.5.3.3-1
  512. - git-1.5.3.3
  513. * Wed Sep 26 2007 James Bowes <jbowes@redhat.com> 1.5.3.2-1
  514. - git-1.5.3.2
  515. * Thu Sep 06 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.3.1-2
  516. - Include git-gui and git-citool docs
  517. * Thu Sep 06 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.3.1-1
  518. - git-1.5.3.1-1
  519. * Thu Aug 23 2007 James Bowes <jbowes@redhat.com> 1.5.2.5-1
  520. - git-1.5.2.5-1
  521. * Fri Aug 03 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.4-1
  522. - git-1.5.2.4-1
  523. * Tue Jul 03 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.2-3
  524. - Add git-daemon and gitweb packages
  525. * Thu Jun 21 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.2-2
  526. - Add emacs-git package (#235431)
  527. * Mon Jun 18 2007 James Bowes <jbowes@redhat.com> 1.5.2.2-1
  528. - git-1.5.2.2
  529. * Fri Jun 08 2007 James Bowes <jbowes@redhat.com> 1.5.2.1-1
  530. - git-1.5.2.1
  531. * Sun May 13 2007 Quy Tonthat <qtonthat@gmail.com>
  532. - Added lib files for git-gui
  533. - Added Documentation/technical (As needed by Git Users Manual)
  534. * Tue May 8 2007 Quy Tonthat <qtonthat@gmail.com>
  535. - Added howto files
  536. * Fri Mar 30 2007 Chris Wright <chrisw@redhat.com> 1.5.0.6-1
  537. - git-1.5.0.6
  538. * Mon Mar 19 2007 Chris Wright <chrisw@redhat.com> 1.5.0.5-1
  539. - git-1.5.0.5
  540. * Tue Mar 13 2007 Chris Wright <chrisw@redhat.com> 1.5.0.3-1
  541. - git-1.5.0.3
  542. * Fri Mar 2 2007 Chris Wright <chrisw@redhat.com> 1.5.0.2-2
  543. - BuildRequires perl-devel as of perl-5.8.8-14 (bz 230680)
  544. * Mon Feb 26 2007 Chris Wright <chrisw@redhat.com> 1.5.0.2-1
  545. - git-1.5.0.2
  546. * Tue Feb 13 2007 Nicolas Pitre <nico@cam.org>
  547. - Update core package description (Git isn't as stupid as it used to be)
  548. * Mon Feb 12 2007 Junio C Hamano <junkio@cox.net>
  549. - Add git-gui and git-citool.
  550. * Sun Dec 10 2006 Chris Wright <chrisw@redhat.com> 1.4.4.2-2
  551. - no need to install manpages executable (bz 216790)
  552. - use bytes for git-cvsserver
  553. * Sun Dec 10 2006 Chris Wright <chrisw@redhat.com> 1.4.4.2-1
  554. - git-1.4.4.2
  555. * Mon Nov 6 2006 Jindrich Novy <jnovy@redhat.com> 1.4.2.4-2
  556. - rebuild against the new curl
  557. * Tue Oct 17 2006 Chris Wright <chrisw@redhat.com> 1.4.2.4-1
  558. - git-1.4.2.4
  559. * Wed Oct 4 2006 Chris Wright <chrisw@redhat.com> 1.4.2.3-1
  560. - git-1.4.2.3
  561. * Fri Sep 22 2006 Chris Wright <chrisw@redhat.com> 1.4.2.1-1
  562. - git-1.4.2.1
  563. * Mon Sep 11 2006 Chris Wright <chrisw@redhat.com> 1.4.2-1
  564. - git-1.4.2
  565. * Thu Jul 6 2006 Chris Wright <chrisw@redhat.com> 1.4.1-1
  566. - git-1.4.1
  567. * Tue Jun 13 2006 Chris Wright <chrisw@redhat.com> 1.4.0-1
  568. - git-1.4.0
  569. * Thu May 4 2006 Chris Wright <chrisw@redhat.com> 1.3.3-1
  570. - git-1.3.3
  571. - enable git-email building, prereqs have been relaxed
  572. * Thu May 4 2006 Chris Wright <chrisw@redhat.com> 1.3.2-1
  573. - git-1.3.2
  574. * Fri Apr 28 2006 Chris Wright <chrisw@redhat.com> 1.3.1-1
  575. - git-1.3.1
  576. * Wed Apr 19 2006 Chris Wright <chrisw@redhat.com> 1.3.0-1
  577. - git-1.3.0
  578. * Mon Apr 10 2006 Chris Wright <chrisw@redhat.com> 1.2.6-1
  579. - git-1.2.6
  580. * Wed Apr 5 2006 Chris Wright <chrisw@redhat.com> 1.2.5-1
  581. - git-1.2.5
  582. * Wed Mar 1 2006 Chris Wright <chrisw@redhat.com> 1.2.4-1
  583. - git-1.2.4
  584. * Wed Feb 22 2006 Chris Wright <chrisw@redhat.com> 1.2.3-1
  585. - git-1.2.3
  586. * Tue Feb 21 2006 Chris Wright <chrisw@redhat.com> 1.2.2-1
  587. - git-1.2.2
  588. * Thu Feb 16 2006 Chris Wright <chrisw@redhat.com> 1.2.1-1
  589. - git-1.2.1
  590. * Mon Feb 13 2006 Chris Wright <chrisw@redhat.com> 1.2.0-1
  591. - git-1.2.0
  592. * Wed Feb 1 2006 Chris Wright <chrisw@redhat.com> 1.1.6-1
  593. - git-1.1.6
  594. * Tue Jan 24 2006 Chris Wright <chrisw@redhat.com> 1.1.4-1
  595. - git-1.1.4
  596. * Sun Jan 15 2006 Chris Wright <chrisw@redhat.com> 1.1.2-1
  597. - git-1.1.2
  598. * Tue Jan 10 2006 Chris Wright <chrisw@redhat.com> 1.1.1-1
  599. - git-1.1.1
  600. * Tue Jan 10 2006 Chris Wright <chrisw@redhat.com> 1.1.0-1
  601. - Update to latest git-1.1.0 (drop git-email for now)
  602. - Now creates multiple packages:
  603. - git-core, git-svn, git-cvs, git-arch, gitk
  604. * Mon Nov 14 2005 H. Peter Anvin <hpa@zytor.com> 0.99.9j-1
  605. - Change subpackage names to git-<name> instead of git-core-<name>
  606. - Create empty root package which brings in all subpackages
  607. - Rename git-tk -> gitk
  608. * Thu Nov 10 2005 Chris Wright <chrisw@osdl.org> 0.99.9g-1
  609. - zlib dependency fix
  610. - Minor cleanups from split
  611. - Move arch import to separate package as well
  612. * Tue Sep 27 2005 Jim Radford <radford@blackbean.org>
  613. - Move programs with non-standard dependencies (svn, cvs, email)
  614. into separate packages
  615. * Tue Sep 27 2005 H. Peter Anvin <hpa@zytor.com>
  616. - parallelize build
  617. - COPTS -> CFLAGS
  618. * Fri Sep 16 2005 Chris Wright <chrisw@osdl.org> 0.99.6-1
  619. - update to 0.99.6
  620. * Fri Sep 16 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
  621. - Linus noticed that less is required, added to the dependencies
  622. * Sun Sep 11 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
  623. - Updated dependencies
  624. - Don't assume manpages are gzipped
  625. * Thu Aug 18 2005 Chris Wright <chrisw@osdl.org> 0.99.4-4
  626. - drop sh_utils, sh-utils, diffutils, mktemp, and openssl Requires
  627. - use RPM_OPT_FLAGS in spec file, drop patch0
  628. * Wed Aug 17 2005 Tom "spot" Callaway <tcallawa@redhat.com> 0.99.4-3
  629. - use dist tag to differentiate between branches
  630. - use rpm optflags by default (patch0)
  631. - own %{_datadir}/git-core/
  632. * Mon Aug 15 2005 Chris Wright <chrisw@osdl.org>
  633. - update spec file to fix Buildroot, Requires, and drop Vendor
  634. * Sun Aug 07 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
  635. - Redid the description
  636. - Cut overlong make line, loosened changelog a bit
  637. - I think Junio (or perhaps OSDL?) should be vendor...
  638. * Thu Jul 14 2005 Eric Biederman <ebiederm@xmission.com>
  639. - Add the man pages, and the --without docs build option
  640. * Thu Jul 7 2005 Chris Wright <chris@osdl.org>
  641. - initial git spec file