ghc-bootstrap-vl.spec 1.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778
  1. %define pkg_name ghc-bootstrap
  2. %define pkg_version 7.10.3
  3. %define pkg_release 1%{?_dist_release}
  4. %ifarch %{ix86}
  5. %define rpmarch i386
  6. %endif
  7. %ifarch x86_64
  8. %define rpmarch x86_64
  9. %endif
  10. %define dlurl https://www.haskell.org/ghc/dist
  11. %define filename ghc-%{pkg_version}-%{rpmarch}-deb8-linux.tar.bz2
  12. Summary: ghc binary for build ghc
  13. Name: %{pkg_name}
  14. Version: %{pkg_version}
  15. Release: %{pkg_release}
  16. License: BSD-like
  17. Group: Applications/Languages
  18. URL: https://www.haskell.org/ghc
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  20. BuildRequires: wget
  21. Vendor: Project Vine
  22. Distribution: Vine Linux
  23. Packager: ara_t
  24. %description
  25. The Glasgow Haskell Compiler (GHC) is a state-of-the-art, open source,
  26. compiler and interactive environment for the functional language Haskell.
  27. This package is ghc binary for building ghc.
  28. %prep
  29. %{__rm} -rf ${RPM_BUILD_ROOT}
  30. wget %{dlurl}/%{version}/%{filename}
  31. %build
  32. %{__tar} xf %{filename}
  33. cd ghc-%{version}
  34. ./configure --prefix=%{_prefix} --libdir=%{_libdir}
  35. %install
  36. cd ghc-%{version}
  37. %{make_install}
  38. %{__mv} ${RPM_BUILD_ROOT}%{_docdir}/ghc \
  39. ${RPM_BUILD_ROOT}%{_docdir}/ghc-%{version} \
  40. %clean
  41. %{__rm} -rf ${RPM_BUILD_ROOT}
  42. %post -p %{_syssbindir}/ldconfig
  43. %postun -p %{_syssbindir}/ldconfig
  44. %files
  45. %defattr(-, root, root)
  46. %{_bindir}/
  47. %{_libdir}/ghc-%{version}/
  48. %{_docdir}/ghc-%{version}/
  49. %{_mandir}/man1/
  50. %changelog
  51. * Sun Apr 10 2016 Toshiaki Ara <ara_t@384.jp> 7.10.3-1
  52. - update to 7.10.3-1
  53. * Sun Apr 10 2016 Toshiaki Ara <ara_t@384.jp> 7.6.3-2
  54. - coorect SPEC file
  55. * Tue Feb 02 2016 Toshiaki Ara <ara_t@384.jp> 7.6.3-1
  56. - new package