gdb-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428
  1. Summary: A GNU source-level debugger for C, C++ and other languages.
  2. Summary(ja): C, C++ その他の言語用 GNU ソースレベルデバッガ
  3. Name: gdb
  4. Version: 7.11
  5. Release: 1%{?_dist_release}
  6. License: GPL
  7. Group: Development/Debuggers
  8. Source: ftp://sources.redhat.com/pub/gdb/releases/gdb-%{version}.tar.xz
  9. Buildroot: %{_tmppath}/%{name}-%{version}-root
  10. URL: http://sources.redhat.com/gdb/
  11. BuildRequires: ncurses-devel glibc-devel gcc make gzip texinfo expat-devel
  12. BuildRequires: python-devel
  13. BuildRequires: zlib-devel
  14. Requires: install-info
  15. Vendor: Project Vine
  16. Distribution: Vine Linux
  17. Packager: Takemikaduchi
  18. %description
  19. GDB, the GNU debugger, allows you to debug programs written in C, C++,
  20. and other languages, by executing them in a controlled fashion and
  21. printing their data.
  22. %description -l ja
  23. GDB (GNU デバッガ) は C, C++ その他の言語で書かれたプログラムのデバッグに
  24. 使うツールです.プログラムの実行を制御し,データを出力することができます.
  25. %prep
  26. %setup -q
  27. %build
  28. export CFLAGS="$RPM_OPT_FLAGS"
  29. rm -fr dejagnu tcl expect
  30. ./configure \
  31. --prefix=%{_prefix} \
  32. --sysconfdir=%{_sysconfdir} \
  33. --mandir=%{_mandir} \
  34. --infodir=%{_infodir} \
  35. %{_target_platform}
  36. make
  37. make info
  38. cp gdb/NEWS .
  39. %install
  40. rm -rf $RPM_BUILD_ROOT
  41. %makeinstall infodir=$RPM_BUILD_ROOT%{_infodir} prefix=$RPM_BUILD_ROOT%{_prefix}
  42. # The above is broken, do this for now:
  43. #mkdir -p $RPM_BUILD_ROOT/%{_infodir}
  44. #cp `find -name "*.info*"` $RPM_BUILD_ROOT/%{_infodir}
  45. # These are part of binutils
  46. #rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  47. #rm -f $RPM_BUILD_ROOT%{_infodir}/dir.info*
  48. rm -f $RPM_BUILD_ROOT%{_infodir}/bfd*
  49. rm -f $RPM_BUILD_ROOT%{_infodir}/configure*
  50. rm -f $RPM_BUILD_ROOT%{_infodir}/standard*
  51. rm -r $RPM_BUILD_ROOT%{_libdir}/lib{bfd*,opcodes*}
  52. rm -f $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/{bfd.mo,opcodes.mo}
  53. rm -rf $RPM_BUILD_ROOT%{_includedir}
  54. %clean
  55. rm -rf $RPM_BUILD_ROOT
  56. %post
  57. [ -f %{_infodir}/annotate.info ] && /sbin/install-info %{_infodir}/annotate.info %{_infodir}/dir || :
  58. [ -f %{_infodir}/annotate.info.gz ] && /sbin/install-info %{_infodir}/annotate.info.gz %{_infodir}/dir || :
  59. [ -f %{_infodir}/gdb.info ] && /sbin/install-info %{_infodir}/gdb.info %{_infodir}/dir || :
  60. [ -f %{_infodir}/gdb.info.gz ] && /sbin/install-info %{_infodir}/gdb.info.gz %{_infodir}/dir || :
  61. [ -f %{_infodir}/stabs.info ] && /sbin/install-info %{_infodir}/stabs.info %{_infodir}/dir || :
  62. [ -f %{_infodir}/stabs.info.gz ] && /sbin/install-info %{_infodir}/stabs.info.gz %{_infodir}/dir || :
  63. %preun
  64. if [ $1 = 0 ]; then
  65. [ -f %{_infodir}/annotate.info ] && /sbin/install-info --delete %{_infodir}/annotate.info %{_infodir}/dir || :
  66. [ -f %{_infodir}/annotate.info.gz ] && /sbin/install-info --delete %{_infodir}/annotate.info.gz %{_infodir}/dir || :
  67. [ -f %{_infodir}/gdb.info ] && /sbin/install-info --delete %{_infodir}/gdb.info %{_infodir}/dir || :
  68. [ -f %{_infodir}/gdb.info.gz ] && /sbin/install-info --delete %{_infodir}/gdb.info.gz %{_infodir}/dir || :
  69. [ -f %{_infodir}/gdbint.info ] && /sbin/install-info --delete %{_infodir}/gdbint.info %{_infodir}/dir || :
  70. [ -f %{_infodir}/gdbint.info.gz ] && /sbin/install-info --delete %{_infodir}/gdbint.info.gz %{_infodir}/dir || :
  71. [ -f %{_infodir}/stabs.info ] && /sbin/install-info --delete %{_infodir}/stabs.info %{_infodir}/dir || :
  72. [ -f %{_infodir}/stabs.info.gz ] && /sbin/install-info --delete %{_infodir}/stabs.info.gz %{_infodir}/dir || :
  73. fi
  74. %files
  75. %defattr(-,root,root)
  76. %doc COPYING COPYING.LIB README NEWS
  77. %{_bindir}/*
  78. %{_mandir}/*/*
  79. %{_datadir}/gdb/syscalls
  80. %{_datadir}/gdb/python/gdb
  81. %{_datadir}/gdb/system-gdbinit/elinos.py
  82. %{_datadir}/gdb/system-gdbinit/wrs-linux.py
  83. %{_infodir}/annotate.info*
  84. %{_infodir}/gdb.info*
  85. %{_infodir}/stabs.info*
  86. %exclude %{_infodir}/dir
  87. %ifarch %{ix86} x86_64
  88. %{_libdir}/libinproctrace.so
  89. %endif
  90. ## don't include the files in include, they are part of binutils
  91. #%{_includedir}/*
  92. #%{_infodir}/bfd.info*
  93. #%{_infodir}/configure.info*
  94. #%{_infodir}/standard.info*
  95. #%{_libdir}/*
  96. #%{_datadir}/locale/*/LC_MESSAGES/bfd.mo
  97. #%{_datadir}/locale/*/LC_MESSAGES/opcode.mo
  98. %changelog
  99. * Sun Apr 24 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.11-1
  100. - new upstream release
  101. * Sun Oct 11 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.10-1
  102. - new upstream release
  103. * Mon Jul 06 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.9.1-1
  104. - new upstream release
  105. * Sun Feb 22 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.9-1
  106. - new upstream release
  107. * Sun Dec 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.8.1-1
  108. - new upstream release
  109. * Sun Aug 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.8-1
  110. - new upstream release
  111. * Sun Nov 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6.1-1
  112. - new upstream release
  113. * Mon Oct 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-1
  114. - new upstream release
  115. * Tue May 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.4.1-1
  116. - new upstream release
  117. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.4-1
  118. - new upstream release
  119. * Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.2-2
  120. - add BuildRequires: python-devel, zlib-devel
  121. - fix %%files
  122. * Thu Apr 28 2011 Shu KONNO <owa@bg.wakwak.com> 7.2-1
  123. - updated gdb to 7.2
  124. * Wed Feb 17 2010 Shu KONNO <owa@bg.wakwak.com> 7.0.1-1
  125. - updated gdb to 7.0.1
  126. - rebuilt with new environment
  127. * Sat Sep 13 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-1vl5
  128. - applied new versioning policy, spec in utf-8
  129. * Mon Feb 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.7.1-0vl4
  130. - rebuild with expat-2.0.1
  131. - add BuildRequires: expat-devel
  132. * Sun Jan 27 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl3
  133. - dropt %%{_localedir}/*/LC_MESSAGES/*.mo conflicts with binutils
  134. * Fri Jan 04 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl2
  135. - dropt %%{_libdir}/lib{bfd*,iberty*,opcodes*} conflicts with binutils-devel
  136. * Mon Dec 31 2007 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl1
  137. - new upstream release
  138. * Wed Jul 12 2006 Shu KONNO <owa@bg.wakwak.com> 6.4.90-0vl1
  139. - new upstream release
  140. * Sat Dec 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.0-0vl1
  141. - new upstream release
  142. * Thu Nov 28 2002 KAZUKI SHIMURA <rito@pos.to> 5.2.1-4vl2
  143. - Oops, spec was written in Shift-JIS. Fixed.
  144. * Mon Nov 11 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.2.1-4vl1
  145. - based on 5.2.1-4 from Rawhide and built for Vine Linux
  146. * Fri Aug 23 2002 Florian La Roche <Florian.LaRoche@redhat.de>
  147. - added mainframe patch from developerworks
  148. * Wed Aug 21 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-3
  149. - Add changelogs to the previous patch
  150. * Wed Aug 14 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-2
  151. - Add some patches from Elena Zannoni <ezannoni@redhat.com>
  152. * Tue Jul 23 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-1
  153. - 5.2.1
  154. * Mon Jul 22 2002 Florian La Roche <Florian.LaRoche@redhat.de>
  155. - compile on mainframe
  156. * Mon Jul 8 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-3
  157. - Rebuild
  158. * Tue May 7 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-2
  159. - Rebuild
  160. * Mon Apr 29 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-1
  161. - 5.2
  162. * Mon Apr 29 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.92-1
  163. - 5.1.92. Hopefully identical to 5.2 final
  164. * Mon Apr 22 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.91-1
  165. - 5.1.91. 5.2 expected in a week
  166. * Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-5
  167. - Update to current
  168. * Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-4
  169. - Update to current
  170. * Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-3
  171. - Update to current
  172. * Wed Mar 20 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-2
  173. - Update to current
  174. * Wed Mar 13 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-1
  175. - Update to current 5.2 branch
  176. * Thu Jan 24 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.1-1
  177. - 5.1.1
  178. - add URL
  179. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  180. - automated rebuild
  181. * Mon Dec 10 2001 Trond Eivind Glomsr <teg@redhat.com> 5.1-2
  182. - Fix some thread+fpu problems
  183. * Mon Nov 26 2001 Trond Eivind Glomsr <teg@redhat.com> 5.1-1
  184. - 5.1
  185. * Mon Nov 19 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.94-0.71
  186. - 5.0.94. Almost there....
  187. * Mon Nov 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.93-2
  188. - Add patch from jakub@redhat.com to improve handling of DWARF
  189. * Mon Nov 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.93-1
  190. - 5.0.93
  191. - handle missing info pages in post/pre scripts
  192. * Wed Oct 31 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.92-1
  193. - 5.0.92
  194. * Fri Oct 26 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.91rh-1
  195. - New snapshot
  196. - Use the 5.0.91 versioning from the snapshot
  197. * Wed Oct 17 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-17
  198. - New snapshot
  199. * Thu Sep 27 2001 Trond Eivind Glomsr <teg@redhat.com>
  200. - New snapshot
  201. * Wed Sep 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-16
  202. - New snapshot
  203. * Mon Aug 13 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-15
  204. - Don't buildrequire compat-glibc (#51690)
  205. * Thu Aug 9 2001 Trond Eivind Glomsr <teg@redhat.com>
  206. - New snapshot, from the stable branch eventually leading to gdb 5.1
  207. * Mon Jul 30 2001 Trond Eivind Glomsr <teg@redhat.com>
  208. - s/Copyright/License/
  209. - Add texinfo to BuildRequires
  210. * Mon Jun 25 2001 Trond Eivind Glomsr <teg@redhat.com>
  211. - New snapshot
  212. * Fri Jun 15 2001 Trond Eivind Glomsr <teg@redhat.com>
  213. - New snapshot
  214. - Add ncurses-devel to buildprereq
  215. - Remove perl from buildprereq, as gdb changed the way
  216. version strings are generated
  217. * Thu Jun 14 2001 Trond Eivind Glomsr <teg@redhat.com>
  218. - New snapshot
  219. * Wed May 16 2001 Trond Eivind Glomsr <teg@redhat.com>
  220. - New snapshot - this had thread fixes for curing #39070
  221. - New way of specifying version
  222. * Tue May 1 2001 Trond Eivind Glomsr <teg@redhat.com>
  223. - New tarball
  224. - Kevin's patch is now part of gdb
  225. * Mon Apr 9 2001 Trond Eivind Glomsr <teg@redhat.com>
  226. - Add patch from kevinb@redhat.com to fix floating point + thread
  227. problem (#24310)
  228. - remove old workarounds
  229. - new snapshot
  230. * Thu Apr 5 2001 Trond Eivind Glomsr <teg@redhat.com>
  231. - New snapshot
  232. * Sat Mar 17 2001 Bill Nottingham <notting@redhat.com>
  233. - on ia64, there are no old headers :)
  234. * Fri Mar 16 2001 Trond Eivind Glomsr <teg@redhat.com>
  235. - build with old headers, new compiler
  236. * Fri Mar 16 2001 Trond Eivind Glomsr <teg@redhat.com>
  237. - new snapshot
  238. * Mon Feb 26 2001 Trond Eivind Glomsr <teg@redhat.com>
  239. - new snapshot which should fix some more IA64 problems (#29151)
  240. - remove IA64 patch, it's now integrated
  241. * Wed Feb 21 2001 Trond Eivind Glomsr <teg@redhat.com>
  242. - add IA64 and Alpha patches from Kevin Buettner <kevinb@redhat.com>
  243. - use perl instead of patch for fixing the version string
  244. * Tue Feb 20 2001 Trond Eivind Glomsr <teg@redhat.com>
  245. - don't use kgcc anymore
  246. - mark it as our own version
  247. - new snapshot
  248. * Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  249. - Link with ncurses 5.x even though we're using kgcc.
  250. No need to drag in requirements on ncurses4 (Bug #24445)
  251. * Fri Jan 19 2001 Trond Eivind Glomsr <teg@redhat.com>
  252. - new snapshot
  253. * Wed Dec 20 2000 Trond Eivind Glomsr <teg@redhat.com>
  254. - new snapshot
  255. * Mon Dec 04 2000 Trond Eivind Glomsr <teg@redhat.com>
  256. - new snapshot
  257. - new alpha patch - it now compiles everywhere. Finally.
  258. * Fri Dec 01 2000 Trond Eivind Glomsr <teg@redhat.com>
  259. - new snapshot
  260. * Mon Nov 20 2000 Trond Eivind Glomsr <teg@redhat.com>
  261. - new CVS snapshot
  262. - disable the patches
  263. - don't use %%configure, as it confuses the autoconf script
  264. - enable SPARC, disable Alpha
  265. * Wed Aug 09 2000 Trond Eivind Glomsr <teg@redhat.com>
  266. - added patch from GDB team for C++ symbol handling
  267. * Tue Jul 25 2000 Trond Eivind Glomsr <teg@redhat.com>
  268. - upgrade to CVS snapshot
  269. - excludearch SPARC, build on IA61
  270. * Wed Jul 19 2000 Trond Eivind Glomsr <teg@redhat.com>
  271. - rebuild
  272. * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
  273. - automatic rebuild
  274. * Sun Jul 02 2000 Trond Eivind Glomsr <teg@redhat.com>
  275. - rebuild
  276. * Thu Jun 08 2000 Trond Eivind Glomsr <teg@redhat.com>
  277. - use %%configure, %%makeinstall, %%{_infodir}, %%{_mandir},
  278. and %%{_tmppath}
  279. - the install scripts for info are broken(they don't care about
  280. you specify in the installstep), work around that.
  281. - don't build for IA64
  282. * Mon May 22 2000 Trond Eivind Glomsr <teg@redhat.com>
  283. - upgraded to 5.0 - dump all patches. Reapply later if needed.
  284. - added the NEWS file to the %%doc files
  285. - don't delete files which doesn't get installed (readline, texinfo)
  286. - let build system handle stripping and gzipping
  287. - don't delete libmmalloc
  288. - apply patch from jakub@redhat.com to make it build on SPARC
  289. * Fri Apr 28 2000 Matt Wilson <msw@redhat.com>
  290. - rebuilt against new ncurses
  291. * Tue Mar 7 2000 Jeff Johnson <jbj@redhat.com>
  292. - rebuild for sparc baud rates > 38400.
  293. * Tue Feb 8 2000 Jakub Jelinek <jakub@redhat.com>
  294. - fix core file handling on i386 with glibc 2.1.3 headers
  295. * Fri Jan 14 2000 Jakub Jelinek <jakub@redhat.com>
  296. - fix reading registers from core on sparc.
  297. - hack around build problems on i386 with glibc 2.1.3 headers
  298. * Thu Oct 7 1999 Jim Kingdon
  299. - List files to install in /usr/info specifically (so we don't pick up
  300. things like info.info from GDB snapshots).
  301. * Thu Oct 7 1999 Jim Kingdon
  302. - Update GDB to 19991004 snapshot. This eliminates the need for the
  303. sigtramp, sparc, xref, and threads patches. Update sparcmin patch.
  304. * Mon Aug 23 1999 Jim Kingdon
  305. - Omit readline manpage.
  306. * Sat Aug 7 1999 Jim Kingdon
  307. - Remove H.J. Lu's patches (they had been commented out).
  308. - Add sigtramp patch (from gdb.cygnus.com) and threads patch (adapted
  309. from code fusion CD-ROM).
  310. * Wed Apr 14 1999 Jeff Johnson <jbj@redhat.com>
  311. - merge H.J. Lu's patches into 4.18.
  312. * Mon Apr 05 1999 Cristian Gafton <gafton@redhat.com>
  313. - updated the kern22 patch with stuff from davem
  314. * Thu Apr 1 1999 Jeff Johnson <jbj@redhat.com>
  315. - sparc with 2.2 kernels no longer uses sunos ptrace (davem)
  316. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  317. - auto rebuild in the new build environment (release 3)
  318. * Mon Mar 8 1999 Jeff Johnson <jbj@redhat.com>
  319. - Sparc fiddles for Red Hat 6.0.