fluxbox-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420
  1. %define FBversion 1.3.5
  2. %define pversion 1.3.0
  3. %define patchversion 1.1.0.1
  4. %define fbumenu_version 0.5.5
  5. %define vinefiles_version 11.4
  6. Summary: Fluxbox is a windowmanager that is based on Blackbox.
  7. summary(ja): Fluxbox は Blackbox から派生したウインドウマネージャです。
  8. Name: fluxbox
  9. Version: %{FBversion}
  10. Release: 2%{?_dist_release}
  11. Group: User Interface/Desktops
  12. License: MIT
  13. URL: http://fluxbox.org/
  14. Vendor: Project Vine
  15. Distribution: Vine Linux
  16. Source0: http://sourceforge.net/projects/fluxbox/files/fluxbox/%{version}/fluxbox-%{version}.tar.bz2
  17. # styles & scripts
  18. Source1: %{name}-vinefiles-%{vinefiles_version}.tar.bz2
  19. Source2: styles2-2.tar.bz2
  20. Source3: fb_libexec.tar.bz2
  21. Source4: fb_extend_menu
  22. ### data/init.in
  23. Patch0: fluxbox-init_in.patch
  24. ### nls/Translation.m
  25. Patch3: fluxbox-%{pversion}.nls-ja.patch
  26. ### util/startfluxbox.in
  27. Patch4: fluxbox-%{pversion}-2.startfb.patch
  28. ### util/sfluxbox-generate_menu
  29. Patch93: fluxbox-1.3.5.menugen.patch
  30. ### util/fbsetbg
  31. Patch10: fbsetbg_setter_priority.patch
  32. ### nls/ja_JP/Makefile.in
  33. Patch40: fluxbox-%{patchversion}.nls-ja-make.patch
  34. ### util/fluxbox-update_configs.cc
  35. Patch41: fluxbox-%{pversion}.update_cfg.patch
  36. ### data/windowmenu
  37. Patch50: fluxbox.windowmenu-1.patch
  38. ### data/keys
  39. Patch51: fluxbox.keys-1.patch
  40. BuildRoot: %{_tmppath}/%{name}-buildroot
  41. BuildRequires: libX11-devel libXext-devel
  42. BuildRequires: bzip2 imlib2-devel zlib-devel freetype2-devel
  43. BuildRequires: libXpm-devel nkf libXft-devel
  44. BuildRequires: libICE-devel libSM-devel libXinerama-devel
  45. BuildRequires: libXrandr-devel libXrender-devel
  46. BuildRequires: fontconfig-devel libtool
  47. Requires: imlib2 imlib2-loader ImageMagick nkf task-xorg-x11
  48. Requires: zenity bash feh
  49. %description
  50. Fluxbox is yet another windowmanager for X.
  51. It's based on the Blackbox 0.61.1 code.
  52. Fluxbox looks like blackbox and handles styles, colors, window
  53. placement and similar thing exactly like blackbox
  54. (100% theme/style compability).
  55. So what's the difference between fluxbox and blackbox then?
  56. The answer is: LOTS!
  57. Here is a list of features that fluxbox already has, or is in the works...
  58. %description -l ja
  59. fluxbox は X Window System 用の、一味違ったウィンドウマネージャです。
  60. それは blackbox-0.61.1 のプログラムコードをベースに開発されています。
  61. fluxbox は blackbox によく似ていて、スタイル、カラーリング、ウィンドウ
  62. の配置などを blackbox 同様に処理します。(スタイル(テーマ)は 100% 互換)
  63. では、fluxbox と blackbox の違いは? ... その答えは「いっぱい」!
  64. fluxbox に何が出来るか、今後何を計画しているのか?
  65. 詳しくは http://fluxbox.sourceforge.net/ をご覧下さい。
  66. %prep
  67. %__rm -rf %{buildroot}
  68. %setup -q -a 1 -a 2 -a 3
  69. ## init
  70. %patch0 -p1
  71. ## nls
  72. %patch3 -p1
  73. ## startfluxbox
  74. %patch4 -p1
  75. ## fluxbox-generete_menu
  76. %patch93 -p1
  77. ## fbsetbg_setter_priority
  78. %patch10 -p1
  79. ## nls Makefile.in
  80. %patch40 -p1
  81. ## fluxbox-update_configs.cc
  82. %patch41 -p1
  83. ## windowmenu
  84. %patch50 -p1
  85. ## keys
  86. %patch51 -p1
  87. %build
  88. CFLAGS="${CFLAGS:-%optflags}" ; export CFLAGS ; \
  89. CXXFLAGS="${CXXFLAGS:-%optflags}" ; export CXXFLAGS ; \
  90. FFLAGS="${FFLAGS:-%optflags}" ; export FFLAGS ; \
  91. ./configure --enable-nls \
  92. --prefix=%{_prefix} \
  93. --exec-prefix=%{_exec_prefix} \
  94. --bindir=%{_bindir} \
  95. --sbindir=%{_sbindir} \
  96. --sysconfdir=%{_sysconfdir} \
  97. --datadir=%{_datadir} \
  98. --includedir=%{_includedir} \
  99. --libdir=%{_libdir} \
  100. --libexecdir=%{_libexecdir} \
  101. --localstatedir=%{_localstatedir} \
  102. --sharedstatedir=%{_sharedstatedir} \
  103. --mandir=%{_mandir} \
  104. --infodir=%{_infodir}
  105. %__make
  106. %install
  107. %__rm -rf %{buildroot}
  108. # fluxbox installation
  109. make "DESTDIR=%{buildroot}" install
  110. # styles
  111. %__rm data/styles/Makefile*
  112. %__cp -a data/styles %{buildroot}%{_datadir}/%{name}/
  113. %__cp -a data/styles2 %{buildroot}%{_datadir}/%{name}/
  114. # wallpapers
  115. %__cp -a data/backgrounds %{buildroot}%{_datadir}/%{name}/
  116. # HTML images
  117. %__cp -a data/images %{buildroot}%{_datadir}/%{name}/
  118. # UserMenu samples
  119. %__cp -a data/UserMenu %{buildroot}%{_datadir}/%{name}/
  120. # HTML docs
  121. %__cp data/*.html %{buildroot}%{_datadir}/%{name}/
  122. # scripts
  123. %__cp data/fb_welcome %{buildroot}%{_datadir}/%{name}/
  124. %__cp data/cng_fbtips %{buildroot}%{_datadir}/%{name}/
  125. %__cp data/change-rootcmd %{buildroot}%{_datadir}/%{name}/
  126. %__cp data/change-init_rootcmd %{buildroot}%{_datadir}/%{name}/
  127. %__cp data/applyoldstyle %{buildroot}%{_datadir}/%{name}/
  128. %__cp data/mk-rootcmds %{buildroot}%{_bindir}/
  129. %__cp data/fbumenu_gen-%{fbumenu_version} %{buildroot}%{_bindir}/fbumenu_gen
  130. # changelog
  131. %__cp ChangeLog %{buildroot}%{_datadir}/%{name}/
  132. # xsession desktop entry
  133. %__mkdir_p %{buildroot}%{_datadir}/xsessions/
  134. #%__cp data/fluxbox.desktop %{buildroot}%{_datadir}/xsessions/
  135. %__install -m 644 data/fluxbox.desktop %{buildroot}%{_datadir}/xsessions/
  136. # logout, reboot, shutdown commands
  137. %__mkdir_p %{buildroot}%{_libexecdir}/%{name}
  138. %__install -m 755 fb_libexec/* %{buildroot}%{_libexecdir}/%{name}/
  139. # extend menu
  140. %__mkdir_p %{buildroot}%{_datadir}/%{name}/
  141. %__install -m 755 %{SOURCE4} %{buildroot}%{_datadir}/%{name}/
  142. if [ -z "$DEBUG" ]; then
  143. strip %{buildroot}%{_bindir}/fluxbox \
  144. %{buildroot}%{_bindir}/fbsetroot \
  145. %{buildroot}%{_bindir}/fbrun
  146. fi
  147. bzip2 %{buildroot}%{_mandir}/man1/*.1
  148. %post
  149. # New menu-system
  150. %__rm %{_datadir}/fluxbox/menu*
  151. %{_bindir}/fluxbox-generate_menu \
  152. -in -B \
  153. -p %{_prefix} \
  154. -o %{_datadir}/fluxbox/menu 2> /dev/null
  155. %clean
  156. %__rm -rf %{buildroot}
  157. %files
  158. %defattr(-,root,root,755)
  159. %doc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
  160. %{_bindir}/*
  161. %{_datadir}/*
  162. %{_libexecdir}/*
  163. %changelog
  164. * Fri Dec 27 2013 TANAKA hiroaki <mosaicist@jcom.home.ne.jp> 1.3.5-2
  165. - rebuild with gcc-4.8
  166. * Wed Jun 12 2013 TANAKA hiroaki mosaicist@jcom.home.ne.jp > 1.3.5-1
  167. - new upstream release
  168. - update fluxbox-%version.menugen.patch
  169. * Mon Feb 13 2012 KATO Masashi <mkato@par.odn.ne.jp> 1.3.2-3
  170. - replaced wallpaper setter "xsri" with "feh"
  171. - update documents(fluxtips.html)
  172. * Mon Nov 14 2011 KATO Masashi <mkato@par.odn.ne.jp> 1.3.2-2
  173. - rewrited spec file
  174. (reformat %changelog)
  175. * Mon Nov 14 2011 KATO Masashi <mkato@par.odn.ne.jp> 1.3.2-1
  176. - new upstream release.
  177. * Sat Mar 26 2011 KATO Masashi <mkato@par.odn.ne.jp> 1.3.1-2
  178. - added wide wall paper
  179. - update documents(flux_news.html)
  180. * Mon Mar 7 2011 KATO Masashi <mkato@par.odn.ne.jp> 1.3.1-1
  181. - new upstream release.
  182. * Tue Mar 1 2011 KATO Masashi <mkato@par.odn.ne.jp> 1.3.0-1
  183. - new upstream release.
  184. - updated patchs.
  185. - added keys & windowmenu patch.
  186. - update documents(flux_news.html,styles.html)
  187. * Tue Oct 5 2010 KATO Masashi <mkato@par.odn.ne.jp> 1.1.1-5
  188. - added BR: libICE-devel libSM-devel libXinerama-devel
  189. libXrandr-devel libXrender-devel fontconfig-devel libtool
  190. - added Requires: task-xorg-x11 bash
  191. - dropped Requires: xinitrc libXpm
  192. * Mon Oct 4 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.1.1-4
  193. - add BR: libXft-devel (1.1.1-3.ppc was built w/o libXft-devel)
  194. * Wed May 26 2010 KATO Masashi <mkato@par.odn.ne.jp> 1.1.1-3
  195. - update & added Vine documents. (apps.html, config_files.html)
  196. - Combined some of patches.
  197. - update fbumenu_gen script(usermenu generator).
  198. - added menu commands. (logout, reboot, shutdown)
  199. - added extend application menu script. (%{SOURCE4})
  200. * Tue Mar 16 2010 KATO Masashi <mkato@par.odn.ne.jp> 1.1.1-2
  201. - updated wallpapers.
  202. - moved desktop-entry to %{_datadir}/xsessions/ .
  203. * Fri Sep 19 2008 KATO Masashi <mkato@par.odn.ne.jp> 1.1.1-1
  204. - new upstream release.
  205. - removed upstream patchs.
  206. - rewrote Vine documents.
  207. * Sat Sep 14 2008 KATO Masashi <mkato@par.odn.ne.jp> 1.1.0.1-3
  208. - Applied upstream patchs.
  209. * Fri Sep 12 2008 KATO Masashi <mkato@par.odn.ne.jp> 1.1.0.1-2
  210. - updated mk-rootcmds
  211. - updated vine documents. (keys.html, flux_news.html)
  212. * Thu Sep 11 2008 KATO Masashi <mkato@par.odn.ne.jp> 1.1.0.1-1
  213. - new upstream release
  214. - removed fluxbox-%{FBversion}.nls-hh.patch
  215. - rewrote documents. (keys.html, flux_news.html)
  216. - added new default keys file
  217. * Sun Aug 24 2008 KATO Masashi <mkato@par.odn.ne.jp> 1.0.0-6
  218. - fixed locale problem
  219. - rewrote scripts for eucJP and UTF-8
  220. - revived fluxbox-%{FBversion}.Xclients.patch. (for startx)
  221. * Sun Jun 22 2008 KATO Masashi <mkato@par.odn.ne.jp> 1.0.0-5
  222. - add new style. (tux)
  223. * Mon Jun 16 2008 KATO Masashi <mkato@par.odn.ne.jp> 1.0.0-3
  224. - corrected line gap of nls-header
  225. - (fluxbox-1.0.0.nls-hh.patch)
  226. * Tue May 27 2008 KATO Masashi <mkato@par.odn.ne.jp> 1.0.0-2
  227. - adjust startup sequence
  228. - (rewrite desktop entry file for dm sessions)
  229. - (remove fluxbox-%{FBversion}.Xclients.patch)
  230. * Sun May 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.0-1
  231. - applied new versioning policy
  232. - rebuilt with xorg-x11 7.3
  233. - spec in UTF-8
  234. * Tue Dec 4 2007 KATO Masashi <mkato@par.odn.ne.jp> 1.0.0-0vl3, 4
  235. - retouch patchs for ja_JP.UTF-8 locale
  236. - : for root menu & help message
  237. - rewrite vine documents
  238. * Mon Oct 15 2007 KATO Masashi <mkato@par.odn.ne.jp> 1.0.0-0vl1, 2
  239. - new upstream 'stable' release
  240. - add new documents(styles tips, keys tips).
  241. - add new styles
  242. - update patch files, vine documents, vine scripts
  243. * Wed Apr 11 2007 KATO Masashi <mkato@par.odn.ne.jp> 1.0-0vl0.rc3.1, 2
  244. - new upstream release
  245. - add rewrited system styles
  246. - update patch files
  247. - update vine documents
  248. * Sun Dec 24 2006 KATO Masashi <mkato@par.odn.ne.jp> 1.0-0vl0.rc2.3, 4
  249. - add BuildRequires: zlib-devel freetype2-devel
  250. - add Requires: xsri
  251. - Change wpsetter''s priority (fbsetbg_setter_priority.patch)
  252. * Thu Jul 20 2006 KATO Masashi <mkato@par.odn.ne.jp> 1.0-0vl0.rc2.1, 2
  253. - new upstream release
  254. - update patch files
  255. - update vine documents
  256. * Thu Jul 6 2006 KATO Masashi <mkato@par.odn.ne.jp> 1.0-0vl0.rc0.1, 2
  257. - new upstream release
  258. - update patch files
  259. - added 'additional applications' extension to fluxbox-generate_menu
  260. * Tue Apr 8 2006 KATO Masashi <mkato@par.odn.ne.jp> 0.9.15.1-0vl1, 2
  261. - new upstream release
  262. - add 'init file rewrite' script for back-compatible
  263. - rewrite documents
  264. * Wed Mar 29 2006 KATO Masashi <mkato@par.odn.ne.jp> 0.9.15-0vl1, 2
  265. - new upstream release
  266. - update *tips*
  267. - update patch files
  268. - add & update script files
  269. - update & retouch style files (VineStyle*, BlueStar*)
  270. - retouch menu structure (Vine tools)
  271. - add script for back compatible to background-style
  272. * Sun Mar 19 2006 KATO Masashi <mkato@par.odn.ne.jp> 0.9.14-0vl1.1, 2.2
  273. - update *_tips.html
  274. (retouch link errors)
  275. - retouch ja_JP/Translation.m
  276. - update menugen patch
  277. - update style file (VineStyle, BlueStar)
  278. - add index.html, scripts for 'wellcome'
  279. * Tue Oct 25 2005 KATO Masashi <mkato@par.odn.ne.jp> 0.9.14-0vl1, 2
  280. - new upstream release
  281. - update vine patch
  282. (retouch init file for new spec.)
  283. - update vinefiles
  284. (update fbumenu_gen(usermenu generator))
  285. (update 2 style files for new spec.)
  286. (update fluxtips.txt)
  287. - update fluxbox_menu_tips.html
  288. * Sun Jun 5 2005 KATO Masashi <mkato@par.odn.ne.jp> 0.9.13-0vl3, 4
  289. - update vine patch
  290. (add some menu items to fluxbox-generate_menu)
  291. (retouch menu structure)
  292. (rewrite 'about menu')
  293. - update vinefiles
  294. (add usermenu generator to x-utilus)
  295. - update fluxbox_menu_tips.html
  296. * Fri May 27 2005 KATO Masashi <mkato@par.odn.ne.jp> 0.9.13-0vl1
  297. - new upstream release
  298. - update vine patch
  299. (add some menu items to fluxbox-generate_menu)
  300. (extend 'about toolbar')
  301. - update nls-ja patch
  302. - update fluxtips.txt
  303. (rewrite, add '0.9.13 news')
  304. * Sun Feb 6 2005 KATO Masashi <mkato@par.odn.ne.jp> 0.9.12-0vl1
  305. - new upstream release
  306. - update vine patch
  307. (add some menu items to fluxbox-generate_menu)
  308. (include blackbox styles)
  309. (extend 'my_mail')
  310. (extend 'about menu')
  311. - add nls-ja patch
  312. * Sun Dec 12 2004 KATO Masashi <mkato@par.odn.ne.jp> 0.9.11-0vl1
  313. - new upstream release
  314. - update vine patch
  315. (generate japanese menu)
  316. (add some menu items to fluxbox-generate_menu)
  317. (retouch menu structure)
  318. (fix menu backup problem)
  319. * Wed Nov 24 2004 IWAI, Masaharu <iwai@alib.jp> 0.9.10-0vl1
  320. - new upstream release
  321. - update vine patch ( merged vine patches )
  322. - add font_locale patch ( Patch100 )
  323. - fix typo: s/buidroot/buildroot/g
  324. * Sun Jun 20 2004 KATO Masashi <mkato@par.odn.ne.jp> 0.9.9-0vl2
  325. - rewrite 2 styles (VineStyleII, BlueStarII)
  326. - rewrite fluxtips.txt(for 0.9.x)
  327. - modifying menu-generator
  328. (fix problems of 'can't generates some menus'')
  329. (add some menu items)
  330. (Japanese help messages)
  331. - modifying 'init' file(default style, menu-alpha)
  332. - append sample of 'keys' file
  333. * Sun May 2 2004 IWAI, Masaharu <iwai@alib.jp> 0.9.9-0vl1
  334. - new upstream release
  335. * Sun Mar 14 2004 IWAI, Masaharu <iwai@alib.jp> 0.9.8-0vl2
  336. - using rpm macros
  337. - fix nonexistent directory for styles in postscript
  338. - add BuildRequires: bzip2
  339. - drop Prefix tag
  340. * Sat Mar 6 2004 IWAI, Masaharu <iwai@alib.jp> 0.9.8-0vl1
  341. - new upstream release
  342. - update vine patch (Patch101)
  343. * Mon Aug 11 2003 IWAI, Masaharu <iwai@alib.jp> 0.1.14-1_0vl2
  344. - build for VineSeed
  345. - fix Group tag for VineLinux:
  346. Graphical desktop/Other -> User Interface/Desktops
  347. - add /usr/share/%%{name} directory in %%files section
  348. * Sat May 31 2003 KATO Masashi <mkato@par.odn.ne.jp> 0.1.14-1_0vl1
  349. - fluxbox for Vine Linux. Japanese menu enabled at default.
  350. (initial package for Vine Linux)
  351. - modified menu-generator patch (x-terminals)
  352. - modified init.in patch (date,workspace name,default style)
  353. - added 2 styles (VineStyle, BlueStar)