file-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395
  1. %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  2. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  3. %define __libtoolize :
  4. Summary: A utility for determining file types.
  5. Summary(ja): ファイルの種類を判別するユーティリティー
  6. Name: file
  7. Version: 5.20
  8. Release: 1%{?_dist_release}
  9. License: BSD
  10. Group: Applications/System
  11. Obsoletes: file-static
  12. Source0: ftp://ftp.astron.com/pub/file/%{name}-%{version}.tar.gz
  13. # Addtional magic file for Vine
  14. Source10: magic.printer-j
  15. # Upstream says it's up to distributions to add a way to support local-magic.
  16. Patch0: file-localmagic.patch
  17. # sent upstream - should be included in next upstream release
  18. Patch1: file-5.10-strength.patch
  19. Patch3: file-4.17-rpm-name.patch
  20. Patch4: file-5.04-volume_key.patch
  21. Patch5: file-5.04-man-return-code.patch
  22. Patch6: file-5.04-generic-msdos.patch
  23. Patch7: file-5.14-x86boot.patch
  24. Patch8: file-5.14-perl.patch
  25. Patch14: file-5.19-cafebabe.patch
  26. #Vine
  27. Patch100: file-5.14-magicbuild-fix.patch
  28. #Security
  29. Patch200: file-5.20-CVE-2014-3710.patch
  30. Buildroot: %{_tmppath}/%{name}-%{version}-root
  31. #BuildRequires: automake
  32. #BuildRequires: autoconf
  33. BuildRequires: zlib-devel
  34. Vendor: Project Vine
  35. Distribution: Vine Linux
  36. Packager: daisuke
  37. %description
  38. The file command is used to identify a particular file according to the
  39. type of data contained by the file. File can identify many different
  40. file types, including ELF binaries, system libraries, RPM packages, and
  41. different graphics formats.
  42. You should install the file package, since the file command is such a
  43. useful utility.
  44. %description -l ja
  45. file コマンドは、ファイルに含まれるデータの種類によって各ファイルが
  46. どのようなファイルかを判定するために使います。file は ELF バイナリ、シ
  47. ステムライブラリ、RPM パッケージ、そして様々なグラフィックフォーマット
  48. を含む、多くの異なるファイルの種類を見分けることができます。
  49. %package devel
  50. Summary: Libraries and header files for file development
  51. Summary(ja): libmagic の開発用ファイル
  52. Group: Development/Libraries
  53. Requires: %{name} = %{version}-%{release}
  54. %description devel
  55. The file-devel package contains the header files and libmagic library
  56. necessary for developing programs using libmagic.
  57. %package -n python-magic
  58. Summary: Python bindings for the libmagic API
  59. Group: Development/Libraries
  60. BuildRequires: python-devel
  61. Requires: %{name} = %{version}-%{release}
  62. %description -n python-magic
  63. This package contains the Python bindings to allow access to the
  64. libmagic API. The libmagic library is also used by the familiar
  65. file(1) command.
  66. %prep
  67. %setup -q
  68. # Don't use -b -- it will lead to problems when compiling magic file!
  69. %patch0 -p1
  70. %patch1 -p1
  71. %patch3 -p1
  72. %patch4 -p1
  73. %patch5 -p1
  74. %patch6 -p1
  75. %patch7 -p1
  76. %patch8 -p1
  77. %patch14 -p1
  78. #Vine
  79. %patch100 -p1
  80. #Security
  81. %patch200 -p1 -b .CVE-2014-3587
  82. cat %{SOURCE10} >> ./magic/Localstuff
  83. iconv -f iso-8859-1 -t utf-8 < doc/libmagic.man > doc/libmagic.man_
  84. touch -r doc/libmagic.man doc/libmagic.man_
  85. mv doc/libmagic.man_ doc/libmagic.man
  86. %build
  87. autoreconf
  88. CFLAGS="%{optflags} -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE" \
  89. %configure --enable-fsect-man5 --disable-rpath
  90. # remove hardcoded library paths from local libtool
  91. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  92. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  93. export LD_LIBRARY_PATH=$RPM_BUILD_ROOT/%{name}-%{version}/src/.libs
  94. make
  95. cd python
  96. CFLAGS="%{optflags}" %{__python} setup.py build
  97. %install
  98. rm -rf $RPM_BUILD_ROOT
  99. mkdir -p $RPM_BUILD_ROOT%{_bindir}
  100. mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1
  101. mkdir -p $RPM_BUILD_ROOT%{_mandir}/man3
  102. mkdir -p $RPM_BUILD_ROOT%{_mandir}/man5
  103. mkdir -p $RPM_BUILD_ROOT%{_datadir}/misc
  104. mkdir -p $RPM_BUILD_ROOT%{_datadir}/file
  105. make install DESTDIR=$RPM_BUILD_ROOT
  106. cat magic/Magdir/* > ${RPM_BUILD_ROOT}%{_datadir}/misc/magic
  107. ln -s misc/magic ${RPM_BUILD_ROOT}%{_datadir}/magic
  108. ##ln -s file/magic.mime ${RPM_BUILD_ROOT}%{_datadir}/magic.mime
  109. ln -s ../magic ${RPM_BUILD_ROOT}%{_datadir}/file/magic
  110. cd python
  111. %{__python} setup.py install -O1 --skip-build --root ${RPM_BUILD_ROOT}
  112. %{__install} -d ${RPM_BUILD_ROOT}%{_datadir}/%{name}
  113. # LIBTOOL=/usr/bin/libtool
  114. #ln -s file/magic ${RPM_BUILD_ROOT}%{_datadir}/magic
  115. #ln -s file/magic.mime ${RPM_BUILD_ROOT}%{_datadir}/magic.mime
  116. #ln -s ../magic ${RPM_BUILD_ROOT}%{_datadir}/misc/magic
  117. #{ cd ${RPM_BUILD_ROOT}
  118. # strip .%{_bindir}/file
  119. # cp %SOURCE1 .%{_datadir}/magic.mime
  120. #}
  121. # remove unuse files
  122. rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
  123. %clean
  124. rm -rf $RPM_BUILD_ROOT
  125. %post -p /sbin/ldconfig
  126. %postun -p /sbin/ldconfig
  127. %files
  128. %defattr(-,root,root)
  129. %doc COPYING ChangeLog README
  130. %{_bindir}/*
  131. %{_libdir}/libmagic.so.*
  132. %{_datadir}/file/*
  133. %{_datadir}/magic*
  134. %{_datadir}/misc/*
  135. %{_mandir}/man[15]/*
  136. %files devel
  137. %defattr(-,root,root,-)
  138. %{_libdir}/*.so
  139. %{_includedir}/magic.h
  140. %{_mandir}/man3/*
  141. %files -n python-magic
  142. %defattr(-, root, root, -)
  143. %doc python/README COPYING python/example.py
  144. %{python_sitelib}/magic.py
  145. %{python_sitelib}/magic.pyc
  146. %{python_sitelib}/magic.pyo
  147. %{python_sitelib}/*egg-info
  148. %changelog
  149. * Sat Nov 15 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.20-1
  150. - new upstream release
  151. - update/drop patches based on fc22
  152. * Fri Oct 24 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 5.14-7
  153. - reflected 6.0 updates and bumped release
  154. * Thu Sep 11 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-6
  155. - drop patch230 (moved to patch320)
  156. - add Patch240 for fix CVE-2014-0207
  157. - add Patch250 for fix CVE-2014-0237
  158. - add Patch260 for fix CVE-2014-0238
  159. - add Patch270 for fix CVE-2014-3478
  160. - add Patch280 for fix CVE-2014-3479
  161. - add Patch290 for fix CVE-2014-3480
  162. - add Patch300 for fix CVE-2014-3487
  163. - add Patch310 for fix CVE-2014-3538
  164. - add Patch320 for fix CVE-2014-3587
  165. These patches are from debian/ubuntu, thanks.
  166. * Thu Aug 28 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-5
  167. - add patch230 for fix CVE-2014-3587 (cdf_read_property_info)
  168. * Thu Mar 27 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-4
  169. - add patch110,220 for fix regression of CVE-2014-2270
  170. * Wed Mar 12 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-3
  171. - add patch210 for fix CVE-2014-2270
  172. * Thu Feb 20 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-2
  173. - add patch200 for fix CVE-2014-1943
  174. * Sun Jul 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.14-2
  175. - rebuild with VineSeed environment
  176. * Sun Sep 22 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-1
  177. - new upstream reelase
  178. - add patch100 to fix build error
  179. - remove -static subpackage and add Obs: file-static
  180. - fix old changelog date...
  181. * Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 5.11-1
  182. - new upstream reelase
  183. - drop all local patches
  184. - import fedora patches
  185. * Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.05-3
  186. - rebuild with python-2.7.2
  187. * Sun Feb 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.05-2
  188. - rebuild package
  189. - fix Patch100
  190. * Sat Feb 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.05-1
  191. - new upstream release
  192. - updated Vine patches (but Patch100 has not been ported yet...)
  193. - split to devel and static subpackcages
  194. * Mon Sep 27 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.21-3
  195. - rebuilt with rpm-4.8.1
  196. - add environment variable LIBTOOL for make command
  197. * Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 4.21-2
  198. - spec in utf-8
  199. - removed *.la
  200. * Mon May 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.21-1
  201. - applied new versioning policy
  202. * Tue Dec 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.21-0vl1
  203. - new upstream release
  204. - import debian/fedora patches
  205. - drop obsolete vine magic.
  206. * Thu Jun 14 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.09-0vl3
  207. - rebuild for VineSeed with new tool chain
  208. * Thu May 31 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.09-0vl2.2
  209. - add patch110 for fix CVE-2007-2799
  210. - add zlib-devel to BuildPreReq tag
  211. * Mon Mar 26 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.09-0vl2.1
  212. - add patch100 for fix CVE-2007-1536
  213. * Sun Sep 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.09-0vl2
  214. - changed Group to Applications/System
  215. * Sun Apr 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4.09-0vl1
  216. - new upstream release
  217. - update vine patches
  218. * Wed Sep 10 2003 Tomoya TAKA <taka@vinelinux.org> 4.03-0vl2
  219. - update Patch10, use 'size_t' in src/jcode.[ch]
  220. * Tue Sep 09 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.03-0vl1
  221. - update to 4.03
  222. - update Patch0, 1, 10 for 4.03
  223. - s/Copyright/License/
  224. * Mon May 12 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.02-1vl1
  225. - update to 4.02
  226. - update Vine patches for 4.02
  227. * Sun Mar 9 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.41-0vl1
  228. - new upstream release
  229. - fixed security bug (http://www.idefense.com/advisory/03.04.03.txt)
  230. - remove unneeded patches.
  231. - update Vine patches for 3.41
  232. * Mon Apr 1 2002 Jun Nishii <jun@vinelinux.org> 3.37-0vl2
  233. - added NPDL2 data [Vine:02348]
  234. * Fri Feb 08 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.37-0vl1
  235. - update to 3.37
  236. * Sun Jul 15 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  237. - 3.35-0vl3
  238. - disable some entries in elf for problems on big-endian archs
  239. * Wed Jun 6 2001 Jun Nishii <jun@vinelinux.org>
  240. - file-3.35-0vl1
  241. - ver.up
  242. - added %doc
  243. * Thu Jan 11 2001 Jun Nishii <jun@vinelinux.org>
  244. - file-3.33-1vl4
  245. - more fix and clean up jtext patch (file-3.33-vinejtext.patch)
  246. * Thu Jan 11 2001 Jun Nishii <jun@vinelinux.org>
  247. - file-3.33-1vl3
  248. - fix again jtext patch (file-3.33-vinejtext.patch)
  249. - added file-3.33-vinenames.patch to avoid miss-judgement
  250. * Wed Jan 10 2001 Jun Nishii <jun@vinelinux.org>
  251. - file-3.33-1vl2
  252. - update jtext patch (file-3.33-vinejtext.patch)
  253. * Mon Jan 8 2001 Jun Nishii <jun@vinelinux.org>
  254. - file-3.33-1vl1
  255. - modify description-ja and spec
  256. * Sun Jul 09 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  257. - file-3.28-2vl2
  258. - fixed %files section to handle compressed man pages
  259. * Tue Jun 13 2000 Lisa Sagami <czs14350@nifty.ne.jp>
  260. - marged RH 3.28-2 and Vine 3.27-3vl3
  261. * Wed Feb 16 2000 Cristian Gafton <gafton@redhat.com>
  262. - add ia64 patch from rth
  263. * Mon Feb 7 2000 Bill Nottingham <notting@redhat.com>
  264. - handle compressed manpages
  265. - update to 3.28
  266. * Mon Sep 6 1999 Norihito Ohmori <ohmori@flatout.org>
  267. - Japanese Text detection bug fix. (by Toru Hoshina <hoshina@best.com>)
  268. * Fri Aug 27 1999 Norihito Ohmori <ohmori@flatout.org>
  269. - patch dues not apply bug.
  270. * Thu Aug 26 1999 Norihito Ohmori <ohmori@flatout.org>
  271. - not need kcc (Thanks for Toru Hoshina <hoshina@best.com>)
  272. - ASCII data and Shift JIS data detected in Japanese Text Detection bug fix.
  273. * Mon Aug 23 1999 Jeff Johnson <jbj@redhat.com>
  274. - identify ELF stripped files correctly (#4665).
  275. - use SPARC (not sparc) consistently throughout (#4665).
  276. - add entries for MS Office files (#4665).
  277. * Thu Aug 12 1999 Jeff Johnson <jbj@redhat.com>
  278. - diddle magic so that *.tfm files are identified correctly.
  279. * Tue Jul 6 1999 Jeff Johnson <jbj@redhat.com>
  280. - update to 3.27.
  281. * Mon Mar 22 1999 Preston Brown <pbrown@redhat.com>
  282. - experimental support for realmedia files added
  283. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  284. - auto rebuild in the new build environment (release 5)
  285. * Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
  286. - strip binary.
  287. * Fri Nov 27 1998 Jakub Jelinek <jj@ultra.linux.cz>
  288. - add SPARC V9 magic.
  289. * Tue Nov 10 1998 Jeff Johnson <jbj@redhat.com>
  290. - update to 3.26.
  291. * Mon Aug 24 1998 Jeff Johnson <jbj@redhat.com>
  292. - update to 3.25.
  293. - detect gimp XCF versions.
  294. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  295. - translations modified for de, fr, tr
  296. * Wed Apr 08 1998 Erik Troan <ewt@redhat.com>
  297. - updated to 3.24
  298. - buildrooted
  299. * Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
  300. - built against glibc
  301. * Mon Mar 31 1997 Erik Troan <ewt@redhat.com>
  302. - Fixed problems caused by 64 bit time_t.
  303. * Thu Mar 06 1997 Michael K. Johnson <johnsonm@redhat.com>
  304. - Improved recognition of Linux kernel images.