directfb-vl.spec 5.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195
  1. %define oname DirectFB
  2. %define libver 1.7-4
  3. Summary: Hardware graphics acceleration library
  4. Name: directfb
  5. Version: 1.7.4
  6. Release: 1%{?_dist_release}
  7. License: GPL
  8. Group: System Environment/Libraries
  9. Source0: http://www.directfb.org/downloads/Core/%{name}-1.7/%{oname}-%{version}.tar.gz
  10. URL: http://www.directfb.org/
  11. BuildRequires: libpng-devel >= 1.2.0
  12. BuildRequires: zlib-devel >= 1.1.3
  13. BuildRequires: libjpeg-turbo-devel
  14. BuildRequires: libtiff-devel
  15. BuildRequires: libwebp-devel
  16. BuildRequires: jasper-devel
  17. BuildRequires: freetype2-devel >= 2.0.2
  18. BuildRequires: libX11-devel
  19. BuildRequires: libdrm-devel
  20. BuildRequires: mesa-libEGL-devel
  21. BuildRequires: mesa-libGLES-devel
  22. BuildRequires: mesa-libgbm-devel
  23. BuildRequires: eudev-libudev-devel
  24. BuildRequires: libvdpau-devel
  25. BuildRequires: libvncserver-devel
  26. BuildRequires: sysfsutils-devel
  27. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  28. Vendor: Project Vine
  29. Distribution: Vine Linux
  30. %description
  31. DirectFB hardware graphics acceleration - libraries.
  32. %package -n lib%{name}
  33. Summary: Shared library part of %oname
  34. Group: System Environment/Libraries
  35. %description -n lib%{name}
  36. DirectFB hardware graphics acceleration - libraries.
  37. This package contains the %oname shared library and interface modules.
  38. It's required for running apps based on %oname.
  39. #'
  40. %package -n lib%{name}-devel
  41. Group: Development/Libraries
  42. Summary: Header files for compiling DirectFB applications
  43. Requires: lib%{name} = %{version}-%{release}
  44. Provides: %{oname}-devel = %{version}-%{release}
  45. %description -n lib%{name}-devel
  46. DirectFB header files for building applications based on %oname.
  47. %package doc
  48. Summary: DirectFB - documentation
  49. Group: Applications/Documentation
  50. %description doc
  51. DirectFB documentation and examples.
  52. %prep
  53. %setup -q -n %{oname}-%{version}
  54. %build
  55. %configure \
  56. --enable-fbdev \
  57. --disable-maintainer-mode \
  58. --enable-shared \
  59. --with-gfxdrivers=all
  60. make
  61. %install
  62. rm -rf $RPM_BUILD_ROOT
  63. make install DESTDIR=$RPM_BUILD_ROOT
  64. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
  65. # we don't ship dfbg ATM
  66. rm -f $RPM_BUILD_ROOT%{_bindir}/dfbg
  67. rm -f $RPM_BUILD_ROOT%{_mandir}/man1/dfbg.1
  68. %clean
  69. rm -rf $RPM_BUILD_ROOT
  70. %post -n lib%{name} -p /sbin/ldconfig
  71. %postun -n lib%{name} -p /sbin/ldconfig
  72. %files -n lib%{name}
  73. %defattr(-,root,root,-)
  74. %doc README* AUTHORS ChangeLog NEWS TODO
  75. %{_bindir}/dfbdump
  76. %{_bindir}/dfbdumpinput
  77. %{_bindir}/dfbfx
  78. %{_bindir}/dfbinfo
  79. %{_bindir}/dfbinput
  80. %{_bindir}/dfbinspector
  81. %{_bindir}/dfbmaster
  82. %{_bindir}/dfblayer
  83. %{_bindir}/dfbplay
  84. %{_bindir}/dfbscreen
  85. %{_bindir}/dfbshow
  86. %{_bindir}/dfbswitch
  87. %{_bindir}/dfbpenmount
  88. %{_bindir}/mkdfiff
  89. %{_bindir}/mkdgiff
  90. %{_bindir}/mkdgifft
  91. %{_bindir}/pxa3xx_dump
  92. %{_libdir}/lib*.so.*
  93. %dir %{_libdir}/directfb-%{libver}
  94. %dir %{_libdir}/directfb-%{libver}/gfxdrivers
  95. %dir %{_libdir}/directfb-%{libver}/inputdrivers
  96. %dir %{_libdir}/directfb-%{libver}/interfaces
  97. %dir %{_libdir}/directfb-%{libver}/systems
  98. %dir %{_libdir}/directfb-%{libver}/wm
  99. %{_libdir}/directfb-%{libver}/gfxdrivers/*.so
  100. %{_libdir}/directfb-%{libver}/inputdrivers/*.so
  101. %{_libdir}/directfb-%{libver}/interfaces/*/*.so
  102. %{_libdir}/directfb-%{libver}/systems/*.so
  103. %{_libdir}/directfb-%{libver}/wm/*.so
  104. %{_datadir}/directfb-%{version}
  105. %{_mandir}/man5/directfbrc.5*
  106. %files -n lib%{name}-devel
  107. %defattr(-,root,root,-)
  108. %{_bindir}/directfb-config
  109. %{_bindir}/directfb-csource
  110. %{_includedir}/*
  111. %{_libdir}/pkgconfig/*.pc
  112. %{_libdir}/*.so
  113. %{_mandir}/man1/directfb-csource.1*
  114. %files doc
  115. %defattr(-,root,root,-)
  116. %doc docs/html/*
  117. %changelog
  118. * Tue Jul 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.4-1
  119. - update to 1.7.4
  120. - remove Patch0 (DirectFB-1.1.1_ppc.patch)
  121. - add BuildRequires: libwebp-devel, jasper-devel, libdrm-devel, mesa-libEGL-devel, mesa-libGLES-devel, mesa-libgbm-devel, eudev-libudev-devel, libvdpau-devel
  122. * Sun May 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.11-2
  123. - fix permission
  124. * Tue Dec 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.11-1
  125. - new upstream release
  126. - change Source URL
  127. - add BuildRequires: libX11-devel, libvncserver-devel, sysfsutils-devel
  128. - change BuildRequires: libjpeg-turbo-devel instead libjpeg-devel >= 6g
  129. - fix %%files
  130. * Mon Oct 11 2010 Shu KONNO <owa@bg.wakwak.com> 1.2.5-1
  131. - updated DirectFB to 1.2.5
  132. - rebuilt with rpm-4.8.1 for pkg-config
  133. * Sun May 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.1.1-2
  134. - add Patch0 to fix ppc build problem (with newer kernels)
  135. * Fri May 2 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.1-1
  136. - new upstream release
  137. * Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.16-2vl2
  138. - changed doc Group to Applications/Documentation
  139. * Fri Nov 26 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.16-2vl1
  140. - changed packages Group:
  141. - cleaned spec file (a little bit!)
  142. * Fri Feb 28 2003 Kazuhisa TAKEI <takei@vinelinux.org> 0.9.16-2vl0
  143. - new upstream version
  144. - convert to Vine Linux
  145. * Fri Dec 27 2002 Gz Waschk <waschk@linux-mandrake.com> 0.9.15-2mdk
  146. - rebuild
  147. * Wed Nov 13 2002 Gz Waschk <waschk@linux-mandrake.com> 0.9.15-1mdk
  148. - new version
  149. * Tue Oct 29 2002 Gz Waschk <waschk@linux-mandrake.com> 0.9.14-1mdk
  150. - fix group of doc package
  151. - new version
  152. * Fri Aug 23 2002 Gz Waschk <waschk@linux-mandrake.com> 0.9.13-1mdk
  153. - add directfb-csource and man page
  154. - 0.9.13
  155. * Thu Jul 11 2002 Gz Waschk <waschk@linux-mandrake.com> 0.9.12-1mdk
  156. - initial package based on PLD effort