curl-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
  3. Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
  4. Name: curl
  5. Version: 7.49.0
  6. Release: 1%{?_dist_release}
  7. License: MIT
  8. Group: Applications/Internet
  9. URL: http://curl.haxx.se/
  10. Source: http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
  11. # patch making libcurl multilib ready
  12. Patch101: 0101-curl-7.32.0-multilib.patch
  13. # prevent configure script from discarding -g in CFLAGS (#496778)
  14. Patch102: 0102-curl-7.36.0-debug.patch
  15. # use localhost6 instead of ip6-localhost in the curl test-suite
  16. Patch104: 0104-curl-7.19.7-localhost6.patch
  17. # work around valgrind bug (#678518)
  18. Patch107: 0107-curl-7.21.4-libidn-valgrind.patch
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  20. BuildRequires: openssl-devel libidn-devel zlib-devel
  21. BuildRequires: openldap-devel gnutls-devel
  22. BuildRequires: openssh-server
  23. BuildRequires: openssh-clients
  24. BuildRequires: pkgconfig
  25. %if "%{?_dist_release}" != "vl6"
  26. BuildRequires: libssh2-devel
  27. %endif
  28. Requires: ca-certificates
  29. Vendor: Project Vine
  30. Distribution: Vine Linux
  31. Packager: daisuke
  32. %description
  33. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  34. Dict servers, using any of the supported protocols. cURL is designed
  35. to work without user interaction or any kind of interactivity. cURL
  36. offers many useful capabilities, like proxy support, user
  37. authentication, FTP upload, HTTP post, and file transfer resume.
  38. %package devel
  39. Summary: Files needed for building applications with libcurl.
  40. Group: Development/Libraries
  41. Requires: %{name} = %{version}-%{release}
  42. Requires: openssl-devel libidn-devel zlib-devel
  43. %description devel
  44. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  45. Dict servers, using any of the supported protocols. The curl-devel
  46. package includes files needed for developing applications which can
  47. use cURL's capabilities internally.
  48. #'
  49. ## to build compat32 for x86_64 architecture support
  50. %package -n compat32-%{name}
  51. Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
  52. Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
  53. Group: System Environment/Libraries
  54. %description -n compat32-%{name}
  55. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  56. Dict servers, using any of the supported protocols. cURL is designed
  57. to work without user interaction or any kind of interactivity. cURL
  58. offers many useful capabilities, like proxy support, user
  59. authentication, FTP upload, HTTP post, and file transfer resume.
  60. %package -n compat32-%{name}-devel
  61. Summary: Files needed for building applications with libcurl.
  62. Group: Development/Libraries
  63. %description -n compat32-%{name}-devel
  64. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  65. Dict servers, using any of the supported protocols. The curl-devel
  66. package includes files needed for developing applications which can
  67. use cURL's capabilities internally.
  68. #'
  69. %prep
  70. %setup -q
  71. # Fedora patches
  72. %patch101 -p1
  73. %patch102 -p1
  74. %patch104 -p1
  75. %patch107 -p1
  76. %build
  77. %configure \
  78. --with-ssl=%{_prefix} \
  79. --with-gnutls \
  80. --with-libidn \
  81. --enable-ipv6 \
  82. --enable-threaded-resolver \
  83. --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
  84. %if "%{?_dist_release}" != "vl6"
  85. --with-libssh2 \
  86. %endif
  87. --enable-ldaps \
  88. --disable-static \
  89. --enable-hidden-symbols
  90. make %{?_smp_mflags}
  91. %install
  92. rm -rf $RPM_BUILD_ROOT
  93. make DESTDIR=$RPM_BUILD_ROOT install
  94. rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
  95. %clean
  96. rm -rf $RPM_BUILD_ROOT
  97. %post -p /sbin/ldconfig
  98. %postun -p /sbin/ldconfig
  99. %files
  100. %defattr(-,root,root)
  101. %doc CHANGES COPYING README
  102. %doc docs/BUGS docs/CONTRIBUTE docs/examples docs/FAQ docs/FEATURES
  103. %doc docs/INSTALL docs/INTERNALS docs/MANUAL docs/RESOURCES
  104. %doc docs/TheArtOfHttpScripting docs/TODO
  105. %{_bindir}/curl
  106. #{_datadir}/curl/*
  107. %{_libdir}/*.so.*
  108. %{_mandir}/man1/*.1*
  109. %files devel
  110. %defattr(-,root,root)
  111. %{_bindir}/curl-config
  112. %{_includedir}/curl
  113. %{_libdir}/*.so
  114. %{_libdir}/pkgconfig/*.pc
  115. %{_mandir}/man1/curl-config.1*
  116. %{_mandir}/man3/*
  117. %{_datadir}/aclocal/libcurl.m4
  118. ## to build compat32 for x86_64 architecture support
  119. %if %{build_compat32}
  120. %files -n compat32-%{name}
  121. %defattr(-,root,root)
  122. %{_libdir}/*.so.*
  123. %files -n compat32-%{name}-devel
  124. %defattr(-,root,root)
  125. %{_libdir}/*.so
  126. %{_libdir}/pkgconfig/*.pc
  127. %endif
  128. %changelog
  129. * Sat May 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.0-1
  130. - new upstream release.
  131. * Sat Mar 12 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.47.1-1
  132. - new upstream release
  133. - built with openssl 1.0.2g
  134. * Fri Jun 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.43.0-1
  135. - new upstream release with security fix .
  136. - removed Patch108 (fixed in upstream).
  137. * Sun Nov 9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.39.0-1
  138. - new upstream release with security fix
  139. * Sun Jan 19 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 7.34.0-1
  140. - new upstream release
  141. - add libcurl.m4 to -devel package
  142. * Wed Sep 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 7.32.0-1
  143. - new upstream release
  144. - import upstream/fedora patches
  145. - disable libssh2 on Vine Linux 6
  146. * Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.1-1
  147. - new upstream reelase
  148. * Sun Oct 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.0-1
  149. - update to 7.28.0
  150. - add configure options
  151. - --enable-ssh2, --enable-threaded-resolver, --enable-ldaps
  152. - add BR: libssh2-devel, openssh-clients, openssh-server, pkgconfig
  153. - use ca-certificates package
  154. - --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt
  155. - R: ca-certificates
  156. * Tue Feb 21 2012 NAKAMURA Kenta <kenta@vinelinux.org> 7.24.0-1
  157. - new upstream release
  158. * Sun Jul 3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.20.1-4
  159. - add patch100 for fix CVE-2011-2192 (gssapi)
  160. - add Vendor/Distri tags
  161. * Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.20.1-3
  162. - rebuild with openssl-1.0.0c
  163. * Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 7.20.1-2
  164. - rebuilt with rpm-4.8.1 for pkg-config
  165. * Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.20.1-1
  166. - new upstream release
  167. * Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.6-1
  168. - new upstream release with security fix
  169. * Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 7.19.5-2
  170. - added compat32 subpackages
  171. * Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.5-1
  172. - new upstream release
  173. - use "_smp_mflags" flag
  174. * Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.4-2
  175. - rebuild with openldap-2.4.11
  176. - add BR: openldap-devel
  177. - remove static library
  178. * Sat Mar 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.4-1
  179. - new upstream release with security fix (CVE-2009-0037)
  180. * Sun Jul 6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.2-1
  181. - new upstream release
  182. * Tue Apr 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.1-1vl5
  183. - new upstream release
  184. * Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.0-1vl5
  185. - new upstream release
  186. * Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.17.1-0vl1
  187. - new upstream release
  188. * Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.4-0vl1
  189. - new upstream release
  190. * Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.16.2-0vl2
  191. - rebuilt with openssl-0.9.8e
  192. * Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.2-0vl1
  193. - new upstream release
  194. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.3-0vl1
  195. - new upstream release
  196. * Tue Feb 28 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.2-0vl1
  197. - new upstream release
  198. - add pkgconfig file to devel package
  199. * Wed Dec 7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.1-0vl1
  200. - new upstream release
  201. * Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.0-0vl1
  202. - new upstream release
  203. * Fri Sep 2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.14.1-0vl1
  204. - new upstream release
  205. * Mon Feb 14 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl3
  206. - added libidn, zlib in Requires
  207. - added libidn-devel, zlib-devel in BuildPrereq
  208. - added zlib-devel in curl-devel's Requires
  209. * Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl2
  210. - added openssl-devel, libidn-devel in curl-devel's Requires
  211. * Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl1
  212. - new upstream release
  213. * Tue Mar 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.11.1-0vl1
  214. - new upstream release
  215. - rebuild with openssl-0.9.7d
  216. * Sun Sep 14 2003 HOTTA Michihide <hotta@net-newbie.com> 7.10.7-0vl1
  217. - upstream release
  218. * Sat Feb 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl2
  219. - add %%{_datadir}/curl/* to %%files section
  220. * Sun Jan 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl1
  221. - source upgrade
  222. * Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.9.8-0vl1
  223. - source upgrade
  224. - add PreReq: ldconfig
  225. - add %%{_libdir}/*.la to %%files devel section
  226. * Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 7.9.2-2vl1
  227. - build for VineSeed
  228. - add Requires: openssl
  229. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  230. - automated rebuild
  231. * Wed Jan 9 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 7.9.2-1
  232. - 7.9.2
  233. * Fri Aug 17 2001 Nalin Dahyabhai <nalin@redhat.com>
  234. - include curl-config in curl-devel
  235. - update to 7.8 to fix memory leak and strlcat() symbol pollution from libcurl
  236. * Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com>
  237. - added openssl-devel build req
  238. * Mon May 21 2001 Tim Powers <timp@redhat.com>
  239. - built for the distro
  240. * Tue Apr 24 2001 Jeff Johnson <jbj@redhat.com>
  241. - upgrade to curl-7.7.2.
  242. - enable IPv6.
  243. * Fri Mar 2 2001 Tim Powers <timp@redhat.com>
  244. - rebuilt against openssl-0.9.6-1
  245. * Thu Jan 4 2001 Tim Powers <timp@redhat.com>
  246. - fixed mising ldconfigs
  247. - updated to 7.5.2, bug fixes
  248. * Mon Dec 11 2000 Tim Powers <timp@redhat.com>
  249. - updated to 7.5.1
  250. * Mon Nov 6 2000 Tim Powers <timp@redhat.com>
  251. - update to 7.4.1 to fix bug #20337, problems with curl -c
  252. - not using patch anymore, it's included in the new source. Keeping
  253. for reference
  254. * Fri Oct 20 2000 Nalin Dahyabhai <nalin@redhat.com>
  255. - fix bogus req in -devel package
  256. * Fri Oct 20 2000 Tim Powers <timp@redhat.com>
  257. - devel package needed defattr so that root owns the files
  258. * Mon Oct 16 2000 Nalin Dahyabhai <nalin@redhat.com>
  259. - update to 7.3
  260. - apply vsprintf/vsnprintf patch from Colin Phipps via Debian
  261. * Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
  262. - enable SSL support
  263. - fix packager tag
  264. - move buildroot to %%{_tmppath}
  265. * Tue Aug 1 2000 Tim Powers <timp@redhat.com>
  266. - fixed vendor tag for bug #15028
  267. * Mon Jul 24 2000 Prospector <prospector@redhat.com>
  268. - rebuilt
  269. * Tue Jul 11 2000 Tim Powers <timp@redhat.com>
  270. - workaround alpha build problems with optimizations
  271. * Mon Jul 10 2000 Tim Powers <timp@redhat.com>
  272. - rebuilt
  273. * Mon Jun 5 2000 Tim Powers <timp@redhat.com>
  274. - put man pages in correct place
  275. - use %%makeinstall
  276. * Mon Apr 24 2000 Tim Powers <timp@redhat.com>
  277. - updated to 6.5.2
  278. * Wed Nov 3 1999 Tim Powers <timp@redhat.com>
  279. - updated sources to 6.2
  280. - gzip man page
  281. * Mon Aug 30 1999 Tim Powers <timp@redhat.com>
  282. - changed group
  283. * Thu Aug 26 1999 Tim Powers <timp@redhat.com>
  284. - changelog started
  285. - general cleanups, changed prefix to /usr, added manpage to files section
  286. - including in Powertools