cppunit-vl.spec 4.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150
  1. Name: cppunit
  2. Version: 1.12.1
  3. Release: 4%{?_dist_release}
  4. Summary: C++ unit testing framework
  5. Summary(ja): C++ 単体テストフレームワーク
  6. License: LGPL
  7. Group: Development/Tools
  8. Url: http://cppunit.sourceforge.net/
  9. #Source: http://download.sf.net/cppunit/cppunit-%{version}.tar.gz
  10. Source: http://downloads.sourceforge.net/cppunit/cppunit-%{version}.tar.gz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: doxygen, graphviz
  13. %description
  14. CppUnit is the C++ port of the famous JUnit framework for unit testing.
  15. Test output is in XML for automatic testing and GUI based for supervised tests.
  16. %package devel
  17. Summary: Libraries and headers for cppunit development
  18. Summary(ja): cppunit 開発用ファイル
  19. Group: Development/Libraries
  20. Requires: pkgconfig, automake
  21. Requires: %{name} = %{version}-%{release}
  22. %description devel
  23. This package contains the libraries and headers necessary for developing
  24. programs that use cppunit.
  25. %package doc
  26. Summary: HTML formatted API documention for cppunit
  27. Summary(ja): cppunit の API ドキュメント (HTMLフォーマット)
  28. Group: Applications/Documentation
  29. Requires: %{name} = %{version}-%{release}
  30. %description doc
  31. The cppunit-doc package contains HTML formatted API documention generated by
  32. the popular doxygen documentation generation tool.
  33. %prep
  34. %setup -q
  35. %build
  36. %configure --enable-doxygen --disable-static
  37. make %{?_smp_mflags}
  38. %install
  39. rm -rf $RPM_BUILD_ROOT
  40. make install DESTDIR=$RPM_BUILD_ROOT
  41. rm $RPM_BUILD_ROOT%{_libdir}/*.la
  42. # remove double of doc
  43. rm -rf $RPM_BUILD_ROOT%{_datadir}/doc/cppunit
  44. # clean up examples
  45. rm -rf dist-examples dist-examples-dir
  46. cp -a examples dist-examples
  47. make -C dist-examples distclean
  48. # Makefile.am files are left as documentation
  49. find dist-examples \( -name Makefile.in -o -name .cvsignore \) -exec rm {} \;
  50. mkdir dist-examples-dir
  51. mv dist-examples dist-examples-dir/examples
  52. %clean
  53. rm -rf $RPM_BUILD_ROOT
  54. %post -p /sbin/ldconfig
  55. %postun -p /sbin/ldconfig
  56. %files
  57. %defattr(-,root,root,-)
  58. %doc AUTHORS COPYING NEWS README THANKS ChangeLog TODO BUGS doc/FAQ
  59. %{_bindir}/DllPlugInTester
  60. %{_libdir}/libcppunit*.so.*
  61. %files devel
  62. %defattr(-,root,root,-)
  63. %{_bindir}/cppunit-config
  64. %{_includedir}/cppunit
  65. %{_libdir}/libcppunit.so
  66. %{_datadir}/aclocal/cppunit.m4
  67. %{_mandir}/man1/cppunit-config.1*
  68. %{_libdir}/pkgconfig/cppunit.pc
  69. %files doc
  70. %defattr(-,root,root,-)
  71. %doc dist-examples-dir/examples/
  72. %doc doc/html/
  73. %changelog
  74. * Mon Jan 13 2014 NAKAMURA Kenta <kenta@vinelinux.org> 1.12.1-4
  75. - rebuilt with the current environment
  76. * Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 1.12.1-3
  77. - rebuilt with rpm-4.8.1 for pkg-config
  78. * Tue Mar 23 2010 Shu KONNO <owa@bg.wakwak.com> 1.12.1-2
  79. - built with new toolchain
  80. - changed source url
  81. * Sat Nov 1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.12.1-1
  82. - new upstream release
  83. - applied new versioning policy
  84. - spec in UTF-8
  85. * Tue Jul 31 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.12.0-3vl3
  86. - rebuilt fot VineSeed
  87. * Tue Jul 31 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.12.0-3vl2
  88. - changed Group to Development/Tools
  89. - changed doc Group to Applications/Documentation
  90. - rebuilt fot VinePlus/4.0
  91. * Thu May 31 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.12.0-3vl1
  92. - updated to 1.12.0 release based on FC package
  93. - Fri Aug 1 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.8.0-0vl2
  94. - Rebuild for new Vine.
  95. - Mon Jun 23 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> 1.8.0-0vl1
  96. - Initial build.
  97. * Mon Jan 29 2007 Patrice Dumas <pertusus@free.fr> 1.12.0-3
  98. - add rightly files to -devel (#224106)
  99. - add necessary requires for -devel (#224106)
  100. - ship examples
  101. * Sun Sep 10 2006 Patrice Dumas <pertusus@free.fr> 1.12.0-2
  102. - rebuild for FC6
  103. * Wed Jul 5 2006 Patrice Dumas <pertusus@free.fr> 1.12.0-1
  104. - update to 1.12
  105. * Sun May 21 2006 Patrice Dumas <pertusus@free.fr> 1.11.6-1
  106. - update to 1.11.6
  107. * Wed Dec 21 2005 Patrice Dumas <pertusus@free.fr> 1.11.4-1
  108. - update
  109. * Mon Aug 15 2005 Tom "spot" Callaway <tcallawa@redhat.com> 1.11.0-2
  110. - various cleanups
  111. * Mon Jul 4 2005 Patrice Dumas <pertusus@free.fr> 1.11.0-1
  112. - update using the fedora template
  113. * Sat Apr 14 2001 Bastiaan Bakker <bastiaan.bakker@lifeline.nl>
  114. - Initial release