clisp-vl.spec 6.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203
  1. %define year 2002
  2. %define month 07
  3. %define day 25
  4. %define name clisp
  5. %define version 2.49
  6. %define release 3%{?_dist_release}
  7. %define clisp_build vine
  8. Summary: Common Lisp (ANSI CL) implementation
  9. Summary(ja): 関数型言語 Common Lisp (ANSI CL) の実装
  10. Name: clisp
  11. Version: %{version}
  12. Release: %{release}
  13. Icon: clisp.gif
  14. License: GPL
  15. Group: Development/Languages
  16. Source: ftp://ftp.gnu.org/pub/gnu/clisp/release/%{version}/%{name}-%{version}.tar.bz2
  17. # patch from suse
  18. # PATCH-FIX-OPENSUSE Correct path for header for System V IPC system calls
  19. Patch0: clisp-linux.patch
  20. # PATCH-FIX-OPENSUSE Glibc got rid of unused __swblk_t type therefore update linux.lisp
  21. Patch1: clisp-glibc-fix.patch
  22. #PATCH-FIX-UPSTREAM patch#3474660 changeset 15557 4f5985f83127
  23. Patch2: clisp-hostname.patch
  24. URL: http://www.clisp.org/
  25. Provides: clisp, ansi-cl
  26. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  27. BuildRequires: imake
  28. BuildRequires: libsigsegv-devel
  29. BuildRequires: readline-devel
  30. BuildRequires: dbus-devel
  31. BuildRequires: diffutils
  32. BuildRequires: fcgi-devel
  33. BuildRequires: ffcall
  34. BuildRequires: gdbm-devel
  35. BuildRequires: gettext
  36. BuildRequires: gtk2-devel
  37. BuildRequires: libICE-devel
  38. BuildRequires: libSM-devel
  39. BuildRequires: libX11-devel
  40. BuildRequires: libXaw-devel
  41. BuildRequires: libXext-devel
  42. BuildRequires: libXft-devel
  43. BuildRequires: libXmu-devel
  44. BuildRequires: libXrender-devel
  45. BuildRequires: libXt-devel
  46. BuildRequires: libglade2-devel
  47. BuildRequires: pcre-devel
  48. BuildRequires: libpq-devel
  49. BuildRequires: openssl-devel
  50. BuildRequires: zlib-devel
  51. %description
  52. Common Lisp is a high-level, general-purpose, object-oriented, dynamic,
  53. functional programming language.
  54. CLISP is a Common Lisp implementation by Bruno Haible, then of Karlsruhe
  55. University, and Michael Stoll, then of Munich University, both in Germany.
  56. It supports the Lisp described in the ANSI Common Lisp standard plus many
  57. extensions.
  58. CLISP includes an interpreter, a compiler, a debugger, CLOS, MOP, a foreign
  59. language interface, i18n, regular expressions, a socket interface, and more.
  60. An X11 interface is available through CLX, Garnet and CLUE/CLIO. Command line
  61. editing is provided by readline. CLISP runs Maxima, ACL2 and many other
  62. Common Lisp packages.
  63. CLISP runs on most GNU and Unix systems (Linux, FreeBSD, NetBSD, OpenBSD,
  64. Solaris, Tru64, HP-UX, BeOS, NeXTstep, IRIX, AIX and others) and on other
  65. systems (Windows NT/2000/XP, Windows 95/98/ME) and needs only 4 MB of RAM.
  66. CLISP is Free Software and may be distributed under the terms of GNU GPL.
  67. You may distribute commercial proprietary applications compiled with CLISP,
  68. see file COPYRIGHT in the CLISP distribution.
  69. The user interface comes in English, German, French, Spanish, Dutch, Russian
  70. and Danish, and can be changed at run time.
  71. %prep
  72. %setup -q
  73. %patch0 -p1
  74. %patch1 -p1 -b .glibc
  75. %patch2 -p0
  76. sed -i 's|http://www.lisp.org/HyperSpec/|http://www.lispworks.com/documentation/HyperSpec/|g' \
  77. doc/* src/*.d src/*.lisp
  78. %build
  79. %ifarch ppc ppc64
  80. %define opt_flags "%{optflags} -DNO_GENERATIONAL_GC -DNO_MULTIMAP_FILE -DNO_SINGLEMAP"
  81. ulimit -s unlimited
  82. %else
  83. %define opt_flags "%{optflags}"
  84. %endif
  85. ./configure --prefix=%{_prefix} \
  86. --libdir=%{_libdir} \
  87. --mandir=%{_mandir} \
  88. --docdir=%{_docdir}/clisp-%{version} \
  89. --fsstnd=redhat \
  90. --hyperspec=http://www.lispworks.com/documentation/HyperSpec/ \
  91. --with-module=bindings/glibc \
  92. --with-module=clx/new-clx \
  93. --with-module=dbus \
  94. --with-module=fastcgi \
  95. --with-module=gdbm \
  96. --with-module=gtk2 \
  97. --with-module=i18n \
  98. --with-module=pcre \
  99. --with-module=postgresql \
  100. --with-module=rawsock \
  101. --with-module=regexp \
  102. --with-module=syscalls \
  103. --with-module=wildcard \
  104. --with-module=zlib \
  105. --with-readline \
  106. --cbc \
  107. build CFLAGS=%opt_flags
  108. %install
  109. rm -rf %{buildroot}
  110. make -C build DESTDIR=%{buildroot} install
  111. rm -f %{buildroot}%{_docdir}/clisp-%{version}/doc/clisp.{dvi,1,ps}
  112. cp -p doc/mop-spec.pdf %{buildroot}%{_docdir}/clisp-%{version}/doc
  113. cp -p doc/*.png %{buildroot}%{_docdir}/clisp-%{version}/doc
  114. cp -p doc/Why-CLISP* %{buildroot}%{_docdir}/clisp-%{version}/doc
  115. cp -p doc/regexp.html %{buildroot}%{_docdir}/clisp-%{version}/doc
  116. find %{buildroot}%{_libdir} -name '*.dvi' | xargs rm -f
  117. %find_lang %{name}
  118. %find_lang %{name}low
  119. cat %{name}low.lang >> %{name}.lang
  120. ## ad-hoc fix <BTS:VineLinux:825>: '--vimdir' option is broken...
  121. %__mkdir_p %{buildroot}%{_sysconfdir}/vim
  122. %__mv %{buildroot}%{_datadir}/vim/vimfiles/after %{buildroot}%{_sysconfdir}/vim
  123. %clean
  124. rm -rf %{buildroot}
  125. %files -f %{name}.lang
  126. %defattr(-,root,root,-)
  127. %{_bindir}/%{name}
  128. %{_bindir}/%{name}-link
  129. %{_mandir}/man1/*
  130. %{_libdir}/%{name}-%{version}
  131. %{_datadir}/aclocal/*.m4
  132. %{_datadir}/emacs/site-lisp/*
  133. %{_sysconfdir}/vim
  134. %doc %{_docdir}/clisp-%{version}
  135. %changelog
  136. * Fri Jul 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.49-3
  137. - rebuild with readline-6.3
  138. - add Patch0,1,2 from suse
  139. - remove BuildRequires: postgresql-devel
  140. - add BuildRequires: libpq-devel, openssl-devel
  141. * Fri Mar 23 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.49-2
  142. - rebuild with current ffcall
  143. * Tue Apr 19 2011 IWAI, Masaharu <iwai@alib.jp> 2.49-1
  144. - new upstream release
  145. - ad-hoc fix <BTS:VineLinux:825>: but '--vimdir' option is broken...
  146. * Tue Apr 12 2011 Shu KONNO <owa@bg.wakwak.com> 2.48-2
  147. - rebuilt with postgresql-9.0.3
  148. * Sat Mar 6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.48-1
  149. - new upstream release
  150. - built with new toolchain, libsigsegv-2.8
  151. - updated build dependencies
  152. * Sun Sep 21 2008 Shu KONNO <owa@bg.wakwak.com> 2.43-1vl5
  153. - applied new versioning policy, spec in utf-8
  154. * Mon Nov 26 2007 Shu KONNO <owa@bg.wakwak.ne.jp> 2.43-0vl1
  155. - version up to 2.43
  156. - updated source url
  157. - changed %%{_libdir}/clisp to %%{_libdir}/clisp-%%{version}
  158. - added option "--libdir=%%{_libdir}" to configure for lib64
  159. * Sun Mar 18 2007 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> 2.41-0vl1
  160. - version up to 2.41
  161. - add BuildRequires : readline-devel, gettext, libsigsegv-devel
  162. - update %%description, %%files, configure options
  163. - drop hfs patch
  164. * Tue Jan 6 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.32-0vl1
  165. - version up to 2.32
  166. - rebuild with new toolchains
  167. - updated hfs patch
  168. * Sun Aug 25 2002 Yoshihiro Ota <ota@j.email.ne.jp>
  169. - version up to 2.29
  170. * Sat Mar 9 2002 Yoshihiro Ota <ota@j.email.ne.jp>
  171. - version up to 2.28
  172. - added BuildRequires : ncurses-devel and removed groff patch
  173. * Fri Jan 18 2002 Yoshihiro Ota <ota@j.email.ne.jp>
  174. - create rpm for release 2.27