ccid-vl.spec 5.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173
  1. %define dropdir %(pkg-config libpcsclite --variable usbdropdir 2>/dev/null)
  2. %define libusb1_ver 1.0.9
  3. %define pcsc_lite_ver 1.8.13
  4. Name: ccid
  5. Version: 1.4.18
  6. Release: 1%{?_dist_release}
  7. Summary: Generic USB CCID smart card reader driver
  8. Summary(ja): Generic USB CCID smart card reader driver
  9. Group: System Environment/Libraries
  10. License: LGPLv2+
  11. URL: http://pcsclite.alioth.debian.org/ccid.html
  12. Source0: http://alioth.debian.org/download.php/1563/%{name}-%{version}.tar.bz2
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  14. BuildRequires: libusb1-devel >= %{libusb1_ver}
  15. BuildRequires: pcsc-lite-devel >= %{pcsc_lite_ver}
  16. Requires(post): initscripts
  17. Requires(postun): initscripts
  18. Requires: libusb1
  19. Requires: pcsc-lite
  20. Provides: pcsc-ifd-handler
  21. Conflicts: ccid145
  22. # 390 does not have libusb or smartCards
  23. ExcludeArch: s390 s390x
  24. %description
  25. Generic USB CCID (Chip/Smart Card Interface Devices) driver.
  26. %prep
  27. %setup -q
  28. for f in ChangeLog README ; do
  29. iconv -f iso-8859-1 -t utf-8 $f > $f.utf8 ; mv $f.utf8 $f
  30. done
  31. %build
  32. %configure --disable-dependency-tracking --disable-static --enable-twinserial
  33. make %{?_smp_mflags}
  34. %install
  35. rm -rf $RPM_BUILD_ROOT
  36. make install DESTDIR=$RPM_BUILD_ROOT
  37. %{__mkdir_p} $RPM_BUILD_ROOT/%{_sysconfdir}/udev/rules.d
  38. %{__install} -m 644 src/92_pcscd_ccid.rules $RPM_BUILD_ROOT/%{_sysconfdir}/udev/rules.d/92-pcscd_ccid.rules
  39. %clean
  40. rm -rf $RPM_BUILD_ROOT
  41. %post
  42. [ -x %{_initrddir}/pcscd ] && %{_initrddir}/pcscd status >> /dev/null 2>&1 && %{_sbindir}/pcscd -H > /dev/null 2>&1
  43. exit 0
  44. %postun
  45. [ -x %{_initrddir}/pcscd ] && %{_initrddir}/pcscd status >> /dev/null 2>&1 && %{_sbindir}/pcscd -H > /dev/null 2>&1
  46. exit 0
  47. %files
  48. %defattr(-,root,root,-)
  49. %doc AUTHORS ChangeLog COPYING NEWS README SCARDGETATTRIB.txt
  50. %{dropdir}/ifd-ccid.bundle/
  51. %{dropdir}/serial/
  52. %config(noreplace) %{_sysconfdir}/reader.conf.d/libccidtwin
  53. %config %{_sysconfdir}/udev/rules.d/92-pcscd_ccid.rules
  54. %changelog
  55. * Mon May 04 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.18-1
  56. - new upstream release
  57. * Tue Jun 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.7-2
  58. - add Conflicts: ccid145
  59. * Sun Jun 24 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.7-1
  60. - new upstream release
  61. - change BuildRequires: libusb1-devel instead of libusb-devel
  62. * Mon Mar 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.8-1
  63. - initial build for Vine Linux
  64. * Tue Aug 26 2008 Bob Relyea <rrelyea@redhat.com> - 1.3.8-1
  65. - update to ccid 1.3.8
  66. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.2.1-4
  67. - Autorebuild for GCC 4.3
  68. * Mon Aug 20 2007 Bob Relyea <rrelyea@redhat.com> - 1.2.1-3
  69. - Update License description to the new Fedora standard
  70. * Mon Apr 30 2007 Bob Relyea <rrelyea@redhat.com> - 1.2.1-2
  71. - Fix the missed use of the version macro
  72. * Tue Feb 06 2007 Bob Relyea <rrelyea@redhat.com> - 1.2.1-1
  73. - Pick up ccid 1.2.1
  74. - use pcscd 'hotplug' feature instead of restarting the daemon
  75. - add enable_udev
  76. * Mon Nov 06 2006 Bob Relyea <rrelyea@redhat.com> - 1.1.0-2
  77. - Fix version macro to remove '-'
  78. * Thu Nov 02 2006 Bob Relyea <rrelyea@redhat.com> - 1.1.0-1
  79. - Pickup ccid 1.1.0
  80. * Thu Jul 20 2006 Florian La Roche <laroche@redhat.com> - 1.0.1-5
  81. - require initscripts for post/postun
  82. * Sun Jul 16 2006 Florian La Roche <laroche@redhat.com> - 1.0.1-4
  83. - fix excludearch line
  84. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.0.1-3.1
  85. - rebuild
  86. * Mon Jul 10 2006 Bob Relyea <rrelyea@redhat.com> - 1.0.1-3
  87. - remove s390 from the build
  88. * Mon Jun 5 2006 Bob Relyea <rrelyea@redhat.com> - 1.0.1-2
  89. - Move to Fedora Core, removed %%{_dist}.
  90. * Sat Apr 22 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.0.1-1
  91. - 1.0.1.
  92. * Mon Mar 6 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.0.0-1
  93. - 1.0.0, license changed to LGPL.
  94. * Wed Feb 15 2006 Ville Skyttä <ville.skytta at iki.fi> - 0.4.1-7
  95. - Rebuild.
  96. * Thu Nov 3 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.4.1-6
  97. - Clean up build dependencies.
  98. - Convert docs to UTF-8.
  99. * Thu Apr 7 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 0.4.1-5
  100. - rebuilt
  101. * Fri Feb 25 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.4.1-4
  102. - Drop Epoch: 0.
  103. - Improve summary.
  104. - Build with dependency tracking disabled.
  105. * Thu Jul 1 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.4.1-0.fdr.3
  106. - Restart pcscd in post(un)install phase if it's available and running.
  107. * Thu May 13 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.4.1-0.fdr.2
  108. - Provide pcsc-ifd-handler (idea from Debian).
  109. * Sat Feb 14 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.4.1-0.fdr.1
  110. - Update to 0.4.1.
  111. * Fri Feb 13 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.4.0-0.fdr.1
  112. - Update to 0.4.0.
  113. * Wed Nov 5 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.3.2-0.fdr.1
  114. - Update to 0.3.2.
  115. - Update URL.
  116. * Thu Oct 16 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.3.1-0.fdr.1
  117. - Update to 0.3.1.
  118. * Wed Sep 10 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.3.0-0.fdr.1
  119. - Update to 0.3.0.
  120. * Wed Aug 27 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.2.0-0.fdr.1
  121. - Update to 0.2.0.
  122. * Tue Aug 19 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.1.0-0.fdr.1
  123. - First build.