cairo-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415
  1. Summary: Cairo - multi-platform 2D graphics library.
  2. Summary(ja): Cairo - マルチプラットフォーム 2D グラフィックスライブラリ
  3. Name: cairo
  4. Version: 1.14.6
  5. Release: 1%{?_dist_release}
  6. License: LGPL/MPL
  7. Group: System Environment/Libraries
  8. Source0: http://cairographics.org/releases/%{name}-%{version}.tar.xz
  9. # don't use serverside gradients, most drivers don't handle those and are
  10. # really slow, should workaround performances issues for ati, nouveau and nvidia
  11. # https://launchpad.net/ubuntu/maverick/+source/cairo/1.10.0-1ubuntu1
  12. Patch1: cairo-1.10.0-dont_use_server_side_gradients.patch
  13. URL: http://cairographics.org/
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: pkgconfig
  16. BuildRequires: pixman-devel
  17. BuildRequires: glib2-devel
  18. BuildRequires: libpng-devel
  19. BuildRequires: freetype2-devel
  20. BuildRequires: fontconfig-devel
  21. BuildRequires: libX11-devel
  22. BuildRequires: libXrender-devel
  23. BuildRequires: gtk-doc
  24. BuildRequires: librsvg2-devel
  25. BuildRequires: mesa-libGL-devel
  26. BuildRequires: mesa-libEGL-devel
  27. BuildConflicts: XOrg-compat70-devel
  28. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  29. Vendor: Project Vine
  30. Distribution: Vine Linux
  31. %description
  32. Cairo provides anti-aliased vector-based rendering for X. Paths
  33. consist of line segments and cubic splines and can be rendered at any
  34. width with various join and cap styles. All colors may be specified
  35. with optional translucence (opacity/alpha) and combined using the
  36. extended Porter/Duff compositing algebra as found in the X Render
  37. Extension.
  38. Cairo exports a stateful rendering API similar in spirit to the path
  39. construction, text, and painting operators of PostScript, (with the
  40. significant addition of translucence in the imaging model). When
  41. complete, the API is intended to support the complete imaging model of
  42. PDF 1.4.
  43. Cairo relies on the Xc library for backend rendering. Xc provides an
  44. abstract interface for rendering to multiple target types. As of this
  45. writing, Xc allows Cairo to target X drawables as well as generic
  46. image buffers. Future backends such as PostScript, PDF, and perhaps
  47. OpenGL are currently being planned.
  48. %package -n compat32-%{name}
  49. Summary: Cairo - multi-platform 2D graphics library.
  50. Summary(ja): Cairo - マルチプラットフォーム 2D グラフィックスライブラリ
  51. Group: System Environment/Libraries
  52. Requires: %{name} = %{version}
  53. %description -n compat32-%{name}
  54. Cairo provides anti-aliased vector-based rendering for X. Paths
  55. consist of line segments and cubic splines and can be rendered at any
  56. width with various join and cap styles. All colors may be specified
  57. with optional translucence (opacity/alpha) and combined using the
  58. extended Porter/Duff compositing algebra as found in the X Render
  59. Extension.
  60. Cairo exports a stateful rendering API similar in spirit to the path
  61. construction, text, and painting operators of PostScript, (with the
  62. significant addition of translucence in the imaging model). When
  63. complete, the API is intended to support the complete imaging model of
  64. PDF 1.4.
  65. Cairo relies on the Xc library for backend rendering. Xc provides an
  66. abstract interface for rendering to multiple target types. As of this
  67. writing, Xc allows Cairo to target X drawables as well as generic
  68. image buffers. Future backends such as PostScript, PDF, and perhaps
  69. OpenGL are currently being planned.
  70. %package devel
  71. Summary: Development files for Cairo library.
  72. Summary(ja): Cairo ライブラリの開発用ファイル
  73. Group: Development/Libraries
  74. Provides: lib%{name}-devel = %{version}-%{release}
  75. Requires: %{name} = %{version}
  76. Requires: libpng-devel
  77. Requires: freetype2-devel
  78. Requires: fontconfig-devel
  79. Requires: libX11-devel
  80. Requires: libXrender-devel
  81. Requires: pixman-devel
  82. Requires: glib2-devel
  83. Requires: mesa-libEGL-devel
  84. %description devel
  85. Development files for Cairo library.
  86. %package tools
  87. Summary: Development tools for cairo
  88. Group: Development/Tools
  89. %description tools
  90. Cairo is a 2D graphics library designed to provide high-quality display
  91. and print output.
  92. This package contains tools for working with the cairo graphics library.
  93. * cairo-trace: Record cairo library calls for later playback
  94. %prep
  95. %setup -q
  96. %patch1 -p1 -b .dont-use-server-side-gradients
  97. %build
  98. %configure --disable-static \
  99. --enable-gtk-doc \
  100. --enable-xlib \
  101. --enable-freetype \
  102. --enable-ps \
  103. --enable-pdf \
  104. --enable-svg \
  105. --enable-tee \
  106. --enable-gobject \
  107. --enable-gl
  108. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  109. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  110. make %{?_smp_mflags}
  111. %install
  112. rm -rf $RPM_BUILD_ROOT
  113. %makeinstall
  114. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
  115. %clean
  116. rm -rf $RPM_BUILD_ROOT
  117. %post -p /sbin/ldconfig
  118. %postun -p /sbin/ldconfig
  119. %post -n compat32-%{name} -p /sbin/ldconfig
  120. %postun -n compat32-%{name} -p /sbin/ldconfig
  121. %files
  122. %defattr(-,root,root,-)
  123. %doc AUTHORS BUGS COPYING COPYING-* ChangeLog NEWS README
  124. %{_libdir}/lib*.so.*
  125. %files devel
  126. %defattr(-,root,root,-)
  127. %{_libdir}/lib*.so
  128. %{_includedir}/*
  129. %{_libdir}/pkgconfig/*.pc
  130. #{_libdir}/lib*.a
  131. %{_datadir}/gtk-doc/html/cairo
  132. %files tools
  133. %defattr(-,root,root,-)
  134. %{_bindir}/cairo-trace
  135. %{_bindir}/cairo-sphinx
  136. %{_libdir}/cairo
  137. %if %{build_compat32}
  138. %files -n compat32-%{name}
  139. %defattr(-,root,root,-)
  140. %{_libdir}/lib*.so.*
  141. %endif
  142. %changelog
  143. * Sun Dec 20 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.6-1
  144. - new upstream release
  145. * Thu Nov 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.4-2
  146. - fix spec file
  147. * Thu Oct 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.4-1
  148. - new upstream release
  149. * Sun May 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.2-2
  150. - remove *.la files
  151. * Sat Mar 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.2-1
  152. - new upstream release
  153. * Sun Nov 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.18-1
  154. - new upstream release
  155. * Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.16-2
  156. - rebuild with libpng-1.6.12
  157. * Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.16-1
  158. - new upstream release
  159. * Sat May 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.14-2
  160. - remove hardcoded libdir and runpath from libtool
  161. * Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.14-1
  162. - new upstream release
  163. * Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.8-1
  164. - new upstream release
  165. * Fri Nov 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.6-1
  166. - new upstream release
  167. * Sat Oct 13 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.4-1
  168. - new upstream release
  169. * Sun Jul 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.2-2
  170. - add Requires: mesa-libEGL-devel
  171. * Sat Jul 21 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.2-1
  172. - new upstream release
  173. - Enable OpenGL backend
  174. - add BR: librsvg2-devel, mesa-libGL-devel, mesa-libEGL-devel
  175. * Sat Mar 31 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
  176. - new upstream release
  177. * Mon Mar 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.2-2
  178. - enable tee support
  179. - add configure options specifically
  180. - disable static library
  181. * Wed Jan 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
  182. - new upstream release
  183. - add BuildRequires: glib2-devel
  184. - add Requires: glib2-devel (devel package)
  185. * Wed Oct 13 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.0-2
  186. - add patch1 from ubuntu to fix performance regressions
  187. - don't use serverside gradients, most drivers don't handle those and are
  188. really slow, should workaround performances issues for ati, nouveau and nvidia
  189. https://launchpad.net/ubuntu/maverick/+source/cairo/1.10.0-1ubuntu1
  190. * Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.0-1
  191. - new upstream release
  192. - add tools sub package
  193. * Tue Sep 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.10-3
  194. - add BuildRequires: fontconfig-devel
  195. - add Requires: fontconfig-devel (devel package)
  196. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.8.10-2
  197. - build with rpm-4.8.1-1 for pkg-config file
  198. * Tue Mar 2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.8.10-1
  199. - new upstream release
  200. * Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.8-1
  201. - new upstream release
  202. * Sat May 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.8.6-2
  203. - applied cairo-1.8.6-status-return-fix.patch from Gentoo Linux
  204. - added BuildRequires: gtk-doc
  205. * Sat Jan 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.6-1
  206. - new upstream release
  207. * Tue Nov 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.4-1
  208. - new upstream release
  209. * Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-1
  210. - new upstream release
  211. * Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.6-1
  212. - new upstream release
  213. * Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.4-1
  214. - new upstream release
  215. * Wed May 28 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.6.4-3
  216. - add Requires: pixman-devel to -devel
  217. * Sun May 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-2
  218. - rebuilt with xorg-x11 7.3
  219. - spec in UTF-8
  220. * Thu May 1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-1
  221. - new upstream release
  222. - removed lib*.la from devel package
  223. * Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.14-1vl5
  224. - used %%{?_dist_release}
  225. * Thu Feb 7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.14-0vl1
  226. - new upstream release
  227. * Sun Dec 9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.12-0vl1
  228. - new upstream release
  229. * Tue Jul 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.10-0vl1
  230. - new upstream release
  231. * Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.6-0vl1
  232. - new upstream release
  233. - remove BuildRequires: pango-devel, gtk2-devel
  234. (these are only needed for testing)
  235. * Sat Mar 31 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.4.2-0vl1
  236. - upstream release
  237. - Patch30 and Patch40 is skipped (not working correctly)
  238. but held in src.rpm
  239. - add BUGS, ROADMAP to %%doc
  240. - add BuildRequires: pango-devel, gtk2-devel
  241. * Tue Oct 24 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-0vl2
  242. - rebuild without XOrg-compat70-devel
  243. - add BuildConflicts: XOrg-compat70-devel
  244. * Sun Oct 22 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-0vl1
  245. - new upstream release
  246. - remove unneeded Patch20 which breaks 8bpp rendering (<BTS:297>)
  247. * Tue Sep 19 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.2-0vl3
  248. - added Patch40 for 15bpp problem
  249. * Tue Sep 5 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.2-0vl2
  250. - added ad-hoc Patch30 for 16bpp problem
  251. * Thu Aug 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-0vl1
  252. - new upstream release
  253. * Sat Aug 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-0vl1
  254. - new upstream release
  255. * Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-0vl1
  256. - new upstream release
  257. * Sat May 20 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.2-0vl4
  258. - added compat32- package for x86_64 architecture support
  259. * Sun Mar 05 2006 Shu KONNO <owa@bg.wakwak.com> 1.0.2-0vl3
  260. - added x86_64 architecture support
  261. * Sat Dec 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl2
  262. - add Patch20 to fix broken desktop rendering on xorg-x11-6.9
  263. - add X.Org 6.9.0 (6090000) to blacklist
  264. * Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl1
  265. - new upstream release
  266. * Tue Oct 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl5
  267. - update Patch10
  268. * Sun Oct 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl4
  269. - add Patch10 to use embedded bitmap font if available.
  270. (controllable by "embeddedbitmap" in fontconfig)
  271. * Thu Sep 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl3
  272. - rebuild with new fontconfig
  273. * Sun Sep 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl2
  274. - add Requires: libpng-devel, XOrg-devel, freetype2-devel
  275. to devel package instead of BuildRequires (typo)
  276. - add Japanese summaries
  277. * Sun Aug 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl1
  278. - new upstream release
  279. - remove libpixman dependency (which is now included in cairo)
  280. - obsoletes libpixman <= 0.1.6
  281. - add more BuildRequires
  282. * Sat Aug 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.2-0vl1
  283. - new upstream version
  284. * Sun Jul 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.1-0vl1
  285. - new upstream version
  286. - fixed License (http://cairographics.org/introduction)
  287. * Sun Mar 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.0-0vl1
  288. - new upstream version
  289. - include gtk-doc files
  290. * Sun Jan 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.0-0vl1
  291. - new upstream version
  292. - add Requires: libpixman
  293. * Mon Nov 01 2004 Satoshi MACHINO <machino@vinelinux.org> 0.2.0-0vl1
  294. - new upstream version (cairo-0.2.0)
  295. * Mon Oct 11 2004 Satoshi MACHINO <machino@vinelinux.org> 0.1.23-1vl1
  296. - rebuilt for VineLinux
  297. * Tue Jun 01 2004 Marcel Pol <mpol@mandrake.org> 0.1.23-1mdk
  298. - 0.1.23
  299. - reenable libtoolize
  300. * Wed May 5 2004 G魚Waschk <waschk@linux-mandrake.com> 0.1.22-1mdk
  301. - fix devel provides
  302. - drop redundant buildrequires
  303. - requires new pixman
  304. - autoconf 2.5 macro
  305. - New release 0.1.22
  306. * Fri Feb 06 2004 Marcel Pol <mpol@mandrake.org> 0.1.17-2mdk
  307. - build with X11
  308. * Sun Feb 01 2004 Marcel Pol <mpol@mandrake.org> 0.1.17-1mdk
  309. - 0.1.17
  310. - provides cairo
  311. - drop patch, use --disable-xlib
  312. - buildrequires
  313. - don't run libtoolize
  314. * Sun Dec 14 2003 Marcel Pol <mpol@mandrake.org> 0.1.13-1mdk
  315. - initial mandrake package