avogadro-vl.spec 8.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289
  1. %define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.7.2)
  2. %define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt-%{qt4_ver})
  3. %define ENABLE_TESTS -DENABLE_TESTS:BOOL=ON
  4. Name: avogadro
  5. Summary: An advanced molecular editor for chemical purposes
  6. Version: 1.1.1
  7. Release: 3%{?_dist_release}
  8. Group: Applications/Editors
  9. License: GPLv2
  10. URL: http://avogadro.openmolecules.net/
  11. Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
  12. Patch0: avogadro-1.0.3-mkspecs-dir.patch
  13. Patch1: avogadro-1.1.1-cmake-3.x.patch
  14. BuildRequires: cmake >= 2.6.0
  15. BuildRequires: qt4-devel >= 4.5.1
  16. BuildRequires: qt4-tools
  17. BuildRequires: eigen2-devel >= 2.0.3
  18. BuildRequires: openbabel-devel >= 2.2.2
  19. BuildRequires: libboost-devel >= 1.35
  20. BuildRequires: libboost-python >= 1.35
  21. BuildRequires: glew-devel >= 1.5.0
  22. BuildRequires: desktop-file-utils
  23. BuildRequires: docbook-utils
  24. BuildRequires: sip-devel >= 4.11
  25. BuildRequires: numpy
  26. Requires: %{name}-libs = %{version}-%{release}
  27. %description
  28. An advanced molecular editor designed for
  29. cross-platform use in computational chemistry,
  30. molecular modeling, bioinformatics, materials science,
  31. and related areas, which offers flexible rendering and
  32. a powerful plugin architecture.
  33. %package libs
  34. Summary: Shared libraries for Avogadro
  35. Summary(ja): Avogadro の共用ライブラリ
  36. Group: System Environment/Libraries
  37. Requires: sip
  38. %description libs
  39. This package contains the shared libraries for the
  40. molecular editor Avogadro.
  41. %package devel
  42. Summary: Development files for Avogadro
  43. Summary(ja): Avogadro の開発用ファイル
  44. Group: Development/Libraries
  45. Requires: %{name}-libs = %{version}-%{release}
  46. Requires: qt4-devel = %{_qt4_version}
  47. Requires: eigen2-devel >= 2.0.3
  48. Requires: glew-devel >= 1.5.0
  49. Requires: pkgconfig
  50. %description devel
  51. This package contains files to develop applications using
  52. Avogadros libraries.
  53. %prep
  54. %setup -q
  55. %patch0 -p1 -b .mkspecs-dir
  56. %patch1 -p1 -b .cmake3x
  57. %build
  58. mkdir -p %{_target_platform}
  59. pushd %{_target_platform}
  60. %cmake -Wno-dev \
  61. -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
  62. -DBIN_INSTALL_DIR:PATH=bin \
  63. -DLIB_INSTALL_DIR:PATH=%{_lib} \
  64. -DENABLE_GLSL:BOOL=ON \
  65. -DENABLE_PYTHON:BOOL=ON \
  66. -DENABLE_RPATH:BOOL=OFF \
  67. -DENABLE_VERSIONED_PLUGIN_DIR:BOOL=OFF \
  68. %{?ENABLE_TESTS} ..
  69. popd
  70. make %{?_smp_mflags} -C %{_target_platform}
  71. %install
  72. rm -rf $RPM_BUILD_ROOT
  73. make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
  74. %check
  75. desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/avogadro.desktop
  76. # all of these currently require an active X session, so will fail
  77. # in mock
  78. %{?ENABLE_TESTS:make test -C %{_target_platform} ||:}
  79. %post libs -p /sbin/ldconfig
  80. %postun libs -p /sbin/ldconfig
  81. %files
  82. %defattr(-,root,root,-)
  83. %doc AUTHORS ChangeLog COPYING
  84. %{_bindir}/avogadro
  85. %{_bindir}/avopkg
  86. # TODO: %lang'ify stuff under %%{_datadir}/avogadro/i18n/
  87. %{_datadir}/avogadro/
  88. %{_datadir}/pixmaps/avogadro-icon.png
  89. %{_datadir}/applications/avogadro.desktop
  90. %{_mandir}/man1/avogadro.1*
  91. %{_mandir}/man1/avopkg.1*
  92. %files devel
  93. %defattr(-,root,root,-)
  94. %{_includedir}/avogadro/
  95. %{_libdir}/libavogadro.so
  96. %{_libdir}/libavogadro_OpenQube.so
  97. %{_libdir}/avogadro/*.cmake
  98. %{_libdir}/avogadro/cmake/
  99. %{_libdir}/pkgconfig/avogadro.pc
  100. %{_qt4_prefix}/mkspecs/features/avogadro.prf
  101. %files libs
  102. %defattr(-,root,root,-)
  103. %{python_sitearch}/Avogadro.so
  104. %{_datadir}/libavogadro/
  105. %{_libdir}/libavogadro.so.*
  106. %{_libdir}/libavogadro_OpenQube.so.*
  107. %dir %{_libdir}/avogadro/
  108. %{_libdir}/avogadro/colors/
  109. %{_libdir}/avogadro/extensions/
  110. %{_libdir}/avogadro/engines/
  111. %{_libdir}/avogadro/tools/
  112. %changelog
  113. * Thu May 12 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.1.1-3
  114. - rebuild with qt4-4.8.7
  115. - add Patch1 (avogadro-1.1.1-cmake-3.x.patch)
  116. * Thu Oct 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.1.1-2
  117. - rebuild with glew-1.13.0
  118. * Thu Jan 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.1.1-1
  119. - update to 1.1.1
  120. * Sun Dec 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.3-1
  121. - update to 1.0.3
  122. - remove old patches
  123. - add Patch0 (avogadro-1.0.3-mkspecs-dir.patch) from fedora
  124. * Sun Jul 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-13
  125. - rebuild with qt4-4.8.5
  126. * Sun Oct 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-12
  127. - rebuild with qt4-4.8.3
  128. * Tue Sep 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-11
  129. - rebuild with qt4-4.8.2
  130. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-10
  131. - rebuild with python-2.7.2
  132. * Tue Jan 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-9
  133. - rebuild with qt4-4.8.0 and glew-1.7.0
  134. * Wed Mar 9 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-8
  135. - rebuilt with qt4-4.7.2
  136. - BR: qt4-tools instead of qt4-designer
  137. * Sun Feb 27 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-7
  138. - added BR: libboost-python
  139. - added R: glew-devel, eigen2-devel to devel package
  140. * Wed Feb 23 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-6
  141. - rebuilt with qt4-4.7.1
  142. - added Patch0 and 1 from Fedora
  143. * Tue Jan 18 2011 Shu KONNO <owa@bg.wakwak.com> - 1.0.1-5
  144. - rebuilt with libboost-1.45.0
  145. * Fri Aug 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-4
  146. - Initial build for Vine Linux
  147. * Wed Aug 04 2010 Rahul Sundaram <sundaram@fedoraproject.org> - 1.0.1-3
  148. - Rebuild for Boost soname bump
  149. - Update to match current guidelines
  150. * Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 1.0.1-2
  151. - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
  152. * Mon May 24 2010 Rex Dieter <rdieter@fedoraproject.org> - 1.0.1-1
  153. - avogadro-1.0.1
  154. - -devel: move cmake-related files here
  155. - -devel: Req: qt4-devel
  156. - %%files: track lib sonames
  157. - %%check section
  158. * Wed Feb 10 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1.0.0-6
  159. - reenable plugin builds and libs subpackage
  160. - fix their build with sip 4.10
  161. * Fri Jan 08 2010 Sebastian Dziallas <sebastian@when.com> - 1.0.0-5
  162. - disable plugin builds and libs subpackage
  163. * Thu Jan 07 2010 Rex Dieter <rdieter@fedoraproject.org> - 1.0.0-4
  164. - rebuild (sip)
  165. * Mon Nov 23 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.0.0-3
  166. - rebuild (for qt-4.6.0-rc1, f13+)
  167. * Mon Nov 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.0.0-2
  168. - -libs: Requires: sip-api(%%_sip_api_major) >= %%_sip_api (#538124)
  169. - Requires: %%{name}-libs ...
  170. * Thu Oct 29 2009 Sebastian Dziallas <sebastian@when.com> 1.0.0-1
  171. - update to new upstream release
  172. * Tue Oct 20 2009 Rex Dieter <rdieter@fedoraproject.org> 0.9.8-3
  173. - rebuild (eigen2)
  174. * Sat Sep 26 2009 Sebastian Dziallas <sebastian@when.com> 0.9.8-2
  175. - fix typo in file list
  176. * Sat Sep 26 2009 Sebastian Dziallas <sebastian@when.com> 0.9.8-1
  177. - update to new upstream release
  178. - enable python and glsl support again
  179. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.6-2
  180. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  181. * Sat Jun 06 2009 Sebastian Dziallas <sebastian@when.com> 0.9.6-1
  182. - new upstream release to fix issue with qt 4.5.0 and earlier
  183. * Wed Jun 03 2009 Sebastian Dziallas <sebastian@when.com> 0.9.5-3
  184. - remove remaining python parts
  185. - fix files section finally
  186. * Wed Jun 03 2009 Sebastian Dziallas <sebastian@when.com> 0.9.5-2
  187. - disable python and glsl for now
  188. - fix files section
  189. * Wed Jun 03 2009 Sebastian Dziallas <sebastian@when.com> 0.9.5-1
  190. - update to new release
  191. * Tue May 12 2009 Sebastian Dziallas <sebastian@when.com> 0.9.4-1
  192. - update to new release
  193. * Fri Apr 10 2009 Sebastian Dziallas <sebastian@when.com> 0.9.3-1
  194. - update to new release
  195. * Sat Mar 21 2009 Sebastian Dziallas <sebastian@when.com> 0.9.2-2
  196. - get desktop file properly installed
  197. * Sat Mar 14 2009 Sebastian Dziallas <sebastian@when.com> 0.9.2-1
  198. - update to new release
  199. * Wed Feb 25 2009 Sebastian Dziallas <sebastian@when.com> 0.9.1-1
  200. - update to new release
  201. * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.0-2
  202. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  203. * Thu Jan 22 2009 Sebastian Dziallas <sebastian@when.com> 0.9.0-1
  204. - update to new release
  205. * Sun Sep 14 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-6
  206. - add handbook to docs
  207. * Sun Sep 14 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-5
  208. - add build requirements and fix group names
  209. * Wed Aug 13 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-4
  210. - fix typos
  211. * Sat Aug 9 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-3
  212. - reorganize spec file
  213. * Sat Aug 9 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-2
  214. - rename shared library package and structure spec file
  215. * Sun Aug 3 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-1
  216. - initial pacakging release based on PackMan release