JF-vl.spec 5.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192
  1. %define _docdir %{_defaultdocdir}
  2. Summary: HOWTO, FAQ, and other documents in Japanese
  3. Summary(ja): 日本語のHOWTO, FAQ, その他の文書です
  4. Name: JF
  5. Version: 20130224
  6. Release: 1%{?_dist_release}
  7. License: distributable
  8. Group: Applications/Documentation
  9. URL: http://linuxjf.sourceforge.jp/
  10. Source0: http://linuxjf.sourceforge.jp/JFdocs/JFtxt.tar.bz2
  11. BuildArch: noarch
  12. Buildroot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: nkf
  14. Vendor: Project Vine
  15. Distribution: Vine Linux
  16. %description
  17. Japanese HOWTOs (instructions for how to do things on Linux), FAQs,
  18. etc. collected from the property of JF (Japanese FAQ) Project.
  19. There are Japanese translations from English HOWTOs, FAQs, etc. and
  20. documents that are originally written in Japanese.
  21. %description -l ja
  22. HOWTO (Linux でいろいろなことを実現する方法を書いた文書)や FAQ
  23. (Frequently Asked Questions:よくある質問と回答)の日本語版など JF
  24. (Japanese FAQ Project) の資産から、Linuxの基本操作に必要な文書を集めま
  25. した。英語版 HOWTO, mini-HOWTO, FAQ の和訳、日本固有のドキュメントなど
  26. が含まれています。
  27. %prep
  28. %setup -n JFdocs -q
  29. # remove documents prohibited to distiribute non-commercially...
  30. # http://linuxjf.sourceforge.jp/copyright.html
  31. rm -f Astronomy-HOWTO*
  32. rm -f Chinese-HOWTO*
  33. rm -f DHCP*
  34. rm -f Debian-Jigdo*
  35. rm -f Ftape-HOWTO*
  36. rm -f GIS-GRASS*
  37. rm -f Offline-Mailing*
  38. rm -f Quota*
  39. rm -f Scanner-HOWTO-mtekscan*
  40. rm -f Securing-X-Windows*
  41. rm -f StarOffice*
  42. rm -f Swap-Space*
  43. # remove unneeded documents
  44. rm -f Parted-README.txt
  45. rm -f BTTV-Mini-HOWTO-0.3.txt
  46. %build
  47. toUTF8(){
  48. for i in `find .` ; do
  49. if [ -f $i ]; then
  50. nkf -w8 -Lu $i >${i%.*}.new
  51. mv ${i%.*}.new $i
  52. fi
  53. done
  54. }
  55. toUTF8
  56. %install
  57. rm -rf %{buildroot}
  58. mkdir -p %{buildroot}%{_docdir}/JF
  59. tar cf - . | (cd %{buildroot}%{_docdir}/JF && tar xfBp -)
  60. (cd %{buildroot}%{_docdir}/JF; gzip -r --best *)
  61. %clean
  62. rm -rf %{buildroot}
  63. %files
  64. %defattr(-,root,root)
  65. %{_docdir}/JF/
  66. %changelog
  67. * Mon Jul 21 2014 Yasumichi Akahoshi <yasumichi@vinelinux.org> 20130224-1
  68. - sources as 20130224
  69. - update URL
  70. * Sat Apr 9 2011 IWAI, Masaharu <iwai@alib.jp> 20110119-1
  71. - source as of 20110119
  72. - update description
  73. * Fri Mar 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 20100222-1
  74. - source as of 20100222
  75. - convert to UTF8 instead of EUC-JP
  76. - s/BuildPreReq/BuildRequires/
  77. * Tue Mar 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 20090320-1
  78. - source as of 20090320
  79. - spec in utf-8
  80. * Mon Apr 28 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 20080415-1
  81. - source as of 20080415
  82. * Sun Aug 5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 20070728-0vl1
  83. - source as of 20070728
  84. * Fri Sep 15 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 20060910-0vl1
  85. - source as of 20060910
  86. * Sat May 20 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 20060412-0vl1
  87. - source as of 20060520
  88. * Wed Sep 14 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 20050910-0vl1
  89. - source as of 20050910
  90. * Thu Dec 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 20041213-0vl1
  91. - source as of 20041213
  92. * Sat Sep 25 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 20040924-0vl1
  93. - source as of 20040924
  94. - remove Swap-Space
  95. * Sat Mar 20 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 20040316-0vl1
  96. - source as of 20040316
  97. - remove Swap-Space
  98. * Wed Sep 17 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 20030914-0vl1
  99. - source as of 20030914
  100. - remove Debian-Jigdo
  101. * Fri Jun 6 2003 Jun Nishii <jun@vinelinux.org> 20030415-0vl1
  102. - fix toEUC
  103. * Wed Apr 16 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 20030415-0vl1
  104. - source as of 20030415
  105. - remove Securing-X-Windows
  106. * Tue Feb 18 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 20030216-0vl1
  107. - source as of 20030216
  108. * Sun Sep 22 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 20020905-0vl1
  109. - source as of 20020905
  110. - remove Astronomy-HOWTO
  111. * Sun Jun 2 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 20020415-0vl1
  112. - source as of 20020415
  113. * Tue Jan 15 2002 Toru Sagami <sagami@vinelinux.org> 20020115-0vl1
  114. - source as of 20020115
  115. * Sat Nov 17 2001 Toru Sagami <sagami@vinelinux.org>
  116. - 20011115-0vl1
  117. * Fri Aug 17 2001 <sagami@vinelinux.org>
  118. - 20010815-0vl1: introduced %%{_docdir} definition
  119. * Sun Jul 15 2001 <sagami@vinelinux.org>
  120. - 20010715-0vl1: eliminate CR at the EOL
  121. * Sun May 27 2001 Yasuhide OMORI <dasen@icntv.ne.jp>
  122. - 20010527-0vl1
  123. - modified the list of non-free documents
  124. - comply with RFC2606 (LAN-mini-HOWTO)
  125. * Wed Apr 18 2001 sagami@vinelinux.org
  126. - 20010415-0vl1
  127. * Mon Dec 25 2000 Toru Sagami <czs14350@mb.infoweb.ne.jp>
  128. - 20001225-0vl1
  129. - added Ethernet-HOWTO, which no longer prevents from commercial distributing
  130. * Mon Sep 4 2000 Jun Nishii <jun@vinelinux.org>
  131. - 20000831-0vl1
  132. * Wed May 10 2000 Toru Sagami <czs14350@nifty.ne.jp>
  133. - 20000509-0vl1
  134. - fixed summary, Buildroot, Distribution
  135. - fixed description by Yoshihiro Ota
  136. * Thu Jan 27 2000 Yasuhide OOMORI <baoying@flatout.org>
  137. - [JF-20000125-1]
  138. - updated to 20000125.
  139. * Thu Jul 29 1999 Jun Nishii <jun@flatout.org>
  140. - updated to 199907
  141. * Mon Feb 15 1999 Jun Nishii <jun@flatout.org>
  142. - updated to 199902
  143. - use JFeuc.tar.bz2
  144. * Tue Feb 2 1999 Jun Nishii <jun@flatout.org>
  145. - updated to 199901
  146. - Now we use version number yyyymm instead of yymmdd
  147. to avoid 2000 y problem B)