AfterStep-APPS-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350
  1. Summary: Various applets for use with AfterStep and compatible window managers.
  2. Name: AfterStep-APPS
  3. Version: 20001212
  4. Release: 0vl3
  5. License: GPL
  6. Group: User Interface/Desktops
  7. Source0: http://www.tigr.net/afterstep/as-apps/download/as-apps-001212.tar
  8. Patch0: AfterStep-APPS-1.5beta1-glibc.patch
  9. Patch1: ascp-paths.patch
  10. Patch2: as-apps-compile.patch
  11. Patch4: xiterm-utmp.patch
  12. Patch5: AfterStep-APPS-xiterm-getopt.patch
  13. Patch6: AfterStep-APPS-xiterm-ccoptions.patch
  14. Patch7: 05-asdm-make.patch
  15. Patch100: asbutton-install.patch
  16. #Requires: /usr/sbin/utempter
  17. Requires: utempter
  18. Prereq: /sbin/ldconfig
  19. BuildPrereq: WindowMaker-devel
  20. BuildRoot: %{_tmppath}/%{name}-root
  21. %description
  22. The AfterStep-APPS package includes a group of applications for use
  23. with the AfterStep window manager. Applications in this package
  24. include an Advanced Power Management system monitor for laptops
  25. (asapm), a CPU load monitor (ascpu), a simple state machine (asexec),
  26. a filesystem monitor (asfsm), a CPU load monitor for use with the PROC
  27. filesystem (asload), a mail checker (asmail), a memory utilization
  28. monitor (asmem), a volume controller knob for the /dev/mixer device
  29. (asmix), a volume controller for various sound inputs (asmixer), a
  30. modem status monitor (asmodem), an analog clock (astime), a color
  31. VT102 emulator (aterm), an audio CD player (ascd), a clock (asclock),
  32. and a control panel for configuring AfterStep (ascp).
  33. Install AfterStep-APPS if you're planning to use the AfterStep window
  34. manager.
  35. %prep
  36. %setup -q -c
  37. rm -f *.asc
  38. for archive in *.tar.gz ; do
  39. tar xzf $archive
  40. rm -f $archive
  41. done
  42. %patch0 -p1 -b .glibc
  43. %patch1 -p1 -b .paths
  44. %patch4 -p1 -b .xiutmp
  45. %patch5 -p1 -b .getopt
  46. %patch6 -p1 -b .ccoptions
  47. # Someone forgot to make clean in some packages :/
  48. find . -name "*.o" -exec rm -f {} \;
  49. find . -name "*~" -exec rm -f {} \;
  50. perl -pi -e "s,#include <linux/ucdrom.h>,," ascdc-0.3/ascdc.c
  51. %patch100 -p0 -b .asbutton
  52. %build
  53. for package in `ls` ; do
  54. cd $package
  55. case $package in
  56. ascd-* )
  57. perl -pi -e "s,/etc/X11,/usr/X11R6/lib/X11,g" * ascd/* libworkman/*
  58. patch -p2 -b --suffix .compile < %{PATCH2}
  59. CFLAGS="$RPM_OPT_FLAGS" CXXFLAGS="$RPM_OPT_FLAGS" ./configure << EOF
  60. /mnt/cdrom
  61. %{_prefix}/X11R6/bin
  62. %{_prefix}/X11R6/man/man1
  63. %{_datadir}/afterstep/ascd
  64. 1
  65. EOF
  66. perl -pi -e "s,/usr/local/share/AScd,/usr/share/$package,g" * misc/*
  67. make MANDIR=/usr/X11R6/man/man1 \
  68. BINDIR=/usr/X11R6/bin \
  69. THEMESDIR=/usr/share/$package \
  70. SHLIBDIR=/usr/X11R6/lib \
  71. CDEBUGFLAGS="$RPM_OPT_FLAGS" \
  72. CXXDEBUGFLAGS="$RPM_OPT_FLAGS"
  73. ;;
  74. asdm* )
  75. # xmkmf'ed stuff...
  76. xmkmf -a
  77. perl -pi -e "s,/etc/X11,/usr/X11R6/lib/X11,g" *
  78. # patch -b --suffix .compile < %{PATCH7}
  79. make CDEBUGFLAGS="$RPM_OPT_FLAGS" \
  80. CXXDEBUGFLAGS="$RPM_OPT_FLAGS" \
  81. XDMDIR=/usr/share/asdm BINDIR=/usr/X11R6/bin \
  82. SHLIBDIR=/usr/lib
  83. ;;
  84. asampcd* | asDrinks* | asampmenu* | randbg* )
  85. # These are perl scripts and don't need to be compiled...
  86. ;;
  87. asbutton* | miniCHESS* )
  88. # Non-autoconf'ed C...
  89. make CCFLAGS="$RPM_OPT_FLAGS" CFLAGS="$RPM_OPT_FLAGS" CXXFLAGS="$RPM_OPT_FLAGS"
  90. ;;
  91. aspbm* )
  92. make CCFLAGS="$RPM_OPT_FLAGS" CFLAGS="$RPM_OPT_FLAGS" CXXFLAGS="$RPM_OPT_FLAGS"
  93. make -C conf CCFLAGS="$RPM_OPT_FLAGS" CFLAGS="$RPM_OPT_FLAGS" CXXFLAGS="$RPM_OPT_FLAGS"
  94. ;;
  95. asmon* )
  96. cd asmon
  97. make
  98. cd ..
  99. ;;
  100. ASFiles* | Tasks* | asfaces* | asfatm* | asppp* | astrash* | astuner* |\
  101. xfascd* | asxmcd* | asftavm* | aswmtheme* )
  102. # ASFiles: needs some odd DnD library
  103. # Tasks: must be compiled inside AfterStep source tree
  104. # asfaces: broken beyond repair
  105. # asfatm: needs temperature measurement kernel patch
  106. # asppp: missing dial.xpm file
  107. # astrash: needs OffiX
  108. # astuner: needs linux/radio.h
  109. # xfascd: needs XForms
  110. # asxmcd: needs Motif
  111. # asftavm: needs i2c& sensors not part of default 2.2 kernels
  112. # aswmtheme: not a module per se.
  113. ;;
  114. xiterm*)
  115. # cough cough, hack hack -- ewt
  116. CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=/usr/X11R6 \
  117. --enable-xpm-background --enable-utmp --enable-wtmp \
  118. --enable-menubar --enable-next-scroll --enable-kanji
  119. xmkmf
  120. make Makefiles
  121. cd src
  122. sed -e "s/EXTRA_LIBRARIES =/EXTRA_LIBRARIES = -lutempter/" \
  123. Makefile > Makefile.foo
  124. sed -e "s/-lsocket //" Makefile.foo > Makefile
  125. make
  126. ;;
  127. asclock*)
  128. perl -pi -e "s,/etc/X11,/usr/X11R6/lib/X11,g" *
  129. CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=/usr/X11R6 << EOF
  130. classic
  131. EOF
  132. make
  133. ;;
  134. *)
  135. #just about every other thing supports autoconf
  136. #
  137. # Look ma, I'm broken! What a shock.
  138. rm -f config.cache
  139. CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=/usr/X11R6 --datadir=/usr/share --with-gtk-prefix=/usr
  140. make
  141. ;;
  142. esac
  143. cd ..
  144. done
  145. %install
  146. rm -rf $RPM_BUILD_ROOT
  147. mkdir -p $RPM_BUILD_ROOT/usr/X11R6/bin
  148. mkdir -p $RPM_BUILD_ROOT/usr/X11R6/man/man1
  149. mkdir -p $RPM_BUILD_ROOT/usr/share/afterstep/desktop/icons/16bpp
  150. for package in `ls` ; do
  151. cd $package
  152. case $package in
  153. ASFiles* | Tasks* | asfaces* | asfatm* | asppp* | astrash* | astuner* | \
  154. xfascd* | asxmcd* | asftavm* )
  155. # We ignore broken stuff and stuff that simply doesn't make
  156. # much sense...
  157. ;;
  158. asDrinks* | asampmenu* | randbg* | aswmtheme* )
  159. cp -a *.pl $RPM_BUILD_ROOT/usr/X11R6/bin
  160. ;;
  161. ascd-* | xiterm*)
  162. if test -d ./ascd; then
  163. mkdir -p $RPM_BUILD_ROOT/usr/share/$package
  164. cp -a ascd/themes/* $RPM_BUILD_ROOT/usr/share/$package
  165. perl -pi -e "s,/usr/local/include,$RPM_BUILD_ROOT/usr/include,g" libworkman/Makefile
  166. perl -pi -e "s,/usr/local/lib,$RPM_BUILD_ROOT/usr/lib,g" libworkman/Makefile
  167. fi
  168. make install install.man \
  169. AFTER_BIN_DIR=$RPM_BUILD_ROOT/usr/X11R6/bin \
  170. AFTER_MAN_DIR=$RPM_BUILD_ROOT/usr/X11R6/man/man1 \
  171. MANDIR=$RPM_BUILD_ROOT/usr/X11R6/man/man1 \
  172. BINDIR=$RPM_BUILD_ROOT/usr/X11R6/bin \
  173. THEMESDIR=$RPM_BUILD_ROOT/usr/share/$package \
  174. SHLIBDIR=$RPM_BUILD_ROOT/usr/X11R6/lib
  175. ;;
  176. ascp-* )
  177. make install \
  178. ASCP_BIN_DIR=$RPM_BUILD_ROOT/usr/X11R6/bin \
  179. ASCP_MAN_DIR=$RPM_BUILD_ROOT/usr/X11R6/man/man1 \
  180. prefx=$RPM_BUILD_ROOT \
  181. DESTDIR=$RPM_BUILD_ROOT
  182. ;;
  183. asmon-* )
  184. cd asmon
  185. perl -pi -e "s,/usr/local/bin,$RPM_BUILD_ROOT/usr/X11R6/bin,g" Makefile
  186. make install \
  187. AFTER_BIN_DIR=$RPM_BUILD_ROOT/usr/X11R6/bin \
  188. AFTER_MAN_DIR=$RPM_BUILD_ROOT/usr/X11R6/man/man1 \
  189. BINDIR=$RPM_BUILD_ROOT/usr/X11R6/bin \
  190. DESTDIR=$RPM_BUILD_ROOT
  191. cd ..
  192. ;;
  193. asclock-* | asdm-* | sessreg-* | xpmroot-* )
  194. make install DESTDIR=$RPM_BUILD_ROOT \
  195. AFTER_BIN_DIR=/usr/X11R6/bin \
  196. BINDIR=/usr/X11R6/bin \
  197. AFTER_MAN_DIR=/usr/X11R6/man/man1 \
  198. XDMDIR=/usr/share/asdm \
  199. MANDIR=/usr/X11R6/man/man1 \
  200. SHLIBDIR=/usr/lib
  201. make install.man DESTDIR=$RPM_BUILD_ROOT \
  202. AFTER_BIN_DIR=/usr/X11R6/bin \
  203. BINDIR=/usr/X11R6/bin \
  204. AFTER_MAN_DIR=/usr/X11R6/man/man1 \
  205. MANDIR=/usr/X11R6/man/man1 \
  206. ;;
  207. miniCHESS-*)
  208. make install DESTDIR=$RPM_BUILD_ROOT/usr/X11R6/bin \
  209. AFTER_BIN_DIR=/usr/X11R6/bin \
  210. BINDIR=/usr/X11R6/bin \
  211. AFTER_MAN_DIR=/usr/X11R6/man/man1
  212. ;;
  213. *)
  214. make install \
  215. AFTER_BIN_DIR=$RPM_BUILD_ROOT/usr/X11R6/bin \
  216. AFTER_MAN_DIR=$RPM_BUILD_ROOT/usr/X11R6/man/man1 \
  217. MANDIR=$RPM_BUILD_ROOT/usr/X11R6/man/man1 \
  218. BINDIR=$RPM_BUILD_ROOT/usr/X11R6/bin \
  219. DESTDIR=$RPM_BUILD_ROOT \
  220. ICONDIR=$RPM_BUILD_ROOT/usr/share/afterstep/desktop/icons/16bpp
  221. make install.man \
  222. AFTER_BIN_DIR=$RPM_BUILD_ROOT/usr/X11R6/bin \
  223. AFTER_MAN_DIR=$RPM_BUILD_ROOT/usr/X11R6/man/man1 \
  224. MANDIR=$RPM_BUILD_ROOT/usr/X11R6/man/man1 \
  225. BINDIR=$RPM_BUILD_ROOT/usr/X11R6/bin \
  226. DESTDIR=$RPM_BUILD_ROOT || true # should work for non-install.man targets as well...
  227. ;;
  228. esac
  229. cd ..
  230. done
  231. rm -f $RPM_BUILD_ROOT/usr/X11R6/{bin,man/man1}/{sessreg,xpmroot,qplot}*
  232. rm -f $RPM_BUILD_ROOT/usr/X11R6/lib/X11/app-defaults/Chooser
  233. chmod 0755 $RPM_BUILD_ROOT/usr/X11R6/bin/asbutton
  234. chmod 0755 $RPM_BUILD_ROOT/usr/share/afterstep/ascp/icons
  235. chmod 0644 $RPM_BUILD_ROOT/usr/X11R6/man/man1/*
  236. # creating file list
  237. rm -f $RPM_BUILD_DIR/master.list.%{name}
  238. #find $RPM_BUILD_ROOT -type d | sed '1,2d;s|^\.|\%attr(-,root,root) \%dir |' \
  239. # > $RPM_BUILD_DIR/master.list.%{name}
  240. find $RPM_BUILD_ROOT -type f -o -type l >> $RPM_BUILD_DIR/master.list.%{name}
  241. sed -e "s,$RPM_BUILD_ROOT,,g" $RPM_BUILD_DIR/master.list.%{name} \
  242. | sed -e "s,/man[0-9]/.*,&\*,g" \
  243. | sort > file.list.%{name}
  244. %clean
  245. rm -rf $RPM_BUILD_ROOT
  246. rm -f $RPM_BUILD_DIR/master.list.%{name}
  247. %post -p /sbin/ldconfig
  248. %postun -p /sbin/ldconfig
  249. %files -f file.list.%{name}
  250. %defattr(-,root,root)
  251. %dir /usr/share/ascd-*
  252. %dir /usr/share/asdm
  253. %changelog
  254. * Wed Jan 30 2002 Toru Sagami <sagami@vinelinux.org> 20001212-0vl3
  255. - Requires for utempter instead of file dependent /usr/sbin/utempter
  256. - s/Copyright/License/
  257. * Wed May 23 2001 <sagami@vinelinux.org>
  258. - 001212-0vl2: add BuildPreReq: WindowMaker-devel and actually use it(ascd)
  259. * Mon May 14 2001 <sagami@vinelinux.org>
  260. - 001212-0vl1 from connectiva 000909
  261. - --enable-kanji for xiterm
  262. * Mon Feb 7 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  263. - remove /usr/X11R6/lib/X11/app-defaults/Chooser
  264. it is provided by XFree86.
  265. * Sun Feb 6 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  266. - fix some Makefile issues:
  267. asclock, asdm, sessreg and xpmroot got installed to
  268. $RPM_BUILD_ROOT/$RPM_BUILD_ROOT and were therefore not included in the
  269. RPM.
  270. minichess was installed to $RPM_BUILD_ROOT/minichess, and therefore wasn't
  271. included in the RPM.
  272. * Fri Feb 4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  273. - Fix permissions on /usr/X11R6/bin/asbutton and /usr/share/afterstep/ascp/icons
  274. * Thu Feb 3 2000 Bill Nottingham <notting@redhat.com>
  275. - add %defattr
  276. * Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
  277. - fix description
  278. * Thu Jan 27 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  279. - 20000124
  280. - BuildPrereq WindowMaker (we need WINGs.h)
  281. * Mon Nov 15 1999 Bernhard Rosenkraenzer <bero@redhat.com>
  282. - fix various bugs
  283. - update source archive
  284. - compile/fix some more components
  285. * Tue Aug 17 1999 Bill Nottingham <notting@redhat.com>
  286. - update source archive.
  287. * Mon Apr 5 1999 Bill Nottingham <notting@redhat.com>
  288. - strip binaries
  289. * Mon Mar 29 1999 Bill Nottingham <notting@redhat.com>
  290. - update source archive
  291. - fix ascp
  292. * Wed Mar 24 1999 Erik Troan <ewt@redhat.com>
  293. - utempter support
  294. - got xiterm building again
  295. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  296. - auto rebuild in the new build environment (release 2)
  297. * Wed Jan 06 1999 Cristian Gafton <gafton@redhat.com>
  298. - build for glibc 2.1
  299. * Wed Sep 30 1998 Cristian Gafton <gafton@redhat.com>
  300. - updated source archive
  301. - remove conflicting files with XFree86
  302. * Wed Sep 16 1998 Cristian Gafton <gafton@redhat.com>
  303. - split from afterstep and packaged for RH 5.2