915resolution-vl.spec 4.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128
  1. %define name 915resolution
  2. %define version 0.5.3
  3. %define release 1%{?_dist_release}
  4. Summary: A tool to force resolution of Intel 8xx,9xx video Card
  5. Summary(ja): Intel 8xx, 9xx ビデオカードの解像度を強制設定するツール
  6. Name: %{name}
  7. Version: %{version}
  8. Release: %{release}
  9. License: Public Domain
  10. Group: Applications/System
  11. Url: http://www.geocities.com/stomljen/
  12. Source0: http://www.geocities.com/stomljen/%{name}-%{version}.tar.gz
  13. Source1: 915resolution.init
  14. Source2: 915resolution.default-sysconfig
  15. Patch: 915resolution-0.5.3-automatically-choose-best-mode.patch
  16. Patch10: 915resolution-0.5.3-new-chipset.patch
  17. BuildRoot: %{_tmppath}/%{name}-buildroot
  18. Exclusivearch: %{ix86} x86_64
  19. Requires: sed, grep
  20. %description
  21. 915resolution is a tool to modify the video BIOS of the 800 and 900 series
  22. Intel graphics chipsets. This includes the 845G, 855G, and 865G chipsets, as
  23. well as 915G, 915GM, and 945G chipsets. This modification is necessary to
  24. allow the display of certain graphics resolutions for an Xorg or XFree86
  25. graphics server.
  26. 915resolution's modifications of the BIOS are transient. There is no risk of
  27. permanent modification of the BIOS. This also means that 915resolution must be
  28. run every time the computer boots inorder for it's changes to take effect.
  29. 915resolution is derived from the tool 855resolution. However, the code differs
  30. substantially. 915resolution's code base is much simpler. 915resolution also
  31. allows the modification of bits per pixel.
  32. %prep
  33. %setup -q
  34. %patch0 -p1 -b .automarically-choose-best-mode
  35. %patch10 -p1 -b .new-chipset
  36. %build
  37. rm -f *.o
  38. %__make
  39. %install
  40. rm -rf $RPM_BUILD_ROOT
  41. install -D -m755 %{name} $RPM_BUILD_ROOT%{_sbindir}/%{name}
  42. install -D -m0755 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/%{name}
  43. install -D -m0644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}
  44. %clean
  45. rm -rf $RPM_BUILD_ROOT
  46. %post
  47. /sbin/chkconfig --add %{name}
  48. %preun
  49. if [ "$1" = 0 ]; then
  50. /sbin/chkconfig --del %{name}
  51. fi
  52. %files
  53. %defattr(-,root,root)
  54. %doc chipset_info.txt README.txt
  55. %{_sbindir}/%{name}
  56. %{_sysconfdir}/rc.d/init.d/*
  57. %config(noreplace) %{_sysconfdir}/sysconfig/*
  58. %changelog
  59. * Sun Sep 14 2008 Shu KONNO <owa@bg.wakwak.com> 0.5.3-1vl5
  60. - applied new versioning policy, spec in utf-8
  61. * Tue Oct 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.3-0vl2
  62. - add Patch10 to support 945GME,965GM/GME/GLE,G33,Q33,Q35
  63. * Fri May 04 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.3-0vl1
  64. - new upstream release
  65. * Tue Dec 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl4
  66. - fix init.d/915resolution (<BTS:416>)
  67. * Wed Sep 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl3
  68. - update init.d/915resolution
  69. - fix bugs (<BTS:0176>)
  70. * Sat Sep 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl2
  71. - update init.d/915resolution
  72. - fix bugs
  73. - automatically detect XRESO and YRESO from xorg.conf.
  74. (use Monitor ModelName "LCD Panel XRESOxYRESO")
  75. * Sat Sep 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl1
  76. - initial build for Vine Linux based on MDV package.
  77. * Fri Aug 04 2006 Olivier Thauvin <nanardon@mandriva.org>
  78. + 08/04/06 19:16:12 (52825)
  79. - rebuild
  80. * Fri Aug 04 2006 Olivier Thauvin <nanardon@mandriva.org>
  81. + 08/04/06 19:14:11 (52823)
  82. Import 915resolution
  83. * Fri Jun 16 2006 Pixel <pixel@mandriva.com> 0.5.2-5mdv2007.0
  84. - fix patch automatically-choose-best-mode
  85. (if no matching X resolution, it was chosing the last entry, even if unreachable)
  86. * Tue May 02 2006 Olivier Thauvin <nanardon@mandriva.org> 0.5.2-4mdk
  87. - Exclusivearch should be x86_64, not only amd64
  88. * Tue May 02 2006 Pixel <pixel@mandriva.com> 0.5.2-3mdk
  89. - Exclusivearch x86 and am64 (bugzilla #22203)
  90. * Fri Apr 28 2006 Pixel <pixel@mandriva.com> 0.5.2-2mdk
  91. - add patch automatically-choose-best-mode allowing "915resolution best <X> <Y>"
  92. which chooses the first bios mode with xres == <X>
  93. (or defaults to the last available mode)
  94. - add a service calling 915resolution before dm is launched
  95. * Thu Apr 27 2006 Olivier Thauvin <nanardon@mandriva.org> 0.5.2-1mdk
  96. - initial mandriva rpm