ibus-el-vl.spec 3.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152
  1. %define _noVersionedDependencies 1
  2. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  3. %define origname ibus-el
  4. %define origver 0.3.0
  5. Summary: a IBus client for GNU Emacs
  6. Summary(ja): GNU Emacs 用 IBus クライアント
  7. Name: %{origname}
  8. Version: %{origver}
  9. Release: 3%{?_dist_release}
  10. # http://launchpad.net/ibus.el
  11. Source0: ibus-el-%{version}.tar.gz
  12. Source1: %{origname}-install.sh
  13. Source2: %{origname}-remove.sh
  14. Source3: vine-default-%{origname}.el
  15. Source4: %{origname}-init.el
  16. #
  17. Patch0: ibus-el-0.2.1-emacs-24.0.90.patch
  18. Patch1: ibus-el-0.3.0-disable-surrounding-text.patch
  19. License: GPLv3
  20. Group: Applications/Editors/Emacs
  21. URL: http://www11.atwiki.jp/s-irie/pages/21.html
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  23. BuildArch: noarch
  24. Requires: emacsen
  25. PreReq: emacsen
  26. %prereq_ge emacsen-common
  27. Requires: python >= 2.5
  28. Requires: ibus >= 1.2
  29. Requires: python-xlib
  30. Distribution: Vine Linux
  31. Vendor: Project Vine
  32. Packager: iwaim, munepi
  33. %description
  34. ibus.el is a IBus client for GNU Emacs. This program allows users
  35. on-the-spot style input with IBus. The input statuses are individually
  36. kept for each buffer, and prefix-keys such as C-x and C-c can be used
  37. even if IBus is active. So you can input various languages fast and
  38. comfortably by using it.
  39. %prep
  40. %setup -q -n %{origname}-%{origver}
  41. #%patch0 -p1 -b .emacs24
  42. %if %{?_dist_release} == "vl6"
  43. %patch1 -p1 -b .surrounding
  44. %endif
  45. %build
  46. %install
  47. [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
  48. [ "%{buildroot}" != "/" ] && mkdir -p %{buildroot}
  49. mkdir -p %{buildroot}%{_datadir}/%{name}
  50. install -m 0755 ibus-el-agent %{buildroot}%{_datadir}/%{name}
  51. mkdir -p %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}/packages
  52. mkdir -p %{buildroot}%{emacsen_pkgdir}/install
  53. mkdir -p %{buildroot}%{emacsen_pkgdir}/remove
  54. #
  55. # install el files
  56. #
  57. cp -p *.el %{SOURCE3} %{SOURCE4} %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}
  58. #
  59. # install script (bytecompile el and install elc , remove)
  60. #
  61. %_installemacsenscript %{origname} %{SOURCE1}
  62. %_removeemacsenscript %{origname} %{SOURCE2}
  63. %clean
  64. [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
  65. %post
  66. #
  67. # bytecompile and install
  68. #
  69. if [ "$1" = 2 ]; then
  70. %_emacsenPackageRemove %{origname}
  71. fi
  72. %_addemacsenlist %{origname}
  73. %_emacsenPackageInstall %{origname}
  74. %preun
  75. if [ "$1" = 0 ]; then
  76. %_emacsenPackageRemove %{origname}
  77. %_removeemacsenlist %{origname}
  78. fi
  79. %files
  80. %defattr(-,root,root)
  81. %doc README doc/COPYING doc/ChangeLog
  82. %{_datadir}/emacs/site-lisp/%{origname}
  83. %{emacsen_pkgdir}/install/%{origname}
  84. %{emacsen_pkgdir}/remove/%{origname}
  85. %dir %{_datadir}/%{name}
  86. %{_datadir}/%{name}/ibus-el-agent
  87. %changelog
  88. * Tue Feb 14 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.3.0-3
  89. - apply ibus-el-0.3.0-disable-surrounding-text.patch (for vl6)
  90. * Mon Feb 13 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.3.0-2
  91. - fix a typo in ibus-el-init.el
  92. * Tue Jan 31 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.3.0-1
  93. - new upstream release
  94. - added "munepi" in Packager tag
  95. * Mon Oct 3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.2.1-3
  96. - supported emacs-24.0.90
  97. - updated ibus-el-init.el
  98. - output "Loading vine-default-ibus-el ..." to the buffer *Messages*
  99. * Tue Apr 5 2011 IWAI, Masaharu <iwai@alib.jp> 0.2.1-2vl6
  100. - fix <BTS:VineLinux:1117>
  101. - update vine-default-ibus-el.el (Source3): sync [VineSeed:22997]
  102. * Wed Nov 24 2010 IWAI, Masaharu <iwai@alib.jp> 0.2.1-1
  103. - new upstream release
  104. * Tue Aug 31 2010 IWAI, Masaharu <iwai@alib.jp> 0.2.0-1
  105. - new upstream release
  106. * Sat Jun 12 2010 IWAI, Masaharu <iwai@alib.jp> 0.1.1-1
  107. - new upstream release
  108. * Mon Jun 7 2010 IWAI, Masaharu <iwai@alib.jp> 0.1.0-1
  109. - first release for Vine Linux