spice-vl.spec 8.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243
  1. # build_client:
  2. # If you want to build both client and server change value to 1
  3. # If you want to only build the server change value to 0
  4. %define build_client 1
  5. Name: spice
  6. Version: 0.12.5
  7. Release: 2%{?_dist_release}
  8. Summary: Implements the SPICE protocol
  9. Group: User Interface/Desktops
  10. License: LGPLv2+
  11. URL: http://www.spice-space.org/
  12. Source0: http://www.spice-space.org/download/releases/%{name}-%{version}.tar.bz2
  13. Source1: spice-xpi-client-spicec
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  15. BuildRequires: pkgconfig
  16. BuildRequires: glib2-devel >= 2.22
  17. BuildRequires: spice-protocol >= 0.12.3
  18. BuildRequires: zlib-devel
  19. BuildRequires: celt051-devel
  20. BuildRequires: pixman-devel alsa-lib-devel openssl-devel libjpeg-turbo-devel
  21. %if %{build_client}
  22. BuildRequires: libXinerama-devel libXrandr-devel cegui06-devel
  23. %endif
  24. BuildRequires: libcacard-devel cyrus-sasl-devel
  25. BuildRequires: pyparsing
  26. %description
  27. The Simple Protocol for Independent Computing Environments (SPICE) is
  28. a remote display system built for virtual environments which allows
  29. you to view a computing 'desktop' environment not only on the machine
  30. where it is running, but from anywhere on the Internet and from a wide
  31. variety of machine architectures.
  32. %if %{build_client}
  33. %package client
  34. Summary: Implements the client side of the SPICE protocol
  35. Group: User Interface/Desktops
  36. %description client
  37. The Simple Protocol for Independent Computing Environments (SPICE) is
  38. a remote display system built for virtual environments which allows
  39. you to view a computing 'desktop' environment not only on the machine
  40. where it is running, but from anywhere on the Internet and from a wide
  41. variety of machine architectures.
  42. This package contains the SPICE client application.
  43. %endif
  44. %package server
  45. Summary: Implements the server side of the SPICE protocol
  46. Group: System Environment/Libraries
  47. %description server
  48. The Simple Protocol for Independent Computing Environments (SPICE) is
  49. a remote display system built for virtual environments which allows
  50. you to view a computing 'desktop' environment not only on the machine
  51. where it is running, but from anywhere on the Internet and from a wide
  52. variety of machine architectures.
  53. This package contains the run-time libraries for any application that wishes
  54. to be a SPICE server.
  55. %package server-devel
  56. Summary: Header files, libraries and development documentation for spice-server
  57. Group: Development/Libraries
  58. Requires: %{name}-server = %{version}-%{release}
  59. Requires: pkgconfig
  60. %description server-devel
  61. This package contains the header files, static libraries and development
  62. documentation for spice-server. If you like to develop programs
  63. using spice-server, you will need to install spice-server-devel.
  64. %prep
  65. %setup -q
  66. %build
  67. %if %{build_client}
  68. %define configure_client --enable-client --enable-gui
  69. %else
  70. %define configure_client --disable-client
  71. %endif
  72. %configure --enable-smartcard %{configure_client}
  73. make WARN_CFLAGS='' %{?_smp_mflags}
  74. %install
  75. make DESTDIR=%{buildroot} install
  76. rm -f %{buildroot}%{_libdir}/libspice-server.a
  77. rm -f %{buildroot}%{_libdir}/libspice-server.la
  78. mkdir -p %{buildroot}%{_libexecdir}
  79. %if %{build_client}
  80. touch %{buildroot}%{_libexecdir}/spice-xpi-client
  81. install -m 0755 %{SOURCE1} %{buildroot}%{_libexecdir}/
  82. %endif
  83. %post server -p /sbin/ldconfig
  84. %postun server -p /sbin/ldconfig
  85. %if %{build_client}
  86. %files client
  87. %defattr(-,root,root,-)
  88. %doc COPYING README NEWS
  89. %{_bindir}/spicec
  90. %ghost %{_libexecdir}/spice-xpi-client
  91. %{_libexecdir}/spice-xpi-client-spicec
  92. %endif
  93. %files server
  94. %defattr(-,root,root,-)
  95. %doc COPYING README NEWS
  96. %{_libdir}/libspice-server.so.*
  97. %files server-devel
  98. %defattr(-,root,root,-)
  99. %{_includedir}/spice-server
  100. %{_libdir}/libspice-server.so
  101. %{_libdir}/pkgconfig/spice-server.pc
  102. %changelog
  103. * Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> - 0.12.5-2
  104. - rebuild with gcc-5.4.0
  105. * Thu Jan 22 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.12.5-1
  106. - updated to 0.12.5
  107. - built with cyrus-sasl 2.1.26
  108. * Sun Nov 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.0-1
  109. - initial build for Vine Linux
  110. * Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.10.1-6
  111. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  112. * Mon May 14 2012 Alon Levy <alevy@redhat.com>
  113. - Fix mjpeg memory leak and bad behavior.
  114. - Add usbredir to list of channels for security purposes. (#819484)
  115. * Sun May 13 2012 Alon Levy <alevy@redhat.com>
  116. - Add double free fix. (#808936)
  117. * Tue Apr 24 2012 Alon Levy <alevy@redhat.com>
  118. - Add 32 bit fixes from git master. (#815717)
  119. * Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.10.1-2
  120. - Rebuilt for c++ ABI breakage
  121. * Mon Jan 23 2012 Hans de Goede <hdegoede@redhat.com> - 0.10.1-1
  122. - New upstream release 0.10.1
  123. * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.10.0-2
  124. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  125. * Thu Nov 10 2011 Alon Levy <alevy@redhat.com> - 0.10.0-1
  126. - New upstream release 0.10.0
  127. - support spice-server.i686
  128. * Wed Sep 28 2011 Marc-André Lureau <marcandre.lureau@redhat.com> - 0.9.1-2
  129. - Provides spice-xpi-client alternative in spice-client
  130. * Thu Aug 25 2011 Hans de Goede <hdegoede@redhat.com> - 0.9.1-1
  131. - New upstream release 0.9.1
  132. * Mon Jul 25 2011 Marc-André Lureau <marcandre.lureau@redhat.com> - 0.9.0-1
  133. - New upstream release 0.9.0
  134. * Wed Apr 20 2011 Hans de Goede <hdegoede@redhat.com> - 0.8.1-1
  135. - New upstream release 0.8.1
  136. * Fri Mar 11 2011 Hans de Goede <hdegoede@redhat.com> - 0.8.0-2
  137. - Fix being unable to send ctrl+alt+key when release mouse is bound to
  138. ctrl+alt (which can happen when used from RHEV-M)
  139. * Tue Mar 1 2011 Hans de Goede <hdegoede@redhat.com> - 0.8.0-1
  140. - New upstream release 0.8.0
  141. * Fri Feb 11 2011 Hans de Goede <hdegoede@redhat.com> - 0.7.3-1
  142. - New upstream release 0.7.3
  143. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.2-2
  144. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  145. * Wed Jan 19 2011 Hans de Goede <hdegoede@redhat.com> - 0.7.2-1
  146. - New upstream release 0.7.2
  147. * Fri Dec 17 2010 Hans de Goede <hdegoede@redhat.com> - 0.7.1-1
  148. - New upstream release 0.7.1
  149. - Drop all patches (all upstreamed)
  150. - Enable smartcard (CAC) support
  151. * Wed Nov 17 2010 Hans de Goede <hdegoede@redhat.com> - 0.6.3-4
  152. - Fix the info layer not showing when used through the XPI
  153. - Do not let the connection gui flash by when a hostname has been specified
  154. on the cmdline
  155. - Fix spice client locking up when dealing with XIM input (#654265)
  156. - Fix modifier keys getting stuck (#655048)
  157. - Fix spice client crashing when dealing with XIM ibus input (#655836)
  158. - Fix spice client only showing a white screen in full screen mode
  159. * Sat Nov 6 2010 Hans de Goede <hdegoede@redhat.com> - 0.6.3-3
  160. - Log to ~/.spicec/cegui.log rather then to CEGUI.log in the cwd, this
  161. fixes spicec from aborting when run in a non writable dir (#650253)
  162. * Fri Nov 5 2010 Hans de Goede <hdegoede@redhat.com> - 0.6.3-2
  163. - Various bugfixes from upstream git:
  164. - Make spicec work together with the Firefox XPI for RHEV-M
  165. - Make sure the spicec window gets properly raised when first shown
  166. * Mon Oct 18 2010 Hans de Goede <hdegoede@redhat.com> - 0.6.3-1
  167. - Update to 0.6.3
  168. - Enable GUI
  169. * Thu Sep 30 2010 Gerd Hoffmann <kraxel@redhat.com> - 0.6.1-1
  170. - Update to 0.6.1.
  171. * Tue Aug 31 2010 Alexander Larsson <alexl@redhat.com> - 0.6.0-1
  172. - Update to 0.6.0 (stable release)
  173. * Tue Jul 20 2010 Alexander Larsson <alexl@redhat.com> - 0.5.3-1
  174. - Update to 0.5.3
  175. * Tue Jul 13 2010 Gerd Hoffmann <kraxel@redhat.com> - 0.5.2-4
  176. - Quote %% in changelog to avoid macro expansion.
  177. * Mon Jul 12 2010 Gerd Hoffmann <kraxel@redhat.com> - 0.5.2-3
  178. - %%configure handles CFLAGS automatically, no need to fiddle
  179. with %%{optflags} manually.
  180. * Mon Jul 12 2010 Gerd Hoffmann <kraxel@redhat.com> - 0.5.2-2
  181. - Fix license: LGPL.
  182. - Cleanup specfile, drop bits not needed any more with
  183. recent rpm versions (F13+).
  184. - Use optflags as-is.
  185. -
  186. * Fri Jul 9 2010 Gerd Hoffmann <kraxel@redhat.com> - 0.5.2-1
  187. - initial package.